Subject: [COSE] FW: New Version Notification for draft-schaad-cose-rfc8152bis-struct-00.txt

From: Jim Schaad <[email-masked]>
Date: Wed, 22 Aug 2018 18:48:09 -0700

I have published two different drafts that between them cover all of RFC 8152.  There actually is overlap between them because I have not figured out things like:

* Should the examples be the structure or the algs draft.  Arguments exist for both points of view.
* How should the IANA registrations be split up between the two drafts for the algorithm specific registries?  Creation in struct or in algs?

Jim

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, August 22, 2018 6:11 PM
To: Jim Schaad <[email-masked]>
Subject: New Version Notification for draft-schaad-cose-rfc8152bis-struct-00.txt

A new version of I-D, draft-schaad-cose-rfc8152bis-struct-00.txt
has been successfully submitted by Jim Schaad and posted to the IETF repository.

Name:		draft-schaad-cose-rfc8152bis-struct
Revision:	00
Title:		CBOR Object Signing and Encryption (COSE) - Structures and Process
Document date:	2018-08-22
Group:		Individual Submission
Pages:		85
URL:            https://www.ietf.org/internet-drafts/draft-schaad-cose-rfc8152bis-struct-00.txt
Status:         https://datatracker.ietf.org/doc/draft-schaad-cose-rfc8152bis-struct/
Htmlized:       https://tools.ietf.org/html/draft-schaad-cose-rfc8152bis-struct-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-schaad-cose-rfc8152bis-struct

Abstract:
   Concise Binary Object Representation (CBOR) is a data format designed
   for small code size and small message size.  There is a need for the
   ability to have basic security services defined for this data format.
   This document defines the CBOR Object Signing and Encryption (COSE)
   protocol.  This specification describes how to create and process
   signatures, message authentication codes, and encryption using CBOR
   for serialization.  This specification additionally describes how to
   represent cryptographic keys using CBOR.

   This document along with [I-D.schaad-cose-rfc8152bis-algs] obsoletes
   RFC8152.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 23 Aug 2018 07:42:22 +0200

> * How should the IANA registrations be split up between the two drafts for the algorithm specific registries?  Creation in struct or in algs?

That’s a weird thing about respinning a document that makes IANA registrations:
The registrations are already made, so you don’t need to respin the document!

Of course, there is specification that goes alongside those registrations, and you may want to respin that text, but apart from that, there fundamentally is no need for re-making those registrations.  You also may want to take the opportunity to simply document what is in the registry in a more structured way than is possible by the simple registration process.

(You also may want to respin the policy definitions around the registries.)

Grüße, Carsten