Subject: [Crisp] Nit in lwz-05

From: Marcos Sanz/Denic <[email-masked]>
Date: Fri, 21 Apr 2006 10:18:17 +0200

Dear list,

while implementing LWZ (yes, you heard it right ;-) we have realized that 
the figure in section 3 tags "payload descriptor" with "3..261" octets.

It should be "6..261" as of section 3.1.1

Best regards,
Marcos

_______________________________________________
Crisp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/crisp

---

From: Andrew Newton <[email-masked]>
Date: Tue, 25 Apr 2006 09:15:00 -0400

> It should be "6..261" as of section 3.1.1

Who keeps putting bugs in these documents? :)

-andy

---

From: Frederico A C Neves <[email-masked]>
Date: Tue, 25 Apr 2006 11:14:12 -0300

We raised this privately to Andy when implementing our prototype.

> Who keeps putting bugs in these documents? :)

We :-)

For requests the range is "6..261", but for responses the value is 3.

So "6..261" would invalidate any response.

If possible the more correct version would be [ 3 or 6..261 ]

> -andy

Fred

---

From: Marcos Sanz/Denic <[email-masked]>
Date: Wed, 26 Apr 2006 10:12:19 +0200

Fred,

> If possible the more correct version would be [ 3 or 6..261 ]

You are right, but what about parenthesizing a bit so that it's clear 
lengths 4 and 5 are forbidden:

3 or [6..261]

The "problem" now is that no other range in the document has square 
brackets...

Regards,
Marcos

---

From: Andrew Newton <[email-masked]>
Date: Thu, 27 Apr 2006 09:18:56 -0400

> The "problem" now is that no other range in the document has square

How about?

3 or 6..261 *

* In request packets, the payload descriptor can vary in length from  
6 to 261 octets (i.e. 6..261).  In response packets, the payload  
descriptor is always 3 octets.

-andy

---

From: Frederico A C Neves <[email-masked]>
Date: Thu, 27 Apr 2006 11:06:50 -0300

> descriptor is always 3 octets.

It's unambiguous. Looks good to me.

Fred