Subject: [Curdle] I-D Action: draft-ietf-curdle-dnskey-eddsa-00.txt

From: [email-masked]
Date: Mon, 18 Apr 2016 12:40:50 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.

        Title           : EdDSA for DNSSEC
        Authors         : Ondrej Sury
                          Robert Edmonds
	Filename        : draft-ietf-curdle-dnskey-eddsa-00.txt
	Pages           : 8
	Date            : 2016-04-18

Abstract:
   This document describes how to specify EdDSA keys and signatures in
   DNS Security (DNSSEC).  It uses the Edwards-curve Digital Security
   Algorithm (EdDSA) with the choice of two curves, Ed25519 and Ed448.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-curdle-dnskey-eddsa/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-curdle-dnskey-eddsa-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ondřej Surý <[email-masked]>
Date: Tue, 19 Apr 2016 20:37:50 +0200 (CEST)

Dear colleagues,

a new EdDSA for DNSSEC draft has been posted in CURDLE WG and is in need of more reviewers ;).

I merged Ed25519 and Ed448 drafts into one, removed reasoning why EdDSA is superior for RFC and I-D in Normative references (thanks goes to Paul Hoffman's review), and introduced using Signature Context[1] in the signatures (thanks dkg for introducing me this idea) <-- this one needs more work, because using Context is defined just for Ed448 and we want to have it also for Ed25519.

Otherwise it's almost ready for WGLC, so if we can get some more reviews before that, it would be awesome.  Thanks.

1. TL;DR just prepend the prepared data with "DNSSEC SIGNATURE\0" before signing or verifying them. 

Cheers,
--
 Ondřej Surý -- Technical Fellow
 --------------------------------------------
 CZ.NIC, z.s.p.o.    --     Laboratoře CZ.NIC
 Milesovska 5, 130 00 Praha 3, Czech Republic
 mailto:[email-masked]    https://nic.cz/
 --------------------------------------------

----- Forwarded Message -----
From: [email-masked]
To: [email-masked]
Cc: [email-masked]
Sent: Monday, April 18, 2016 9:40:50 PM
Subject: [Curdle] I-D Action: draft-ietf-curdle-dnskey-eddsa-00.txt

        Title           : EdDSA for DNSSEC
        Authors         : Ondrej Sury
                          Robert Edmonds

Abstract:

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle