Subject: [Curdle] Mirja Kühlewind's No Objection on draft-ietf-curdle-dnskey-eddsa-03: (with COMMENT)

From: "Mirja Kuehlewind" <[email-masked]>
Date: Mon, 02 Jan 2017 03:40:19 -0800

Mirja Kühlewind has entered the following ballot position for
draft-ietf-curdle-dnskey-eddsa-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-curdle-dnskey-eddsa/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I am a little suprised to read this:

"A sufficiently large
   quantum computer would be able to break both. "
What's sufficiently large in terms of quantum comupting? Is it really
already necessary to say this? 

And here:
"Reasonable projections of the abilities of classical computers conclude
that Ed25519 is perfectly safe."
What's perfectly safe?

However no need to change anything... was just wondering.

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 2 Jan 2017 15:03:58 +0000

Hiya,

On 02/01/17 11:40, Mirja Kuehlewind wrote:
> What's sufficiently large in terms of quantum comupting? 

Enough qubits basically to run the relevant algorithms. I've
not looked into the ECC/DL stuff in detail, but for an RSA
modulus with 2048 bits, you'd need a bunch of qubit registers
of that size. [1] I think the same would be true for eddsa
so probably a QC with a bunch of 256 qubit registers would
be needed.

   [1] https://en.wikipedia.org/wiki/Shor%27s_algorithm

> Is it really

Yeah, I guess "currently considered" would be ok. IIRC, the issue
is that we don't want to encourage folks to all plump for 448 on
the spurious basis that longer/stronger is always better and the
language is trying to encourage people to ack that 25519 is just
fine for all known cases.

> However no need to change anything... was just wondering.

I'll take a peek when all the comments are in, might well be worth a
tweak or two.

Cheers,
S.

> 
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle
>