Subject: Re: [Curdle] I-D Action: draft-ietf-curdle-ssh-dh-group-exchange-04.txt

From: Daniel Migault <[email-masked]>
Date: Thu, 6 Jul 2017 15:34:01 -0400

Hi,

The current draft seems to have reached consensus. I am willing to move it
forward early next week, if you have any concerns please let us know.

Yours,
Daniel

I only have a minor editorial comment

OLD
    <t>
[RFC4419] specifies
      a recommended minimum size of 1024 bits for k,
      which is the modulus length of the DH Group.  It also suggests that
      in all cases, the size of the group needs be at least 1024 bits.This
      document updates  <xref target="RFC4419"/> as described below:
      section 3 Paragraph 9: Servers and
       clients SHOULD support groups with a modulus length of k
       bits where 2048 &lt;&#61; k &lt;&#61; 8192.  The recommended
       minimum values for min and max are 2048 and 8192,
       respectively.  This document also updates <xref target="RFC4419"/>
Section 3
       Paragraph 11 as follows: In all cases, the size of the group SHOULD
be
       at least 2048 bits.
     </t>

NEW
    <t>
[RFC4419] specifies
      a recommended minimum size of 1024 bits for k,
      which is the modulus length of the DH Group.  It also suggests that
      in all cases, the size of the group needs be at least 1024 bits.This
      document updates  <xref target="RFC4419"/> as described below:

      <list style="symbols">

      <t>section 3 Paragraph 9: Servers and
       clients SHOULD support groups with a modulus length of k
       bits where 2048 &lt;&#61; k &lt;&#61; 8192.  The recommended
       minimum values for min and max are 2048 and 8192,
       respectively.</t>

       <t> Section 3
       Paragraph 11: In all cases, the size of the group SHOULD be
       at least 2048 bits. </t>
       </list>

       </t>

On Thu, Jun 22, 2017 at 3:42 AM, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the CURves, Deprecating and a Little more
> Encryption of the IETF.
>
>         Title           : Increase SSH minimum recommended DH modulus size
> to 2048 bits
>         Authors         : Loganaden Velvindron
>                           Mark D. Baushke
>         Filename        : draft-ietf-curdle-ssh-dh-group-exchange-04.txt
>         Pages           : 4
>         Date            : 2017-06-22
>
> Abstract:
>    The Diffie-Hellman (DH) Group Exchange for the Secure Shell (SSH)
>    Transport layer Protocol specifies that servers and clients should
>    support groups with a modulus length of k bits, where the recommended
>    minumum value is 1024 bits.  Recent security research has shown that
>    a minimum value of 1024 bits is insufficient against state-sponsored
>    actors.  As such, this document formally updates the specification
>    such that the minimum recommended value for k is 2048 bits and the
>    group size is 2048 bits at minimum.  This RFC updates RFC4419 which
>    allowed for DH moduli less than 2048 bits.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-curdle-ssh-dh-group-exchange/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-curdle-ssh-dh-group-exchange-04
> https://datatracker.ietf.org/doc/html/draft-ietf-curdle-
> ssh-dh-group-exchange-04
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-curdle-ssh-dh-
> group-exchange-04
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle
>

---

From: Loganaden Velvindron <[email-masked]>
Date: Fri, 7 Jul 2017 17:01:51 +0400

>        Paragraph 11: In all cases, the size of the group SHOULD be

Dear Daniel, I have made the modifications, as requested, but I cannot
upload it as it will be unlocked after the 16th.

Meanwhile, I have attached it.

---

From: Daniel Migault <[email-masked]>
Date: Fri, 7 Jul 2017 13:40:34 +0000

Thank you. The upload is blocked two weeks prior the IETF, but you  will be able to upload it right after the IETF starts, i.e Monday 17.

Yours

-----Original Message-----
From: Loganaden Velvindron [mailto:[email-masked]] 
Sent: Friday, July 07, 2017 9:02 AM
To: Daniel Migault <[email-masked]>
Cc: curdle <[email-masked]>
Subject: Re: [Curdle] I-D Action: draft-ietf-curdle-ssh-dh-group-exchange-04.txt

On Thu, Jul 6, 2017 at 11:34 PM, Daniel Migault <[email-masked]> wrote:
> Hi,
>
> The current draft seems to have reached consensus. I am willing to 
> move it forward early next week, if you have any concerns please let us know.
>
> Yours,
> Daniel
>
>        respectively.  This document also updates <xref 
> target="RFC4419"/> Section 3
>        Paragraph 11 as follows: In all cases, the size of the group 
> SHOULD be
>        at least 2048 bits.
>      </t>
>
>
> NEW
>     <t>
> [RFC4419] specifies

Dear Daniel, I have made the modifications, as requested, but I cannot upload it as it will be unlocked after the 16th.