Subject: [Curdle] I-D Action: draft-ietf-curdle-pkix-05.txt

From: [email-masked]
Date: Mon, 03 Jul 2017 16:19:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the CURves, Deprecating and a Little more Encryption of the IETF.

        Title           : Algorithm Identifiers for Ed25519, Ed448, X25519 and X448 for use in the Internet X.509 Public Key Infrastructure
        Authors         : Simon Josefsson
                          Jim Schaad
	Filename        : draft-ietf-curdle-pkix-05.txt
	Pages           : 17
	Date            : 2017-07-03

Abstract:
   This document specifies algorithm identifiers and ASN.1 encoding
   formats for Elliptic Curve constructs using the curve25519 and
   curve448 curves.  The signature algorithms covered are Ed25519 and
   Ed448.  The key agreement algorithm covered are X25519 and X448.  The
   encoding for Public Key, Private Key and EdDSA digital signature
   structures is provided.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-curdle-pkix/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-curdle-pkix-05
https://datatracker.ietf.org/doc/html/draft-ietf-curdle-pkix-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-curdle-pkix-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jim Schaad <[email-masked]>
Date: Mon, 3 Jul 2017 22:11:52 -0700

I think that I have addressed the open issues from the AD review document
EXCET for the following.

Brian Smith wants to have a full test set at the end of the document.  I do
not believe that it is appropriate for this document and therefore have only
included a couple of test that demonstrate errors.

Jim

-----Original Message-----
From: Curdle [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, July 3, 2017 4:20 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Curdle] I-D Action: draft-ietf-curdle-pkix-05.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the CURves, Deprecating and a Little more
Encryption of the IETF.

        Title           : Algorithm Identifiers for Ed25519, Ed448, X25519
and X448 for use in the Internet X.509 Public Key Infrastructure
        Authors         : Simon Josefsson
                          Jim Schaad
	Filename        : draft-ietf-curdle-pkix-05.txt
	Pages           : 17
	Date            : 2017-07-03

Abstract:

_______________________________________________
Curdle mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/curdle

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 4 Jul 2017 14:45:39 +0000

> Brian Smith wants to have a full test set at the end of the document.  I do not
> believe that it is appropriate for this document and therefore have only

Is there anyone else in the WG who shares Brian's opinion?

---

From: Yoav Nir <[email-masked]>
Date: Tue, 4 Jul 2017 18:32:33 +0300

> On 4 Jul 2017, at 17:45, Salz, Rich <[email-masked]> wrote:
> 

IMO the examples in section 10 are sufficient. A full test is appropriate the an algorithm RFC such as 8032 (for EdDSA) and 7748 (for Curve25519 and Curve448)

RFC 8032 has  a good set of test vectors. RFC 7748 has a rather small set, but even if it’s not enough, I don’t think a PKIX update is the place to fix it.

Yoav

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Wed, 12 Jul 2017 08:31:14 +0200

On Mon, 2017-07-03 at 16:19 -0700, [email-masked] wrote:
>         Title           : Algorithm Identifiers for Ed25519, Ed448,
> X25519 and X448 for use in the Internet X.509 Public Key
> Infrastructure

Minor request. It would be nice if the certificate issuer of the cert
in 10.2 was included in the document. That would provide a certificate
with a ed25519 key, and would allow testing certificate chain
verification.

regards,
Nikos

---

From: Ilari Liusvaara <[email-masked]>
Date: Sun, 16 Jul 2017 21:46:55 +0300

On Tue, Jul 04, 2017 at 06:32:33PM +0300, Yoav Nir wrote:
> >> Brian Smith wants to have a full test set at the end of the
> >> document.  I do not believe that it is appropriate for this
> >> document and therefore have only included a couple of test
> >> that demonstrate errors.
> > 
> IMO the examples in section 10 are sufficient. A full test is
> appropriate the an algorithm RFC such as 8032 (for EdDSA) and 7748
> (for Curve25519 and Curve448)
> 
> RFC 8032 has  a good set of test vectors. RFC 7748 has a rather small
> set, but even if it’s not enough, I don’t think a PKIX update is the
> place to fix it.

Furthermore, all these concern private key formatting, which I regard
as some of the least important things in this document (I am even not
sure if the private key examples already are useful or not).

So I do not consider more examples here important.

Also, what's going on with the draft? Its status was set over two
months ago (and to value I consider rather bizarre), and since there
only has been a version bump.

-Ilari