Subject: [Curdle] [Technical Errata Reported] RFC8419 (5869)

From: RFC Errata System <[email-masked]>
Date: Wed, 2 Oct 2019 15:35:28 -0700 (PDT)

The following errata report has been submitted for RFC8419,
"Use of Edwards-Curve Digital Signature Algorithm (EdDSA) Signatures in the Cryptographic Message Syntax (CMS)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5869

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: 2.3

Original Text
-------------
      hashalgs  OBJECT IDENTIFIER  ::=  { joint-iso-itu-t(2)
                              country(16) us(840) organization(1)
                              gov(101) csor(3) nistalgorithm(4) 2 }

Corrected Text
--------------
      hashAlgs  OBJECT IDENTIFIER  ::=  { joint-iso-itu-t(2)
                              country(16) us(840) organization(1)
                              gov(101) csor(3) nistalgorithm(4) 2 }

Notes
-----
The "hashAlgs" requires a capital letter for the other definitions in the section.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8419 (draft-ietf-curdle-cms-eddsa-signatures-08)
--------------------------------------
Title               : Use of Edwards-Curve Digital Signature Algorithm (EdDSA) Signatures in the Cryptographic Message Syntax (CMS)
Publication Date    : August 2018
Author(s)           : R. Housley
Category            : PROPOSED STANDARD
Source              : CURves, Deprecating and a Little more Encryption
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Russ Housley <[email-masked]>
Date: Thu, 3 Oct 2019 11:42:56 -0400

This is a simple one-letter typo, but if you copy the ASN.1 chunks into a module, they do not compile without this change.

Russ

> On Oct 2, 2019, at 6:35 PM, RFC Errata System <[email-masked]> wrote:
> 
> _______________________________________________
> Curdle mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/curdle