Subject: [cuss] Open Issue: REQ-3

From: Alan Johnston <[email-masked]>
Date: Fri, 01 Oct 2010 12:38:44 -0500

On the call, Keith indicated that he didn't think this use case on UUI
inserted at redirection was supported in the standard ISDN service.

However, this is a common usage, since ISDN UUI is used in contact
center scenarios where the UUI is not inserted by the original caller
but added later as the call routes through ACDs (Automatic Call
Distributers) and IVRs (Interactive Voice Response) and rendered to the
answering agent.

I will investigate to see if there is some other standard that covers
this usage for ISDN.

Regardless, this usage seems useful in a SIP service, so I propose we
keep REQ-3, although perhaps restricting it in ISDN usage scenarios if
necessary.

- Alan -

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 1 Oct 2010 21:53:46 +0200

I will also investigate further on this one. So my main comment on this one is that I believe it complicates what is otherwise needed, particularly in multiple forwarding scenarios.

The additional point I raised on the call about this requirement is that if it stands, it introduces the need for other requirements.

So I would suggest we add some such requirement already.

"REQ-x:	The recipient of UUI MUST be able to determine the entity that inserted the UUI. It is acceptable that this is performed implicitly where it is known that there is only one other end UA involved in the dialog. Where that does not exist, some other mechanism will need to be provided. "

regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Alan Johnston
> Sent: Friday, October 01, 2010 6:39 PM
> To: [email-masked]
> Subject: [cuss] Open Issue: REQ-3
> 
> On the call, Keith indicated that he didn't think this use 
> case on UUI inserted at redirection was supported in the 
> standard ISDN service.
> 
> However, this is a common usage, since ISDN UUI is used in 
> contact center scenarios where the UUI is not inserted by the 
> original caller but added later as the call routes through 
> ACDs (Automatic Call
> Distributers) and IVRs (Interactive Voice Response) and 
> rendered to the answering agent.
> 
> I will investigate to see if there is some other standard 
> that covers this usage for ISDN.
> 
> Regardless, this usage seems useful in a SIP service, so I 
> propose we keep REQ-3, although perhaps restricting it in 
> ISDN usage scenarios if necessary.
> 
> - Alan -
> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss
>