Subject: [cuss] Adopting draft-drage-cuss-sip-uui-isdn

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 27 Sep 2011 09:04:10 -0500

Folks: As discussed during last week's virtual interim
meeting [1], the WG needs to choose a draft that satisfies
the last orphan milestone (ISDN UUI Service application usage
specification).

Keith Drage has an individual draft [2] that could be used towards
the milestone.  A call for additional candidate drafts went out on
Sep-08-2011 [3], but did not result in any new entries.

Therefore, during the interim meeting of Sep-21-2011, it was
decided to adopt draft-drage-cuss-sip-uui-isdn as the working
group draft towards the ISDN UUI Service application usage
milestone.

As such, Enrico and I seek to ratify this decision on the mailing
list and request Keith to submit a WG -00 version of his draft
no later than Tuesday, Aug-4-2011.

If there are any concerns, please let the WG know.

[1] Draft minutes at
   http://www.ietf.org/mail-archive/web/cuss/current/msg00263.html
[2] http://tools.ietf.org/html/draft-drage-cuss-sip-uui-isdn-01
[3] http://www.ietf.org/mail-archive/web/cuss/current/msg00234.html

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: <[email-masked]>
Date: Tue, 27 Sep 2011 16:36:30 +0200

Hi,
I have no concerns, so Keith can provide a WG version.

Regards

Roland

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im
> Auftrag von Vijay K. Gurbani
> Gesendet: Dienstag, 27. September 2011 16:04
> An: [email-masked]
> Betreff: [cuss] Adopting draft-drage-cuss-sip-uui-isdn
>
> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss
>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Tue, 27 Sep 2011 16:35:53 +0000

+1, agreed move forward
Martin C. Dolly
Sent to you by AT&T... America's Fastest Mobile Broadband Network. Rethink Possible.
+1.609.903.3360

----- Original Message -----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, September 27, 2011 10:36 AM
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [cuss] Adopting draft-drage-cuss-sip-uui-isdn

Hi,

Regards

Roland

---

From: Laura Liess <[email-masked]>
Date: Tue, 27 Sep 2011 21:55:20 +0200

I agree with moving on with the draft.

regards, Laura

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 28 Sep 2011 02:03:34 +0200

If and when I submit a -00 next week (dependent of course on the WG response to the request by the WG chairs below, I would like to introduce some additional changes, based on comments made in the interim meeting, and on some alignment discussion held with the editors of the UUI mechanism draft.

If there are issues with any of these, then please say so and I will not include them, and we can defer them to further discussion. Please be specific as to which items you have issues with if responding - I'd rather not see a default to all not handled.

My proposed changes are:

1)	Discussions on the list have highlighted the overburdening of the word "application". As a result it is proposed to change the name of the "app" header field parameter in the mechanism draft to "package" header field parameter. This has a consequential impact on the ISDN document. The word "application" is now solely reserved for the name of the functionality that passes the UUI to the SIP functionality to send, and to which the UUI is delivered on receipt by the SIP functionality. As well as the change of the name of the header field parameter, this results in a number of instances of the word "application" becoming "package". A couple of instances relating to the coding of the "content" header field parameter become "SIP entity".

2)	Section 5 needs substantial rewording as it no longer applies in this manner. I propose that we modify the text to indicate that if one wants to use an enhanced UUI where both endpoints are SIP, but still work with the ISDN, then one will have to same information using two different packages, one the ISDN one, and the other some enhanced package.

My current proposal is to delete the last sentence of the first paragraph and reword the second paragraph as follows:

"The SIP UUI mechanism provides a way to achieve this transition.  As an endpoint moves from being an ISDN gateway to a native SIP endpoint, and a package for some form of enhanced UUI has been standardized, the endpoint can carry the UUI data both as ISDN and as some other package in parallel.  This will permit the other endpoint to use the UUI according to the ISDN package if it is an ISDN gateway or the enhanced package if it is a native SIP endpoint."

3)	In section 8, a couple of requirements relating to the "content" header field parameter actually relate to the "package" header field parameter (formerly "app" header field parameter). These are corrected.

4)	Update references from "draft-johnston-cuss-sip-uui" to "draft-ietf-cuss-sip-uui".

5)	Make clear throughout the document that the UUI payload is a protocol discriminator plus 128 octets of data.

6)	Make clearer that it is the initial INVITE request and responses and the BYE request and responses only that carry the information in this package.

7)	Make clear that there are no normative requirements on the protocol discriminator. This text is added to the end of section 9:

" This document places no other normative requirement on the use of the protocol discriminator; it is required at interworking gateways to allow mapping into the appropriate fields in the ISDN protocols, but otherwise the usage is entirely up to the application, and outside the scope of this document. Valid values are identified and documented by ITU-T, and there is no IANA registry for these values."

8)	Remove the following text from section 7, as it is a duplicate of the text in section 9:

" When sending UUI, the sending application MUST include a protocol discriminator octet, conforming to table 4-26 of ITU-T Recommendation Q.931 [Q931] as the first octet of the payload information."

9)	Define a media feature tag specific for the package. It has been proposed to do this for all packages. "sip.uui-isdn" is proposed.

10)	Correct the short title for the draft.

I am aware we need to rework the security considerations text but that will require a little more research, so I will stick at this list for the moment.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Vijay K. Gurbani
> Sent: 27 September 2011 15:04
> To: [email-masked]
> Subject: [cuss] Adopting draft-drage-cuss-sip-uui-isdn
>

---

From: Alan Johnston <[email-masked]>
Date: Thu, 29 Sep 2011 07:08:29 -0500

I support adopting this draft as a working group item.  We will soon
produce a revision to the mechanism draft to align with these changes.

- Alan -