Subject: [cuss] Registration requirements for new parameter values in the User-to-User header field

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 19 Sep 2011 13:42:04 +0200

The syntax defines a number of new parameters for the header field.

        UUI         = "User-to-User" HCOLON uui-data *(SEMI uui-param)
        uui-data    = token
        uui-param   = enc-param | cont-param | app-param | generic-param
        enc-param   = "encoding="("hex" | token)
        cont-param  = "content=" token
        app-param   = "app=" token

The registration requirement for defining new header field parameter values according to RFC 3968 is a published RFC, but this says nothing about the strength required to define a new value - which are not registered.

The only text we have in draft-ietf-cuss-sip-uui-01 about registration strength for new values is on the encoding parameter, which seems to require standards track RFC.

My starting question is what strength do we really want to make on adding new values to this header field, which ultimately comes down to what limitations do we want to place on defining new application packages (such as ISDN-UUI. Should it be standards track or are we going to make it as wide open as the info-package definition.

Regards

Keith

---

From: Alan Johnston <[email-masked]>
Date: Mon, 19 Sep 2011 19:47:19 -0500

Keith,

Initially, it seems to be a good idea to require all extensions to be standards track RFC.    Once we get some experience with the types of UUI people are interested in, we could decide to change this.  But for now, we should require the maximum IETF review.

- Alan -

On Sep 19, 2011, at 6:42 AM, DRAGE, Keith (Keith) wrote:

> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss