Subject: Re: [cuss] Status of cuss documents => purpose parameter value for ISDN

From: <[email-masked]>
Date: Thu, 5 Jul 2012 14:44:23 +0000

Hello,

Since you may be currently updating the documents with the remarks received from WGLC review, I would like to come back again on a topic previously discussed (see http://www.ietf.org/mail-archive/web/cuss/current/msg00355.html-comment C10 and http://www.ietf.org/mail-archive/web/cuss/current/msg00418.html): the value of purpose parameter for ISDN.
Indeed, some implementations are currently generating purpose="isdn-interwork" (as indicated in draft-johnston-sipping-cc-uui-08) so this will cause a backward compatibility issue because currently in the ISDN draft, if present, purpose parameter value MUST be set to "isdn-uui" and, if received, its value MUST be set to "isdn-uui", otherwise the header would be discarded (as described in sections 7 and 8 of the ISDN draft) and the interworking not performed. 

Since some implementations may already be using purpose="isdn-uui", it may not be acceptable to simply change it back to purpose="isdn-interwork". Therefore, I propose as a compromise to add the following note along the line of what has been done in draft-ietf-bfcpbis-rfc4583bis-01 (section 6) for BFCP topic:

Note: 'isdn-interwork' value for purpose parameter was used in Internet-Drafts that have led to the publication of the present RFC. Although these documents had not other status than "work in progress", it is implemented by some vendors. Therefore, it is RECOMMENDED to support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving. 

Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Vijay K. Gurbani
Envoyé : jeudi 7 juin 2012 16:15
À : [email-masked]
Objet : [cuss] Status of cuss documents

Folks: The WGLC date for the two remaining documents has passed.

The WG received a WGLC review on draft-ietf-cuss-sip-uui-06 courtesy
of Laura Liess.

The review for draft-ietf-cuss-sip-uui-isdn-04 is still pending, and
should be out by next week.

In the meantime, could the authors of draft-ietf-cuss-sip-uui please
start to address the WGLC comments and sent out a revision addressing
the comments?

To the extent that there are dependencies between these two drafts, I
suspect that cuss-sip-uui-isdn depends on cuss-sip-uui.  Thus we can
start preparation for cuss-sip-uui while we wait for the WGLC review
of cuss-sip-uui-isdn.

Thanks,

Vijay K. Gurbani and Enrico Marocco

_______________________________________________
cuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cuss

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Mon, 9 Jul 2012 07:53:51 +0200

Hi,
I can agree on such a note.

BR

Roland Jesske

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von [email-masked]
Gesendet: Donnerstag, 5. Juli 2012 16:44
An: [email-masked]
Cc: [email-masked]
Betreff: Re: [cuss] Status of cuss documents => purpose parameter value for ISDN

Hello,

Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Vijay K. Gurbani Envoyé : jeudi 7 juin 2012 16:15 À : [email-masked] Objet : [cuss] Status of cuss documents

The WG received a WGLC review on draft-ietf-cuss-sip-uui-06 courtesy of Laura Liess.

The review for draft-ietf-cuss-sip-uui-isdn-04 is still pending, and should be out by next week.

In the meantime, could the authors of draft-ietf-cuss-sip-uui please start to address the WGLC comments and sent out a revision addressing the comments?

To the extent that there are dependencies between these two drafts, I suspect that cuss-sip-uui-isdn depends on cuss-sip-uui.  Thus we can start preparation for cuss-sip-uui while we wait for the WGLC review of cuss-sip-uui-isdn.

Thanks,

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.