Subject: [cuss] To "isdn-network" or not

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 09 Aug 2013 09:06:33 -0500

Folks: Keith has opened up a thread to ask WG guidance on whether to
include "isdn-network" in the purpose parameter.  His detailed email
laying out the argument is is in [1].

We need to close this issue as soon as possible in order to move
forward.  In the past, Enrico and I have received emails from other
standards groups asking to move this work along quickly.  Thus, we
assume that there is a need for expediency if the work is to remain
relevant.

Can the folks who have an opinion on this issue please post to the
mailing list.  At this point, is only one additional voice (Bruno)
besides Keith who has expressed an opinion.  We need more.

Please provide some input so we can gauge consensus on this issue,
close it and move on.

Thank you,

[1] http://www.ietf.org/mail-archive/web/cuss/current/msg00476.html

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 09 Aug 2013 16:22:23 +0200

Precisely what semantics are being sought for this new purpose param 
value? Are isdn-uui and isdn-network to be treated as synonyms in all 
cases, or is isdn-network to *replace* isdn-uui? Or are they to be 
treated as separate but equal - that some may support one and some may 
support the other?

	Thanks,
	Paul

---

From: <[email-masked]>
Date: Tue, 13 Aug 2013 08:54:17 +0000

As both values are already in use in the field, I think the simplest approach would be to treat them as synonyms.

Another solution if people prefer to give preference to the new value would be to deprecate sending "isdn-interwork" but to require the receiver to still treat them as synonyms.

BC

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Paul Kyzivat
> Envoyé : vendredi 9 août 2013 16:22
> À : [email-masked]
> Objet : Re: [cuss] To "isdn-network" or not
> 
> Precisely what semantics are being sought for this new purpose param value?
> Are isdn-uui and isdn-network to be treated as synonyms in all cases, or is
> isdn-network to *replace* isdn-uui? Or are they to be treated as separate
> but equal - that some may support one and some may support the other?
> 
> 	Thanks,
> 	Paul
> 
> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Tue, 13 Aug 2013 14:09:08 +0200

Hi Paul,
Celine and I had at least the agreement (http://www.ietf.org/mail-archive/web/cuss/current/msg00430.html) that we can include a Note into the draft which indicates:

Note: 'isdn-interwork' value for purpose parameter was used in Internet-Drafts that have led to the publication of the present RFC. Although these documents had not other status than "work in progress", it is implemented by some vendors. Therefore, it is RECOMMENDED to support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving.

So from my side implementations should only sent the "isdn-uui" but if "isdn-interwork" is received all implementations should understand also this value.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Paul Kyzivat
Gesendet: Freitag, 9. August 2013 16:22
An: [email-masked]
Betreff: Re: [cuss] To "isdn-network" or not

Precisely what semantics are being sought for this new purpose param value? Are isdn-uui and isdn-network to be treated as synonyms in all cases, or is isdn-network to *replace* isdn-uui? Or are they to be treated as separate but equal - that some may support one and some may support the other?

	Thanks,
	Paul

---

From: "VAN GEEL Jan (CIS/SCC)" <[email-masked]>
Date: Tue, 13 Aug 2013 12:18:41 +0000

Knowing from experience that there will always be implementers which only implement the "required" stuff and not the recommended stuff, wouldn't it be better to make the note a little bit more pushing.

For example:

 Note: 'isdn-interwork' value for purpose parameter was used in Internet-Drafts that have led to the publication of the present RFC. Although these documents had no other status than "work in progress", it is implemented by some vendors. Therefore, in order to ensure interoperability, it is REQUIRED to support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving.

Kind regards

Jan Van Geel
IT and Network Specialist
Belgacom CIS/SCC/FVC
Tel: +32 2 202 1035
Tel: +32 2 207 9032
Email : [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday 13 August 2013 14:09
To: [email-masked]; [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

Hi Paul,

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] Im Auftrag von Paul Kyzivat
Gesendet: Freitag, 9. August 2013 16:22
An: [email-masked]<mailto:[email-masked]>
Betreff: Re: [cuss] To "isdn-network" or not

        Thanks,
        Paul

_______________________________________________
cuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cuss
_______________________________________________
cuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cuss

  ________________________________

***** Disclaimer *****
http://www.belgacom.be/maildisclaimer

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 13 Aug 2013 16:39:26 +0200

On 8/13/13 2:18 PM, VAN GEEL Jan (CIS/SCC) wrote:
> Knowing from experience that there will always be implementers which
> only implement the "required" stuff and not the recommended stuff,
> wouldn't it be better to make the note a little bit more pushing.
> For example:
> Note: 'isdn-interwork' value for purpose parameter was used in
> Internet-Drafts that have led to the publication of the present RFC.
> Although these documents had no other status than "work in progress", it
> is implemented by some vendors. Therefore, in order to ensure
> interoperability, it is REQUIRED to support parsing and interpreting
> 'isdn-interwork' the same way as 'isdn-uui' when receiving.

This is easy to do. Will it be sufficient?

If you have stuff deployed out there that uses and knows only 
isdn-interwork, then won't it fail when *receiving* isdn-uui?

In the extreme, if there is stuff deployed that only uses 
isdn-interwork, and other stuff deployed that only uses isdn-uui, then 
to be compatible with both, new stuff will need to send requests with 
*both*.

	Thanks,
	Paul

> Celine and I had at least the agreement
> (http://www.ietf.org/mail-archive/web/cuss/current/msg00430.html) that
> we can include a Note into the draft which indicates:
> Note: 'isdn-interwork' value for purpose parameter was used in
> Internet-Drafts that have led to the publication of the present RFC.
> Although these documents had not other status than "work in progress",
> it is implemented by some vendors. Therefore, it is RECOMMENDED to
> support parsing and interpreting 'isdn-interwork' the same way as
> 'isdn-uui' when receiving.
> So from my side implementations should only sent the "isdn-uui" but if
> "isdn-interwork" is received all implementations should understand also
> this value.
> Best Regards
> Roland
> Von: [email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] Im Auftrag von Paul Kyzivat
> An: [email-masked] <mailto:[email-masked]>
>> [1]http://www.ietf.org/mail-archive/web/cuss/current/msg00476.html
>>
>> - vijay
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> _  ________________________________ _
>
> ***** Disclaimer *****

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 13 Aug 2013 09:50:52 -0500

Keith, Alan: I suspect we can agree that there appears to be some
consensus for "isdn-network" to be treated as a second-class alias for
"isdn-uui".

I am sympathetic to the ramifications of the unnecessary complexity on
supporting deprecated parameter values --- the deprecated
"transport=tls" parameter issues we faced in SIP raise their ugly head
in my memory.  But I suspect that supporting the "isdn-network" as an
alias that is strongly bounded by language you suggest towards the
bottom of your email [1] limits its scope in creating problems.

Unless there are other views to be considered, can you please indicate
whether you think this issue is equitably settled so we can move
forward.

Thanks,

- vijay

---

From: <[email-masked]>
Date: Thu, 15 Aug 2013 09:56:00 +0200

Hi,
does this mean that we add the proposed note?

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Vijay K. Gurbani
Gesendet: Dienstag, 13. August 2013 16:51
An: [email-masked]
Betreff: Re: [cuss] To "isdn-network" or not

Keith, Alan: I suspect we can agree that there appears to be some consensus for "isdn-network" to be treated as a second-class alias for "isdn-uui".

I am sympathetic to the ramifications of the unnecessary complexity on supporting deprecated parameter values --- the deprecated "transport=tls" parameter issues we faced in SIP raise their ugly head in my memory.  But I suspect that supporting the "isdn-network" as an alias that is strongly bounded by language you suggest towards the bottom of your email [1] limits its scope in creating problems.

Unless there are other views to be considered, can you please indicate whether you think this issue is equitably settled so we can move forward.

Thanks,

- vijay
--
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent 1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq _______________________________________________
cuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cuss

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 15 Aug 2013 10:11:25 -0500

> does this mean that we add the proposed note?

Roland:

I believe that Paul's thoughts on this subject [1] deserve a response
from the working group if we are to add this note.

My operating assumption when I posted my comment [2] was that the
legacy gear that is sending out "isdn-network" is only acting as a UAC
(a PSTN to SIP gateway/PBX, for instance).  Thus, it can get away with
only sending "isdn-network".

But if this is not true, and we have legacy UAS that only accept
"isdn-network", then how does a random UAC know whether it will send
"isdn-network" or "isdn-uui"?

Thoughts?

[1] http://www.ietf.org/mail-archive/web/cuss/current/msg00484.html
[2] http://www.ietf.org/mail-archive/web/cuss/current/msg00485.html

Thanks,

- vijay

---

From: <[email-masked]>
Date: Fri, 16 Aug 2013 08:13:29 +0000

Vijay's operating assumption is valid from my point of view. That's why the proposed note should be OK.
BC

> Vijay K. Gurbani
> Envoyé : jeudi 15 août 2013 17:11
> À : [email-masked]
> Cc : [email-masked]
> I believe that Paul's thoughts on this subject [1] deserve a response from
> the working group if we are to add this note.
> 
> My operating assumption when I posted my comment [2] was that the legacy
> gear that is sending out "isdn-network" is only acting as a UAC (a PSTN to
> SIP gateway/PBX, for instance).  Thus, it can get away with only sending
> "isdn-network".
> 
> But if this is not true, and we have legacy UAS that only accept "isdn-
> network", then how does a random UAC know whether it will send "isdn-
> network" or "isdn-uui"?
> 
> Thoughts?
>

---

From: Atle Monrad <[email-masked]>
Date: Fri, 16 Aug 2013 08:35:28 +0000

All

As said before, 3GPP is really waiting for the cuss-sip-uui drafts to complete.

The new NOTE as outlined by Jan:
Note: 'isdn-interwork' value for purpose parameter was used in Internet-Drafts that have led to the publication of the present RFC. Although these documents had no other status than "work in progress", it is implemented by some vendors. Therefore, in order to ensure interoperability, it is REQUIRED to support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving.

Seem to give a graceful transition from the existing implementations to this "soon-to-be RFC".

Hope this will satisfy all parties.

Thanks
/atle

Atle Monrad
3GPP CT Chairman

Group Function Technology - Standardization and Technical Regulation
Ericsson

From: [email-masked] [mailto:[email-masked]] On Behalf Of VAN GEEL Jan (CIS/SCC)
Sent: 13. august 2013 14:19
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

For example:

Kind regards

Jan Van Geel
IT and Network Specialist
Belgacom CIS/SCC/FVC
Tel: +32 2 202 1035
Tel: +32 2 207 9032
Email : [email-masked]<mailto:[email-masked]>

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday 13 August 2013 14:09
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [cuss] To "isdn-network" or not

Hi Paul,

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] Im Auftrag von Paul Kyzivat
Gesendet: Freitag, 9. August 2013 16:22
An: [email-masked]<mailto:[email-masked]>
Betreff: Re: [cuss] To "isdn-network" or not

        Thanks,
        Paul

***** Disclaimer *****

---

From: <[email-masked]>
Date: Fri, 16 Aug 2013 10:38:43 +0200

+1

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] 
Gesendet: Freitag, 16. August 2013 10:13
An: Vijay K. Gurbani; Jesske, Roland
Cc: [email-masked]
Betreff: RE: [cuss] To "isdn-network" or not

> De : [email-masked] [mailto:[email-masked]] De la part 
> de Vijay K. Gurbani Envoyé : jeudi 15 août 2013 17:11 À : 
> [email-masked] Cc : [email-masked] Objet : Re: [cuss] To 
> "isdn-network" or not
> 
> "isdn- network", then how does a random UAC know whether it will send 
> "isdn- network" or "isdn-uui"?
> 
> Thoughts?
> 
> Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent 1960 Lucent Lane, 
> Rm. 9C-533, Naperville, Illinois 60563 (USA)
> Web: http://ect.bell-labs.com/who/vkg/  | Calendar: 
> http://goo.gl/x3Ogq _______________________________________________
> cuss mailing list
> [email-masked]

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "VAN GEEL Jan (CIS/SCC)" <[email-masked]>
Date: Mon, 19 Aug 2013 07:42:30 +0000

Just for my understanding:

If a UAC is allowed to send "isdn-network" isn't it then required that ALL UAS are able to accept this value ?

If yes then I believe a UAC can send either "isdn-network" or "isdn-uui" and every UAS needs to understand "isdn-network" and "isdn-uui".
As long as the text or note reflects this without leaving room for different interpretation I'm fine.

Kind regards

Jan Van Geel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Thursday 15 August 2013 17:11
To: [email-masked]
Cc: [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

Roland:

I believe that Paul's thoughts on this subject [1] deserve a response from the working group if we are to add this note.

My operating assumption when I posted my comment [2] was that the legacy gear that is sending out "isdn-network" is only acting as a UAC (a PSTN to SIP gateway/PBX, for instance).  Thus, it can get away with only sending "isdn-network".

But if this is not true, and we have legacy UAS that only accept "isdn-network", then how does a random UAC know whether it will send "isdn-network" or "isdn-uui"?

Thoughts?

Thanks,

- vijay

***** Disclaimer *****

---

From: <[email-masked]>
Date: Tue, 20 Aug 2013 13:13:07 +0200

Hi Jan,
we have the definition of isdn-uui since a couple of years within the Draft.
Nevertheless to avoid backwards compatibility problems it is useful that the new uui interworking entities will understand also "isdn-network".
When we start that sending should be also allowed also we will end up in a never ending situation where equipment will be produced using "isdn-uui" and also equipment with "isdn-network".
With our current "agreed" note "isdn-network" we will end up hopefully in a couple of years and networks will then only use "isdn-uui".
As a side effect we have also to rewrite 3GPP specifications.
What carriers using the old extension will do in cases when they receive "isdn-network" is their problem. I assume they will ignore it.
But this cannot be solved by the current draft.
We had an agreement of adding a note pointing to the fact than "isdn-uui" should be understood by all entities providing interworking.

So my proposal is still to add the note we agreed one year ago and where I thought it will be only some months till the RFC will appear. (And also that time when we started to implement the draft.):

Could we agree on counting who is OK with this Note?
Or can we have an alternative proposal?

Thank you and Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: VAN GEEL Jan (CIS/SCC) [mailto:[email-masked]] 
Gesendet: Montag, 19. August 2013 09:43
An: Vijay K. Gurbani; Jesske, Roland
Cc: [email-masked]
Betreff: RE: [cuss] To "isdn-network" or not

Kind regards

Jan Van Geel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Thursday 15 August 2013 17:11
To: [email-masked]
Cc: [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

Roland:

Thoughts?

Thanks,

- vijay

***** Disclaimer *****

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 20 Aug 2013 08:54:38 -0500

On 08/20/2013 06:13 AM, [email-masked] wrote:
[...]
> Or can we have an alternative proposal?

Roland: While not an actual count, I would note that all the people
who expressed an opinion on this --- except for Paul's observation [1]
--- supported the addition of the note with the understanding in [2].

As such, Enrico and I would exhort the authors of the draft to chime
in on the mailing list with their acquiescence (or questions) and
close this issue by producing a revision as soon as possible.

Authors?

[1] http://www.ietf.org/mail-archive/web/cuss/current/msg00484.html
[2] http://www.ietf.org/mail-archive/web/cuss/current/msg00487.html

Thanks,

- vijay

---

From: Atle Monrad <[email-masked]>
Date: Wed, 21 Aug 2013 20:54:14 +0000

All

I would like to support moving along with text in line with previous discussions (i.e. the already identified Note) and not reopen old discussions. We'll never be able to complete the draft otherwise.

3GPP has a number of long-lasting drafts that move extremely slowly.
I would be happy to report progress on the draft-ietf-cuss-sip-uui-isdn and the linked and pending draft-ietf-cuss-sip-uui to get this "package" completed and out of the way ;-)

Thanks and have a nice day.
/atle

Atle Monrad
3GPP CT Chairman

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of VAN GEEL Jan (CIS/SCC)
Sent: 19. august 2013 09:43
To: Vijay K. Gurbani; [email-masked]
Cc: [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

Kind regards

Jan Van Geel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Thursday 15 August 2013 17:11
To: [email-masked]
Cc: [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

Roland:

Thoughts?

Thanks,

- vijay

***** Disclaimer *****

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 22 Aug 2013 16:30:33 +0000

Hi,

I am also ok with the suggested way forward, using a Note.

Keep in mind, though, that since the receiver has to be able to parse both values, they both need to be in the ABNF.

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: [email-masked] [mailto:[email-masked]] Puolesta Atle Monrad
Lähetetty: 21. elokuuta 2013 23:54
Vastaanottaja: VAN GEEL Jan (CIS/SCC); Vijay K. Gurbani; [email-masked]
Kopio: [email-masked]
Aihe: Re: [cuss] To "isdn-network" or not

All

Atle Monrad
3GPP CT Chairman

Group Function Technology - Standardization and Technical Regulation Ericsson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of VAN GEEL Jan (CIS/SCC)
Sent: 19. august 2013 09:43
To: Vijay K. Gurbani; [email-masked]
Cc: [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

Kind regards

Jan Van Geel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Thursday 15 August 2013 17:11
To: [email-masked]
Cc: [email-masked]
Subject: Re: [cuss] To "isdn-network" or not

Roland:

Thoughts?

Thanks,

- vijay

***** Disclaimer *****

---

From: Alan Johnston <[email-masked]>
Date: Thu, 22 Aug 2013 13:24:29 -0500

I agree. Both need to be in the ABNF. 

- Alan -