Subject: [cuss] draft-ietf-cuss-sip-uui-isdn-05

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sun, 4 Aug 2013 10:26:43 +0000

I have just posted a -05 version of this draft.

This leaves one issue which was raised by Celine a while back.

Celine argued for the value "isdn-interwork" to be included for purpose in addition to the one defined. This was for the purpose of backwards compatibility.

This value only appears in the examples in the draft-johnston-cuss-sip-uui and in -00 version of draft-ietf-cuss-sip-uui.

It has never appeared in any version of draft-drage-cuss-sip-uui-isdn or draft-ietf-cuss-sip-uui-isdn.

It does appear defined in draft-johnston-sipping-cc-uui, but only in the -08 and -09 versions, and not in prior versions. (3rd Jan 2010 through 14th December 2010 when it was replaced by the CUSS author draft)

My understanding of the implications of this would be that a sender MUST NOT send this value. A receiver MUST support this value when received, and corresponding requirements would be needed. The ABNF and IANA considerations would also need to be updated to reflect this value.

Could WG members indicate their preference for making this change, or for not making this change.

To start the discussion, my preference would be not to make this change, on the basis that it conveys complexity for a previous draft version that was not in existence for very long. As far as I can recall, neither of the two versions that define this were ever referenced by 3GPP.

Regards

Keith

---

From: <[email-masked]>
Date: Tue, 6 Aug 2013 07:05:04 +0000

Hi Keith, all, 

Unfortunately draft-johnston-sipping-cc-uui-08 was referenced by previous versions of 3GPP TS 24.229. See for example reference 126 in TS 24.229 versions 9.10.0 or 10.0.0 (and some others as well). As mentioned by Celine in the email sent on 5 July 2012, there are implementations based on this version of the Johnson draft.

Due to the holiday period we may not receive many answers from WG members about their preference. However, a request for feedback was already made last year and there was no objection against Celine's requested change. 

http://www.ietf.org/mail-archive/web/cuss/current/msg00430.html	
http://www.ietf.org/mail-archive/web/cuss/current/msg00445.html

My preference is of course to make this change.

Best Regards
BC

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> DRAGE, Keith (Keith)
> Envoyé : dimanche 4 août 2013 12:27
> À : [email-masked]
> Objet : [cuss] draft-ietf-cuss-sip-uui-isdn-05
> 
> Celine argued for the value "isdn-interwork" to be included for purpose in
> addition to the one defined. This was for the purpose of backwards
> compatibility.
> 
> This value only appears in the examples in the draft-johnston-cuss-sip-uui
> and in -00 version of draft-ietf-cuss-sip-uui.
> 
> It does appear defined in draft-johnston-sipping-cc-uui, but only in the -
> 08 and -09 versions, and not in prior versions. (3rd Jan 2010 through 14th
> December 2010 when it was replaced by the CUSS author draft)
> 
> My understanding of the implications of this would be that a sender MUST
> NOT send this value. A receiver MUST support this value when received, and
> corresponding requirements would be needed. The ABNF and IANA
> considerations would also need to be updated to reflect this value.
> 
> To start the discussion, my preference would be not to make this change, on
> the basis that it conveys complexity for a previous draft version that was
> not in existence for very long. As far as I can recall, neither of the two
> versions that define this were ever referenced by 3GPP.
> 
> Regards
> 
> Keith
> 
> 
> _______________________________________________
> cuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cuss

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 6 Aug 2013 07:11:58 +0000

Just to point out that the request for comment last year produced one supporter and one who did not respond further after the impact was clarified.

I regarded that as indefinite, and certainly did not take it as support in the WG.

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 06 August 2013 08:05
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: RE: draft-ietf-cuss-sip-uui-isdn-05
> 
> Hi Keith, all,
> 
> Unfortunately draft-johnston-sipping-cc-uui-08 was referenced by previous
> versions of 3GPP TS 24.229. See for example reference 126 in TS 24.229
> versions 9.10.0 or 10.0.0 (and some others as well). As mentioned by
> Celine in the email sent on 5 July 2012, there are implementations based
> on this version of the Johnson draft.
> 
> Due to the holiday period we may not receive many answers from WG members
> about their preference. However, a request for feedback was already made
> last year and there was no objection against Celine's requested change.
> 
> > Could WG members indicate their preference for making this change, or
> for
> > not making this change.
> >
> __________________________________________________________________________
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;