Subject: [cuss] Fwd: Re: To "isdn-network" or not

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 05 Sep 2013 09:42:18 -0500

Authors of CUSS ISDN Service draft, please advise on the matter below
regarding the availability of a new version.

Thanks,

-------- Original Message --------
Subject: Re: [cuss] To "isdn-network" or not
Date: Tue, 20 Aug 2013 08:54:38 -0500
From: Vijay K. Gurbani <[email-masked]>
Organization: Bell Laboratories, Alcatel-Lucent
To: [email-masked]
CC: [email-masked]

On 08/20/2013 06:13 AM, [email-masked] wrote:
[...]
> Could we agree on counting who is OK with this Note?
> Or can we have an alternative proposal?

Roland: While not an actual count, I would note that all the people
who expressed an opinion on this --- except for Paul's observation [1]
--- supported the addition of the note with the understanding in [2].

As such, Enrico and I would exhort the authors of the draft to chime
in on the mailing list with their acquiescence (or questions) and
close this issue by producing a revision as soon as possible.

Authors?

[1] http://www.ietf.org/mail-archive/web/cuss/current/msg00484.html
[2] http://www.ietf.org/mail-archive/web/cuss/current/msg00487.html

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq
_______________________________________________
cuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cuss

---

From: Atle Monrad <[email-masked]>
Date: Tue, 10 Sep 2013 13:59:46 +0000

Vijay

I'm not one of the draft authors, but as stated before 

I would like to support moving along with text in line with previous discussions (i.e. the already identified Note) and not reopen old discussions. We'll never be able to complete the draft otherwise.

I would also like to ask the authors of cuss-sip-uui & cuss-sip-uui-isdn to kindly find a timeslot to wrap up the remaining topics and complete the drafts.

thanks
/atle

________________________________ 

Atle Monrad
3GPP CT Chairman

Group Function Technology - Standardization and Technical Regulation 
Ericsson

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: 5. september 2013 15:42
To: [email-masked]
Cc: [email-masked]
Subject: [cuss] Fwd: Re: To "isdn-network" or not

Authors of CUSS ISDN Service draft, please advise on the matter below regarding the availability of a new version.

Thanks,

-------- Original Message --------
Subject: Re: [cuss] To "isdn-network" or not
Date: Tue, 20 Aug 2013 08:54:38 -0500
From: Vijay K. Gurbani <[email-masked]>
Organization: Bell Laboratories, Alcatel-Lucent
To: [email-masked]
CC: [email-masked]

> Or can we have an alternative proposal?

Roland: While not an actual count, I would note that all the people who expressed an opinion on this --- except for Paul's observation [1]
--- supported the addition of the note with the understanding in [2].

As such, Enrico and I would exhort the authors of the draft to chime in on the mailing list with their acquiescence (or questions) and close this issue by producing a revision as soon as possible.

Authors?

Thanks,

- vijay
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq _______________________________________________

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 10 Sep 2013 15:04:27 +0000

All these mails keep referring to a proposed note.

However statements from the same source stated they wanted it normative.

Either it is normative, and not a note, or it is informative and we'll put it in a note.

Can you please clarify which it is.

Regards

Keith

> Sent: 05 September 2013 15:42

---

From: <[email-masked]>
Date: Tue, 10 Sep 2013 15:57:49 +0000

Hello,

Our preference would be that it is normative.
Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de DRAGE, Keith (Keith)
Envoyé : mardi 10 septembre 2013 17:04
À : Gurbani, Vijay K (Vijay); [email-masked]
Cc : [email-masked]
Objet : Re: [cuss] Fwd: Re: To "isdn-network" or not

Regards

Keith

> Web: http://ect.bell-labs.com/who/vkg/  | Calendar: 
> http://goo.gl/x3Ogq _______________________________________________
> cuss mailing list
> [email-masked]

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 11 Sep 2013 07:30:14 +0200

Hello,
>From my understanding we had the agreement that we keep it in a Note.

Best Regards

Roalnd

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von [email-masked]
Gesendet: Dienstag, 10. September 2013 17:58
An: DRAGE, Keith (Keith)
Cc: [email-masked]; Gurbani, Vijay K (Vijay); [email-masked]
Betreff: Re: [cuss] Fwd: Re: To "isdn-network" or not

Hello,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de DRAGE, Keith (Keith) Envoyé : mardi 10 septembre 2013 17:04 À : Gurbani, Vijay K (Vijay); [email-masked]
Cc : [email-masked]
Objet : Re: [cuss] Fwd: Re: To "isdn-network" or not

Regards

Keith

> Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent 1960 Lucent Lane, 
> Rm. 9C-533, Naperville, Illinois 60563 (USA)

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 11 Sep 2013 12:18:06 +0000

As in informative?

I.e. no uppercase MUST or SHOULD?

Keith

> From: [email-masked] [mailto:[email-masked]]
> Sent: 11 September 2013 06:30
> To: [email-masked]; DRAGE, Keith (Keith)
> Subject: AW: [cuss] Fwd: Re: To "isdn-network" or not
> 
> Hello,
> De : [email-masked] [mailto:[email-masked]] De la part de
> DRAGE, Keith (Keith) Envoyé : mardi 10 septembre 2013 17:04 À : Gurbani,
> Vijay K (Vijay); [email-masked]
> Cc : [email-masked]
> __________________________________________________________________________
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
> exploites ou copies sans autorisation. Si vous avez recu ce message par
> erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
> pieces jointes. Les messages electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law; they should not be distributed,
> used or copied without authorisation.

---

From: <[email-masked]>
Date: Thu, 12 Sep 2013 13:01:21 +0000

Hello,

As done in our proposition of July 2012, we would like to use the term of "RECOMMENDED" as defined in RFC 2119 and it seems to us that nothing forbids its usage in a Note. It is for instance used in this way in draft-ietf-bfcpbis-rfc4583bis-07 in section 6:

Note: In [15] 'm-stream' was erroneously used in Section 10. Although the example was non-normative, it is implemented by some vendors and occurs in cases where the endpoint is willing to act as an server.  Therefore, it is RECOMMENDED to support parsing and interpreting 'm-stream' the same way as 'mstrm' when receiving.

Our proposed note (same as in July 2012) following this approach: 
Note: 'isdn-interwork' value for purpose parameter was used in Internet-Drafts that have led to the publication of the present RFC. Although these documents had not other status than "work in progress", it is implemented by some vendors. Therefore, it is RECOMMENDED to support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving.

Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : DRAGE, Keith (Keith) [mailto:[email-masked]] 
Envoyé : mercredi 11 septembre 2013 14:18
À : [email-masked]; SERRUT-VALETTE Celine IMT/OLN
Cc : [email-masked]; Gurbani, Vijay K (Vijay); [email-masked]
Objet : RE: [cuss] Fwd: Re: To "isdn-network" or not

As in informative?

Keith

> De : [email-masked] [mailto:[email-masked]] De la part 
> de DRAGE, Keith (Keith) Envoyé : mardi 10 septembre 2013 17:04 À : 
> Gurbani, Vijay K (Vijay); [email-masked]
> Cc : [email-masked]
> > Authors of CUSS ISDN Service draft, please advise on the matter 
> > below regarding the availability of a new version.
> >
> > Thanks,
> >
> > Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent 1960 Lucent 
> > Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
> ______________________________________________________________________
> ____ _______________________________________________
> 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete 
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.

---

From: <[email-masked]>
Date: Thu, 12 Sep 2013 15:15:29 +0200

Full Support.

Thank you.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] 
Gesendet: Donnerstag, 12. September 2013 15:01
An: DRAGE, Keith (Keith); Jesske, Roland
Cc: [email-masked]; Gurbani, Vijay K (Vijay); [email-masked]
Betreff: RE: [cuss] Fwd: Re: To "isdn-network" or not

Hello,

Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : DRAGE, Keith (Keith) [mailto:[email-masked]]
Envoyé : mercredi 11 septembre 2013 14:18 À : [email-masked]; SERRUT-VALETTE Celine IMT/OLN Cc : [email-masked]; Gurbani, Vijay K (Vijay); [email-masked] Objet : RE: [cuss] Fwd: Re: To "isdn-network" or not

As in informative?

Keith

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 12 Sep 2013 13:20:52 +0000

If we are going to do that, then I would suggest we delete the word "Note." 

Its presence implies there are two levels of meaning of the word "RECOMMENDED", those that are included in Notes and those that are not.

Keith

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: 12 September 2013 14:01
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: RE: [cuss] Fwd: Re: To "isdn-network" or not
> 
> Hello,
> 
> As done in our proposition of July 2012, we would like to use the term of
> "RECOMMENDED" as defined in RFC 2119 and it seems to us that nothing
> forbids its usage in a Note. It is for instance used in this way in draft-
> ietf-bfcpbis-rfc4583bis-07 in section 6:
> 
> Note: In [15] 'm-stream' was erroneously used in Section 10. Although the
> example was non-normative, it is implemented by some vendors and occurs in
> cases where the endpoint is willing to act as an server.  Therefore, it is
> RECOMMENDED to support parsing and interpreting 'm-stream' the same way as
> 'mstrm' when receiving.
> 
> Note: 'isdn-interwork' value for purpose parameter was used in Internet-
> Drafts that have led to the publication of the present RFC. Although these
> documents had not other status than "work in progress", it is implemented
> by some vendors. Therefore, it is RECOMMENDED to support parsing and
> interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving.
> 
> Regards,
> 
> Celine Serrut-Valette
> Orange Labs
> 
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> information that may be protected by law;

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 12 Sep 2013 08:36:14 -0500

On 09/12/2013 08:20 AM, DRAGE, Keith (Keith) wrote:
> Its presence implies there are two levels of meaning of the word
> "RECOMMENDED", those that are included in Notes and those that are
> not.

I think the group had also agreed to add that implementations conformant
to the RFC-to-be MUST NOT generate 'isdn-network' when sending requests.

Thanks,

- vijay

---

From: <[email-masked]>
Date: Thu, 12 Sep 2013 13:39:30 +0000

No, I don't think so, we did not agree to add such statement.

Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : Vijay K. Gurbani [mailto:[email-masked]] 
Envoyé : jeudi 12 septembre 2013 15:36
À : DRAGE, Keith (Keith)
Cc : SERRUT-VALETTE Celine IMT/OLN; [email-masked]; [email-masked]; [email-masked]
Objet : Re: [cuss] Fwd: Re: To "isdn-network" or not

> "RECOMMENDED", those that are included in Notes and those that are 

I think the group had also agreed to add that implementations conformant to the RFC-to-be MUST NOT generate 'isdn-network' when sending requests.

Thanks,

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 12 Sep 2013 08:56:40 -0500

> No, I don't think so, we did not agree to add such statement.

Celine: Never mind; it looks like I really should not read emails and
post responses while being on a conference call.

Cheers,

- vijay

---

From: <[email-masked]>
Date: Fri, 13 Sep 2013 08:05:31 +0200

Even that there are no rules in IETF what is allowed in a note to write and what is not allowed I can agree on your proposal.

So the text is then:

'isdn-interwork' value for purpose parameter was used in 
Internet- Drafts that have led to the publication of the present RFC. 
Although these documents had not other status than "work in progress", 
it is implemented by some vendors. Therefore, it is RECOMMENDED to 
support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: DRAGE, Keith (Keith) [mailto:[email-masked]] 
Gesendet: Donnerstag, 12. September 2013 15:21
An: [email-masked]; Jesske, Roland
Cc: [email-masked]; Gurbani, Vijay K (Vijay); [email-masked]
Betreff: RE: [cuss] Fwd: Re: To "isdn-network" or not

Keith

> As done in our proposition of July 2012, we would like to use the term 
> of "RECOMMENDED" as defined in RFC 2119 and it seems to us that 
> nothing forbids its usage in a Note. It is for instance used in this 
> way in draft-
> Note: In [15] 'm-stream' was erroneously used in Section 10. Although 
> the example was non-normative, it is implemented by some vendors and 
> occurs in cases where the endpoint is willing to act as an server.  
> Therefore, it is RECOMMENDED to support parsing and interpreting 
> 'm-stream' the same way as 'mstrm' when receiving.
> 
> Note: 'isdn-interwork' value for purpose parameter was used in 
> Internet- Drafts that have led to the publication of the present RFC. 
> Although these documents had not other status than "work in progress", 
> it is implemented by some vendors. Therefore, it is RECOMMENDED to 
> support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving.
> 
> Regards,
> 
> Celine Serrut-Valette
> Orange Labs
> 
> Envoyé : mercredi 11 septembre 2013 14:18 À : [email-masked]; 
> SERRUT-VALETTE Celine IMT/OLN Cc : 
> [email-masked]; Gurbani, Vijay K (Vijay); 
> [email-masked] Objet : RE: [cuss] Fwd: Re: To "isdn-network" or not
> 
> As in informative?
> 
> > Gurbani, Vijay K (Vijay); 
> > [email-masked]
> > Cc : [email-masked]
> > > Roland: While not an actual count, I would note that all the 
> > > people who expressed an opinion on this --- except for Paul's 
> > > observation [1]
> > > As such, Enrico and I would exhort the authors of the draft to 
> > > chime in on the mailing list with their acquiescence (or 
> > > questions) and close this issue by producing a revision as soon as possible.
> > >
> > > Authors?
> > >
> > > [1] 
> > > http://www.ietf.org/mail-archive/web/cuss/current/msg00484.html
> > > [2] 
> > > http://www.ietf.org/mail-archive/web/cuss/current/msg00487.html
> > >
> > > Thanks,
> > >
> > > - vijay
> > > --
> > > http://goo.gl/x3Ogq 
> > ____________________________________________________________________
> > __ ____ _______________________________________________
> >
> > confidentielles ou privilegiees et ne doivent donc pas etre 
> > diffuses, exploites ou copies sans autorisation. Si vous avez recu 
> > ce message par erreur, veuillez le signaler a l'expediteur et le 
> > detruire ainsi que les pieces jointes. Les messages electroniques 
> > etant susceptibles d'alteration, Orange decline toute responsabilite 
> > si ce message a ete altere, deforme ou falsifie. Merci.
> >
> > If you have received this email in error, please notify the sender 
> > and delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that 
> > have been modified, changed or falsified.
> > Thank you.
> >