Subject: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 02 Dec 2013 09:16:13 -0600

Folks:

The WGLC for draft-ietf-cuss-sip-uui-isdn is now over.

Below is my personal interpretation of where the matter stands, i.e.,
what I write below is not written as a co-chair but rather to determine
if the WG agree that this is where matters now stand.  Please comment
if I deviate from what you all agree.

- "isdn-network" is tacitly supported, but not overtly so.

- More specifically, "isdn-network" is not IANA registered, and all
   text related to it is not normative.

- The addition of the Note uses non-normative language, i.e.,

      "The 'isdn-interwork' value for purpose parameter was used
      in Internet-Drafts that have led to the publication of the
      present RFC. Although these documents had no other status than
      "work in progress", this value is implemented by some vendors.
      Therefore, it is recommended to support parsing and interpreting
      'isdn-interwork' the same way as 'isdn-uui' when receiving
      messages."

Is this an accurate representation?

Now back with the co-chair hat on ...

There has been reviews of the draft [1,2,3] by key WG members.  Can the
draft authors please comment on next steps with respect to revising the
draft.  Enrico and I will start the shepherding step in parallel to the
revision to be submitted.

[1] http://www.ietf.org/mail-archive/web/cuss/current/msg00531.html
[2] http://www.ietf.org/mail-archive/web/cuss/current/msg00539.html
[3] http://www.ietf.org/mail-archive/web/cuss/current/msg00522.html

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Andrew Allen <[email-masked]>
Date: Mon, 2 Dec 2013 16:27:51 +0000

I think it might be wise to indicate in the IANA registry that the value "isdn-network" is reserved for historical reasons and its use has been deprecated.

----- Original Message -----
From: Vijay K. Gurbani [mailto:[email-masked]]
Sent: Monday, December 02, 2013 10:16 AM Eastern Standard Time
To: [email-masked] <[email-masked]>
Subject: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Folks:

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq
_______________________________________________
cuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cuss
---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Atle Monrad <[email-masked]>
Date: Tue, 3 Dec 2013 06:53:45 +0000

Folks

When I came to Vancouver to discuss how to complete the draft, it was also my understanding that the involved parties could live with an informative note, thus I support Vijays conclusion. 

I'd like to add that while [1] and [3] are easy nits, on [2] http://www.ietf.org/mail-archive/web/cuss/current/msg00539.html, there are some further comments from Keith + the fact that we have moved to an informative note, thus I'm not that sure how much that is left of this comment.

Note also that if the current authors cannot find time to complete the work rather soon, I still have the backup author - Roland Jesske. I assume that Vijay will contact him if necessary. I would hope that 3GPP does not need to wait for too long for completion. I'd propose to give people time until end-of-the-week to revise the draft.

__________

On the IANA-registry, I have nothing against this as long as it is formally correct with the current phrased note by Vijay and doesn't cause more work to the draft and/or delay the completion process. However, IMHO we shouldn't restart the debate if IANA-registries isn't possible without normative statements in the drafts.

thanks
/atle

________________________________ 

Atle Monrad
3GPP CT Chairman

Group Function Technology - Standardization and Technical Regulation 
Ericsson

----- Original Message -----
From: Vijay K. Gurbani [mailto:[email-masked]]
Sent: Monday, December 02, 2013 10:16 AM Eastern Standard Time
To: [email-masked] <[email-masked]>
Subject: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Folks:

Below is my personal interpretation of where the matter stands, i.e., what I write below is not written as a co-chair but rather to determine if the WG agree that this is where matters now stand.  Please comment if I deviate from what you all agree.

There has been reviews of the draft [1,2,3] by key WG members.  Can the draft authors please comment on next steps with respect to revising the draft.  Enrico and I will start the shepherding step in parallel to the revision to be submitted.

Thanks,

- vijay
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq _______________________________________________

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 3 Dec 2013 06:55:46 +0000

In terms of the text added, I have a preference for not using lower case forms of RFC 2119 language if we can avoid it. The reasoning is that it leads to questions as to whether the upper case form was meant, both in final review, publication, and by developers. If we can find therefore some other wording that expresses the same intent.

I am having trouble thinking of some suitable wording, but my suggestion might be:

"The 'isdn-interwork' value for purpose parameter was used in Internet-Drafts that have led to the publication of the present RFC. Although these documents had no other status than "work in progress", this value is implemented by some vendors. While not defined by this document, implementations could find it useful for interoperability purposes to support parsing and interpreting 'isdn-interwork' the same way as 'isdn-uui' when receiving messages."

I will work through the other comments and respond hopefully later this week.

Keith

> From: cuss [mailto:[email-masked]] On Behalf Of Vijay 
> K. Gurbani
> Sent: 02 December 2013 15:16
> To: [email-masked]
> Below is my personal interpretation of where the matter 
> stands, i.e., what I write below is not written as a co-chair 
> but rather to determine if the WG agree that this is where 
> matters now stand.  Please comment if I deviate from what you 
> all agree.
> 
> There has been reviews of the draft [1,2,3] by key WG 
> members.  Can the draft authors please comment on next steps 
> with respect to revising the draft.  Enrico and I will start 
> the shepherding step in parallel to the revision to be submitted.
> 
> Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent 1960 
> Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
> Web: http://ect.bell-labs.com/who/vkg/  | Calendar: 
> http://goo.gl/x3Ogq _______________________________________________
> cuss mailing list
> [email-masked]

---

From: Atle Monrad <[email-masked]>
Date: Tue, 3 Dec 2013 07:42:04 +0000

Keith

Thanks for a quick reply and an alternative phrase that at least to me also clearly identify the point in an informative way.

Good to hear that your target for completion is end-of-this-week.

cheers
/atle

Atle Monrad
3GPP CT Chairman

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. desember 2013 15:56
To: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Keith

> From: cuss [mailto:[email-masked]] On Behalf Of Vijay K. 
> Gurbani
> what I write below is not written as a co-chair but rather to 
> determine if the WG agree that this is where matters now stand.  
> Please comment if I deviate from what you all agree.
> 
> There has been reviews of the draft [1,2,3] by key WG members.  Can 
> the draft authors please comment on next steps with respect to 
> revising the draft.  Enrico and I will start the shepherding step in 
> parallel to the revision to be submitted.
> 
> Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent 1960 Lucent Lane, 
> Rm. 9C-533, Naperville, Illinois 60563 (USA)

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Dec 2013 08:31:54 +0000

Hi,

I think the text suggested by Keith looks good.

Regards,

Christer

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. joulukuuta 2013 8:56
To: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Keith

---

From: "Belling, Thomas (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 3 Dec 2013 09:41:00 +0000

+1

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of ext Christer Holmberg
Sent: Tuesday, December 03, 2013 9:32 AM
To: DRAGE, Keith (Keith); Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Hi,

Regards,

Christer

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. joulukuuta 2013 8:56
To: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Keith

---

From: <[email-masked]>
Date: Tue, 3 Dec 2013 11:46:14 +0100

+1

Roland

-----Ursprüngliche Nachricht-----
Von: cuss [mailto:[email-masked]] Im Auftrag von Christer Holmberg
Gesendet: Dienstag, 3. Dezember 2013 09:32
An: DRAGE, Keith (Keith); Gurbani, Vijay K (Vijay); [email-masked]
Betreff: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Hi,

Regards,

Christer

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. joulukuuta 2013 8:56
To: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Keith

---

From: "VAN GEEL Jan (CIS/SCC)" <[email-masked]>
Date: Tue, 3 Dec 2013 11:18:03 +0000

+1

Jan Van Geel
IT and Network Specialist
Belgacom CIS/SCC/FVC
Tel: +32 2 202 1035
Tel: +32 2 207 9032
Email : [email-masked]

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday 3 December 2013 11:46
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

+1

Roland

-----Ursprüngliche Nachricht-----
Von: cuss [mailto:[email-masked]] Im Auftrag von Christer Holmberg
Gesendet: Dienstag, 3. Dezember 2013 09:32
An: DRAGE, Keith (Keith); Gurbani, Vijay K (Vijay); [email-masked]
Betreff: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Hi,

Regards,

Christer

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. joulukuuta 2013 8:56
To: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Keith

***** Disclaimer *****
http://www.belgacom.be/maildisclaimer

---

From: Andrew Allen <[email-masked]>
Date: Wed, 4 Dec 2013 02:48:52 +0000

I am also OK with Keith's proposal

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Tuesday, December 03, 2013 3:32 AM
To: DRAGE, Keith (Keith); Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Hi,

Regards,

Christer

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. joulukuuta 2013 8:56
To: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Keith

---

From: <[email-masked]>
Date: Thu, 5 Dec 2013 09:52:20 +0000

Hello,

We also agree with this proposal.

Regards,

Celine Serrut-Valette
Orange Labs

-----Message d'origine-----
De : cuss [mailto:[email-masked]] De la part de Andrew Allen
Envoyé : mercredi 4 décembre 2013 03:49
À : Christer Holmberg; DRAGE, Keith (Keith); Gurbani, Vijay K (Vijay); [email-masked]
Objet : Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Tuesday, December 03, 2013 3:32 AM
To: DRAGE, Keith (Keith); Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Hi,

Regards,

Christer

-----Original Message-----
From: cuss [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. joulukuuta 2013 8:56
To: Gurbani, Vijay K (Vijay); [email-masked]
Subject: Re: [cuss] WGLC done for draft-ietf-cuss-sip-uui-isdn; next steps

Keith

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 13 Dec 2013 18:14:11 +0000

I've included this in section 8 UAS requirements as a new 5th paragraph

Keith 

> Sent: 03 December 2013 06:56
> In terms of the text added, I have a preference for not using 
> lower case forms of RFC 2119 language if we can avoid it. The 
> reasoning is that it leads to questions as to whether the 
> upper case form was meant, both in final review, publication, 
> and by developers. If we can find therefore some other 
> wording that expresses the same intent.
> 
> "The 'isdn-interwork' value for purpose parameter was used in 
> Internet-Drafts that have led to the publication of the 
> present RFC. Although these documents had no other status 
> than "work in progress", this value is implemented by some 
> vendors. While not defined by this document, implementations 
> could find it useful for interoperability purposes to support 
> parsing and interpreting 'isdn-interwork' the same way as 
> 'isdn-uui' when receiving messages."
> 
> stands, i.e., 
> Lucent Lane,