Subject: Re: [Detnet] detnet Digest, Vol 2, Issue 40

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Mon, 29 Sep 2014 09:20:55 +0000

Hi all,

Following the AFDX effort, SAE has started works to endorse Deterministic networking.

Standards development/revision activities

·       AS6003  TTP Communication Protocol

·       AS6066  TTP Physical Layer

·       AS6802  Time-Triggered Ethernet

Not sure you want to mention it or not.

Patrick

From: Pascal THUBERT <[email-masked]<mailto:[email-masked]>>
Date: Monday 29 September 2014 10:17
To: Marcel Kiessling <[email-masked]<mailto:[email-masked]>>, "Ethan Hoewisch (ehoewisc)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] detnet Digest, Vol 2, Issue 40

Dear Ethan and Marcel:

I tried to include both of your suggestions and generalize a bit as I suggested to Ethan.

This got me with the following text for the background. Is that covering sufficient space now?

Background on deterministic networking

Operational Technology (OT) refers to industrial networks that are typically used for monitoring systems and supporting control loops, as well as movement detection systems for use in process control (i.e., process manufacturing) and factory automation (i.e., discrete manufacturing). Due to its different goals, OT has evolved in parallel but in a manner that is radically different from IT/ICT, focusing on highly secure, reliable and deterministic networks, with limited scalability over a bounded area.

The convergence of IT and OT technologies, also called the Industrial Internet, represents a major evolution for both sides. The work has already started; in particular, the industrial automation space has been developing a number of Ethernet-based replacements for existing digital control systems, often not packet-based (“fieldbus” technologies). These replacements are meant to provide similar behavior as the incumbent protocols, and their common focus is to transport a fully characterized flow over a well-controlled environment (i.e., a factory floor), with a bounded latency, extraordinarily low frame loss, and a very narrow jitter. Examples of such protocols include PROFINET, ODVA Ethernet/IP, and EtherCAT.
In parallel, the need for determinism in professional and home audio/video markets drove the formation of the Audio/Video Bridging (AVB) standards effort of IEEE 802.1. With the explosion of demand for connectivity and multimedia in transportation in general, the Ethernet AVB technology has become one of the hottest topics, in particular in the automotive connectivity. It is finding application in all elements of the vehicle from head units, to rear seat entertainment modules, to amplifiers and camera modules. While aimed at less critical applications than some industrial networks, AVB networks share the requirement for extremely low packet loss rates and guaranteed finite latency and jitter.

Other instances of in-vehicle deterministic networks have arisen as well for control networks in cars, trains and buses, as well as and avionics, with, for instance, the mission-critical “Avionics Full-Duplex Switched Ethernet” (AFDX) that was designed as part of the ARINC 664 standards. Existing automotive control networks such as the LIN, CAN and FlexRay standards were not designed to cover these increasing demands in terms of bandwidth and scalability that we see with various kinds of Driver Assistance Systems (DAS) and new multiplexing technologies based on Ethernet are now getting traction.

The generalization of the needs for more deterministic networks have led to the IEEE 802.1 AVB Task Group becoming the Time-Sensitive Networking (TSN) Task Group (TG), with a much-expanded constituency from the industrial and vehicular markets. Along with this expansion, the networks in consideration are becoming larger and structured, requiring deterministic forwarding beyond the LAN boundaries. For instance, Industrial Automation segregates the network along the broad lines of the Purdue Enterprise Reference Architecture (PERA), using different technologies at each level, and public infrastructures such as Electricity Automation require deterministic properties over the Wide Area. The realization is now coming that the convergence of IT and OT networks requires Layer-3, as well as Layer-2, capabilities.

In order to serve this extended requirement, the IETF and the IEEE must collaborate and define an abstract model that can be applicable both at Layer-2 and Layer-3, and along segments of different technologies. With this new work, a path may span, for instance, across a (limited) number of 802.1 bridges and then a (limited) number of IP routers. In that example, the IEEE802.1 bridges may be operating at Layer-2 over Ethernet whereas the IP routers may be 6TiSCH nodes operating at Layer-2 and/or Layer-3 over the IEEE802.15.4e MAC. The proposed model should enable a fully scheduled operation orchestrated by a central controller, as well as a more distributed operation with probably lesser capabilities. In any fashion, the model should not compromise the ability of a network to keep carrying the sorts of traffic that is already carried today.

Once the abstract model is agreed upon, the IETF will need to specify the signaling elements to be used to establish a path and the tagging elements to be used identify the flows that are to be forwarded along that path. The IETF will also need to specify the necessary protocols, or protocol additions, based on relevant IETF technologies such as PCE, MPLS and 6TiSCH, to implement the selected model. As a result of this work, it will be possible to establish a multi-hop path over the IP network, for a particular flow with precise timing and throughput requirements, and carry this particular flow along the multi-hop path with such characteristics as low latency and ultra-low jitter, duplication and elimination of packets over non-congruent paths for a higher delivery ratio, and/or zero congestion loss. Depending on the network capabilities and on the current state, requests to establish a path by an end-node or a network management entity may be granted or rejected, and an existing path may be moved or removed.

Please note that I am using http://trac.tools.ietf.org/bof/trac/wiki/DetNet to store a copy of the WIP charter but ultimately the two documents would fork.
I maintain a public copy here : https://bitbucket.org/pthubert/detnet/raw/master/detnet%20charter.txt that you can probably edit (to be validated).

Cheers,

Pascal

From: Marcel Kiessling [mailto:[email-masked]]
Sent: lundi 29 septembre 2014 09:11
To: Pascal Thubert (pthubert)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: detnet Digest, Vol 2, Issue 40

Hi Pascal,

thanks for your work.

I think we can add a list after "vehicles" to clarify the intended networks.
It is helpful for a better understanding to explicitly list some vehicles, e.g. "in the context of vehicles (including control networks in cars, trains and buses)".

I also found one little typo:
"which was designed as part of the ARIC 664 standard" --> ARINC 664

Cheers,
Marcel

---------- Forwarded message ----------
From: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
To: "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Cc: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, Jouni Korhonen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Sat, 27 Sep 2014 06:52:11 +0000
Subject: Re: [Detnet] almost final charter proposal
Thanks Ethan!

We are actually listing "vehicles" in the proposed charter text to mean cars trains and buses control networks on top of avionics.

Should we have more emphasis?

Pascal

Le 26 sept. 2014 à 20:18, Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>> a écrit :
A couple more very tiny typos:

1) "Once the abstract model is agreed upon, the IETF will need to specify the signaling elements to be used to establish a path and the tagging elements to be used identify the flows that are to be forwarded along that path. the IETF" (--> The IETF).

2) "The Working Group will initially specify the protocol elements that are required to enable an multi-hop path" (--> a multi-hop path)

3) No mention of automotive - assume that is intentional since not internet related?

Ethan.

---

From: Marcel Kiessling <[email-masked]>
Date: Mon, 29 Sep 2014 13:23:34 +0200

Dear Pascal,

I think the background is now better understandable to people that are not
familiar with the AVB usage.

You changed a sentence that sounds incorrect to me, but I am not sure if it
is a typo:
"as well as and avionics" after the changed description of the background.

Marcel

On Mon, Sep 29, 2014 at 11:20 AM, Patrick Wetterwald (pwetterw) <
[email-masked]> wrote:

>   From: Pascal THUBERT <[email-masked]>
> To: Marcel Kiessling <[email-masked]>, "Ethan Hoewisch
> (ehoewisc)" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Operational Technology (OT) refers to industrial networks that are
> typically used for monitoring systems and supporting control loops, as well
> as movement detection systems for use in process control (i.e., process
> manufacturing) and factory automation (i.e., discrete manufacturing). Due
> to its different goals, OT has evolved in parallel but in a manner that is
> radically different from IT/ICT, focusing on highly secure, reliable and
> deterministic networks, with limited scalability over a bounded area.
>
>
>
> The convergence of IT and OT technologies, also called the Industrial
> Internet, represents a major evolution for both sides. The work has already
> started; in particular, the industrial automation space has been developing
> a number of Ethernet-based replacements for existing digital control
> systems, often not packet-based (“fieldbus” technologies). These
> replacements are meant to provide similar behavior as the incumbent
> protocols, and their common focus is to transport a fully characterized
> flow over a well-controlled environment (i.e., a factory floor), with a
> bounded latency, extraordinarily low frame loss, and a very narrow jitter.
> Examples of such protocols include PROFINET, ODVA Ethernet/IP, and EtherCAT.
>
>  In parallel, the need for determinism in professional and home
> audio/video markets drove the formation of the Audio/Video Bridging (AVB)
> standards effort of IEEE 802.1. With the explosion of demand for
> connectivity and multimedia in transportation in general, the Ethernet AVB
> technology has become one of the hottest topics, in particular in the
> automotive connectivity. It is finding application in all elements of the
> vehicle from head units, to rear seat entertainment modules, to amplifiers
> and camera modules. While aimed at less critical applications than some
> industrial networks, AVB networks share the requirement for extremely low
> packet loss rates and guaranteed finite latency and jitter.
>
>
>
> Other instances of in-vehicle deterministic networks have arisen as well
> for control networks in cars, trains and buses, as well as and avionics,
> with, for instance, the mission-critical “Avionics Full-Duplex Switched
> Ethernet” (AFDX) that was designed as part of the ARINC 664 standards.
> Existing automotive control networks such as the LIN, CAN and FlexRay
> standards were not designed to cover these increasing demands in terms of
> bandwidth and scalability that we see with various kinds of Driver
> Assistance Systems (DAS) and new multiplexing technologies based on
> Ethernet are now getting traction.
>
>
>
> The generalization of the needs for more deterministic networks have led
> to the IEEE 802.1 AVB Task Group becoming the Time-Sensitive Networking
> (TSN) Task Group (TG), with a much-expanded constituency from the
> industrial and vehicular markets. Along with this expansion, the networks
> in consideration are becoming larger and structured, requiring
> deterministic forwarding beyond the LAN boundaries. For instance,
> Industrial Automation segregates the network along the broad lines of the
> Purdue Enterprise Reference Architecture (PERA), using different
> technologies at each level, and public infrastructures such as Electricity
> Automation require deterministic properties over the Wide Area. The
> realization is now coming that the convergence of IT and OT networks
> requires Layer-3, as well as Layer-2, capabilities.
>
>
>
> In order to serve this extended requirement, the IETF and the IEEE must
> collaborate and define an abstract model that can be applicable both at
> Layer-2 and Layer-3, and along segments of different technologies. With
> this new work, a path may span, for instance, across a (limited) number of
> 802.1 bridges and then a (limited) number of IP routers. In that example,
> the IEEE802.1 bridges may be operating at Layer-2 over Ethernet whereas the
> IP routers may be 6TiSCH nodes operating at Layer-2 and/or Layer-3 over the
> IEEE802.15.4e MAC. The proposed model should enable a fully scheduled
> operation orchestrated by a central controller, as well as a more
> distributed operation with probably lesser capabilities. In any fashion,
> the model should not compromise the ability of a network to keep carrying
> the sorts of traffic that is already carried today.
>
>
>
> Once the abstract model is agreed upon, the IETF will need to specify the
> signaling elements to be used to establish a path and the tagging elements
> to be used identify the flows that are to be forwarded along that path. The
> IETF will also need to specify the necessary protocols, or protocol
> additions, based on relevant IETF technologies such as PCE, MPLS and
> 6TiSCH, to implement the selected model. As a result of this work, it will
> be possible to establish a multi-hop path over the IP network, for a
> particular flow with precise timing and throughput requirements, and carry
> this particular flow along the multi-hop path with such characteristics as
> low latency and ultra-low jitter, duplication and elimination of packets
> over non-congruent paths for a higher delivery ratio, and/or zero
> congestion loss. Depending on the network capabilities and on the current
> state, requests to establish a path by an end-node or a network management
> entity may be granted or rejected, and an existing path may be moved or
> removed.
>
>
>
>
>
>
>
> Please note that I am using
> http://trac.tools.ietf.org/bof/trac/wiki/DetNet to store a copy of the
> WIP charter but ultimately the two documents would fork.
>
> I maintain a public copy here :
> https://bitbucket.org/pthubert/detnet/raw/master/detnet%20charter.txt
> that you can probably edit (to be validated).
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* Marcel Kiessling [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* lundi 29 septembre 2014 09:11
> *To:* Pascal Thubert (pthubert)
> *Cc:* [email-masked]
> *Subject:* Re: detnet Digest, Vol 2, Issue 40
>
>
>
> Hi Pascal,
>
>
>
> thanks for your work.
>
>
>
> It is helpful for a better understanding to explicitly list some vehicles,
> e.g. "in the context of vehicles (including control networks in cars,
> trains and buses)".
>
>
>
> "which was designed as part of the ARIC 664 standard" --> ARI*N*C 664
>
>
>
> Cheers,
>
> Marcel
>
>
>
> From: "Pascal Thubert (pthubert)" <[email-masked]>
> To: "Grossman, Ethan A." <[email-masked]>
> Cc: Thomas Watteyne <[email-masked]>, Jouni Korhonen <
> [email-masked]>, "[email-masked]" <[email-masked]>
> We are actually listing "vehicles" in the proposed charter text to mean
> cars trains and buses control networks on top of avionics.
>
>
>
> Le 26 sept. 2014 à 20:18, Grossman, Ethan A. <[email-masked]> a écrit :
>
> 1) "Once the abstract model is agreed upon, the IETF will need to specify
> the signaling elements to be used to establish a path and the tagging
> elements to be used identify the flows that are to be forwarded along that
> path. the IETF" (--> The IETF).
>
>
>
> 2) "The Working Group will initially specify the protocol elements that
> are required to enable an multi-hop path" (--> a multi-hop path)
>
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 29 Sep 2014 11:53:07 +0000

I had spotted it as well, Marcel.

It is now fixed on the web page (removed the ‘and’ that was replaced by ‘as well as’).

Cheers,

Pascal

From: Marcel Kiessling [mailto:[email-masked]]
Sent: lundi 29 septembre 2014 13:24
To: Pascal Thubert (pthubert); [email-masked]
Subject: Re: [Detnet] detnet Digest, Vol 2, Issue 40

Dear Pascal,

I think the background is now better understandable to people that are not familiar with the AVB usage.

You changed a sentence that sounds incorrect to me, but I am not sure if it is a typo:
"as well as and avionics" after the changed description of the background.

Marcel

On Mon, Sep 29, 2014 at 11:20 AM, Patrick Wetterwald (pwetterw) <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Patrick

Dear Ethan and Marcel:

Cheers,

Pascal

Hi Pascal,

thanks for your work.

Cheers,
Marcel

---------- Forwarded message ----------
From: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
To: "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Cc: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, Jouni Korhonen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Sat, 27 Sep 2014 06:52:11 +0000
Subject: Re: [Detnet] almost final charter proposal
Thanks Ethan!

Pascal

Ethan.