Subject: Re: [Detnet] almost final charter proposal

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 29 Sep 2014 07:22:56 +0000

Hello again Ethan:

Do you think that there is a chance to extend automotive requirements to in-board control systems as well as A/V? In understand that planes have a number of networks (at least 3) with different usages and safety requirements. A generalizing sentence at the end of your text would help fit it in.

I also understand that there is an effort to converge some buses from specific technologies such as CAN (and/or interface them through gateway) onto more generic technologies such as 100Mbps Ethernet over unshielded twisted pairs (UTP).
http://www.automotive-eetimes.com/en/ip-and-ethernet-in-motor-vehicles.html?cmp_id=71&news_id=222902889

Shall we need determinism in the Ethernet side? Shall we need deterministic properties across the CAN/Ethernet gateway? Shall we need determinism to the garage infrastructure to perform tests and diagnostics? Is there a case for deterministic wireless in such an environment dominated by metallic structures?

I think we need a problem statement draft for automotive alone. Would you be willing to lead that effort?

Cheers,

Pascal

From: Grossman, Ethan A. [mailto:[email-masked]]
Sent: samedi 27 septembre 2014 10:16
To: Pascal Thubert (pthubert)
Cc: Thomas Watteyne; Jouni Korhonen; [email-masked]
Subject: RE: [Detnet] almost final charter proposal

Hi Pascal (A friend of Norm's is a friend of mine ;-)

On the one hand my take is that at least half a sentence should be devoted, given the depth of contribution of the Automotive community to the AVB standards, and that it is a hot topic in that industry:

"With the explosion of demand for connectivity and multimedia in the automobile, the need for standards-based A/V networking that can be easily deployed has been growing. Ethernet AVB (Audio Video Bridging) has become one of the hottest topics in automotive connectivity. It is finding application in all elements of the car from head units, to rear seat entertainment modules, to amplifiers and camera modules. Furthermore, existing vehicle control networks such as the LIN, CAN and FlexRay standards are not designed to cover these increasing demands in terms of bandwidth and scalability that we see with various kinds of Driver Assistance Systems (DAS)." (http://www.xzadium.com/blog/avb-emerging-technology-in-audio-video-transmission)

But on the other hand, Automotive AVB systems tend to be closed systems, and thus perhaps are not as "interesting" to the IETF crowd (I have no idea if this is true). Anyway if one feels it is worthwhile to add a few more words, perhaps the above could provide some ideas.

Best,
Ethan.

________________________________
From: Pascal Thubert (pthubert) [[email-masked]]
Sent: Friday, September 26, 2014 11:52 PM
To: Grossman, Ethan A.
Cc: Thomas Watteyne; Jouni Korhonen; [email-masked]<mailto:[email-masked]>
Subject: Re: [Detnet] almost final charter proposal
Thanks Ethan!

We are actually listing "vehicles" in the proposed charter text to mean cars trains and buses control networks on top of avionics.

Should we have more emphasis?

Pascal

Le 26 sept. 2014 à 20:18, Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>> a écrit :
A couple more very tiny typos:

1) "Once the abstract model is agreed upon, the IETF will need to specify the signaling elements to be used to establish a path and the tagging elements to be used identify the flows that are to be forwarded along that path. the IETF" (--> The IETF).

2) "The Working Group will initially specify the protocol elements that are required to enable an multi-hop path" (--> a multi-hop path)

3) No mention of automotive - assume that is intentional since not internet related?

Ethan.

________________________________
From: Thomas Watteyne [[email-masked]<mailto:[email-masked]>]
Sent: Friday, September 26, 2014 11:02 AM
To: Jouni Korhonen
Cc: Pascal Thubert (pthubert); [email-masked]<mailto:[email-masked]>
Subject: Re: [Detnet] almost final charter proposal
+1

Congratulations to all for the fantastic work, this will be a very good activity to have at the IETF.

(very) minor typos:
- focusses -> focuses
- IEEE801.1TSN -> IEEE802.1TSN

On Fri, Sep 26, 2014 at 3:57 AM, Jouni Korhonen <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Pascal. Looks good to me now.
--
Jouni Korhonen
Broadcom

(Sent from my mobile..)

"Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>> kirjoitti 26.9.2014 kello 13.15:
detnet: "deterministic networking"

Background on deterministic networking

Operational Technology (OT) refers to industrial networks that are typically used for monitoring systems and supporting control loops, as well as movement detection systems for use in process control (i.e., process manufacturing) and factory automation (i.e., discrete manufacturing). Due to its different goals, OT has evolved in parallel but in a manner that is radically different from IT/ICT, focusing on highly secure, reliable and deterministic networks, with limited scalability over a bounded area.

The convergence of IT and OT technologies, also called the Industrial Internet, represents a major evolution for both sides. The work has already started; in particular, the industrial automation space has been developing a number of Ethernet-based replacements for existing digital control systems, often not packet-based ("fieldbus" technologies). These replacements are meant to provide similar behavior as the incumbent protocols, and their common focus is to transport a fully characterized flow over a well-controlled environment (i.e., a factory floor), with a bounded latency, extraordinarily low frame loss, and a very narrow jitter. Examples of such protocols include PROFINET, ODVA Ethernet/IP, and EtherCAT.

In parallel, the need for determinism drove the formation of the Audio/Video Bridging (AVB) standards effort of IEEE 802.1, destined to the professional and home audio/video markets. While aimed at less critical applications than some industrial networks, AVB networks share the requirement for extremely low packet loss rates and guaranteed finite latency and jitter. Other instances of deterministic networks have arisen as well, for instance in the context of vehicles and avionics, such as the mission-critical "Avionics Full-Duplex Switched Ethernet" (AFDX), which was designed as part of the ARIC 664 standards.

The success of the 802.1 AVB standards in the professional studio environment and the needs of the industrial networking markets have led to the IEEE 802.1 AVB Task Group becoming the Time-Sensitive Networking (TSN) Task Group (TG), with a much-expanded constituency from the industrial and vehicular markets. Along with this expansion, the networks in consideration are becoming larger and structured, and require deterministic forwarding beyond the LAN boundaries. For instance, Industrial Automation segregates the network along the broad lines of the Purdue Enterprise Reference Architecture (PERA), using different technologies at each level, and public infrastructures such as Electricity Automation require deterministic properties over the Wide Area. The realization is now coming that the convergence of IT and OT networks requires Layer-3, as well as Layer-2, capabilities.

In order to serve this extended requirement, the IETF and the IEEE must collaborate and define an abstract model that can be applicable both at Layer-2 and Layer-3, and along segments of different technologies. With this new work, a path may span, for instance, across a (limited) number of 802.1 bridges and then a (limited) number of IP routers. In that example, the IEEE802.1 bridges may be operating at Layer-2 over Ethernet whereas the IP routers may be 6TiSCH nodes operating at Layer-2 and/or Layer-3 over the IEEE802.15.4e MAC. The proposed model should enable a fully scheduled operation orchestrated by a central controller, as well as a more distributed operation with probably lesser capabilities. In any fashion, the model should not compromise the ability of a network to keep carrying the sorts of traffic that is already carried today.

Once the abstract model is agreed upon, the IETF will need to specify the signaling elements to be used to establish a path and the tagging elements to be used identify the flows that are to be forwarded along that path. the IETF will also need to specify the necessary protocols, or protocol additions, based on relevant IETF technologies such as PCE, MPLS and 6TiSCH, to implement the selected model. As a result of this work, it will be possible to establish an multi-hop path over the IP network, for a particular flow with precise timing and throughput requirements, and carry this particular flow along the multi-hop path with such characteristics as low latency and ultra-low jitter, duplication and elimination of packets over non-congruent paths for a higher delivery ratio, and/or zero congestion loss. Depending on the network capabilities and on the current state, requests to establish a path by na end-node or a network management entity may be granted or rejected, and an existing path may be moved or removed.

WG description

The deterministic networking Working Group (detnet) will focus on the establishment and maintenance of multi-hop paths over Layer-2 Bridged and Layer-3 routed segments. Though only Layer-3 operations will be specified by the WG as Standard Track documents, the group will collaborate with IEEE802.1TSN, which designs the Layer-2 operations, to define a common paradigm, leveraging cross-participation and liaison work to maintain consistency. In that common paradigm, a number of elements such as the host operation should be agnostic to the organization of the multi-hop path.

The considered network will initially be of a moderate size, composed of mixed Layer-2 / Layer-3 sub-networks of IEEE802.1 bridges, routers, and hosts. A single administrative domain such as a campus, a Small/Home office Network, or a controlled Wide Area Network will be assumed to start with, and approaches that can be applied to the Internet at large will be favored.
The Working Group will initially specify the protocol elements that are required to enable an multi-hop path, and forward along that path with the deterministic properties of controlled latency, low packet loss, ultra-low jitter, and high reliability. The work will apply to and only to flows that can be characterized in a manner that allows the network to 1) reserve the appropriate resources for the flows in advance, and 2) release/reuse the resources when they are no more required. The work will cover the characterization of flows, the tagging of packets, the required forwarding behaviors, as well as the state that may need to be established in intermediate nodes; it will not include end-to-end consideration such as transport protocols. This work focusses on flows and does not depend on the path setup protocol that will be selected. The data models and flow tagging should be compatible with the similar work done at IEEE801.1TSN so they could be either directly usable at both layers, or mappable in an unambiguous fashion.
The WG will interface with other appropriate groups in the IETF in the Internet (e.g. 6TiSCH), Transport (e.g. TSVWG), Operations and Management, Routing and Security areas. As the work progresses, some of the items initially considered the deterministic networking WG may be transferred to those working groups as deemed appropriate by all parties.

The WG will conclude this round with the selection of a solution paradigm and suggest a base protocol that can be applied or extended.
Work Items

- Deliverables:

  * An analysis of the needs in various deployment environments. 3-4 informational track documents which could include factory automation, grid automation, avionics and audio/video studios.

  * A generic problem statement including an analysis of the proposed solutions of the related work at IEEE802.1TSN.

  * A study of generic scoping. For IPv6, the study will include the definition of Link-Local, Realm-Local and Admin-Local scoped operation (as per RFC 7346). For instance, the deterministic technology needs to be consistent over a Link- or a Realm-Local scope and achievable across technologies and layers over an Admin-Local scope. Similar scoping will be studied for IPv4.

  * A solution taxonomy, where potential solution paradigms will be explored, such as peer-to-peer protocols (along the lines of MSRP or RSVP), central controller (along the lines of SDN or PCE), connection to operations (application) controllers, and mixed scenarios, in relation to the generic scoping of IP.
  * A standards track data flow characterization model document for use in flow reservation protocol. The model should be independent from the protocol(s) that are selected from the solution taxonomy (e.g. an evolution of PCEP or RSVP).

  * A standards track flow identification document for use in packet forwarding, with the specific application to at least classical IP, 6TiSCH track forwarding, and MPLS.

  * A standards track data model for the abstract state to be installed in the forwarding device and the associated packet forwarding behavior.

  The WG will conclude this round with the selection of a paradigm and a base protocol that can be applied or extended.

Cheers,

Pascal
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v1/url?u=https://www.ietf.org/mailman/listinfo/detnet&k=UrRpYe6NZ%2F2y3fFcm1dpZA%3D%3D%0A&r=oIBsd6zVa3NydYM8E7NmP5Ygimfr0ucB13K%2FaVFvYLE%3D%0A&m=5Z3Md9DQuyTl9Lhy3ThHYKiHUoaudmhRwwCNgTWLQ5g%3D%0A&s=6c7a1ae910ebfd83487812a7e05977b2f2776396e8aa2a5afdf53ba7813bb38b>

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v1/url?u=https://www.ietf.org/mailman/listinfo/detnet&k=UrRpYe6NZ%2F2y3fFcm1dpZA%3D%3D%0A&r=oIBsd6zVa3NydYM8E7NmP5Ygimfr0ucB13K%2FaVFvYLE%3D%0A&m=5Z3Md9DQuyTl9Lhy3ThHYKiHUoaudmhRwwCNgTWLQ5g%3D%0A&s=6c7a1ae910ebfd83487812a7e05977b2f2776396e8aa2a5afdf53ba7813bb38b>

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Mon, 29 Sep 2014 16:02:13 +0000

Hi Pascal,
I am not really the guy for details on AVB for Automotive, but I am including Gordon Bechtel, who is the guy. Gordy, can you please have a look at this thread and comment, and bring in anyone else you think should be involved?
Thanks,
Ethan.
________________________________
From: Pascal Thubert (pthubert) [[email-masked]]
Sent: Monday, September 29, 2014 12:22 AM
To: Grossman, Ethan A.
Cc: Thomas Watteyne; Jouni Korhonen; [email-masked]
Subject: RE: [Detnet] almost final charter proposal

Hello again Ethan:

I also understand that there is an effort to converge some buses from specific technologies such as CAN (and/or interface them through gateway) onto more generic technologies such as 100Mbps Ethernet over unshielded twisted pairs (UTP).
http://www.automotive-eetimes.com/en/ip-and-ethernet-in-motor-vehicles.html?cmp_id=71&news_id=222902889<https://urldefense.proofpoint.com/v1/url?u=http://www.automotive-eetimes.com/en/ip-and-ethernet-in-motor-vehicles.html?cmp_id%3D71%26news_id%3D222902889&k=UrRpYe6NZ%2F2y3fFcm1dpZA%3D%3D%0A&r=dPU%2BBUuPbDtLfSGFUfCLwQ%3D%3D%0A&m=0Us%2Byu2%2BRS2%2BawmIAHeVz3w4u%2FRUgYkkvMhLpks%2BWVA%3D%0A&s=ccd12b46c51558cb62e0f50640e3bea5ab6051647871420936d7f954f3ad5eb3>

Cheers,

Pascal

"With the explosion of demand for connectivity and multimedia in the automobile, the need for standards-based A/V networking that can be easily deployed has been growing. Ethernet AVB (Audio Video Bridging) has become one of the hottest topics in automotive connectivity. It is finding application in all elements of the car from head units, to rear seat entertainment modules, to amplifiers and camera modules. Furthermore, existing vehicle control networks such as the LIN, CAN and FlexRay standards are not designed to cover these increasing demands in terms of bandwidth and scalability that we see with various kinds of Driver Assistance Systems (DAS)." (http://www.xzadium.com/blog/avb-emerging-technology-in-audio-video-transmission<https://urldefense.proofpoint.com/v1/url?u=http://www.xzadium.com/blog/avb-emerging-technology-in-audio-video-transmission&k=UrRpYe6NZ%2F2y3fFcm1dpZA%3D%3D%0A&r=dPU%2BBUuPbDtLfSGFUfCLwQ%3D%3D%0A&m=0Us%2Byu2%2BRS2%2BawmIAHeVz3w4u%2FRUgYkkvMhLpks%2BWVA%3D%0A&s=2d803d4700207408064080bdaa15225ad07d699177e4cbc0b51147a742fd3d13>)

Best,
Ethan.

Pascal

Ethan.

(very) minor typos:
- focusses -> focuses

(Sent from my mobile..)

The convergence of IT and OT technologies, also called the Industrial Internet, represents a major evolution for both sides. The work has already started; in particular, the industrial automation space has been developing a number of Ethernet-based replacements for existing digital control systems, often not packet-based (“fieldbus” technologies). These replacements are meant to provide similar behavior as the incumbent protocols, and their common focus is to transport a fully characterized flow over a well-controlled environment (i.e., a factory floor), with a bounded latency, extraordinarily low frame loss, and a very narrow jitter. Examples of such protocols include PROFINET, ODVA Ethernet/IP, and EtherCAT.

In parallel, the need for determinism drove the formation of the Audio/Video Bridging (AVB) standards effort of IEEE 802.1, destined to the professional and home audio/video markets. While aimed at less critical applications than some industrial networks, AVB networks share the requirement for extremely low packet loss rates and guaranteed finite latency and jitter. Other instances of deterministic networks have arisen as well, for instance in the context of vehicles and avionics, such as the mission-critical “Avionics Full-Duplex Switched Ethernet” (AFDX), which was designed as part of the ARIC 664 standards.

WG description

- Deliverables:

Cheers,

Pascal