Subject: [Detnet] Which Area for DetNet?

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Wed, 17 Sep 2014 18:51:00 +0000

Let’s get this important discussion going.  In which Area should DetNet
go?  I heard a number of suggestions in Toronto, but let’s get them out on
the list.  RTAI and Internet are the two that have been mentioned to me
most often.  Any others?  Any strong opinions?

— Norm

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 17 Sep 2014 23:12:03 +0000

Norm,

My preference would be routing area. Just that tictoc is under internet area does not mean detnet needs to be there. Then again I would prefer transport area over rtai, since transport protocols and queuing are done in transport. 

Jouni

-- 
Jouni Korhonen
Broadcom

(Sent from my mobile..)

> "Norman Finn (nfinn)" <[email-masked]> kirjoitti 18.9.2014 kello 2.51:
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: James Polk <[email-masked]>
Date: Wed, 17 Sep 2014 18:35:31 -0500

Unofficially, IMO, this is a transport area subject.

You have asked for a new EF codepoint - that's transport.
You deal with congestion control issues - that's transport.

At 06:12 PM 9/17/2014, Jouni Korhonen wrote:
>Norm,
>
>My preference would be routing area. Just that 
>tictoc is under internet area does not mean 
>detnet needs to be there. Then again I would 
>prefer transport area over rtai, since transport 
>protocols and queuing are done in transport.
>
>Jouni
>
>--
>Jouni Korhonen
>Broadcom
>
>(Sent from my mobile..)
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 18 Sep 2014 06:50:07 +0000

Yes, Jim,

clearly the detnet work will push problems to transport area. But the work is between L2 and L3 as opposed to L4.

I understand that PCE is in Routing Area, which tends to indicate that the work could happen there. But it has a lot to with forwarding and signaling and little to do with routing.

My preferred bet would be Internet Area, and Routing would be second. Ultimately that is not our decision but that of the IESG after the BoF is successful.
So there is not emergency there, what we really need is an AD who is sensitive to the issues at hand and willing to help us carry the work out.

I see that Alia stepped in the discussion. So maybe that problem is already solved and we do not know it?

Cheers,

Pascal

> -----Original Message-----
> From: detnet [mailto:[email-masked]] On Behalf Of James Polk
> (jmpolk)
> Sent: jeudi 18 septembre 2014 01:36
> To: Jouni Korhonen
> Cc: [email-masked]
> Subject: Re: [Detnet] Which Area for DetNet?
> 
> >My preference would be routing area. Just that tictoc is under internet
> >area does not mean detnet needs to be there. Then again I would prefer
> >transport area over rtai, since transport protocols and queuing are
> >done in transport.
> >
> >Jouni
> >
> >--
> >Jouni Korhonen
> >Broadcom
> >
> >(Sent from my mobile..)
> >
> > > Let's get this important discussion going.  In which Area should
> > > DetNet go?  I heard a number of suggestions in Toronto, but let's
> > > get them out on the list.  RTAI and Internet are the two that have
> > > been mentioned to me most often.  Any others?  Any strong opinions?
> > >
> > > - Norm
> > >

---

From: Alia Atlas <[email-masked]>
Date: Thu, 18 Sep 2014 08:51:16 -0400

Pascal,

While I did join the list to monitor and in case it made sense in routing,
I haven't actually seen any materials or details to form an opinion.  If you
can send me pointers, I can read them.  I did also ping Martin & Spencer
to see if they were aware of detnet.

Regards,
Alia

On Thu, Sep 18, 2014 at 2:50 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> I understand that PCE is in Routing Area, which tends to indicate that the
> work could happen there. But it has a lot to with forwarding and signaling
> and little to do with routing.
>
> My preferred bet would be Internet Area, and Routing would be second.
> Ultimately that is not our decision but that of the IESG after the BoF is
> successful.
> So there is not emergency there, what we really need is an AD who is
> sensitive to the issues at hand and willing to help us carry the work out.
>

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Fri, 19 Sep 2014 16:46:21 +0000

This introductory slide deck was presented at an IEEE 801.1-sponsored side meeting at IETF90:

http://www.ieee802.org/1/files/public/docs2014/tsn-nfinn-Deterministic-Networking-L2-L3-0714-v1.pdf

It’s a start.  See also Pascal’s postings and mine on this (still fairly short) mailing list.

— Norm

From: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 18, 2014 at 05:51 AM
To: Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Cc: Jouni Korhonen <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "James Polk (jmpolk)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] Which Area for DetNet?

Pascal,

Regards,
Alia

On Thu, Sep 18, 2014 at 2:50 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Yes, Jim,

Cheers,

Pascal

> From: detnet [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of James Polk
> (jmpolk)
> Cc: [email-masked]<mailto:[email-masked]>
> > > "Norman Finn (nfinn)" <[email-masked]<mailto:[email-masked]>> kirjoitti 18.9.2014 kello 2.51:
> > >
> > > [email-masked]<mailto:[email-masked]>
> >[email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet