Subject: [Detnet] Compilation of documents available to the IESG for BoF evaluation

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 25 Sep 2014 15:42:10 +0000

Dear all:

Please let me know if I missed important references (and thanks Craig!)

IEEE 802.1 AVB/TSN references

*        Forwarding and Queuing (IEEE 802.1Qav-2009): http://standards.ieee.org/getieee802/download/802.1Qav-2009.pdf

*        Stream Reservation Protocol (IEEE 802.1Qat-2010): http://standards.ieee.org/getieee802/download/802.1Qat-2010.pdf

*        Timing and Synchronizations (IEEE 802.1AS-2011): http://standards.ieee.org/getieee802/download/802.1AS-2011.pdf

*        AVB Systems (IEEE 802.1BA-2011): http://standards.ieee.org/getieee802/download/802.1BA-2011.pdf

Note that 802.1Qav-2009 and 802.1Qat-2010 have been rolled into the publication of IEEE 802.1Q-2011.
MAC Bridges and VLANs (IEEE 802.1Q-2011): http://standards.ieee.org/getieee802/download/802.1Q-2011.pdf

See also the section on TSN ongoing work in: http://www.ieee802.org/1/

IETF references

*        Deterministic flow tagging  https://tools.ietf.org/html/draft-svshah-tsvwg-deterministic-forwarding

*        Deterministic track establishment and forwarding https://tools.ietf.org/html/draft-ietf-6tisch-architecture

*        Industrial applicability of RPL https://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability

*        Industrial requirements for RPL https://tools.ietf.org/html/RFC5673

ISA100.11a-2011 / IEC 62734 links

A copy of the standard appears to be posted here: http://www.2shared.com/document/FtlhGiHh/ISA-100-11a-2011.html but I cannot say if it is original and legal to get it.
More information in http://books.google.co.uk/books?id=RZ1BBAAAQBAJ&pg=SA32-PA3&lpg=SA32-PA3&dq=ISA100.11a-2011&source=bl&ots=_sOsbwH5fi&sig=FCOrHarKEtVibdS8oeH37vh7JXo&hl=fr&sa=X&ei=ADYkVJ7MM4rKaKT7gsgJ&ved=0CDkQ6AEwAzgK#v=onepage&q=ISA100.11a-2011&f=false
More at http://en.wikipedia.org/wiki/ISA100.11a and http://www.isa100wci.org/en-US/Documents/PDF/3405-ISA100-WirelessSystems-Future-broch-WEB-ETSI.aspx

Other resources

https://www.tttech.com/fileadmin/content/general/files/pdf/company/academic/publications/2014_Towards_Synchronous_Deterministic_Channels_for_the_Internet_of_Things.pdf

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 25 Sep 2014 21:26:45 +0000

Pascal, all,

Thanks for the hard work. I have few comments and edit proposals on the latest revision of the text:

1) “duplication and elimination over non-congruent paths, and/or zero congestion loss. Depending on the network capabilities and on the current state, requests may be granted or rejected, and the associated reservation may be moved or cancelled.   “

* Duplication and elimination of what? Packets or paths?
* Request may be granted.. who send requests and granted/rejected by whom?

2) “be of moderate size, composed of mixed Layer 2 / Layer 3 sub-networks of IEEE802.1 bridges,”

* s/Layer 2/Layer-2
* s/Layer 3/Layer-3

3) “multi-hop paths over Layer-2 Bridged and Layer-3 routed segments.”

* Using ‘segment’ here does not sound good to me. Maybe
  “multi-hop paths over Layer-2 Bridged LANs and Layer-3 routed networks.”  ??

4) “The WG will interface with other appropriate groups in the IETF in the Internet (e.g. 6TiSCH), Transport (e.g. TSVWG),”

* Do we need to list WGs here? I rather avoid that, since if we do so, I would have few others to add here. I propose removing WG examples.

5) “progresses, some of the items initially considered at detnet may be transferred to those”

* s/detnet/the deterministic networking WG

6) The work items text.. suggest the following rewrite. Note that I removed most of the “informational vs. standards track” comments. Those will be repeated anyway when forming the milestones. Problem statements and studies are by default informational documents.

OLD:
- Deliverables:
  * an analysis of the needs in a number of environments (3-4 drafts which could include factory automation, grid automation, avionics and audio/video studios)
  * A general problem statement including an analysis of the proposed solutions of the related work at IEEE802.1TSN, with a status of the work done and left to be achieved, and the directions that are being taken.
  * a study of generic scoping. For IPv6, the study will include the definition of Link-Local, Realm-Local and Admin-Local scoped operation (per RFC 7346) where for instance the deterministic technology is consistent over a Link or a Realm Local Scope and achievable across technologies and layers over an Admin-Local scope. Similar scoping will be studied for IPv4.
  * A solution taxonomy, where potential solution paradigms will be explored, such as Peer-to-peer protocols (along the lines of MSRP or RSVP), Central controller (along the lines of SDN or PCE), Connection to Operations (Application) Controllers, and Mixed scenarios, in relation to the IP generic scoping.
  * The group will conclude this round with the selection of a paradigm and a base protocol that can be applied or extended.

  ->  all those documents planned for informational track

  * a data model for flow characterization for use in flow reservation by the protocol(s) selected by the WG from the solution taxonomy (e.g. an evolution of PCEP or RSVP).
  * a flow identification for use in packet forwarding, with the specific application to at least classical IP, 6TiSCH track forwarding, and MPLS.

  -> those would be standard track, and the work would progress once dependencies are resolved. The data models and flow tagging should be compatible with the similar work done at IEEE801.1TSN so they could be either directly usable at both layers, or mappable in an unambiguous fashion.

NEW:
  * An analysis of the needs in various deployment environments. 3-4 informational track documents which could include factory automation, grid automation, avionics and audio/video studios.
  * A generic problem statement including an analysis of the proposed solutions of the related work at IEEE802.1 TSN.
  * A study of generic scoping. For IPv6, the study will include the definition of Link-Local, Realm-Local and Admin-Local scoped operation (as per RFC 7346). For instance, the deterministic technology needs to be consistent over a Link- or a Realm-Local scope and achievable across technologies and layers over an Admin-Local scope. Similar scoping will be studied for IPv4.
  * A solution taxonomy, where potential solution paradigms will be explored, such as peer-to-peer protocols (along the lines of MSRP or RSVP), central controller (along the lines of SDN or PCE), connection to operations (application) controllers, and mixed scenarios, in relation to the generic scoping of IP.
  * The WG will conclude this round with the selection of a paradigm and a base protocol that can be applied or extended.
 * A standards track data flow characterization model document for use in flow reservation. The protocol(s) are selected by the WG from the solution taxonomy (e.g. an evolution of PCEP or RSVP).
  * A standards track flow identification document for use in packet forwarding, with the specific application to at least classical IP, 6TiSCH track forwarding, and MPLS.

7) “Milestones..”

* The milestones text can be removed all together from the charter text at this point.

8) The current text uses both “IEEE802.1 TSN” and “IEEE802.1TSN”. Use one form.

My 0.02€,
Jouni

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, September 25, 2014 6:42 PM
To: [email-masked]
Subject: [Detnet] Compilation of documents available to the IESG for BoF evaluation

Dear all:

·        Forwarding and Queuing (IEEE 802.1Qav-2009): http://standards.ieee.org/getieee802/download/802.1Qav-2009.pdf

·        Stream Reservation Protocol (IEEE 802.1Qat-2010): http://standards.ieee.org/getieee802/download/802.1Qat-2010.pdf

·        Timing and Synchronizations (IEEE 802.1AS-2011): http://standards.ieee.org/getieee802/download/802.1AS-2011.pdf

·        AVB Systems (IEEE 802.1BA-2011): http://standards.ieee.org/getieee802/download/802.1BA-2011.pdf

IETF references

·        Deterministic flow tagging  https://tools.ietf.org/html/draft-svshah-tsvwg-deterministic-forwarding

·        Deterministic track establishment and forwarding https://tools.ietf.org/html/draft-ietf-6tisch-architecture

·        Industrial applicability of RPL https://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability

·        Industrial requirements for RPL https://tools.ietf.org/html/RFC5673

Other resources