Subject: [Detnet] are there any drafts published yet?

From: Alia Atlas <[email-masked]>
Date: Tue, 23 Sep 2014 13:19:20 -0400

If you want a BoF in Honolulu then you need to get a lot of things done
before Friday! A BoF proposal without any drafts will not be taken
seriously. The IESG cannot discuss this without background material.

Charter discussion is a bit premature.

Regards,
Alia

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Tue, 23 Sep 2014 22:43:30 +0000

Understood, Alia.  It’s not clear we can make the deadline.  It was hard to get things started in earnest before the IEEE 802.1 meeting held Sep 8-11.  We’ll see how much we can get down, by then.

— Norm

From: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 23, 2014 at 07:19 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Spencer Dawkins <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] are there any drafts published yet?

If you want a BoF in Honolulu then you need to get a lot of things done before Friday! A BoF proposal without any drafts will not be taken seriously. The IESG cannot discuss this without background material.

Regards,
Alia

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 24 Sep 2014 09:10:19 +0000

Hello Alia and Norm:

The effort here is a bit un-classical but the background material effectively exists:

- the work has started at the IEEE so we do not have I-Drafts covering that yet. There are actual standards that cover a consistent layer-2 fabric. Between others, we may point at documents from 802.1BA, IEEE1733 which relates to RTP timing, and 802.1Qav. The IEEE is now working on the 2nd generation and we want that work to span capabilities at Layer-3, and I’m sure that the value of that work will not escape the IESG.

- There are actually shipping products for AVB/AVnu and pre-6TiSCH (ISA100.11a/IEC62734).

- the IETF effort has started in a distributed fashion at ROLL, TSVWG and 6TiSCH. This work should be orchestrated through detnet to ensure consistency.

Related IETF documents include:
* draft-svshah-tsvwg-deterministic-forwarding
* draft-ietf-6tisch-architecture
* draft-phinney-roll-rpl-industrial-applicability
* RFC5673

We can put together an early draft on the problem statement quite rapidly, but with Norm in vacations, probably not before BoF cut-off.

What do you think?

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Norman Finn (nfinn)
Sent: mercredi 24 septembre 2014 00:44
To: Alia Atlas; [email-masked]
Cc: Spencer Dawkins
Subject: Re: [Detnet] are there any drafts published yet?

— Norm

Regards,
Alia

---

From: "Gunther, Craig" <[email-masked]>
Date: Wed, 24 Sep 2014 15:49:08 +0000

All,

In an effort to help move our BOF draft(s) forward here are some pointers to the IEEE 802.1 AVB/TSN docs that have been referenced in these discussions so far:

Forwarding and Queuing (IEEE 802.1Qav-2009): http://standards.ieee.org/getieee802/download/802.1Qav-2009.pdf
Stream Reservation Protocol (IEEE 802.1Qat-2010): http://standards.ieee.org/getieee802/download/802.1Qat-2010.pdf
Timing and Synchronizations (IEEE 802.1AS-2011): http://standards.ieee.org/getieee802/download/802.1AS-2011.pdf
AVB Systems (IEEE 802.1BA-2011): http://standards.ieee.org/getieee802/download/802.1BA-2011.pdf

Note that 802.1Qav-2009 and 802.1Qat-2010 have been rolled into the publication of IEEE 802.1Q-2011.
MAC Bridges and VLANs (IEEE 802.1Q-2011): http://standards.ieee.org/getieee802/download/802.1Q-2011.pdf

You can also go here: http://www.ieee802.org/1/ and look at the TSN section to see ongoing work.

I personally support Pascal’s comment 100%: “we want that work to span capabilities at Layer-3”.  My own interested in providing professional quality audio and video throughout our customers networks has convinced me that a layer-3 solution is absolutely necessary.  Personally, I hope to see this technology in my home some day.

Pascal also mentioned AVnu.  Here’s information about their certification program with links to certified products: http://www.avnu.org/certification.  There are several large AVB system installations in the Pro Audio world today and I suspect several more products are going through certification right now.

Regards,
Craig

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Wednesday, September 24, 2014 3:10 AM
To: Norman Finn (nfinn); Alia Atlas; [email-masked]
Cc: Spencer Dawkins
Subject: Re: [Detnet] are there any drafts published yet?

Hello Alia and Norm:

What do you think?

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Norman Finn (nfinn)
Sent: mercredi 24 septembre 2014 00:44
To: Alia Atlas; [email-masked]<mailto:[email-masked]>
Cc: Spencer Dawkins
Subject: Re: [Detnet] are there any drafts published yet?

— Norm

Regards,
Alia