Subject: Re: [Detnet] What we need to get a BOF in November

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 18 Sep 2014 06:58:10 +0000

Obvious to me would be to ask Erik Nordmark if he is willing to help us out here.

What do others think ?

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Norman Finn (nfinn)
Sent: mercredi 17 septembre 2014 21:09
To: Alia Atlas
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Detnet] What we need to get a BOF in November

From whom do I acquire an IAB BOF Shepherd?  I see document shepherds on the IETF site, but …

— Norm

From: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 17, 2014 at 07:12 AM
To: Norman Finn <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] What we need to get a BOF in November

Norm,

Have you asked for an IAB BOF Shepherd?   I would recommend doing so.
A shepherd would be able to help you figure out how to scope the desired BOF,
provide comments, and be able to answer questions when the BOF proposal is
discussed.  There is extremely limited time before the BOF requests are discussed.

Regards,
Alia

On Tue, Sep 16, 2014 at 7:11 PM, Norman Finn (nfinn) <[email-masked]<mailto:[email-masked]>> wrote:
The deadline for application for a BOF is Sept 26.  At the IEEE meeting, last week, we talked about several things we might do for the BOF, including:

Pick one or two leaders.
Write some drafts.

In particular, it was felt we need a Problem Statement draft.  Here is a proposed outline.  Comments/suggestions welcome:

1. Goal of document
  - Describe the Deterministic Networking problem statement, with an eye to a BOF and consequent working group.
2. Fundamental problem statement
  Given:
   * A moderate-sized mixed Layer 2 / Layer 3 network composed of bridges, routers, and end stations;
   * One or more “critical flows,” consisting of unicast or multicast data flows;
   • The willingness of a network administrator and/or application programs to take steps to allocate network resources before transmitting a critical data flow (and to be told, “no” if the resources are not available); and
   * Suitable buffering, queuing, shaping, and scheduling facilities in the network nodes;
   Provide to those flows a Quality of Service that has one or more of the following characteristics:
   * Guaranteed minimum and maximum end-to-end latency; and
   * Arbitrarily low packet loss probability;
   With as few restrictions as possible with regard to:
   * Bandwidth of critical flows (must support critical flows totaling >= 75% of links’ bandwidth);
   * Bandwidth of non-critical flows (all bandwidth unused by critical flows must be available to best-effort traffic);
   * Any particular choice of L2 or L3 topology control or routing protocol; or
   * Any specific transport protocol.
3. Demonstrated user communitites
   • Audio and video studios
   * Automobiles and other vehicles
   * Factory floor, machinery control, process control
4. Demonstrated solutions and their limitations
   * IEC 62439-3 HSR/PRP
   * IEEE 802.1BA Audio Video Bridging
   * IEEE 802.1 Time-Sensitive Networking standards in progress
5. Potential avenues for exploration: Zero congestion loss
   * 802.1 credit-based shaper
   * 802.1 Cyclical Queuing and Forwarding
   * 802.1 Time-scheduled queues
   * Urgency Based Shaping
6. Potential avenues for exploration: Multiple paths
   * Various forms of Seamless Redundancy
   * The serial number problem: HSR/PRP vs. 802.1 vs Pseudowires vs various transport protocols
7. Potential avenues for exploration: data plane and packet identification
   * {VLAN, Destination MAC address}
   * IP 5-tuple
   * Other
8. Potential avenues for exploration: Control paradigms
   * Peer-to-peer protocols (along the lines of MSRP or RSVP)
   * Central controller (along the lines of SDN or PCE)
   * Connection to Operations (Application) Controllers
   * Mixed scenarios

— Norm

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 18 Sep 2014 07:18:59 +0000

Erik would be a great shepherd.

I also sent a request to the IAB – hope that they will answer speedily.

Regards,

Dan

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, September 18, 2014 9:58 AM
To: Norman Finn (nfinn); Alia Atlas
Cc: [email-masked]
Subject: Re: [Detnet] What we need to get a BOF in November

What do others think ?

Pascal

— Norm

Norm,

Regards,
Alia

Pick one or two leaders.
Write some drafts.

1. Goal of document

— Norm

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Fri, 19 Sep 2014 16:41:16 +0000

I know and trust Erik.

— Norm

From: Pascal Thubert <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, September 17, 2014 at 23:58 PM
To: Norman Finn <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Detnet] What we need to get a BOF in November

What do others think ?

Pascal

— Norm

Norm,

Regards,
Alia

Pick one or two leaders.
Write some drafts.

1. Goal of document

— Norm