Subject: [Detnet] Looking for partners for Gap Analysis draft

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 25 Mar 2015 10:49:08 -0500

Dear all,
            I have published the first (-00) version of the
Gap Analysis draft:

https://tools.ietf.org/html/draft-dujovne-detnet-gap-analysis-00

 I'm looking for co-authors to collaborate
to build this draft. Let me know through the list
if you are interested.
Thank you.

                            Diego Dujovne

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Pat Kinney <[email-masked]>
Date: Wed, 25 Mar 2015 15:09:33 -0500

I would like to assist in this effort, especially towards 4.1 Industrial Controls.  I plan to work with my partners in the ISA organization to define the basic requirements for these applications.

Regards, Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715
[email-masked] <mailto:[email-masked]>

On 25, Mar2015, at 10:49, Prof. Diego Dujovne <[email-masked]> wrote:

Dear all,

https://tools.ietf.org/html/draft-dujovne-detnet-gap-analysis-00 <https://tools.ietf.org/html/draft-dujovne-detnet-gap-analysis-00>

                            Diego Dujovne

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl <http://www.ingenieria.udp.cl/>
(56 2) 676 8125
_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 25 Mar 2015 21:17:17 +0000

Hello Pat:

Thanks a bunch for the offer!

If you can convince ISA to participate to a requirements draft that would look like https://tools.ietf.org/html/draft-wetterwald-detnet-utilities-reqs-00  that would be fantastic.

>From there we can justify the application of the detnet architecture in industrial, which in turns would enable a gap analysis from existing things at the IETF.

We figure that detnet requires new work at least from  TEAS, CCAMP and PCE, to implement our resource constraints (time, channels, buffers…) as well as the new path capabilities (replication and elimination).

Does that make sense ?

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Pat Kinney
Sent: mercredi 25 mars 2015 14:10
To: Prof. Diego Dujovne
Cc: [email-masked]
Subject: Re: [Detnet] Looking for partners for Gap Analysis draft

Regards, Pat

Pat Kinney

Kinney Consulting LLC

ISA100.11a WG chair

O: +1.847.960.3715

 <mailto:[email-masked]> [email-masked]

Dear all,

Gap Analysis draft:

if you are interested.

Thank you.

                            Diego Dujovne

-- 

DIEGO DUJOVNE

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 25 Mar 2015 17:48:52 -0500

Pat,
      Thank you for joining!
Regards,

                        Diego

2015-03-25 15:09 GMT-05:00 Pat Kinney <[email-masked]>:

> I would like to assist in this effort, especially towards 4.1 Industrial
> Controls.  I plan to work with my partners in the ISA organization to
> define the basic requirements for these applications.
>
> Regards, Pat
>
> Pat Kinney
> *Kinney Consulting LLC*
> [email-masked]
>
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 26 Mar 2015 14:26:05 -0000

Hello all,
 
I think this can be useful work, but I am confused about the direction because it seems that the gaps you can find have to assume an architectural solution and probably a choice of protocol components.
 
So there may be a need to write an early section on a framework to provide the context for showing the gaps.
 
Adrian
 
From: detnet [mailto:[email-masked]] On Behalf Of Prof. Diego Dujovne
Sent: 25 March 2015 22:49
To: Pat Kinney
Cc: [email-masked]
Subject: Re: [Detnet] Looking for partners for Gap Analysis draft
 
Pat,
      Thank you for joining
Regards,
                        Diego

Regards, Pat
 
Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, TG chair
ISA100.11a WG chair
O: +1.847.960.3715 <tel:%2B1.847.960.3715> 
 <mailto:[email-masked]> [email-masked]

Dear all,

---

From: Jouni Korhonen <[email-masked]>
Date: Thu, 26 Mar 2015 14:30:55 +0000

Hi,

I am willing to give a hand here.

- jouni

Sent from a smart phone.. Mind the typos..

Prof. Diego Dujovne <[email-masked]<mailto:[email-masked]>> kirjoitti 25.3.2015 kello 10.49:

Dear all,

                            Diego Dujovne

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: Anca Zamfir <[email-masked]>
Date: Thu, 26 Mar 2015 20:17:55 +0100

Hi Adrian,
There is an architecture draft started at
https://tools.ietf.org/html/draft-finn-detnet-architecture-00. Would a
reference to that address your concerns?
I was also looking for a similar (gap analysis) type of doc in IETF repo,
anyone could point me to one?

thanks,
-anca

On Thu, Mar 26, 2015 at 3:26 PM, Adrian Farrel <[email-masked]> wrote:

> Hello all,
>
>
>
> I think this can be useful work, but I am confused about the direction
> because it seems that the gaps you can find have to assume an architectural
> solution and probably a choice of protocol components.
>
>
>
> *From:* detnet [mailto:[email-masked]] *On Behalf Of *Prof.
> Diego Dujovne
> *Sent:* 25 March 2015 22:49
> *To:* Pat Kinney
> *Cc:* [email-masked]
> *Subject:* Re: [Detnet] Looking for partners for Gap Analysis draft
>
>
>
> Pat,
>
>       Thank you for joining
>
> Regards,
>
>                         Diego
>
>
>
> 2015-03-25 15:09 GMT-05:00 Pat Kinney <[email-masked]
> >:
>

---

From: Jouni Korhonen <[email-masked]>
Date: Tue, 31 Mar 2015 17:38:00 +0000

Hi,

I was reading the draft.. Thanks for initiating the work! Few quick questions and comments.

In Section 3.2 or as a separate section shouldn’t we also point at IEEE 802.1CB as a L2 mechanism to provide redundancy. Also, instead of referring to MPLS I would rather talk PWEs instead.

Then another comment specifically regarding Section 3 gap analysis. As it stands now it is more like a rundown of solutions. I do not see a gap to anything discussed/pointed here? Each of these sections should list what is missing or what cannot be supported if transport goes over IP.

What I would do is to first list down the issues / building blocks that we know are must to have to realize a deterministic networking at L3. After that each technology have a short description, followed by (bullet) list what can be supported and what not. And then a short summary for each technology. Comments?

- Jouni

From: detnet [mailto:[email-masked]] On Behalf Of Prof. Diego Dujovne
Sent: Wednesday, March 25, 2015 8:49 AM
To: [email-masked]
Subject: [Detnet] Looking for partners for Gap Analysis draft

Dear all,