Subject: [Detnet] DetNet Use Case Statements: Plug-And-Play

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 7 Apr 2016 21:00:06 +0000

Statement:
Plug-And-Play (new device, replace device)
Discussion:
Ethan: There are enough use cases and available technology for doing this, and enough "feel of the room" that I claim it is in scope. It won't always be possible (or useful) in every use case, so it must a feature that can be selectively included in a given DetNet implementation. There is some distinction between introducing a "new" device into the network and replacing a removed/failed device. However since a replacement for a failed device might not be "exactly" the same as the original device (e.g. different firmware revision) then some renegotiation seems inevitable (though maybe not as much as for a new device).

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 14 Apr 2016 03:22:56 +0000

Hello Ethan:

In my world, the use case is a failing device replacement. What the use case tells me is that there should be a way to provision the new device to that it replaces the old device with a minimum of hassle, which means that it could fit in the predecessor's shoes without having to recompute the paths and/or reinstall them.

Certainly this places also a requirement on the new device, which is expected to have the same capabilities as the predecessor, or more. But that much is acceptable. This also places requirements like that the semantics used in the detnet signaling are universal enough so that there meaning is understandable by the replacement. Eg, can the replacement use a label that was locally significant to the predecessor?

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: jeudi 7 avril 2016 14:00
To: [email-masked]
Subject: [Detnet] DetNet Use Case Statements: Plug-And-Play

Statement:

---

From: "Schmitt, Juergen" <[email-masked]>
Date: Thu, 14 Apr 2016 07:24:30 +0000

Hi Pascal,

I'm not sure this is the only use case for new devices. Especially in industry publish-subcribe is a widespread communication pattern. Not to be able to add additional subscribers (such as a measurement system) at runtime would be a major issue.

Juergen

Von: detnet [mailto:[email-masked]] Im Auftrag von Pascal Thubert (pthubert)
Gesendet: Donnerstag, 14. April 2016 05:23
An: Grossman, Ethan A.; [email-masked]
Betreff: Re: [Detnet] DetNet Use Case Statements: Plug-And-Play

Hello Ethan:

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: jeudi 7 avril 2016 14:00
To: [email-masked]<mailto:[email-masked]>
Subject: [Detnet] DetNet Use Case Statements: Plug-And-Play

Statement:

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 18 Apr 2016 13:57:59 +0000

Hi,

In my view plug-and-play operation should cover all possible changes in the population of the involved endpoints:
1, adding new device: which was not part of detnet communications before (see Jürgen's comment).
2, replacing an existing device: due to failure or application update or whatever other reason we intend to replace a device (see Pascal's comment)
3, removing a device: this is the case where (e.g., due to the change of the network scenario) a device is removed from the group of detnet endpoints (e.g., you do not need a given sensor anymore, etc.). That removal should automatically free-up the booked network resources. We have discussed so far, that unused BW of detnet flows should be available for non-critical traffic, however the booked resources of a removed endpoint may block the addition of new detnet flows. Therefore removing a device (and related network resources) should be also part of Plag-and-Play considerations.

I think the "Stream start-up (or re-start) time" is also related to plug-and-play functions. It is something to be considered for the first case (add new device), but also impacts heavily how the second case (replacing) is designed.

Cheers
Bala'zs

From: detnet [mailto:[email-masked]] On Behalf Of Schmitt, Juergen
Sent: Thursday, April 14, 2016 9:25 AM
To: [email-masked]
Subject: Re: [Detnet] DetNet Use Case Statements: Plug-And-Play

Hi Pascal,

Juergen

Von: detnet [mailto:[email-masked]] Im Auftrag von Pascal Thubert (pthubert)
Gesendet: Donnerstag, 14. April 2016 05:23
An: Grossman, Ethan A.; [email-masked]<mailto:[email-masked]>
Betreff: Re: [Detnet] DetNet Use Case Statements: Plug-And-Play

Hello Ethan:

Cheers,

Pascal

Statement: