Subject: Re: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Mon, 4 Apr 2016 01:19:53 +0000

Ethan, Norm,

Agree for the non support of the Big-I Internet with the following precision: Utilities may ask a SP to provide them with a "deterministic" link (like a leased line) with a guarantee of max delay,  Jitter and packet loss. But I guess this use case is included in "enterprise" right ?

Thanks,

Patrick

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of "Norman Finn (nfinn)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 31 March 2016 at 19:46
To: "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

Ethan,

Making DetNet work over the Big-I Internet is not one of my goals, at least.  I often use the term "enterprise" for the scope in which I'm interested.

Timekeeping is an essential part of many, probably most, of the applications that also find DetNet useful.  That having been said, so is protection against EMI and electrical power saving. Let's concentrate DetNet on reliable, on-time delivery of packets.  I'm not even sure that "a way to specify the required accuracy" need be in scope.

- Norm

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, March 29, 2016 at 12:13 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

Hi Folks,

I claim that we have brought the DetNet Use Cases draft up to a state where I can say with a straight face "please read this document, it won't hurt you". So if you haven't already done so, please look it over.

https://tools.ietf.org/html/draft-ietf-detnet-use-cases-09

Moving on to the next step, we need to start the discussion on which aspects of the use cases will be within scope of the DetNet work. Or, perhaps it is easier to enumerate which ones are not in scope, at least for a start.

The most obvious first item to decide on is requests to have DetNet work on the open Internet - I think we're pretty clear that that is "not in scope" because our architecture depends on there being "centralized control" (which may be distributed among multiple network entities, but which together constitute a single point of control). I have also heard this phrased as "corporate networks". Do we agree on this?

Another example is timekeeping - this will be specified by other existing means, right? The only explicit DetNet Ask for this is in M2M as "Precise time synchronization accuracy (1us)" and I think the intent (as in other use cases) is that the DetNet Ask is for a way to specify the required accuracy, not how to achieve that accuracy.

Anyone else see anything that might not be in scope? I plan to ask this question in the Use Cases part of the IETF session, so if you have any thoughts please send them to the list (or if that doesn't happen, bring them to the live discussion).

Thanks,
Your faithful Use Cases Editor,
Ethan.

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Thu, 7 Apr 2016 20:19:19 +0000

Sure.  That also relates to the “one administrative domain split into islands by a WAN service” case in another thread.

— Norm

From: "Patrick Wetterwald (pwetterw)" <[email-masked]<mailto:[email-masked]>>
Date: Sunday, April 3, 2016 at 22:19 PM
To: Norman Finn <[email-masked]<mailto:[email-masked]>>, "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] DetNet Use Cases - Starting the "what is in scope for DetNet" discussion

Ethan, Norm,

Agree for the non support of the Big-I Internet with the following precision: Utilities may ask a SP to provide them with a “deterministic” link (like a leased line) with a guarantee of max delay,  Jitter and packet loss. But I guess this use case is included in “enterprise” right ?

Thanks,

Patrick

Ethan,

Making DetNet work over the Big-I Internet is not one of my goals, at least.  I often use the term “enterprise” for the scope in which I’m interested.

Timekeeping is an essential part of many, probably most, of the applications that also find DetNet useful.  That having been said, so is protection against EMI and electrical power saving. Let’s concentrate DetNet on reliable, on-time delivery of packets.  I’m not even sure that “a way to specify the required accuracy” need be in scope.

— Norm

Hi Folks,

I claim that we have brought the DetNet Use Cases draft up to a state where I can say with a straight face “please read this document, it won’t hurt you”. So if you haven’t already done so, please look it over.

The most obvious first item to decide on is requests to have DetNet work on the open Internet – I think we’re pretty clear that that is “not in scope” because our architecture depends on there being “centralized control” (which may be distributed among multiple network entities, but which together constitute a single point of control). I have also heard this phrased as “corporate networks”. Do we agree on this?

Another example is timekeeping – this will be specified by other existing means, right? The only explicit DetNet Ask for this is in M2M as “Precise time synchronization accuracy (1us)” and I think the intent (as in other use cases) is that the DetNet Ask is for a way to specify the required accuracy, not how to achieve that accuracy.

Anyone else see anything that might not be in scope? I plan to ask this question in the Use Cases part of the IETF session, so if you have any thoughts please send them to the list (or if that doesn’t happen, bring them to the live discussion).

Thanks,