Subject: [Detnet] DetNet Use Case Statements: Providing Synchronized Time

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 7 Apr 2016 20:04:56 +0000

Statement:
Providing Synchronized Time (not in scope)
Discussion:
A point came up about whether DetNet streams could serve as a way to deliver timekeeping packets in a more timely way in order to provide more accurate time. We concluded that this was a possible use case for DetNet, and invite contributions of use case text on the topic. However since DetNet itself depends on time sync to function, making timekeeping depend on DetNet is a circular dependency so doesn't seem feasible.

---

From: Jiangyuanlong <[email-masked]>
Date: Tue, 12 Apr 2016 08:53:07 +0000

Hi Ethan,

It seems to me this use case can be further partitioned into two different problems:
1. Providing sync info within a DetNet, so that all nodes in the DetNet are synchronized to the same clock, for example, each node runs in the BC mode of IEEE 1588v2 and an external GPS/GNSS receiver provides the clock source for all nodes in this DetNet network;
2. Transporting sync info for the 3rd party across a DetNet. This can further be divided into two cases:
a) The DetNet is not aware of the timing info, but take it as a low delay service.
b) The DetNet is aware of the timing info, some of the nodes in the DetNet may provide timing correction for the timing info. For example, several nodes in the DetNet network can work in the TC mode of IEEE 1588v2.

IMO, 2.a) is already in the scope of the DetNet; 1 is essential for DetNet, but not yet in its scope; 2.b) can be an interesting application for the DetNet.

Regards,
Yuanlong

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Friday, April 08, 2016 4:05 AM
To: [email-masked]
Subject: [Detnet] DetNet Use Case Statements: Providing Synchronized Time

Statement: