Subject: [Detnet] DetNet Use Case Statements: Link Aggregation

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 7 Apr 2016 20:44:54 +0000

Statement:
Link Aggregation
Discussion:
I used the term "link aggregation" without understanding that it is a reserved word in this context, so I need to figure out what the correct term is. The use case is that the user has a high bandwidth stream such as video but there is no single network link between talker and listener which has available bandwidth (for whatever reason) and the question is can DetNet "seamlessly" split the stream and send parts of it across different paths to the listener. It seemed like the feel of the room was that we shouldn't be involved in doing this, however it was brought up that this function could be implemented in a similar way as packet replication and deletion, except that the packet sequence numbers are not duplicates so they would be accepted and it might "just work". It sounds to me like it might be a useful thing to keep in there since it doesn't seem like it would be that hard, but perhaps this is a DetNet "future feature" that we don't have to address now as long as we don't do anything that would preclude developing it later.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 7 Apr 2016 21:02:08 +0000

Here is the Use Case draft text:
For transmitting streams that require more bandwidth than a single link in
                        the target network can support, link aggregation is a technique for
                        combining (aggregating) the bandwidth available on multiple physical links
                        to create a single logical link of the required bandwidth. However, if
                        aggregation is to be used, the network controller (or equivalent) must be
                        able to determine the maximum latency of any path through the aggregate
                        link.

From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Thursday, April 07, 2016 5:45 PM
To: [email-masked]
Subject: [Detnet] DetNet Use Case Statements: Link Aggregation

Statement:
Link Aggregation
Discussion: