Subject: [Detnet] detnet architecture, and privacy considerations

From: Tim Chown <[email-masked]>
Date: Tue, 5 Apr 2016 16:43:14 +0000

Hi,

The question I asked at the mic today was driven by seeing an architecture text (draft-finn-detnet-architecture-04) where there’s no explicit mention of privacy handling, and being aware that since RFC 7258 was published we should be thinking about appropriate privacy considerations in such documents.

So, for example, one ‘open issue' slide in Norman’s talk asked about identifying streams, and L2 addresses or the 5-tuple were mentioned, but in a world where L2 addresses are randomised over time, and encryption is more widespread, other mechanisms may be required, ones that one might argue should be opaque to the network operator.

Wearing my dnssd WG chair hat, we’ve discussed similar issues this week, specifically how you might do device naming and service discovery with privacy, while using ‘broadcast’ protocols such as mDNS and DNS-SD (see https://www.ietf.org/proceedings/95/slides/slides-95-dnssd-0.pdf, if interested).

Whatever privacy considerations are put into the architecture, I think we should at least ensure we discuss them, noting that while detnet is scoped by charter to initially only be applicable within a single administrative domain, use of the word ‘initially’ implies its scope may/will grow later.

Tim

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Thu, 7 Apr 2016 20:16:07 +0000

Definitely will address this comment when preparing another version for possible adoption.

Thanks!!

— Norm

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of Tim Chown <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 5, 2016 at 13:43 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] detnet architecture, and privacy considerations

Hi,

Tim