Subject: [Detnet] DetNet Use Case Statements: Stream Start-up (or re-start) Time

From: "Grossman, Ethan A." <[email-masked]>
Date: Thu, 7 Apr 2016 20:28:06 +0000

Statement:
Stream Start-up (or re-start) Time
Discussion:
It was noted that systems that really need a timely replacement for a failed device would probably use other methods (e.g. redundancy) rather than depending on a bounded stream start-up time.  I don't have a sense of the answer to this one.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 10 Apr 2016 17:26:19 +0000

Hello Ethan

What you point at it very true, and the point is probably that since you do not know what will break, you cannot guarantee that it can be fixed by a simple reboot or will require a complete rebuild of the system. So people are after all forms of diversity to avoid that any individual cause of failure breaks the service.

In wireless communications, such diversity includes not only path redundancy but also time (ARQ), frequency (TSCH, FH), and encoding (network coding, CDMA, FEC).

At one extreme we find safety related applications. People will apply parallelism to any degree that they feel necessary, down to requiring different implementations in the parallel operations, or more than 1+1. An Example of this extreme can be found in the plane control systems of an X-29: 3 analog and 3 Digital computers.

At the other extreme we have things like live-live video. Their need is pretty much that of MPLS TP. They want a non congruent plan B to be established between the content source and consumer so the path can be switched before the user can feel it.

In that case, most of the detnet features are actually done at the app layer and the buffers used to absorb jitter also compensate for duplicate and out of sequence datagrams. How would they have designed this app if the network had been deterministic to start with ?

I hope this helps,

Pascal

Le 7 avr. 2016 ? 13:28, Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>> a ?crit :

Statement:

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet