Subject: [Detnet] detnet use case wind farm

From: Xavier Vilajosana <[email-masked]>
Date: Tue, 19 Jul 2016 10:48:25 +0200

Dear Ethan, all

following up from yesterday meeting. We would like to propose the inclusion
of the wind farm use case to the Detnet use cases.

https://tools.ietf.org/html/draft-vilajosana-detnet-windfarm-usecase-00

We consider it relevant, with a very well defined application case, narrow
in scope but with a wide set of requirements, all of them extracted from
the study of the implemented standards (IEC) and traces analysis from a
wind farm in Denmark. Please, let us know if you have any consideration on
that matter.

kind regards,
Xavi

*Xavier Vilajosana*
*CIO*

Mobile: (+34) 646 633 681 <%28%2B34%29%2093%20418%2005%2085>
Office: (+34) 93 418 05 85

Aragó, 383, 4th floor
08013 Barcelona, Spain

9-10 Carlos Place, Mayfair
London W1K 3AT, UK

*This email may contain confidential information and may be subject to
professional secrecy. Its dissemination, copying, distribution,
reproduction, forwarding or any other unauthorized use is strictly
prohibited. If you receive this email in error, please notify us
immediately and arrange for its deletion, together with any attached
documents.*

*Este correo electrónico puede contener información estrictamente
confidencial, y puede estar sometido al secreto profesional. Está prohibida
su difusión, copia, distribución, reproducción, reenvío o cualquier otro
uso no autorizado. En caso de recibir este correo por error, rogamos nos
lo comunique de inmediato y proceda a su eliminación, así como de cualquier
documento que se adjunte.*

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

9-10 Carlos Place, Mayfair
London W1K 3AT, UK

*This email may contain confidential information and may be subject to 
professional secrecy. Its dissemination, copying, distribution, 
reproduction, forwarding or any other unauthorized use is strictly 
prohibited. If you receive this email in error, please notify us 
immediately and arrange for its deletion, together with any attached 
documents.*

*Este correo electrónico puede contener información estrictamente 
confidencial, y puede estar sometido al secreto profesional. Está prohibida 
su difusión, copia, distribución, reproducción, reenvío o cualquier otro 
uso no autorizado. En caso de recibir este correo por error, rogamos nos 
lo comunique de inmediato y proceda a su eliminación, así como de cualquier 
documento que se adjunte.*

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 19 Jul 2016 08:51:12 +0000

I support this.

I find this is an excellent and very informative document.

Regards,

Pascal

Le 19 juil. 2016 ? 10:48, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> a ?crit :

Dear Ethan, all

following up from yesterday meeting. We would like to propose the inclusion of the wind farm use case to the Detnet use cases.

We consider it relevant, with a very well defined application case, narrow in scope but with a wide set of requirements, all of them extracted from the study of the implemented standards (IEC) and traces analysis from a wind farm in Denmark. Please, let us know if you have any consideration on that matter.

kind regards,
Xavi

Xavier Vilajosana
CIO

Mobile: (+34) 646 633 681<tel:%28%2B34%29%2093%20418%2005%2085>

Office: (+34) 93 418 05 85<tel:%28%2B34%29%2093%20418%2005%2085>

[http://www.worldsensing.com/files/logo_WS.png]

Arag?, 383, 4th floor
08013 Barcelona, Spain

This email may contain confidential information and may be subject to professional secrecy. Its dissemination, copying, distribution, reproduction, forwarding or any other unauthorized use is strictly prohibited. If you receive this email in error, please notify us immediately and arrange for its deletion, together with any attached documents.

Este correo electr?nico puede contener informaci?n estrictamente confidencial, y puede estar sometido al secreto profesional. Est? prohibida su difusi?n, copia, distribuci?n, reproducci?n, reenv?o o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminaci?n, as? como de cualquier documento que se adjunte.

[http://www.worldsensing.com/files/logo_WS.png]

Arag?, 383, 4th floor
08013 Barcelona, Spain

This email may contain confidential information and may be subject to professional secrecy. Its dissemination, copying, distribution, reproduction, forwarding or any other unauthorized use is strictly prohibited. If you receive this email in error, please notify us immediately and arrange for its deletion, together with any attached documents.

Este correo electr?nico puede contener informaci?n estrictamente confidencial, y puede estar sometido al secreto profesional. Est? prohibida su difusi?n, copia, distribuci?n, reproducci?n, reenv?o o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminaci?n, as? como de cualquier documento que se adjunte.
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 19 Jul 2016 07:38:32 -0500

I also support the inclusion of the wind farm use case to the Detnet use cases.

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, SC chair
ISA100 co-chair, ISA100.20 chair
O: +1.847.960.3715
[email-masked] <mailto:[email-masked]>

On 19, Jul2016, at 3:51, Pascal Thubert (pthubert) <[email-masked]> wrote:

I support this.

Regards,

Pascal

Le 19 juil. 2016 à 10:48, Xavier Vilajosana <[email-masked] <mailto:[email-masked]>> a écrit :

> https://tools.ietf.org/html/draft-vilajosana-detnet-windfarm-usecase-00 <https://tools.ietf.org/html/draft-vilajosana-detnet-windfarm-usecase-00>
> 
> Mobile: (+34) 646 633 681 <tel:%28%2B34%29%2093%20418%2005%2085>
> Office: (+34) 93 418 05 85 <tel:%28%2B34%29%2093%20418%2005%2085>
> 
> 
> Aragó, 383, 4th floor
> 08013 Barcelona, Spain
> 
> Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.
> 
> 
> 
> Aragó, 383, 4th floor
> 08013 Barcelona, Spain
> 
> Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/detnet <https://www.ietf.org/mailman/listinfo/detnet>
[email-masked]

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 19 Jul 2016 15:04:11 +0200

+1 for including this use case

On Tuesday, July 19, 2016, [email-masked] <
[email-masked]> wrote:

> *Kinney Consulting LLC*
> [email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>
> On 19, Jul2016, at 3:51, Pascal Thubert (pthubert) <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
> I support this.
>
> Le 19 juil. 2016 à 10:48, Xavier Vilajosana <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> a écrit :
>
> Dear Ethan, all
>
> following up from yesterday meeting. We would like to propose the
> inclusion of the wind farm use case to the Detnet use cases.
>
> Office: (+34) 93 418 05 85 <%28%2B34%29%2093%20418%2005%2085>
>
>
>
> Aragó, 383, 4th floor
> 08013 Barcelona, Spain
>
> documento que se adjunte. *
>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: "Maik Seewald (maseewal)" <[email-masked]>
Date: Tue, 19 Jul 2016 13:42:00 +0000

+1; The underlying requirements are derived from typical power automation and protection scenarios.
Windpark communication needs high availability to ensure protection schemas in order to fulfill safety and system protection.
BR. Maik

From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Dienstag, 19. Juli 2016 15:04
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>, Spiros Spirou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahmoodi, Toktam" <[email-masked]<mailto:[email-masked]>>, "Kulkarni, Vivek" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] detnet use case wind farm

On Tuesday, July 19, 2016, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> wrote:
I also support the inclusion of the wind farm use case to the Detnet use cases.

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, SC chair
ISA100 co-chair, ISA100.20 chair
O: +1.847.960.3715
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>

On 19, Jul2016, at 3:51, Pascal Thubert (pthubert) <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:

I support this.

Regards,

Pascal

Le 19 juil. 2016 à 10:48, Xavier Vilajosana <[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>> a écrit :

Dear Ethan, all

kind regards,
Xavi

Xavier Vilajosana
CIO

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.
_______________________________________________
detnet mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/detnet
_______________________________________________
detnet mailing list
[email-masked]<javascript:_e(%7B%7D,'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/detnet

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 19 Jul 2016 15:56:10 +0200

+1 to include the use case.

2016-07-19 15:04 GMT+02:00 Thomas Watteyne <[email-masked]>:

>> Le 19 juil. 2016 à 10:48, Xavier Vilajosana <[email-masked]>
>> a écrit :
>>
>> Dear Ethan, all
>>
>> We consider it relevant, with a very well defined application case,
>> narrow in scope but with a wide set of requirements, all of them extracted
>> from the study of the implemented standards (IEC) and traces analysis from
>> a wind farm in Denmark. Please, let us know if you have any consideration
>> on that matter.
>>
>> kind regards,
>> Xavi
>>
>> *Xavier Vilajosana*
>> *CIO*
>>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Tue, 19 Jul 2016 15:07:24 +0000

I’ll be happy to work with you in defining / refining the difference with the Electrical utility use cases that are already included in the WG document.

Wind farms are a specific generation use case and, as Maik already mentioned, derived from power automation scenarios. Ethan did an excellent job on summarising the requirements in a bullet list for each of the big use cases. We need to look if it already covers your case.

The interesting part (at least for me) is the use of Internet that you listed in your draft. My current understanding from the WG is that it is out of the scope of Detnet. Lets discuss it if this has to be changed.

Thanks,

Patrick

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of "Maik Seewald (maseewal)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 19 July 2016 at 15:42
To: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Pascal THUBERT <[email-masked]<mailto:[email-masked]>>, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>, Spiros Spirou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahmoodi, Toktam" <[email-masked]<mailto:[email-masked]>>, "Kulkarni, Vivek" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] detnet use case wind farm

Pat

Pat Kinney
Kinney Consulting LLC

I support this.

Regards,

Pascal

Dear Ethan, all

kind regards,
Xavi

Xavier Vilajosana
CIO

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

Thomas Watteyne, PhD

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 19 Jul 2016 17:20:32 +0000

Hello Xavi et al,

I agree we should include this use case, and I agree with Patrick that the Internet part has to be adapted.

Presumably, once we agree on wording, the result will be that text from this draft will be merged into the DetNet Use Cases draft as either a new top level section or a sub-section of the existing Electrical Utilities section. I can perform that integration step, but it would be nice if we had the XML text pretty much in shape in advance of that step. I think that is what Lou was getting at when he was asking you for "proposed changes" (to the DetNet Use Cases draft). That is, your proposed text adapted to match the form of a new section for the current draft.

Then once that text was approved I could pretty much cut and paste it (in XML format) into the DetNet Use Cases draft. At that point you could leaving your existing draft as a stand-alone document in its original form (e.g. with its current notion of use of the Internet) if you have a use for that, but otherwise that document would not be directly adopted by DetNet WG and could be left to expire.

My observation, along with Patrick, is that the only place in which it diverges from the current DetNet use cases is the integration with the Internet - however I will pose the question - do you (or anyone else) know of any other place in which this use case has expectations that are not currently satisfied by the list of "Common  Themes" as presented in my Use Cases preso slides at IETF 96? If so please let us know so that we can consider them also.

Thanks again for contributing this work, I see it as entirely relevant to DetNet and our existing use cases.

Best,

Ethan.

________________________________
From: Patrick Wetterwald (pwetterw) <[email-masked]>
Sent: Tuesday, July 19, 2016 8:07 AM
To: Maik Seewald (maseewal); Thomas Watteyne; [email-masked]
Cc: Pascal Thubert (pthubert); Xavier Vilajosana; Spiros Spirou; Grossman, Ethan A.; Mahmoodi, Toktam; Kulkarni, Vivek; [email-masked]
Subject: Re: [Detnet] detnet use case wind farm

Thanks,

Patrick

Pat

Pat Kinney
Kinney Consulting LLC

I support this.

Regards,

Pascal

Le 19 juil. 2016 à 10:48, Xavier Vilajosana <[email-masked]> a écrit :

Dear Ethan, all

https://tools.ietf.org/html/draft-vilajosana-detnet-windfarm-usecase-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dvilajosana-2Ddetnet-2Dwindfarm-2Dusecase-2D00&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=LxhKQc7uhoBtd2LqKb53h8ZerZ5TlshjbPB76BjdRe0&e=>

kind regards,
Xavi

Xavier Vilajosana
CIO

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

Este correo electrónico puede contener información estrictamente confidencial, y puede estar sometido al secreto profesional. Está prohibida su difusión, copia, distribución, reproducción, reenvío o cualquier otro uso no autorizado. En caso de recibir este correo por error, rogamos nos lo comunique de inmediato y proceda a su eliminación, así como de cualquier documento que se adjunte.
_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=qeCA-COiBpQkpzlHwtkPXZ1nCGahp_2hG9IqgQox1V4&e=>
_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=qeCA-COiBpQkpzlHwtkPXZ1nCGahp_2hG9IqgQox1V4&e=>

Thomas Watteyne, PhD

www.thomaswatteyne.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.thomaswatteyne.com&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=tWL2uwYfgQhSMOtlrOcRyRbdsE_BmS-oRkn3lGZdjCo&e=>
_______________________________________

---

From: "Maik Seewald (maseewal)" <[email-masked]>
Date: Tue, 19 Jul 2016 17:21:56 +0000

We can also fetch requirement, use cases and data model  specifications from already existing IEC specification, especially from the IEC 61400-25 series.
There is a lot of work already done. Best, Maik

From: Patrick Wetterwald <[email-masked]<mailto:[email-masked]>>
Date: Dienstag, 19. Juli 2016 17:07
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>, Spiros Spirou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Mahmoodi, Toktam" <[email-masked]<mailto:[email-masked]>>, "Kulkarni, Vivek" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] detnet use case wind farm

Thanks,

Patrick

Pat

Pat Kinney
Kinney Consulting LLC

I support this.

Regards,

Pascal

Dear Ethan, all

kind regards,
Xavi

Xavier Vilajosana
CIO

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

Thomas Watteyne, PhD

---

From: Xavier Vilajosana <[email-masked]>
Date: Wed, 20 Jul 2016 11:56:57 +0200

Dear Ethan, Patrick, all,

I propose the following:

We will go through the Electrical Utilities use case and identify
differences and information that can be augmented by our use case. We will
also bring up the intra-domain aspects that we have identified. With that
we will generate a summary so we can further discuss. Once we agree on the
content we will provide the xml file with the right format so you can
easily integrate.

One think we consider very interesting from a use case document is that it
brings the requirements to research and industrial communities. This is
really key to drive and motivate lots of research and innovations, and
specially if this is also motivating the work in an standardization work
group. In our case, we provide a particular description of the wind turbine
components and the requirements between them. This is narrower than what is
in the current Electrical Utilities section. I think that this information
is still useful and we can discuss if this can be kept as an annex, as a
short subsection or somewhere else as gives an accurate and applied
description of the system (which is different than other energy generation
technologies e,g solar, thermal, etc...) and hence the requirements are
slightly different.

what do you think?

kind regards,
Xavi

*Xavier Vilajosana*
*CIO*

Aragó, 383, 4th floor
08013 Barcelona, Spain

2016-07-19 19:20 GMT+02:00 Grossman, Ethan A. <[email-masked]>:

> Presumably, once we agree on wording, the result will be that text from
> this draft will be merged into the DetNet Use Cases draft as either a new
> top level section or a sub-section of the existing Electrical Utilities
> section. I can perform that integration step, but it would be nice if we
> had the XML text pretty much in shape in advance of that step. I think that
> is what Lou was getting at when he was asking you for
> "proposed changes" (to the DetNet Use Cases draft). That is,
> your proposed text adapted to match the form of a new section for the
> current draft.
>
>
> Then once that text was approved I could pretty much cut and paste it (in
> XML format) into the DetNet Use Cases draft. At that point you could
> leaving your existing draft as a stand-alone document in its original form
> (e.g. with its current notion of use of the Internet) if you have a use for
> that, but otherwise that document would not be directly adopted by DetNet
> WG and could be left to expire.
>
>
> My observation, along with Patrick, is that the only place in which it
> diverges from the current DetNet use cases is the integration with the
> Internet - however I will pose the question - do you (or anyone else) know
> of any other place in which this use case has expectations that are not
> currently satisfied by the list of "Common  Themes" as presented in my Use
> Cases preso slides at IETF 96? If so please let us know so that we can
> consider them also.
>
>
> ------------------------------
> *From:* Patrick Wetterwald (pwetterw) <[email-masked]>
> *Sent:* Tuesday, July 19, 2016 8:07 AM
> *To:* Maik Seewald (maseewal); Thomas Watteyne;
> *Cc:* Pascal Thubert (pthubert); Xavier Vilajosana; Spiros Spirou;
> Grossman, Ethan A.; Mahmoodi, Toktam; Kulkarni, Vivek; [email-masked]
>
> *Subject:* Re: [Detnet] detnet use case wind farm
>
> I’ll be happy to work with you in defining / refining the difference with
> the Electrical utility use cases that are already included in the WG
> document.
>
> Wind farms are a specific generation use case and, as Maik already
> mentioned, derived from power automation scenarios. Ethan did an excellent
> job on summarising the requirements in a bullet list for each of the big
> use cases. We need to look if it already covers your case.
>
> The interesting part (at least for me) is the use of Internet that you
> listed in your draft. My current understanding from the WG is that it is
> out of the scope of Detnet. Lets discuss it if this has to be changed.
>
> Thanks,
>
> Patrick
>
>
> From: detnet <[email-masked]> on behalf of "Maik Seewald
> (maseewal)" <[email-masked]>
> To: Thomas Watteyne <[email-masked]>, "
> [email-masked]" <[email-masked]>
> Cc: Pascal THUBERT <[email-masked]>, Xavier Vilajosana <
> [email-masked]>, Spiros Spirou <[email-masked]>,
> "[email-masked]" <[email-masked]>, "Mahmoodi, Toktam"
> <[email-masked]>, "Kulkarni, Vivek" <[email-masked]>,
> "[email-masked]" <[email-masked]>
> Windpark communication needs high availability to ensure protection
> schemas in order to fulfill safety and system protection.
> BR. Maik
>
> From: Thomas Watteyne <[email-masked]>
> To: "[email-masked]" <
> [email-masked]>
> Cc: "Pascal Thubert (pthubert)" <[email-masked]>, Xavier Vilajosana <
> [email-masked]>, Spiros Spirou <[email-masked]>,
> "[email-masked]" <[email-masked]>, "Mahmoodi, Toktam"
> <[email-masked]>, "Kulkarni, Vivek" <[email-masked]>,
> "[email-masked]" <[email-masked]>
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dvilajosana-2Ddetnet-2Dwindfarm-2Dusecase-2D00&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=LxhKQc7uhoBtd2LqKb53h8ZerZ5TlshjbPB76BjdRe0&e=>
>>
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=qeCA-COiBpQkpzlHwtkPXZ1nCGahp_2hG9IqgQox1V4&e=>
>>
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=qeCA-COiBpQkpzlHwtkPXZ1nCGahp_2hG9IqgQox1V4&e=>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>
> --
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.thomaswatteyne.com&d=DQMGaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=o70oZ2kUSjKLvmrL51To4giAVx8MYGkodiHsSU6toJ4&m=pbza_bnrbJCAjX4cQE0h24lPp2cbLF1fmPIXjGKQRMU&s=tWL2uwYfgQhSMOtlrOcRyRbdsE_BmS-oRkn3lGZdjCo&e=>

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Wed, 20 Jul 2016 10:12:00 +0000

Sounds perfect to me.

2 questions / remarks that I have:

  *   The intra-domain / inter-domain need to be clearly specify.
  *   Better distinguish the deterministic flows from best effort ones. For instance “protection” is clearly real time and deterministic (leading to 4ms latency). Axle vibration is somewhere between best effort and real time (leading more to seconds). Corrosion is clearly best effort.

Happy to work with you to have this use case included  :-)

Thanks,

Patrick

From: Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 20 July 2016 at 11:56
To: "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Cc: pwetterw <[email-masked]<mailto:[email-masked]>>, "Maik Seewald (maseewal)" <[email-masked]<mailto:[email-masked]>>, Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Pascal THUBERT <[email-masked]<mailto:[email-masked]>>, Spiros Spirou <[email-masked]<mailto:[email-masked]>>, "Mahmoodi, Toktam" <[email-masked]<mailto:[email-masked]>>, "Kulkarni, Vivek" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] detnet use case wind farm

I propose the following:

We will go through the Electrical Utilities use case and identify differences and information that can be augmented by our use case. We will also bring up the intra-domain aspects that we have identified. With that we will generate a summary so we can further discuss. Once we agree on the content we will provide the xml file with the right format so you can easily integrate.

One think we consider very interesting from a use case document is that it brings the requirements to research and industrial communities. This is really key to drive and motivate lots of research and innovations, and specially if this is also motivating the work in an standardization work group. In our case, we provide a particular description of the wind turbine components and the requirements between them. This is narrower than what is in the current Electrical Utilities section. I think that this information is still useful and we can discuss if this can be kept as an annex, as a short subsection or somewhere else as gives an accurate and applied description of the system (which is different than other energy generation technologies e,g solar, thermal, etc...) and hence the requirements are slightly different.

what do you think?

kind regards,
Xavi

Xavier Vilajosana
CIO

Aragó, 383, 4th floor
08013 Barcelona, Spain

2016-07-19 19:20 GMT+02:00 Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>>:

Hello Xavi et al,

Best,

Ethan.

________________________________
From: Patrick Wetterwald (pwetterw) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 19, 2016 8:07 AM
To: Maik Seewald (maseewal); Thomas Watteyne; [email-masked]<mailto:[email-masked]>
Cc: Pascal Thubert (pthubert); Xavier Vilajosana; Spiros Spirou; Grossman, Ethan A.; Mahmoodi, Toktam; Kulkarni, Vivek; [email-masked]<mailto:[email-masked]>

Thanks,

Patrick

Pat

Pat Kinney
Kinney Consulting LLC
IEEE 802.15 WG vice chair, SC chair
ISA100 co-chair, ISA100.20 chair
O: +1.847.960.3715<tel:%2B1.847.960.3715>
[email-masked]

I support this.

Regards,

Pascal

Dear Ethan, all

kind regards,
Xavi

Xavier Vilajosana
CIO

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

Thomas Watteyne, PhD

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: Karl Weber <[email-masked]>
Date: Wed, 20 Jul 2016 11:06:25 +0000

To find the exact cause of vibration a very close correlation to the real world actions is needed. I would not use a best effort sampling of me sure values as in error situations this channel may not work and vibration could be safety critical.

Vibration is a hot topic in manufacturing as well.

Karl

Von meinem Samsung Gerät gesendet.

-------- Ursprüngliche Nachricht --------
Von: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Datum: 20.07.16 06:12 (GMT-05:00)
An: Xavier Vilajosana <[email-masked]>, "Grossman, Ethan A." <[email-masked]>
Cc: "Pascal Thubert (pthubert)" <[email-masked]>, Spiros Spirou <[email-masked]>, "Mahmoodi, Toktam" <[email-masked]>, "Maik Seewald (maseewal)" <[email-masked]>, "Kulkarni, Vivek" <[email-masked]>, Thomas Watteyne <[email-masked]>, [email-masked], [email-masked]
Betreff: Re: [Detnet] detnet use case wind farm

Sounds perfect to me.

Thanks,

Patrick

I propose the following:

what do you think?

kind regards,
Xavi

Xavier Vilajosana
CIO

Aragó, 383, 4th floor
08013 Barcelona, Spain

Beckhoff Automation GmbH & Co. KG | Managing Director: Dipl. Phys. Hans Beckhoff
Registered office: Verl, Germany | Register court: Guetersloh HRA 7075

Hello Xavi et al,

Best,

Ethan.

Thanks,

Patrick

Pat

Pat Kinney
Kinney Consulting LLC

I support this.

Regards,

Pascal

Dear Ethan, all

kind regards,
Xavi

Xavier Vilajosana
CIO

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

Thomas Watteyne, PhD

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: Xavier Vilajosana <[email-masked]>
Date: Tue, 26 Jul 2016 17:55:55 +0200

Dear Ethan, Patrick, all

we have gone through the utility networks use case. We have identified the
following possible fitting:

In section 3.1.2 Generation Use Case.

We propose to split it in 2 parts.
1- Control of the generated power
2- Control of the generation infrastructure
   The generation system, requires certain levels of QoS. As defined in the
Wind Farm generation use case.
   Add it as an example. (at least the table in the wind farm use case +
the figure with the different subsystems)

We have also identified one more detail that may be important: This is a
general requirement that may apply to other subsystems.
In Table 7, communication requirements can be augmented by adding a
limitation on consecutive packet losses. The rationale is that consecutive
packet loss have impact to the operation of the system, and not only the
probability of packet loss. In a Wind Farm the requirement is to receive at
least one packet for each application cycle, otherwise the control system
triggers an alarm. So, the maximum number of consecutive packet losses
depends on the application cycle and the report frequency. When this
happens, the SCADA system triggers an alarm to stop the turbine/generation
system, even if the probability is below, e.g. the 0.1% presented in table
7.

In the measured Wind Farm we found a 10-20 ms one way latency, the SCADA
had an application cycle of 150ms which included some space for
computational delays. The later gives an indication of the number of times
a packet can be lost before the SCADA stops the system.

As for the Inter-domain requirements (through Internet) we propose to add
it as a new section and maybe point out whether Detnet addresses it or not.
We are happy to participate in that discussion and bring in our vision
about inter-domain requirements.

kind regards,
Xavi

*Xavier Vilajosana*
*CIO*

Aragó, 383, 4th floor
08013 Barcelona, Spain

2016-07-20 13:06 GMT+02:00 Karl Weber <[email-masked]>:

> To find the exact cause of vibration a very close correlation to the real
> world actions is needed. I would not use a best effort sampling of me sure
> values as in error situations this channel may not work and vibration could
> be safety critical.
>
> Cc: "Pascal Thubert (pthubert)" <[email-masked]>, Spiros Spirou <
> [email-masked]>, "Mahmoodi, Toktam" <[email-masked]>,
> "Maik Seewald (maseewal)" <[email-masked]>, "Kulkarni, Vivek" <
> [email-masked]>, Thomas Watteyne <[email-masked]>,
> [email-masked], [email-masked]
>    - The intra-domain / inter-domain need to be clearly specify.
>    - Better distinguish the deterministic flows from best effort ones.
>    For instance “protection” is clearly real time and deterministic (leading
>    to 4ms latency). Axle vibration is somewhere between best effort and real
>    time (leading more to seconds). Corrosion is clearly best effort.
>
> From: Xavier Vilajosana <[email-masked]>
> To: "Grossman, Ethan A." <[email-masked]>
> Cc: pwetterw <[email-masked]>, "Maik Seewald (maseewal)" <
> [email-masked]>, Thomas Watteyne <[email-masked]>, "
> [email-masked]" <[email-masked]>,
> Pascal THUBERT <[email-masked]>, Spiros Spirou <
> [email-masked]>, "Mahmoodi, Toktam" <[email-masked]>,
> "Kulkarni, Vivek" <[email-masked]>, "[email-masked]" <
> [email-masked]>
>> "[email-masked]" <[email-masked]>, "Mahmoodi,
>> Toktam" <[email-masked]>, "Kulkarni, Vivek" <
>> [email-masked]>, "[email-masked]" <[email-masked]>
>> "[email-masked]" <[email-masked]>, "Mahmoodi,
>> Toktam" <[email-masked]>, "Kulkarni, Vivek" <
>> [email-masked]>, "[email-masked]" <[email-masked]>

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: "Patrick Wetterwald (pwetterw)" <[email-masked]>
Date: Wed, 27 Jul 2016 13:32:47 +0000

Hi Xavier,

I agree with the approach. Let’s work on this direction.

A few comments:

  *   I saw the requirements for consecutive packet loss in the industrial automation space. I guess that wind turbine is a mix of power automation and industrial automation (rotating engine). I agree that we can add this requirements in the table (s). In some cases it was hidden behind what I called “recovery time on node failure” and the “hitless” requirement but let’s do it explicit.
  *   Inter-domain requirements: Personally, I would love to see it addressed but more discussion needs to happen in the working group.

I guess you will send an XML proposal to Ethan?

Thanks,

Patrick

From: Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 26 July 2016 at 17:55
To: Karl Weber <[email-masked]<mailto:[email-masked]>>
Cc: pwetterw <[email-masked]<mailto:[email-masked]>>, "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>, Pascal THUBERT <[email-masked]<mailto:[email-masked]>>, Spiros Spirou <[email-masked]<mailto:[email-masked]>>, "Mahmoodi, Toktam" <[email-masked]<mailto:[email-masked]>>, "Maik Seewald (maseewal)" <[email-masked]<mailto:[email-masked]>>, "Kulkarni, Vivek" <[email-masked]<mailto:[email-masked]>>, Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] detnet use case wind farm

Dear Ethan, Patrick, all

we have gone through the utility networks use case. We have identified the following possible fitting:

We propose to split it in 2 parts.
1- Control of the generated power
2- Control of the generation infrastructure
   The generation system, requires certain levels of QoS. As defined in the Wind Farm generation use case.
   Add it as an example. (at least the table in the wind farm use case + the figure with the different subsystems)

We have also identified one more detail that may be important: This is a general requirement that may apply to other subsystems.
In Table 7, communication requirements can be augmented by adding a limitation on consecutive packet losses. The rationale is that consecutive packet loss have impact to the operation of the system, and not only the probability of packet loss. In a Wind Farm the requirement is to receive at least one packet for each application cycle, otherwise the control system triggers an alarm. So, the maximum number of consecutive packet losses depends on the application cycle and the report frequency. When this happens, the SCADA system triggers an alarm to stop the turbine/generation system, even if the probability is below, e.g. the 0.1% presented in table 7.

In the measured Wind Farm we found a 10-20 ms one way latency, the SCADA had an application cycle of 150ms which included some space for computational delays. The later gives an indication of the number of times a packet can be lost before the SCADA stops the system.

As for the Inter-domain requirements (through Internet) we propose to add it as a new section and maybe point out whether Detnet addresses it or not. We are happy to participate in that discussion and bring in our vision about inter-domain requirements.

kind regards,
Xavi

Xavier Vilajosana
CIO

Aragó, 383, 4th floor
08013 Barcelona, Spain

2016-07-20 13:06 GMT+02:00 Karl Weber <[email-masked]<mailto:[email-masked]>>:
To find the exact cause of vibration a very close correlation to the real world actions is needed. I would not use a best effort sampling of me sure values as in error situations this channel may not work and vibration could be safety critical.

Karl

-------- Ursprüngliche Nachricht --------
Von: "Patrick Wetterwald (pwetterw)" <[email-masked]<mailto:[email-masked]>>
Datum: 20.07.16 06:12 (GMT-05:00)
An: Xavier Vilajosana <[email-masked]<mailto:[email-masked]>>, "Grossman, Ethan A." <[email-masked]<mailto:[email-masked]>>
Cc: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>, Spiros Spirou <[email-masked]<mailto:[email-masked]>>, "Mahmoodi, Toktam" <[email-masked]<mailto:[email-masked]>>, "Maik Seewald (maseewal)" <[email-masked]<mailto:[email-masked]>>, "Kulkarni, Vivek" <[email-masked]<mailto:[email-masked]>>, Thomas Watteyne <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Betreff: Re: [Detnet] detnet use case wind farm

Sounds perfect to me.

Thanks,

Patrick

I propose the following:

what do you think?

kind regards,
Xavi

Xavier Vilajosana
CIO

Aragó, 383, 4th floor
08013 Barcelona, Spain

Hello Xavi et al,

Best,

Ethan.

Thanks,

Patrick

Pat

Pat Kinney
Kinney Consulting LLC

I support this.

Regards,

Pascal

Dear Ethan, all

kind regards,
Xavi

Xavier Vilajosana
CIO

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

[X]

Aragó, 383, 4th floor
08013 Barcelona, Spain

Thomas Watteyne, PhD

Aragó, 383, 4th floor
08013 Barcelona, Spain

Aragó, 383, 4th floor
08013 Barcelona, Spain

---

From: Xavier Vilajosana <[email-masked]>
Date: Wed, 27 Jul 2016 15:35:20 +0200

Hi Patrick,

thanks for your quick action. I can send our current xml file and  help on
the merging if needed. Maybe I synchronize with him offline.

thanks and kind regards,
Xavi

*Xavier Vilajosana*
*CIO*

Aragó, 383, 4th floor
08013 Barcelona, Spain

2016-07-27 15:32 GMT+02:00 Patrick Wetterwald (pwetterw) <[email-masked]
>:

>    - I saw the requirements for consecutive packet loss in the industrial
>    automation space. I guess that wind turbine is a mix of power automation
>    and industrial automation (rotating engine). I agree that we can add this
>    requirements in the table (s). In some cases it was hidden behind what I
>    called “recovery time on node failure” and the “hitless” requirement but
>    let’s do it explicit.
>    - Inter-domain requirements: Personally, I would love to see it
>    addressed but more discussion needs to happen in the working group.
>
> To: Karl Weber <[email-masked]>
> Cc: pwetterw <[email-masked]>, "Grossman, Ethan A." <[email-masked]>,
> [email-masked]>, Thomas Watteyne <[email-masked]>, "
>> One think we consider very interesting from a use case document is that
>> it brings the requirements to research and industrial communities. This is
>>> Then once that text was approved I could pretty much cut and paste
>>> it (in XML format) into the DetNet Use Cases draft. At that point you could
>>> I’ll be happy to work with you in defining / refining the difference
>>> with the Electrical utility use cases that are already included in the WG
>>> document.
>>>
>>> Cc: "Pascal Thubert (pthubert)" <[email-masked]>, Xavier Vilajosana
>>> <[email-masked]>, Spiros Spirou <[email-masked]>,

-- 

Aragó, 383, 4th floor
08013 Barcelona, Spain