Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-10.txt

From: [email-masked]
Date: Mon, 04 Jul 2016 19:52:54 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Deterministic Networking of the IETF.

        Title           : Deterministic Networking Use Cases
        Authors         : Ethan Grossman
                          Craig Gunther
                          Pascal Thubert
                          Patrick Wetterwald
                          Jean Raymond
                          Jouni Korhonen
                          Yu Kaneko
                          Subir Das
                          Yiyong Zha
                          Balázs Varga
                          János Farkas
                          Franz-Josef Goetz
                          Juergen Schmitt
	Filename        : draft-ietf-detnet-use-cases-10.txt
	Pages           : 72
	Date            : 2016-07-04

Abstract:
   This draft documents requirements in several diverse industries to
   establish multi-hop paths for characterized flows with deterministic
   properties.  In this context deterministic implies that streams can
   be established which provide guaranteed bandwidth and latency which
   can be established from either a Layer 2 or Layer 3 (IP) interface,
   and which can co-exist on an IP network with best-effort traffic.

   Additional requirements include optional redundant paths, very high
   reliability paths, time synchronization, and clock distribution.
   Industries considered include wireless for industrial applications,
   professional audio, electrical utilities, building automation
   systems, radio/mobile access networks, automotive, and gaming.

   For each case, this document will identify the application, identify
   representative solutions used today, and what new uses an IETF DetNet
   solution may enable.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-detnet-use-cases/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-detnet-use-cases-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-detnet-use-cases-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 5 Jul 2016 03:23:17 +0000

Hi Folks,
This update to the DetNet Use Cases draft incorporates the preliminary conclusions drawn from the DetNet list discussions around the various "use case statement" threads that I started after IETF95. I will be reviewing these conclusions with you at IETF  96 (albeit remotely). Of the 21 discussions it appeared to me that we reached preliminary conclusions on 17 of them, so there are 4 that I would like to discuss further at IETF 96, which are: 

Providing Synchronized Time
	?How to express app time accuracy and reliability needs?
Stream Start-up (or re-start) Time 
	?Beyond DetNet, must be handled by app, e.g. redundancy
Latency matching – single- or bi-directional
	?Utilities needs this, but not clear how to address in DetNet?
Traffic Segregation (multicast MAC addrs to many devices, IPv4)
	?Problem for P-N-P networks – not for centrally configured networks? (No discussion on thread)

If you have questions or comments on any of this, or have any new use case related items to discuss please speak up. Also, FYI, I assembled all of the related text from these threads into a (MS Word) doc so that I could see it all in one place. If you want me to forward that doc to you off-list just let me know. 

Your faithful Use Cases draft editor,
Ethan.

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 04, 2016 7:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-10.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
detnet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 5 Jul 2016 03:27:40 +0000

Yes there are 4 items below, missed a carriage return somehow.  Should read like this: 

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Monday, July 04, 2016 8:23 PM
To: [email-masked]
Subject: Re: [Detnet] I-D Action: draft-ietf-detnet-use-cases-10.txt

Hi Folks,

	?Beyond DetNet, must be handled by app, e.g. redundancy Latency matching – single- or bi-directional

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 04, 2016 7:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-10.txt

Abstract:

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 5 Jul 2016 03:30:05 +0000

Wow same problem again. The third item should read 

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of Grossman, Ethan A.
Sent: Monday, July 04, 2016 8:23 PM
To: [email-masked]
Subject: Re: [Detnet] I-D Action: draft-ietf-detnet-use-cases-10.txt

Hi Folks,

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 04, 2016 7:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Detnet] I-D Action: draft-ietf-detnet-use-cases-10.txt

Abstract: