Subject: [Detnet] Layer 2/3 architecture

From: John Dowdell <[email-masked]>
Date: Thu, 21 Jul 2016 10:56:05 +0100

Hi

Having looked at the problem statement, use case and architecture drafts,
it is not clear to me how the work of the various SDOs is intended to fit
together. I fully understand that the IETF outputs should be useable with
the output of any other SDO (eg the 802.1 TSN group) but this makes the
architecture so general it becomes difficult for a newcomer to work out how
the various outputs can be used to implement a combined layer 2/3 system.

I believe the problem statement draft adequately explains the position with
regard to the relationship, but either the architecture or a seperate
informational draft needs to articulate how the extensions to 802.1 are
intended to dovetail with the outputs of detnet. If there are other
significant layer 2 SDOs then the dovetailing should be similarly explained
for that context. Doing this also means that reviewers can better follow
discussion and design threads between the various working groups and better
highlight when detnet can be assessed to be done with a particular
milestone, or are waiting on another SDO for a resolution or pending update.

It will also help with ensuring that [1] remains true.

Even though I am a newcomer to this particular corner of networking, I
would be very happy to work with the experts to propose and review text for
this.

Best regards
John

[1] https://mailarchive.ietf.org/arch/msg/detnet/kZyK_o6s8cHDpQIfneJqYv2MtjQ

---

From: "Norman Finn (nfinn)" <[email-masked]>
Date: Mon, 25 Jul 2016 15:41:19 +0000

Thanks for the offer to help, John.

IMO, there are two parts to the DetNet architecture, which is a little clearer in v07.  One is the congestion protection, meaning queuing/shaping to achieve low or zero congestion loss, and the other is service protection (this term may change), which is using multiple paths to avoid loss due to equipment failures.  I know of only one data plane standard for low/zero congestion loss, and that’s the 802.1 AVB and TSN stuff.  For the multipathing, there are lots of possible standards, as outlined in the data plane alternatives draft, for L2.5 and above.  For strictly L2, I don’t get the impression that the DetNet WG want to become involved.  There are two standards complete or in progress I know of, IEEE 082.1CB (in progress) and ISO/IEC 62439-3 (complete).  There is ongoing work and liaisons in progress to ensure that these standards are interworkable.

I agree that dovetailing 802 and DetNet will be necessary, and will take a fair amount of work.  But, I think that most of that work will be in the data plane, and we haven’t started that, yet.  I look forward to working with you in that effort.

— Norm

From: detnet <[email-masked]<mailto:[email-masked]>> on behalf of John Dowdell <[email-masked]<mailto:[email-masked]>>
Date: Thursday, July 21, 2016 at 02:56 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] Layer 2/3 architecture

Hi

Having looked at the problem statement, use case and architecture drafts, it is not clear to me how the work of the various SDOs is intended to fit together. I fully understand that the IETF outputs should be useable with the output of any other SDO (eg the 802.1 TSN group) but this makes the architecture so general it becomes difficult for a newcomer to work out how the various outputs can be used to implement a combined layer 2/3 system.

I believe the problem statement draft adequately explains the position with regard to the relationship, but either the architecture or a seperate informational draft needs to articulate how the extensions to 802.1 are intended to dovetail with the outputs of detnet. If there are other significant layer 2 SDOs then the dovetailing should be similarly explained for that context. Doing this also means that reviewers can better follow discussion and design threads between the various working groups and better highlight when detnet can be assessed to be done with a particular milestone, or are waiting on another SDO for a resolution or pending update.

Even though I am a newcomer to this particular corner of networking, I would be very happy to work with the experts to propose and review text for this.

Best regards
John