Subject: [Detnet] FW: New Version Notification for draft-zha-detnet-flow-info-model-00.txt

From: zhayiyong <[email-masked]>
Date: Fri, 8 Jul 2016 10:11:38 +0000

Hi Folks，

There is a new draft detnet flow information model for your reading pleasure. Hope we can discuss more on that. Thank you.

Regards,
Yiyong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 08, 2016 11:40 AM
To: Liang Geng; 4c 69 61 6e 67 20 47 65 6e 67; zhayiyong; Jiangyuanlong
Subject: New Version Notification for draft-zha-detnet-flow-info-model-00.txt

A new version of I-D, draft-zha-detnet-flow-info-model-00.txt
has been successfully submitted by Yiyong Zha and posted to the IETF repository.

Name:		draft-zha-detnet-flow-info-model
Revision:	00
Title:		Deterministic Networking Flow Information Model
Document date:	2016-07-08
Group:		Individual Submission
Pages:		10
URL:            https://www.ietf.org/internet-drafts/draft-zha-detnet-flow-info-model-00.txt
Status:         https://datatracker.ietf.org/doc/draft-zha-detnet-flow-info-model/
Htmlized:       https://tools.ietf.org/html/draft-zha-detnet-flow-info-model-00

Abstract:
   Deterministic Networking (DetNet) provides end-to-end absolute
   delay and loss guarantee to serve real-time applications. DetNet
   is focused on a general approach that use techniques such as 1)
   data plane resources reservation for DetNet flows; 2) providing
   fixed path for DetNet flows; 3)sequentializng, replicating, and
   eliminating duplicate packets transmission [I-D.finn-detnet-
   architecture] to guarantee the worst case delay of DetNet flow
   while allow sharing among best effort traffic. Data flow
   information model is important to the DetNet work that it defines
   information be used by flow establishment and control protocols.
   This document describes and DetNet flow information model that
   represents the flow identifier, traffic description information so
   that can make resource reservation and provide differentiate
   service.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Rodney Cummings <[email-masked]>
Date: Fri, 8 Jul 2016 21:17:22 +0000

Hello Yinlong,

You and others in DetNet might be interested in the information model that has been in work in the IEEE 802.1 Time-Sensitive Networking (TSN) task group, as part of the 802.1Qcc amendment. I am the current editor of 802.1Qcc.

The most recent draft of 802.1Qcc is:
	http://ieee802.org/1/files/private/cc-drafts/d1/802-1Qcc-d1-0.pdf
You can obtain the login to view drafts by subscribing to the 802.1 mailing list:
	http://www.ieee802.org/1/email-pages/eszelbig.html#spsub
or a web search for "802.1 information ietf" is likely to find it.

The specifications for the information model are all in "clause 99" (you can ignore the rest). The overall goals and design seem to be aligned with your draft. Specifically, the TrafficSpecification (99.2.2.5) is designed to support both asynchronous and synchronous (scheduled) traffic.

Feedback on the 802.1Qcc draft is welcomed, even if we decide not to align that project with DetNet work.

Thanks,
---
Rodney Cummings
Principal Software Architect, Industrial/Embedded Networks
National Instruments

> From: detnet [mailto:[email-masked]] On Behalf Of zhayiyong
> Sent: Friday, July 8, 2016 5:12 AM
> To: [email-masked]
> Subject: [Detnet] FW: New Version Notification for draft-zha-detnet-flow-
> info-model-00.txt
> 
> Hi Folks，
> 
> There is a new draft detnet flow information model for your reading
> pleasure. Hope we can discuss more on that. Thank you.
> 
> Regards,
> Yiyong
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: zhayiyong <[email-masked]>
Date: Mon, 11 Jul 2016 09:30:10 +0000

Hi Rodney,

Thank you for your comments. IMO, Qcc information such as TrafficSpecification is useful for DetNet and should be included. DetNet Flow model should define a set of information used for flow establishment and control, reservation protocols and YANG data models. It might be more than Qcc. 

Regards,
Yiyong

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of Rodney Cummings
Sent: Saturday, July 09, 2016 5:17 AM
To: [email-masked]
Subject: Re: [Detnet] New Version Notification for draft-zha-detnet-flow-info-model-00.txt

Hello Yinlong,

Thanks,
---
Rodney Cummings
Principal Software Architect, Industrial/Embedded Networks National Instruments

> Subject: [Detnet] FW: New Version Notification for 
> draft-zha-detnet-flow- info-model-00.txt
> 
> Hi Folks，
> 
> Subject: New Version Notification for 
> draft-zha-detnet-flow-info-model- 00.txt
> 
>

---

From: Yu KANEKO <[email-masked]>
Date: Tue, 12 Jul 2016 09:33:58 +0900

Hello Yinlong,

The flow traffic description stated in the section 3.2 seem to be able to specify periodic burst traffic characteristics. On the other hand, I think there are some cases applications don't know when it sends data. For example, on detection of fire in building automation systems, some critical packets is sent to fire shutters, sprinklers and alarms. Those kind of event-driven packets should be dealt with high priority but applications don't know when it occur.

I'm interested in how to specify those event-driven packets in flow information model. How do you think about this?

Best Regards,
Kaneko

> 2016/07/11 18:30、zhayiyong <[email-masked]> のメール：
> 
> Hi Rodney,
>

---

From: zhayiyong <[email-masked]>
Date: Tue, 12 Jul 2016 09:25:28 +0000

Hi Kaneko-san,

Thank you for your comments. As you mentioned, synchronized traffic flow can be well described with traffic model. For event-driven packets or flow, a predefined traffic model or traffic profile can be applied. For example, the traffic from a fire alarm sensor may be fixed with same number of packets or same traffic pattern. So every time there is fire alarm, put identifier on first packet, so the network can identify it is fire alarm and reserve resource as "fire alarm" traffic model. 
Hope it make some sense. We need to take into account more scenarios. 
BTW, there are two people, Yiyong and Yuanlong, I know it is confusing.  :)  

Regards,
Yiyong

-----Original Message-----
From: Yu KANEKO [mailto:[email-masked]] 
Sent: Tuesday, July 12, 2016 8:34 AM
To: zhayiyong
Cc: [email-masked]
Subject: Re: [Detnet] New Version Notification for draft-zha-detnet-flow-info-model-00.txt

Hello Yinlong,

Best Regards,
Kaneko

---

From: Yu Kaneko <[email-masked]>
Date: Tue, 12 Jul 2016 21:14:36 +0900

Dear Yiyong,

I'm really sorry for my mistake in your name.

And, thank you for your response. The approach you mentioned (putting an 
identifier) makes sense to me.

Thanks,
Kaneko

---

From: zhayiyong <[email-masked]>
Date: Wed, 13 Jul 2016 01:07:18 +0000

It is ok, hope we can discuss more on that.

-----Original Message-----
From: Yu Kaneko [mailto:[email-masked]] 
Sent: Tuesday, July 12, 2016 8:15 PM
To: zhayiyong
Cc: [email-masked]
Subject: Re: [Detnet] New Version Notification for draft-zha-detnet-flow-info-model-00.txt

Dear Yiyong,

Thanks,
Kaneko