Subject: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02

From: Pat Thaler <[email-masked]>
Date: Tue, 9 Aug 2016 14:36:55 -0700

Authors, Contributors, WG,

As part of the preparation for WG Adoption

Are you aware of any IPR that applies to the draft identified above?

Please state either:

"No, I'm not aware of any IPR that applies to this draft"
or
"Yes, I'm aware of IPR that applies to this draft"

If so, has this IPR been disclosed in compliance with IETF IPR rules
(see RFCs 3979, 4879, 3669 and 5378 for more details)?

If yes to the above, please state either:

"Yes, the IPR has been disclosed in compliance with IETF IPR rules"
or
"No, the IPR has not been disclosed"

If you answer no, please provide any additional details you think
appropriate.

If you are listed as a document author or contributor please answer the
above by responding to this email regardless of whether or not you are
aware of any relevant IPR. This document will not advance to the next
stage until a response has been received from each author and listed
contributor. NOTE: THIS APPLIES TO ALL OF YOU LISTED IN THIS MESSAGE'S
TO LINES.

If you are on the WG email list or attend WG meetings but are not listed
as an author or contributor, we remind you of your obligations under
the IETF IPR rules which encourages you to notify the IETF if you are
aware of IPR of others on an IETF contribution, or to refrain from
participating in any contribution or discussion related to your
undisclosed IPR. For more information, please see the RFCs listed above
and
http://trac.tools.ietf.org/group/iesg/trac/wiki/IntellectualProperty.

Thank you,
DetNet WG Chairs

PS Please include all listed in the headers of this message in your
response.

---

From: Lou Berger <[email-masked]>
Date: Tue, 9 Aug 2016 17:45:59 -0400

No, I'm not aware of any IPR that applies to this draft

Lou

(As Contributor)

On 8/9/2016 5:36 PM, Pat Thaler wrote:
> http://trac.tools.ietf.org/group/iesg/trac/wiki/IntellectualProperty
> <http://trac.tools.ietf.org/group/iesg/trac/wiki/IntellectualProperty>.
>
> Thank you,
> DetNet WG Chairs
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

---

From: "Jouni.nosmap" <[email-masked]>
Date: Tue, 9 Aug 2016 14:48:09 -0700

Jouni

Sent from a smart phone.. Mind the typos..

> On Aug 9, 2016, at 14:36, Pat Thaler <[email-masked]> wrote:
>

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 9 Aug 2016 21:49:28 +0000

No, I'm not aware of any IPR that applies to this draft.

                Regards,
                                Greg

From: Pat Thaler [mailto:[email-masked]]
Sent: Tuesday, August 09, 2016 2:37 PM
To: [email-masked]; Janos Farkas <[email-masked]>; Gregory Mirsky <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>; Zhuangyan (Yan) <[email-masked]>; Lou Berger <[email-masked]>
Cc: DetNet Chairs <[email-masked]>; [email-masked]
Subject: Regarding IPR on draft-dt-detnet-dp-alt-02

Please state either:

Thank you,
DetNet WG Chairs

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 9 Aug 2016 19:25:43 -0300

El ago 9, 2016 5:50 PM, "Gregory Mirsky" <[email-masked]>
escribió:

> *From:* Pat Thaler [mailto:[email-masked]]
> *Sent:* Tuesday, August 09, 2016 2:37 PM
> *To:* [email-masked]; Janos Farkas <[email-masked]>;
> Gregory Mirsky <[email-masked]>; Pascal Thubert (pthubert) <
> [email-masked]>; Zhuangyan (Yan) <[email-masked]>; Lou
> Berger <[email-masked]>
> *Cc:* DetNet Chairs <[email-masked]>; [email-masked]
> *Subject:* Regarding IPR on draft-dt-detnet-dp-alt-02
>
>
>

---

From: "Zhuangyan (Yan)" <[email-masked]>
Date: Wed, 10 Aug 2016 06:08:24 +0000

Best Regards,

Yan

发件人: Pat Thaler [mailto:[email-masked]]
发送时间: 2016年8月10日 5:37
收件人: [email-masked]; János Farkas; [email-masked]; Pascal Thubert (pthubert); Zhuangyan (Yan); Lou Berger
抄送: DetNet Chairs; [email-masked]
主题: Regarding IPR on draft-dt-detnet-dp-alt-02

Please state either:

Thank you,
DetNet WG Chairs

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 10 Aug 2016 06:53:32 +0000

Hello Lou

Regards,

Pascal

> Le 9 août 2016 à 23:36, Pat Thaler <[email-masked]> a écrit :
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 10 Aug 2016 07:16:18 +0000

Hello Pat

"Yes, I'm aware of IPR that applies to this draft"
Yes, the IPR has been disclosed in compliance with IETF IPR rules"

Regards,

Pascal

Le 9 août 2016 à 23:36, Pat Thaler <[email-masked]<mailto:[email-masked]>> a écrit :

Please state either:

Thank you,
DetNet WG Chairs

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 10 Aug 2016 07:16:50 +0000

Please disregard this;

Regards,

Pascal

> Le 10 août 2016 à 08:53, Pascal Thubert (pthubert) <[email-masked]> a écrit :
> 
> Hello Lou
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 10 Aug 2016 08:47:51 +0000

Damn,

I rechecked and the IPR is being published but was not yet. I'll update the chairs when it is.

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 10 août 2016 09:16
To: Pat Thaler <[email-masked]>
Cc: Lou Berger <[email-masked]>; [email-masked]; [email-masked]; János Farkas <[email-masked]>; DetNet Chairs <[email-masked]>; [email-masked]; Zhuangyan (Yan) <[email-masked]>
Subject: Re: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02

Hello Pat

Regards,

Pascal

Please state either:

Thank you,
DetNet WG Chairs

---

From: János Farkas <[email-masked]>
Date: Fri, 12 Aug 2016 00:59:30 +0200

Janos

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 12 Aug 2016 10:18:23 +0000

Dear chairs and all:

(I'm not a lawyer, so please make you own opinion on the below)

The IPR disclosure (https://datatracker.ietf.org/ipr/2844/) was posted as promised. This covers the adaptation of BIER-TE for traceability and OAM management.

What's presented in draft-dt-detnet-dp-alt-02 is merely an outline, but there is IPR related to that outline, which is not (yet) in a referenceable draft, so I had to announce it here.

I was explained that the delay to publish this IPR statement (since draft 00) was due to the informational nature of this draft, making terms a bit more complex to decide. The ask from the chairs triggered the decision and pure RAND terms were published, to fulfill IETF expectations.

If DetNet expresses interest in the approach, then I'll take this design to BIER for standard track work, and I understand that the terms for standard track will be at least as good as the RAND here, and probably better, in the line of Cisco's behavior WRT to IPR statements for standard track.

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 10 août 2016 10:48
To: Pat Thaler <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; János Farkas <[email-masked]>; DetNet Chairs <[email-masked]>; Lou Berger <[email-masked]>; Zhuangyan (Yan) <[email-masked]>
Subject: Re: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02

Damn,

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 10 août 2016 09:16
To: Pat Thaler <[email-masked]<mailto:[email-masked]>>
Cc: Lou Berger <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; János Farkas <[email-masked]<mailto:[email-masked]>>; DetNet Chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Zhuangyan (Yan) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02

Hello Pat

Regards,

Pascal

Please state either:

Thank you,
DetNet WG Chairs

---

From: Lou Berger <[email-masked]>
Date: Fri, 12 Aug 2016 08:07:09 -0400

Pascal,

    Perhaps it would be best to move the novel portion of the text to
it's own draft and have the "Solution Alternatives" draft reference it?

This would actually bring the document more in line with what at least I
expected as the DT output when the DT was chartered, from
https://www.ietf.org/mail-archive/web/detnet/current/msg00418.html :
    The DT is tasked with identifying the existing IP and/or
    MPLS data plane technologies that should be considered as the
    possible the foundation for the DetNet data plane definition.

What do you think?

Lou

On 8/12/2016 6:18 AM, Pascal Thubert (pthubert) wrote:
>
> Dear chairs and all:
>
>  
>
> (I’m not a lawyer, so please make you own opinion on the below)
>
>  
>
> The IPR disclosure (https://datatracker.ietf.org/ipr/2844/)was posted
> as promised. This covers the adaptation of BIER-TE for traceability
> and OAM management.
>
>  
>
> What’s presented in draft-dt-detnet-dp-alt-02 is merely an outline,
> but there is IPR related to that outline, which is not (yet) in a
> referenceable draft, so I had to announce it here.
>
>  
>
> I was explained that the delay to publish this IPR statement (since
> draft 00) was due to the informational nature of this draft, making
> terms a bit more complex to decide. The ask from the chairs triggered
> the decision and pure RAND terms were published, to fulfill IETF
> expectations.
>
>  
>
> If DetNet expresses interest in the approach, then I’ll take this
> design to BIER for standard track work, and I understand that the
> terms for standard track will be at least as good as the RAND here,
> and probably better, in the line of Cisco’s behavior WRT to IPR
> statements for standard track.
>
>  
>
> Cheers,
>
>  
>
> Pascal
>
>  
>
> *From:*detnet [mailto:[email-masked]] *On Behalf Of *Pascal
> Thubert (pthubert)
> *Sent:* mercredi 10 août 2016 10:48
> *To:* Pat Thaler <[email-masked]>
> *Cc:* [email-masked]; [email-masked];
> [email-masked]; János Farkas <[email-masked]>;
> DetNet Chairs <[email-masked]>; Lou Berger <[email-masked]>;
> Zhuangyan (Yan) <[email-masked]>
> *Subject:* Re: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02
>
>  
>
> Damn,
>
>  
>
> I rechecked and the IPR is being published but was not yet. I’ll
> update the chairs when it is.
>
>  
>
> Cheers,
>
>  
>
> Pascal
>
>  
>
> *From:*detnet [mailto:[email-masked]] *On Behalf Of *Pascal
> Thubert (pthubert)
> *Sent:* mercredi 10 août 2016 09:16
> *To:* Pat Thaler <[email-masked]
> <mailto:[email-masked]>>
> *Cc:* Lou Berger <[email-masked] <mailto:[email-masked]>>;
> [email-masked] <mailto:[email-masked]>;
> [email-masked] <mailto:[email-masked]>;
> János Farkas <[email-masked]
> <mailto:[email-masked]>>; DetNet Chairs
> <[email-masked] <mailto:[email-masked]>>;
> [email-masked] <mailto:[email-masked]>; Zhuangyan (Yan)
> <[email-masked] <mailto:[email-masked]>>
> *Subject:* Re: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02
>
>  
>
> Hello Pat
>
> Le 9 août 2016 à 23:36, Pat Thaler <[email-masked]
> <mailto:[email-masked]>> a écrit :
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 12 Aug 2016 13:26:55 +0000

Hello Lou:

Fair question;

I like the current form of the draft since it is a one stop shopping for selecting technology to achieve the various results that the data-plane needs, and what the efforts from the existing technologies to get there are. Certainly, the DT is sensitive to maturity and the draft has a metric for it, we're covered there I think.

The technology described in the BIER-TE section has been tested on real hardware; it "exists", works, and it is not mature. And it can do things that we appear to want, like traceability and OAM with control for the Replication function, and I've not seen mature technologies with equivalent capabilities already built in. So I'd keep the section for completeness in the DetNet work. If based on that work, interest is raised at the DetNet WG to integrate this technology with the solution, then we will have substantial motivation for BIER work, as yes, I'll be happy to contribute to the draft that you are suggesting. If not, we'll have a transparent proof that the technology was visible to the DetNet group and was not selected, but no motivation for spending BIER cycles.

Also I think that having clarity on IPR is actually a valuable information in such a catalog. There's probably IPR on most if not all the technologies discussed in the document, but for the most part it is a lot, lot harder to figure... I do not think that we are at the stage of building a solution and list all the IPR that gets dragged along with that solution. We have to admit that IPR there will be, and do our best in due time to ensure that this IPR follows IETF requirements.

What do others think?

Pascal

From: Lou Berger [mailto:[email-masked]]
Sent: vendredi 12 août 2016 14:07
To: Pascal Thubert (pthubert) <[email-masked]>; DetNet Chairs <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: Regarding IPR on draft-dt-detnet-dp-alt-02

Pascal,

    Perhaps it would be best to move the novel portion of the text to it's own draft and have the "Solution Alternatives" draft reference it?
This would actually bring the document more in line with what at least I expected as the DT output when the DT was chartered, from https://www.ietf.org/mail-archive/web/detnet/current/msg00418.html :
    The DT is tasked with identifying the existing IP and/or
    MPLS data plane technologies that should be considered as the
    possible the foundation for the DetNet data plane definition.

What do you think?

Lou

Cheers,

Pascal

From: detnet [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: mercredi 10 août 2016 10:48
To: Pat Thaler <[email-masked]><mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; János Farkas <[email-masked]><mailto:[email-masked]>; DetNet Chairs <[email-masked]><mailto:[email-masked]>; Lou Berger <[email-masked]><mailto:[email-masked]>; Zhuangyan (Yan) <[email-masked]><mailto:[email-masked]>
Subject: Re: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02

Damn,

Cheers,

Pascal

Hello Pat

Regards,

Pascal

Please state either:

Thank you,
DetNet WG Chairs

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 16 Aug 2016 07:21:23 +0000

Cheers
Bala’zs

From: detnet [mailto:[email-masked]] On Behalf Of Pat Thaler
Sent: Tuesday, August 09, 2016 11:37 PM
To: [email-masked]; Janos Farkas <[email-masked]>; Gregory Mirsky <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>; Zhuangyan (Yan) <[email-masked]>; Lou Berger <[email-masked]>
Cc: [email-masked]; DetNet Chairs <[email-masked]>
Subject: [Detnet] Regarding IPR on draft-dt-detnet-dp-alt-02

Please state either:

Thank you,
DetNet WG Chairs

---

From: Lou Berger <[email-masked]>
Date: Tue, 16 Aug 2016 10:48:47 -0400

All,

    I think it would be good to hear from the WG on the question of if
the WG document on Data Plane Alternatives should:

(a) include an extended definition of BIER-TE (which precipitated the
IPR disclosure discussed below)

(b) simply reference the existing (or new) BIER-TE document

(c) drop any reference to BIER-TE as its definition is currently not
within the charter of any IETF WG

Please send your opinion to the list if you wish to voice one.

Lou

PS:
As chair, my preference is (c) as BEIR-TE has no standing from the IETF
process perspective.  Of course I'm also happy to follow WG consensus.
As contributor, my preference is (b) as I'm open to being comprehensive
in surveying current options, but don't think this is the right document
to define solutions.

On 8/12/2016 9:26 AM, Pascal Thubert (pthubert) wrote:
>
> Hello Lou:
>
>  
>
> Fair question;
>
>  
>
> I like the current form of the draft since it is a one stop shopping
> for selecting technology to achieve the various results that the
> data-plane needs, and what the efforts from the existing technologies
> to get there are. Certainly, the DT is sensitive to maturity and the
> draft has a metric for it, we’re covered there I think.
>
>  
>
> The technology described in the BIER-TE section has been tested on
> real hardware; it “exists”, works, and it is not mature. And it can do
> things that we appear to want, like traceability and OAM with control
> for the Replication function, and I’ve not seen mature technologies
> with equivalent capabilities already built in. So I’d keep the section
> for completeness in the DetNet work. If based on that work, interest
> is raised at the DetNet WG to integrate this technology with the
> solution, then we will have substantial motivation for BIER work, as
> yes, I’ll be happy to contribute to the draft that you are suggesting.
> If not, we’ll have a transparent proof that the technology was visible
> to the DetNet group and was not selected, but no motivation for
> spending BIER cycles.
>
>  
>
> Also I think that having clarity on IPR is actually a valuable
> information in such a catalog. There’s probably IPR on most if not all
> the technologies discussed in the document, but for the most part it
> is a lot, lot harder to figure… I do not think that we are at the
> stage of building a solution and list all the IPR that gets dragged
> along with that solution. We have to admit that IPR there will be, and
> do our best in due time to ensure that this IPR follows IETF
> requirements.
>
>  
>
> What do others think?
>
>  
>
> Pascal
>
>  
>
> *From:*Lou Berger [mailto:[email-masked]]
> *Sent:* vendredi 12 août 2016 14:07
> *To:* Pascal Thubert (pthubert) <[email-masked]>; DetNet Chairs
> <[email-masked]>; [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: Regarding IPR on draft-dt-detnet-dp-alt-02
>
>  
>
> Pascal,
>
> This would actually bring the document more in line with what at least
> I expected as the DT output when the DT was chartered, from
>     The IPR disclosure (https://datatracker.ietf.org/ipr/2844/)was
>     posted as promised. This covers the adaptation of BIER-TE for
>     traceability and OAM management.
>
>      
>
>     What’s presented in draft-dt-detnet-dp-alt-02 is merely an
>     outline, but there is IPR related to that outline, which is not
>     (yet) in a referenceable draft, so I had to announce it here.
>
>      
>
>     I was explained that the delay to publish this IPR statement
>     (since draft 00) was due to the informational nature of this
>     draft, making terms a bit more complex to decide. The ask from the
>     chairs triggered the decision and pure RAND terms were published,
>     to fulfill IETF expectations.
>
>      
>
>     terms for standard track will be at least as good as the RAND
>     here, and probably better, in the line of Cisco’s behavior WRT to
>     IPR statements for standard track.
>
>      
>
>     Cheers,
>
>      
>
>     Pascal
>
>      
>
>     *From:*detnet [mailto:[email-masked]] *On Behalf Of
>     *Pascal Thubert (pthubert)
>     <mailto:[email-masked]>
>     *Cc:* [email-masked] <mailto:[email-masked]>;
>     János Farkas <[email-masked]>
>     <mailto:[email-masked]>; DetNet Chairs
>     <[email-masked]> <mailto:[email-masked]>; Lou
>     Berger <[email-masked]> <mailto:[email-masked]>; Zhuangyan
>     (Yan) <[email-masked]>
>     <mailto:[email-masked]>
>     *From:*detnet [mailto:[email-masked]] *On Behalf Of
>     *Pascal Thubert (pthubert)

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 16 Aug 2016 14:55:48 +0000

I'd take the (a) train, Lou.

I think the reader needs to understand what's doable.

Cheers,

Pascal

> -----Original Message-----
> Sent: mardi 16 août 2016 16:49
> To: Pascal Thubert (pthubert) <[email-masked]>; DetNet Chairs <detnet-
> [email-masked]>; [email-masked]
> Cc: [email-masked]
> Subject: BIER-TE definition in Dataplane Alternatives WG document (was Re:
> Regarding IPR on draft-dt-detnet-dp-alt-02)
> 
> All,
> 
>     I think it would be good to hear from the WG on the question of if the WG
> document on Data Plane Alternatives should:
> 
> (a) include an extended definition of BIER-TE (which precipitated the IPR
> disclosure discussed below)
> 
> (c) drop any reference to BIER-TE as its definition is currently not within the
> charter of any IETF WG
> 
> As chair, my preference is (c) as BEIR-TE has no standing from the IETF process
> perspective.  Of course I'm also happy to follow WG consensus.
> As contributor, my preference is (b) as I'm open to being comprehensive in
> surveying current options, but don't think this is the right document to define
> solutions.
> 
> > draft has a metric for it, we're covered there I think.
> >
> >
> >
> > real hardware; it "exists", works, and it is not mature. And it can do
> > for the Replication function, and I've not seen mature technologies
> > with equivalent capabilities already built in. So I'd keep the section
> > yes, I'll be happy to contribute to the draft that you are suggesting.
> > If not, we'll have a transparent proof that the technology was visible
> > information in such a catalog. There's probably IPR on most if not all
> > is a lot, lot harder to figure. I do not think that we are at the
> >     What's presented in draft-dt-detnet-dp-alt-02 is merely an
> >     If DetNet expresses interest in the approach, then I'll take this
> >     here, and probably better, in the line of Cisco's behavior WRT to

---

From: Balázs Varga A <[email-masked]>
Date: Wed, 17 Aug 2016 07:17:28 +0000

Hi,
My preference would be (b).
I think we need to reconsider (re-evaluate?) BIER-TE after all the layering/terminology discussions of the last meeting.
Cheers
Bala'zs

-----Original Message-----
From: detnet [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Tuesday, August 16, 2016 4:49 PM
To: Pascal Thubert (pthubert) <[email-masked]>; DetNet Chairs <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: [Detnet] BIER-TE definition in Dataplane Alternatives WG document (was Re: Regarding IPR on draft-dt-detnet-dp-alt-02)

All,

    I think it would be good to hear from the WG on the question of if the WG document on Data Plane Alternatives should:

(a) include an extended definition of BIER-TE (which precipitated the IPR disclosure discussed below)

(c) drop any reference to BIER-TE as its definition is currently not within the charter of any IETF WG

Lou

PS:
As chair, my preference is (c) as BEIR-TE has no standing from the IETF process perspective.  Of course I'm also happy to follow WG consensus.
As contributor, my preference is (b) as I'm open to being comprehensive in surveying current options, but don't think this is the right document to define solutions.

---

From: Subir Das <[email-masked]>
Date: Wed, 17 Aug 2016 08:53:05 -0400

My  preference is (c).

We can possibly revisit (b) when it is within the charter of an IETF WG.

-Subir

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 17 Aug 2016 09:01:15 -0700

I am actually ok with (a) if we somehow add a note of IPR in the
evaluation.. i.e., giving a hint the possible solution is then subject to
licensing. If this is not doable then (c). I either want to have the
discussion (with a note) or not at all.. Having just a reference to a draft
that is not in DetNet context does not help IMHO.

- Jouni

-- 
Jouni Korhonen, Broadcom Ltd.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 17 Aug 2016 17:09:23 +0000

Hi,
I think that the option (c) is the right thing to do at this moment. When BIER-TE becomes adopted by a working group the DetNet WG may consider its applicability and decide to update this document or have a new document to that. Having normative reference to the individual draft would, as I understand the process, create the dependency and lock publication of dp-alt draft. Informational, I agree with Jouni, wouldn’t do much service.

                Regards,
                                Greg

From: detnet [mailto:[email-masked]] On Behalf Of Jouni Korhonen
Sent: Wednesday, August 17, 2016 9:01 AM
To: Subir Das <[email-masked]>
Cc: [email-masked]; Pascal Thubert (pthubert) <[email-masked]>; Lou Berger <[email-masked]>; [email-masked]; DetNet Chairs <[email-masked]>
Subject: Re: [Detnet] BIER-TE definition in Dataplane Alternatives WG document (was Re: Regarding IPR on draft-dt-detnet-dp-alt-02)

I am actually ok with (a) if we somehow add a note of IPR in the evaluation.. i.e., giving a hint the possible solution is then subject to licensing. If this is not doable then (c). I either want to have the discussion (with a note) or not at all.. Having just a reference to a draft that is not in DetNet context does not help IMHO.

- Jouni

On Wed, Aug 17, 2016 at 5:53 AM, Subir Das <[email-masked]<mailto:[email-masked]>> wrote:
My  preference is (c).

On Tue, Aug 16, 2016 at 10:48 AM, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:
All,

Lou

PS:

On 8/12/2016 9:26 AM, Pascal Thubert (pthubert) wrote:
> *From:*Lou Berger [mailto:[email-masked]<mailto:[email-masked]>]
> *To:* Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>; DetNet Chairs
> <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> *Cc:* [email-masked]<mailto:[email-masked]>
>     *From:*detnet [mailto:[email-masked]<mailto:[email-masked]>] *On Behalf Of
>     *To:* Pat Thaler <[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     *Cc:* [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>;
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>;
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>;
>     János Farkas <[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]>>; DetNet Chairs
>     <[email-masked]<mailto:[email-masked]>> <mailto:[email-masked]<mailto:[email-masked]>>; Lou
>     Berger <[email-masked]<mailto:[email-masked]>> <mailto:[email-masked]<mailto:[email-masked]>>; Zhuangyan
>     (Yan) <[email-masked]<mailto:[email-masked]>>
>     <mailto:[email-masked]<mailto:[email-masked]>>
>     *From:*detnet [mailto:[email-masked]<mailto:[email-masked]>] *On Behalf Of
>     *To:* Pat Thaler <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>
>     *Cc:* Lou Berger <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>;
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>;
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>;
>     János Farkas <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>; DetNet Chairs
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>;
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>; Zhuangyan (Yan)
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     Le 9 août 2016 à 23:36, Pat Thaler <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>> a écrit :
>

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: Lou Berger <[email-masked]>
Date: Wed, 17 Aug 2016 13:33:46 -0400

Hi Jouni,

On 8/17/2016 12:01 PM, Jouni Korhonen wrote:
> evaluation.. i.e., giving a hint the possible solution is then subject
> to licensing.

I'm not sure about doing this, but we could say that "the definition of
BEIR-TE is not within the chartered scope of the DetNet WG".

> If this is not doable then
Would you want to keep (a) with the addition of the above?

Lou

> (c). I either want to have the discussion (with a note) or not at
> all.. Having just a reference to a draft that is not in DetNet context
> does not help IMHO.
>
> - Jouni
>
>
>
>         > *To:* Pascal Thubert (pthubert) <[email-masked]
>         <mailto:[email-masked]>>; DetNet Chairs
>         [email-masked]
>         <mailto:[email-masked]>
>         > *Cc:* [email-masked] <mailto:[email-masked]>
>         https://www.ietf.org/mail-archive/web/detnet/current/msg00418.html
>         <https://www.ietf.org/mail-archive/web/detnet/current/msg00418.html>
>         :
>         >     The IPR disclosure
>         (https://datatracker.ietf.org/ipr/2844/)was
>         <https://datatracker.ietf.org/ipr/2844/%29was>
>         >     *From:*detnet [mailto:[email-masked]
>         <mailto:[email-masked]>] *On Behalf Of
>         >     *Cc:* [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>;
>         >     [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>;
>         >     [email-masked]
>         <mailto:[email-masked]>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>;
>         <mailto:[email-masked]>>
>         >     <mailto:[email-masked]
>         >     <[email-masked] <mailto:[email-masked]>>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>; Lou
>         >     Berger <[email-masked] <mailto:[email-masked]>>
>         <mailto:[email-masked] <mailto:[email-masked]>>; Zhuangyan
>         >     *From:*detnet [mailto:[email-masked]
>         <mailto:[email-masked]>] *On Behalf Of
>         >     *Cc:* Lou Berger <[email-masked]
>         <mailto:[email-masked]> <mailto:[email-masked]
>         <mailto:[email-masked]>>>;
>         >     [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>;
>         >     [email-masked]
>         <mailto:[email-masked]>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>;
>         <mailto:[email-masked]>
>         >     <mailto:[email-masked]
>         <mailto:[email-masked]>>>; DetNet Chairs
>         >     <[email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>>;
>         >     [email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked] <mailto:[email-masked]>>; Zhuangyan (Yan)
>         >     <[email-masked]
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>>
>         >     Le 9 août 2016 à 23:36, Pat Thaler
>         <[email-masked] <mailto:[email-masked]>
>         >     <mailto:[email-masked]
>         <mailto:[email-masked]>>> a écrit :
>         >
>         >         Are you aware of any IPR that applies to the draft
>         identified
>         >         above?
>         >
>         >         Please state either:
>         >
>         >         If so, has this IPR been disclosed in compliance
>         with IETF IPR
>         >         rules
>         >         "Yes, the IPR has been disclosed in compliance with
>         IETF IPR
>         >         rules"
>         >         or
>         >         If you are listed as a document author or
>         contributor please
>         >         answer the
>         >         above by responding to this email regardless of
>         whether or not
>         >         you are
>         >         aware of any relevant IPR. This document will not
>         advance to
>         >         the next
>         >         stage until a response has been received from each
>         author and
>         >         listed
>         >         contributor. NOTE: THIS APPLIES TO ALL OF YOU LISTED
>         IN THIS
>         >         MESSAGE'S
>         >         TO LINES.
>         >
>         >         If you are on the WG email list or attend WG
>         meetings but are
>         >         not listed
>         >         as an author or contributor, we remind you of your
>         obligations
>         >         under
>         >         the IETF IPR rules which encourages you to notify
>         the IETF if
>         >         you are
>         >         undisclosed IPR. For more information, please see
>         the RFCs
>         >         listed above
>         >         and
>         >       
>         >         PS Please include all listed in the headers of this
>         message in
>         >         your
>         >         response.
>         >
>         >
>         >
>         >
>         >
>         >
>         >
>
>
>         [email-masked] <mailto:[email-masked]>
>         <https://www.ietf.org/mailman/listinfo/detnet>
>
>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/detnet>
>
>
>
>
> --

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 17 Aug 2016 12:12:57 -0700

Hi Lou,

> I'm not sure about doing this, but we could say that "the definition of

​Yep.. I have had similar case once in IESG and the IPR note got carved out
(I asked for it to be removed, actually ;)​

> BEIR-TE is not within the chartered scope of the DetNet WG".

​This is ok.​

> Would you want to keep (a) with the addition of the above?

​I am ok with the note and thus (a) is ok as well.

​- Jouni​

> >         <mailto:[email-masked]>>
> >         <mailto:[email-masked]>>>
> >         <mailto:[email-masked] <mailto:[email-masked]
> >>>;

---

From: Subir Das <[email-masked]>
Date: Wed, 17 Aug 2016 15:31:59 -0400

I agree that having a reference to a draft that is not in DetNet context is
not helpful. Then why to choose the option (a) with a note? I would avoid
it altogether and go with option (c).

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 17 Aug 2016 13:40:37 -0700

My acceptance - not preference - for (a) is because dp-alt draft is 
informational (no harm done with IPRs) and the discussion part of the 
BIER-TE is good. It would be a waste to lose it.

- JOuni

8/17/2016, 12:31 PM, Subir Das kirjoitti:
> I agree that having a reference to a draft that is not in DetNet context
> is not helpful. Then why to choose the option (a) with a note? I would
> avoid it altogether and go with option (c).
>
> On Wed, Aug 17, 2016 at 12:01 PM, Jouni Korhonen
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     evaluation.. i.e., giving a hint the possible solution is then
>     subject to licensing. If this is not doable then (c). I either want
>     to have the discussion (with a note) or not at all.. Having just a
>     reference to a draft that is not in DetNet context does not help IMHO.
>
>     - Jouni
>
>
>
>             <https://datatracker.ietf.org/ipr/2844/)was>
>             <mailto:[email-masked]>>>;
>             >         "Yes, the IPR has been disclosed in compliance
>             with IETF IPR
>             >         rules"
>             >         or
>             >         contributor. NOTE: THIS APPLIES TO ALL OF YOU
>             LISTED IN THIS
>             >         MESSAGE'S
>             >         TO LINES.
>             >
>             >         PS Please include all listed in the headers of
>             this message in
>             >         your
>             >         response.
>             >
>             >
>             >
>             >
>             >
>             >
>             >
>
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 17 Aug 2016 17:13:32 -0400

Jouni/All,

How about this as next steps:

1. You publish an update to the draft that adds the note along the lines
that "The definition of BIER-TE is outside the scope of the DetNet WG
charter."

2. We start the adoption poll, and then discuss
acceptance/objections/desired changes per normal process.  (And this
topic can be raised there by any who would like to see a change.)

Lou

---

From: Jouni Korhonen <[email-masked]>
Date: Wed, 17 Aug 2016 14:16:46 -0700

WFM.

On Wed, Aug 17, 2016 at 2:13 PM, Lou Berger <[email-masked]> wrote:

> >>             >     [email-masked] <mailto:[email-masked]
> >
> >>             >     [email-masked] <mailto:[email-masked]
> >
> Zhuangyan
> >>             (Yan)

---

From: Subir Das <[email-masked]>
Date: Wed, 17 Aug 2016 18:52:20 -0400

Understood

On Wed, Aug 17, 2016 at 4:40 PM, Jouni Korhonen <[email-masked]>
wrote:

>>             <mailto:[email-masked] <mailto:[email-masked]
>> >>;
>>             <mailto:[email-masked] <mailto:[email-masked]
>> >>;

---

From: Subir Das <[email-masked]>
Date: Wed, 17 Aug 2016 18:54:17 -0400

Okay with me.