Subject: [Detnet] DetNet MPLS Work Meeting 25Jun18 - notes

From: "Grossman, Ethan A." <[email-masked]>
Date: Mon, 25 Jun 2018 16:35:13 +0000

Present: Jouni, Balazs, Lou, Norm, AndyM, Ethan
Next MPLS DP discussion: Thursday 5Jul18 7am Pacific time (1 hour time slot), Lou to host.
Lou: MPLS DP draft review - Good conceptual text, not yet a lot of good text for how to implement, how to conform with this. E.g. Sec 8, 9, 10 are boilerplate. Good background but need to define operation of the data plane - needs requirements for implementing data plane to allow two implementations to interoperate.
Balazs: These are intended to be placeholders until after draft 00.
Jouni will be leaving on vacation from this coming Sunday. Will submit latest MPLS draft on Sat evening. Cutoff for pull requests is before Friday eve.
We need a presentation for MPLS DP draft for IETF 102. Jouni won't be at Montreal, so Balazs to take lead on this - Balazs to put together first cut at preso for review July 5.
Balazs won't be at Montreal, remote only - should someone else who will be local present this?
Norm will look at MPLS over TSN section - will try to get something written by Thurs.
Naming of POF, PREOF function definition and references need to be propagated to various drafts. Plan to fix in Arch doc then refer to it elsewhere.
For upcoming work on IP DP draft: Balazs will work on Interaction between IP domain and TSN domain. Lou to work on IP encapsulation procedure.
-----------------------------------------

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Jun 2018 18:08:45 +0100

On 25/06/2018 17:35, Grossman, Ethan A. wrote:
> Lou: MPLS DP draft review - Good conceptual text, not yet a lot of 
> good text for how to implement, how to conform with this. E.g. Sec 8, 
> 9, 10 are boilerplate. Good background but need to define operation of 
> the data plane – needs requirements for implementing data plane to 
> allow two implementations to interoperate.
>
> Jouni will be leaving on vacation from this coming Sunday. Will submit 
> latest MPLS draft on Sat evening. Cutoff for pull requests is before 
> Friday eve.
>
> We need a presentation for MPLS DP draft for IETF 102. Jouni won’t be 
> at Montreal, so Balazs to take lead on this - Balazs to put together 
> first cut at preso for review July 5.
>
> Balazs won’t be at Montreal, remote only – should someone else who 
> will be local present this?
>

I can present if that helps.

- Stewart

---

From: Balázs Varga A <[email-masked]>
Date: Tue, 26 Jun 2018 11:21:58 +0000

Hi Stewart,
Thanks for the offer. I can present remote and You can be a local
backup if there are any technical difficulties.
Cheers
Bala'zs

From: detnet <[email-masked]> On Behalf Of Stewart Bryant
Sent: 2018. június 25. 19:09
To: DetNet WG <[email-masked]>
Subject: Re: [Detnet] DetNet MPLS Work Meeting 25Jun18 - notes

- Stewart

---

From: Norman Finn <[email-masked]>
Date: Wed, 27 Jun 2018 01:02:09 +0000

I will be in a chorus rehearsal in Orlando at that time.

Here is some baseline text for the "DetNet over an IEEE 802 TSN subnetwork" section:

If a subnetwork interconnecting two or more DetNet nodes is an IEEE Std 802.1Q bridged LAN, then IEEE 802.1 Time-Sensitive Networking (TSN) standards can be used to extend the DetNet quality of service across the subnetwork.

Each DetNet flow across the subnetwork requires a {destination MAC address, VLAN identifier} pair that is unique over that subnetwork (bridged LAN).  The destination MAC address must be an IEEE 802 multicast address, regardless of whether the flow is a unicast (point-to-point) or a multicast (point-to-multipoint) flow.  Each flow requires its own {destination MAC address, VLAN identifier} pair, even if the source and destination IP addresses are the same for more than one of the flows, or for other, non-DetNet flows.  This is because 1) an IEEE Std 802.1Q bridge makes its forwarding decisions, even for explicit paths, based on the {destination MAC address, VLAN identifier} pair, and 2) the use of a multicast destination MAC address allows an IEEE 802.1Q bridge to interrupt the forwarding of a single data flow to prevent it from adversely affecting the Qos given to another flow.

A given TSN bridged LAN (subnetwork) may also impose other requirements DetNet flows in general, and on specific DetNet flows (TSN streams), that differ from normal practice over IEEE Std 802.1Q subnetworks.  Such requirements can include different choices for the VLAN Identifier or the Layer 2 priority than are used for non-DetNet flows operating among the same IP addresses.

-- Norm

________________________________
From: detnet [[email-masked]] on behalf of Stewart Bryant [[email-masked]]
Sent: Monday, June 25, 2018 10:08 AM
To: DetNet WG
Subject: Re: [Detnet] DetNet MPLS Work Meeting 25Jun18 - notes

On 25/06/2018 17:35, Grossman, Ethan A. wrote:
Present: Jouni, Balazs, Lou, Norm, AndyM, Ethan
Next MPLS DP discussion: Thursday 5Jul18 7am Pacific time (1 hour time slot), Lou to host.
Lou: MPLS DP draft review - Good conceptual text, not yet a lot of good text for how to implement, how to conform with this. E.g. Sec 8, 9, 10 are boilerplate. Good background but need to define operation of the data plane – needs requirements for implementing data plane to allow two implementations to interoperate.
Balazs: These are intended to be placeholders until after draft 00.
Jouni will be leaving on vacation from this coming Sunday. Will submit latest MPLS draft on Sat evening. Cutoff for pull requests is before Friday eve.
We need a presentation for MPLS DP draft for IETF 102. Jouni won’t be at Montreal, so Balazs to take lead on this - Balazs to put together first cut at preso for review July 5.
Balazs won’t be at Montreal, remote only – should someone else who will be local present this?

- Stewart