Subject: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

From: "Venkatesan, Ganesh" <[email-masked]>
Date: Mon, 22 Oct 2018 03:56:04 +0000

Hello DetNet members:

We proposed adding IEEE802.11 as a L2 media for DetNet. Based on our experience with IEEE802.11 in managed deployments, we believe that 802.11 links can meet DetNet requirements described in the use case document. In addition there is a lot of work underway in IEEE802.1ax Task Group and in other Topic Interest Groups within IEEE802.11 Working Group that renders 802.11 as a versatile L2 media for DetNet.

Please let me know if you have comments/questions on this submission:

Proposed addition of IEEE802.11 as a L2 Media to the draft-ietf-detnet-use-cases-19 document:

Rationale: 802.11 in a managed network environment meets the Use Case requirements described in this document. The proposal is to use the 802.11 link in the DetNet network as the first or the last hop of the wired/wireless end-to-end path.

Editor: the proposed text below can either be a standalone section or added to the relevant subsections to section 11 of https://www.ietf.org/id/draft-ietf-detnet-use-cases-19.txt.

x. Use Case Common Themes with L2 Medium Access Control as IEEE802.11

Thus far IEEE 802.11 has been the only wireless media technology that has already included support for some of the 802.1 TSN capabilities required to address the use cases described in this document. The IEEE 802.11 working group has been working in collaboration with the IEEE 802.1 group for several years extending 802.1 features over 802.11. Therefore, in the Use Cases described in this document, an IEEE 802.11 hop fits naturally into the network. In all these cases, the DetNet under consideration is a wired/wireless network with the first and/or the last nodes being IEEE802.11 hops and the rest of the network is wired. As with any wireless media, 802.11 imposes new constraints and restrictions to TSN-grade QoS, and tradeoffs between latency and reliability guarantees must be considered as well as managed deployment requirements.
The 802.1 and 802.11 feature set that is already part of IEEE802.11-2016 (along with a set of Wi-Fi Alliance Certifications to ensure interoperability) and the work that is ongoing in IEEE802.11 WG renders IEEE802.11 a natural fit for the DetNet described in this document.

The following sub-sections are analogues of corresponding subsections in section-11. The intent is to demonstrate how well IEEE802.11 MAC fits into a network with DetNet properties where the edges of the network are IEEE802.11 links: e.g the low cost seat speakers being connected over a IEEE802.11 hop to the network, the HMI at the building management network, the sensors/alarms in the electric utility network.

x.1.1 Extension to Ethernet and 802.1 TSN

In addition to IEEE 802.3, 802.11 is also a target media for 802.1 TSN capabilities that are being now extended to routed networks by DetNet. IEEE 802.11ak bridges already defined bridging between 802.1 and 802.11 networks while maintaining domain-specific semantics. Several 802.1 AVB/TSN specifications have equivalents in the IEEE802.11 domain (e.g. Clause 12 of IEEE802.1AS describes the 802.11 Timing Measurement protocol to enable 802.1AS over 802.11 links, IEEE802.1Qat Stream Reservation Protocol triggers generation of equivalent IEEE802.11 Add TS management frames). Equivalent of the IEEE 802.1Qbv is being discussed in a IEEE802.11 Topic Interest Group (IEEE802.11 TIG for Real Time Applications).

x.1.4 L2 and L3 Integration
In a managed network, mechanisms to integrate L2 and L3 layers ("making AVB/TSN-type deterministic performance available from layer-3 applications" or "connecting two AVB/TSN LANs or 'islands' together through a standard router") should extend to IEEE802.11 as L2. AVB/TSN protocol support over IEEE802.11 is already supported for time synchronization, stream identification and reservation and additional TSN capabilities are under development (support for IEEE802.1Qbv, for instance).

x.1.5 Consideration for IPv4
As discussed in x.1.4, L3 DetNet performance over IPv4 over an IEEE802.11 L2 link is achievable when the network is managed. From a wireless perspective, this means that there is traffic planning to avoid over subscription of wireless resources; frequency planning to minimize/eliminate interference/congestion; stream identification for prioritization; admission control to prevent over-subscription; time synchronization as defined in 802.1AS, and 802.1Qbv-like control to prioritize time-sensitive traffic.

x.1.6 Guaranteed End-to-End Delivery

Guaranteed e2e delivery is achieved in DetNet by constraining the network (the network is not the open Internet but a constrained/managed network).
With 802.11, similar constraints can be put in place in a managed deployment. For instance, multiple channels and Basic Service Sets (BSSs) may be defined that restrict access based on traffic stream identification and admission control features already jointly supported by 802.1 and 802.11. There are additional constraints that may be defined to achieve the guarantees.

x.1.7 Replacement for Multiple Proprietary Deterministic Networks
IEEE802.11 has demonstrated interoperable ubiquitous deployment and it already has the basic capabilities to interoperate with 802.1 TSN networks. With the mechanisms outlined in earlier sub-sections, this can extend to provide DetNet performance.

x.1.8 Mix of Deterministic and Best-Effort Traffic

IEEE802.11 has QoS support to identify and prioritize time-sensitive operational traffic. The prioritization (and the resulting improved latency/reliability) becomes effective in a managed IEEE802.11 network and has the potential to be even more effective with high efficiency features from IEEE802.11ax, IEEE802.1Qbv over IEEE802.11, etc.
x.1.9 Unused Reserved BW to be available to Best Effort Traffic
The IEEE 802.11ax amendment enables the APs to have more control of the medium and not only prioritize time-sensitive traffic, but also efficiently allocate resources to Best Effort traffic. 802.11ax can significantly improve efficiency while reducing contention and latency, which are key aspects to support the TSN and DetNet use cases defined in this document.

x.1.10 Lower Cost, Multi Vendor Solutions
IEEE802.11 implementations supporting IEEE802.11 features have been consistently available from multiple vendors at low cost. When IEEE802.11 feature set is enhanced, the roll out of enhancements typically follows a stable amendment in the IEEE 802.11 WG, development of a corresponding interoperability certification from Wi-Fi Alliance and broad market availability of the enhancements.

In a managed network, we expect the off-the-shelf implementations of IEEE802.11 protocol to be part of the DetNet and satisfy the requirements. In situations where IEE802.11 enhancements that are currently under development of being planned for development soon, we envision the roll out described above and the availability of lower cost, interoperable multi-vendor implementations with the enhancements to become available.

x.3.1 Bounded Latency
In managed IEEE802.11 networks, where Admission Control prevents over-subscribing and minimizes collisions, and where QoS provides prioritization of Operational Traffic, bounded latency for Operational Traffic is achievable [reference: 18-1160r0]

x.3.2 Low Latency

Low latency requirement depends on the Use Case in question. There is some trade-off in the low latency requirement for the convenience of being not tethered to a wire, being mobile and being able to reconfigure the network as needed for the specific situation within the Use Case.

However, low latencies [Reference 18-1160r0] to meet the requirements of a variety of Use Cases (pro AV, synchronized multi-channel audio, mobile robotics, repetitive cyclic control systems (1 - 10 millisecond latencies over the wireless hop) is achievable in a managed 802.11 network by leveraging current TSN capabilities over 802.11, such as time synchronization, stream identification and time-aware shaping.
x.5 Security
WFA WPA3 provides robust security both for management and data packets. In addition, WFA Easy Connect provides for robust security while supporting easy onboarding of headless devices into the network.

x.6 Future work
x.6.1. Centrally Administered
Central/distributed Administration - there are aspects of the wireless network (or the wireless hop from a wired/wireless bridge to a wireless endpoint) that will have to be defined. For instance, the controller that does the central administration may send the desired configuration to the wired/wireless bridge (the wireless part in this bridge is the AP function) where it gets converted into parameters that are 802.11-specific.

x.6.2 Standardized Data Flow Information Models
Co-ordination between IETF DetNet and IEEE802.11 Working Groups will be required to ensure that this requirement is met when DetNet operates over IEEE802.11 links.

x.6.3 Symmetrical Path Delays
This may be a challenge in 802.11 (probably in all wireless networks, specifically indoors). Need to research this further.

References:

  1.  IEEE802.11-2016: Wireless LAN Medium Access Control (MAC) and Physical Layer (PHY) Specifications
  2.  IEEE802.11ak-2017: Enhancements for Transit Links Within Bridged Networks
  3.  IEEE802.11ax D3.0: Enhancements for High Efficiency WLAN
  4.  WNG documents on RTA (18-1160r0): https://mentor.ieee.org/802.11/dcn/18/11-18-1160-00-0wng-controlling-latency-in-802-11.pptx
  5.  Wi-Fi Alliance Wireless Protected Access 2 (WPA2)
  6.  Wi-Fi Alliance Wireless Multi-Media Admission Control (WMM-AC)
  7.  Wi-Fi Alliance Wireless Protected Access 3 (WPA3)
  8.  Wi-Fi Alliance TimeSyncTM

Cheers --
ganesh

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 22 Oct 2018 10:15:02 -0400

Ganesh,

For those of us that don't attend IEEE, can you fill us in on the
relationship between 801.11 and TSN? As the DetNet documents already refer
(in many places) to IEEE TSN as a layer 2 media for DetNet, if 801.11 is
already included in the TSN umbrella, then it would seem to me that we
don't need to include explicit references to 802.11. Just a thought.

Thanks,
Andy

On Sun, Oct 21, 2018 at 11:56 PM Venkatesan, Ganesh <
[email-masked]> wrote:

> Hello DetNet members:
>
>
>
> We proposed adding IEEE802.11 as a L2 media for DetNet. Based on our
> experience with IEEE802.11 in managed deployments, we believe that 802.11
> links can meet DetNet requirements described in the use case document. In
> addition there is a lot of work underway in IEEE802.1ax Task Group and in
> other Topic Interest Groups within IEEE802.11 Working Group that renders
> 802.11 as a versatile L2 media for DetNet.
>
>
>
> *Proposed addition of IEEE802.11 as a L2 Media to the
> draft-ietf-detnet-use-cases-19 document:*
>
>
>
> *Rationale: 802.11 in a managed network environment meets the Use Case
> requirements described in this document. The proposal is to use the 802.11
> link in the DetNet network as the first or the last hop of the
> wired/wireless end-to-end path.. *
>
>
>
> *Editor: the proposed text below can either be a standalone section or
> added to the relevant subsections to section 11 of
> https://www.ietf.org/id/draft-ietf-detnet-use-cases-19.txt
> <https://www.ietf.org/id/draft-ietf-detnet-use-cases-19.txt>.*
>
>
>
> Thus far IEEE 802.11 has been the only wireless media technology that has
> already included support for some of the 802.1 TSN capabilities required to
> address the use cases described in this document. The IEEE 802.11 working
> group has been working in collaboration with the IEEE 802.1 group for
> several years extending 802.1 features over 802.11. Therefore, in the Use
> Cases described in this document, an IEEE 802.11 hop fits naturally into
> the network. In all these cases, the DetNet under consideration is a
> wired/wireless network with the first and/or the last nodes being
> IEEE802.11 hops and the rest of the network is wired. As with any wireless
> media, 802.11 imposes new constraints and restrictions to TSN-grade QoS,
> and tradeoffs between latency and reliability guarantees must be considered
> as well as managed deployment requirements.
>
> The 802.1 and 802.11 feature set that is already part of IEEE802.11-2016
> (along with a set of Wi-Fi Alliance Certifications to ensure
> interoperability) and the work that is ongoing in IEEE802.11 WG renders
> IEEE802.11 a natural fit for the DetNet described in this document.
>
>
>
> The following sub-sections are analogues of corresponding subsections in
> section-11. The intent is to demonstrate how well IEEE802.11 MAC fits into
> a network with DetNet properties where the edges of the network are
> IEEE802.11 links: e.g the low cost seat speakers being connected over a
> IEEE802.11 hop to the network, the HMI at the building management network,
> the sensors/alarms in the electric utility network.
>
>
>
> In addition to IEEE 802.3, 802.11 is also a target media for 802.1 TSN
> capabilities that are being now extended to routed networks by DetNet. IEEE
> 802.11ak bridges already defined bridging between 802.1 and 802.11 networks
> while maintaining domain-specific semantics. Several 802.1 AVB/TSN
> specifications have equivalents in the IEEE802.11 domain (e.g. Clause 12 of
> IEEE802.1AS describes the 802.11 Timing Measurement protocol to enable
> 802.1AS over 802.11 links, IEEE802.1Qat Stream Reservation Protocol
> triggers generation of equivalent IEEE802.11 Add TS management frames).
> Equivalent of the IEEE 802.1Qbv is being discussed in a IEEE802.11 Topic
> Interest Group (IEEE802.11 TIG for Real Time Applications).
>
>
>
> In a managed network, mechanisms to integrate L2 and L3 layers (“making
> AVB/TSN-type deterministic performance available from layer-3 applications”
> or “connecting two AVB/TSN LANs or ‘islands’ together through a standard
> router”) should extend to IEEE802.11 as L2. AVB/TSN protocol support over
> IEEE802.11 is already supported for time synchronization, stream
> identification and reservation and additional TSN capabilities are under
> development (support for IEEE802.1Qbv, for instance).
>
>
>
> As discussed in x.1.4, L3 DetNet performance over IPv4 over an IEEE802.11
> L2 link is achievable when the network is managed. From a wireless
> perspective, this means that there is traffic planning to avoid over
> subscription of wireless resources; frequency planning to
> minimize/eliminate interference/congestion; stream identification for
> prioritization; admission control to prevent over-subscription; time
> synchronization as defined in 802.1AS, and 802.1Qbv-like control to
> prioritize time-sensitive traffic.
>
>
>
> Guaranteed e2e delivery is achieved in DetNet by constraining the network
> (the network is not the open Internet but a constrained/managed network).
>
> With 802.11, similar constraints can be put in place in a managed
> deployment. For instance, multiple channels and Basic Service Sets (BSSs)
> may be defined that restrict access based on traffic stream identification
> and admission control features already jointly supported by 802.1 and
> 802.11. There are additional constraints that may be defined to achieve the
> guarantees.
>
>
>
> IEEE802.11 has demonstrated interoperable ubiquitous deployment and it
> already has the basic capabilities to interoperate with 802.1 TSN networks.
> With the mechanisms outlined in earlier sub-sections, this can extend to
> provide DetNet performance.
>
>
>
> IEEE802.11 has QoS support to identify and prioritize time-sensitive
> operational traffic. The prioritization (and the resulting improved
> latency/reliability) becomes effective in a managed IEEE802.11 network and
> has the potential to be even more effective with high efficiency features
> from IEEE802.11ax, IEEE802.1Qbv over IEEE802.11, etc.
>
> The IEEE 802.11ax amendment enables the APs to have more control of the
> medium and not only prioritize time-sensitive traffic, but also efficiently
> allocate resources to Best Effort traffic. 802.11ax can significantly
> improve efficiency while reducing contention and latency, which are key
> aspects to support the TSN and DetNet use cases defined in this document.
>
>
>
> IEEE802.11 implementations supporting IEEE802.11 features have been
> consistently available from multiple vendors at low cost. When IEEE802.11
> feature set is enhanced, the roll out of enhancements typically follows a
> stable amendment in the IEEE 802.11 WG, development of a corresponding
> interoperability certification from Wi-Fi Alliance and broad market
> availability of the enhancements.
>
>
>
> In a managed network, we expect the off-the-shelf implementations of
> IEEE802.11 protocol to be part of the DetNet and satisfy the requirements.
> In situations where IEE802.11 enhancements that are currently under
> development of being planned for development soon, we envision the roll out
> described above and the availability of lower cost, interoperable
> multi-vendor implementations with the enhancements to become available.
>
>
>
> x.3.1 Bounded Latency
>
> In managed IEEE802.11 networks, where Admission Control prevents
> over-subscribing and minimizes collisions, and where QoS provides
> prioritization of Operational Traffic, bounded latency for Operational
> Traffic is achievable [reference: 18-1160r0]
>
>
>
> x.3.2 Low Latency
>
> Low latency requirement depends on the Use Case in question. There is some
> trade-off in the low latency requirement for the convenience of being not
> tethered to a wire, being mobile and being able to reconfigure the network
> as needed for the specific situation within the Use Case.
>
> However, low latencies [Reference 18-1160r0] to meet the requirements of a
> variety of Use Cases (pro AV, synchronized multi-channel audio, mobile
> robotics, repetitive cyclic control systems (1 – 10 millisecond latencies
> over the wireless hop) is achievable in a managed 802.11 network by
> leveraging current TSN capabilities over 802.11, such as time
> synchronization, stream identification and time-aware shaping..
>
> x.5 Security
>
> WFA WPA3 provides robust security both for management and data packets. In
> addition, WFA Easy Connect provides for robust security while supporting
> easy onboarding of headless devices into the network.
>
>
>
> x.6 Future work
>
> Central/distributed Administration – there are aspects of the wireless
> network (or the wireless hop from a wired/wireless bridge to a wireless
> endpoint) that will have to be defined. For instance, the controller that
> does the central administration may send the desired configuration to the
> wired/wireless bridge (the wireless part in this bridge is the AP function)
> where it gets converted into parameters that are 802.11-specific.
>
>
>
> Co-ordination between IETF DetNet and IEEE802.11 Working Groups will be
> required to ensure that this requirement is met when DetNet operates over
> IEEE802.11 links.
>
>
>
> This may be a challenge in 802.11 (probably in all wireless networks,
> specifically indoors). Need to research this further.
>
>
>
> References:
>
>    4. WNG documents on RTA (18-1160r0):
>    https://mentor.ieee.org/802.11/dcn/18/11-18-1160-00-0wng-controlling-latency-in-802-11.pptx
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>

---

From: "Venkatesan, Ganesh" <[email-masked]>
Date: Mon, 22 Oct 2018 19:33:49 +0000

Hello Andy:

Reading the current draft, specifically section 5.1.1, I get the impression that the current Use Case document does not consider IEEE802.11 as part of ‘IEEE TSN as a layer2 for DetNet’. Given that the TSN work is done in IEEE802.1 TSN, do you perceive IEEE802.11 as ‘IEEE TSN as a layer2 for DetNet’? And would that be the perception of the rest of the IETF DetNet membership? If your answer is Yes to both the questions, then I would agree (and if we delete the reference in section 5.1.1 where the current draft calls out IEEE802.11 (WiFi) as unsuited for DetNet)  that “we don’t need to include explicit references to 802.11”, but carefully call out in other pertinent IETF DetNet RFCs where IEEE802.11 mechanisms required to meet DetNet requirements explicitly.

Cheers --
ganesh

From: Andrew G. Malis <[email-masked]>
Sent: Monday, October 22, 2018 10:15 AM
To: Venkatesan, Ganesh <[email-masked]>
Cc: detnet WG <[email-masked]>
Subject: Re: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Ganesh,

For those of us that don't attend IEEE, can you fill us in on the relationship between 801.11 and TSN? As the DetNet documents already refer (in many places) to IEEE TSN as a layer 2 media for DetNet, if 801.11 is already included in the TSN umbrella, then it would seem to me that we don't need to include explicit references to 802.11. Just a thought.

Thanks,
Andy

On Sun, Oct 21, 2018 at 11:56 PM Venkatesan, Ganesh <[email-masked]<mailto:[email-masked]>> wrote:
Hello DetNet members:

Rationale: 802.11 in a managed network environment meets the Use Case requirements described in this document. The proposal is to use the 802.11 link in the DetNet network as the first or the last hop of the wired/wireless end-to-end path..

x.1.4 L2 and L3 Integration
In a managed network, mechanisms to integrate L2 and L3 layers (“making AVB/TSN-type deterministic performance available from layer-3 applications” or “connecting two AVB/TSN LANs or ‘islands’ together through a standard router”) should extend to IEEE802.11 as L2. AVB/TSN protocol support over IEEE802.11 is already supported for time synchronization, stream identification and reservation and additional TSN capabilities are under development (support for IEEE802.1Qbv, for instance).

x.3.1 Bounded Latency

x.3.2 Low Latency

However, low latencies [Reference 18-1160r0] to meet the requirements of a variety of Use Cases (pro AV, synchronized multi-channel audio, mobile robotics, repetitive cyclic control systems (1 – 10 millisecond latencies over the wireless hop) is achievable in a managed 802.11 network by leveraging current TSN capabilities over 802.11, such as time synchronization, stream identification and time-aware shaping..
x.5 Security
WFA WPA3 provides robust security both for management and data packets. In addition, WFA Easy Connect provides for robust security while supporting easy onboarding of headless devices into the network.

x.6 Future work
x.6.1. Centrally Administered
Central/distributed Administration – there are aspects of the wireless network (or the wireless hop from a wired/wireless bridge to a wireless endpoint) that will have to be defined. For instance, the controller that does the central administration may send the desired configuration to the wired/wireless bridge (the wireless part in this bridge is the AP function) where it gets converted into parameters that are 802.11-specific.

References:

Cheers --
ganesh

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: Norman Finn <[email-masked]>
Date: Mon, 22 Oct 2018 20:17:45 +0000

There is a strong desire from a number of application domains for deterministic wireless networks.  This desire has generated projects such as the 6TiSCH working group in the WPAN world.  There are things that one can do to greatly improve the reliability and timeliness of 802.11 networks.  I was the primary instigator of 802.11ak, that make it possible to have an 802.11 link in the middle of a wired network; the wired robot attached to a wired network on a factory floor via Wi-Fi was one of the examples I used to promote the idea.

Having said that ...

In the wired world, simply eliminating congestion loss gets us to 7 or 8 nines in reliability.  Dual pathing gets us to 10 or more nines.  And, these are things that we know how to accomplish, today.

In the wireless world, signal interference can easily drop you to 3 nines.  Deterministic wireless needs different techniques for achieving reliability -- for example, spreading the data out in time to avoid interference, and hop-by-hop ACK/retransmission.  These are not required in the wired world.  This leads me to talk about the (latency)*(loss rate) product.  That is, in wireless, it is meaningful to have a direct tradeoff between latency and loss rate, to give room for retransmissions and time spreading.  That product is orders of magnitude different between the wired and wireless cases, and that means that the applications that can use the service have orders of magnitude different requirements.

I would fully support the creation of a Deterministic Wireless WG.  I believe that such a group and DetNet would complement each others' efforts.  The goals are similar, but the solutions are sufficiently different that I would not want wireless support to be a goal of DetNet.

-- Norm

________________________________
From: detnet [[email-masked]] on behalf of Venkatesan, Ganesh [[email-masked]]
Sent: Monday, October 22, 2018 12:33 PM
To: Andrew G. Malis
Cc: detnet WG
Subject: Re: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Hello Andy:

Cheers --
ganesh

Ganesh,

Thanks,
Andy

x.3.1 Bounded Latency

x.3.2 Low Latency

x.6 Future work

References:

Cheers --
ganesh

---

From: "Venkatesan, Ganesh" <[email-masked]>
Date: Mon, 22 Oct 2018 20:37:44 +0000

Hello Norm:

Not all Use Cases in draft-ietf-detnet-use-cases-19 require a reliability of 7 or 8 nines in reliability. For instance, section 3 Electrical Utilities has a requirement of 0.1-1% packet loss (3.1.1.1.4). Do you think a managed IEEE802.11 network would not meet that requirement?

I would agree with your assessment (cannot achieve reliability to 7 or 8 nines) if we are exclusively focusing on IEEE802.11 only networks. The proposal is to consider a 802.1 core DetNet with IEEE802.11 links at the last (or first) hop, for Use Cases where a managed IEEE802.11 network (where the wireless configuration takes into account the need for low latency and high reliability for TSN traffic).

Cheers --
ganesh

From: Norman Finn <[email-masked]>
Sent: Monday, October 22, 2018 4:18 PM
To: Venkatesan, Ganesh <[email-masked]>; Andrew G. Malis <[email-masked]>
Cc: detnet WG <[email-masked]>
Subject: RE: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Having said that ...

-- Norm

Reading the current draft, specifically section 5.1.1, I get the impression that the current Use Case document does not consider IEEE802.11 as part of 'IEEE TSN as a layer2 for DetNet'. Given that the TSN work is done in IEEE802.1 TSN, do you perceive IEEE802.11 as 'IEEE TSN as a layer2 for DetNet'? And would that be the perception of the rest of the IETF DetNet membership? If your answer is Yes to both the questions, then I would agree (and if we delete the reference in section 5.1.1 where the current draft calls out IEEE802.11 (WiFi) as unsuited for DetNet)  that "we don't need to include explicit references to 802.11", but carefully call out in other pertinent IETF DetNet RFCs where IEEE802.11 mechanisms required to meet DetNet requirements explicitly.

Cheers --
ganesh

From: Andrew G. Malis <[email-masked]<mailto:[email-masked]>>
Sent: Monday, October 22, 2018 10:15 AM
To: Venkatesan, Ganesh <[email-masked]<mailto:[email-masked]>>
Cc: detnet WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Ganesh,

Thanks,
Andy

x.3.1 Bounded Latency

x.3.2 Low Latency

However, low latencies [Reference 18-1160r0] to meet the requirements of a variety of Use Cases (pro AV, synchronized multi-channel audio, mobile robotics, repetitive cyclic control systems (1 - 10 millisecond latencies over the wireless hop) is achievable in a managed 802.11 network by leveraging current TSN capabilities over 802.11, such as time synchronization, stream identification and time-aware shaping..
x.5 Security
WFA WPA3 provides robust security both for management and data packets. In addition, WFA Easy Connect provides for robust security while supporting easy onboarding of headless devices into the network.

x.6 Future work

References:

Cheers --
ganesh

---

From: Norman Finn <[email-masked]>
Date: Mon, 22 Oct 2018 21:12:06 +0000

I think I was misunderstanding your wishes, Ganesh.  Sorry.  I thought you wanted to add 802.11 to the core of DetNet and/or to the architecture.  Now I see that you are talking about a use case.  I'd have to look more at the details to have an opinion.

Given the variability of 802.11 delivery, can you comment about how the difference between DetNet service and typical weighted priorities would be critical to the success of your envisioned applications?  I have heard arguments about needing DetNet/TSN to enable timed deliveries.

-- Norm

________________________________
From: Venkatesan, Ganesh [[email-masked]]
Sent: Monday, October 22, 2018 1:37 PM
To: Norman Finn; Andrew G. Malis
Cc: detnet WG
Subject: RE: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Hello Norm:

Cheers --
ganesh

Having said that ...

-- Norm

Cheers --
ganesh

Ganesh,

Thanks,
Andy

x.3.1 Bounded Latency

x.3.2 Low Latency

x.6 Future work

References:

Cheers --
ganesh

---

From: "Venkatesan, Ganesh" <[email-masked]>
Date: Mon, 22 Oct 2018 22:10:52 +0000

Hello Norm:

Please see my response(s) inline, below.

Cheers --
ganesh

Sent: Monday, October 22, 2018 5:12 PM

Given the variability of 802.11 delivery, can you comment about how the difference between DetNet service and typical weighted priorities would be critical to the success of your envisioned applications?  I have heard arguments about needing DetNet/TSN to enable timed deliveries.
[[gv]] We argue that the 'variability of 802.11 delivery' is an artifact of an unplanned/unmanaged IEEE802.11 deployment (and can be eliminated). A deployment where the traffic characteristics is taken into account (including the fact that some of the traffic in the network is TSN, the IEEE802.11 portion(s) of the network is configured to:

  1.  Allocate operational channels to eliminate wireless collisions
  2.  Use admission control to avoid over-subscription of the network (may be even use SRP over IEEE802.11)
  3.  With IEEE802.1AS over IEEE802.11 (and IEEE802.1) enable time synchronization and schedule transmit opportunities for TSN traffic
  4.  In the future we will be able to execute IEEE802.1Qbv over IEEE802.11 (this is a Topic Interest Group at this time).

If this configuration is done right, the one-hop overhead is just time it takes to transmit the payload (at a given MCS).

Going forward, the performance will only improve with IEEE802.11ax where OFDMA can be used to transmit to/receive from multiple destinations/transmitters simultaneously.

-- Norm

Cheers --
ganesh

From: Norman Finn <[email-masked]<mailto:[email-masked]>>
Sent: Monday, October 22, 2018 4:18 PM
To: Venkatesan, Ganesh <[email-masked]<mailto:[email-masked]>>; Andrew G. Malis <[email-masked]<mailto:[email-masked]>>
Cc: detnet WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Having said that ...

-- Norm

Cheers --
ganesh

Ganesh,

Thanks,
Andy

x.3.1 Bounded Latency

x.3.2 Low Latency

x.6 Future work

References:

Cheers --
ganesh

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 23 Oct 2018 08:16:01 +0000

I agree 100% with Norm below.

Wireless can apply to use cases with a whole different range of requirements and with a whole different set of techniques. I participated to DetNet with wireless in mind, and realized that the interest of the group are largely related to wired TSN.

Wireless needs something different, and probably the term "deterministic" should be excluded in favor of something like "predictable and available wireless" (PAW), be it just to avoid grinding teeth from all parties.

I'd  be happy to have a BAR BoF during IETF 103 or at an evening dinner during the week end before IEEE to discuss that.

Cheers,

Pascal

From: detnet <[email-masked]> On Behalf Of Norman Finn
Sent: lundi 22 octobre 2018 23:12
To: Venkatesan, Ganesh <[email-masked]>; Andrew G. Malis <[email-masked]>
Cc: detnet WG <[email-masked]>
Subject: Re: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

-- Norm

Not all Use Cases in draft-ietf-detnet-use-cases-19 require a reliability of 7 or 8 nines in reliability. For instance, section 3 Electrical Utilities has a requirement of 0.1-1% packet loss (3.1.1.1.4).. Do you think a managed IEEE802.11 network would not meet that requirement?

Cheers --
ganesh

To: Venkatesan, Ganesh <[email-masked]>; Andrew G.. Malis <[email-masked]>

Having said that ...

-- Norm

Cheers --
ganesh

From: Andrew G. Malis <[email-masked]<mailto:agmalis@gmail..com>>
Sent: Monday, October 22, 2018 10:15 AM
To: Venkatesan, Ganesh <ganesh.venkatesan@intel..com<mailto:ganesh.venkatesan@intel..com>>
Cc: detnet WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Ganesh,

Thanks,
Andy

Rationale: 802.11 in a managed network environment meets the Use Case requirements described in this document. The proposal is to use the 802.11 link in the DetNet network as the first or the last hop of the wired/wireless end-to-end path...

x.3.1 Bounded Latency

x.3.2 Low Latency

x.6 Future work

References:

Cheers --
ganesh

---

From: John Grant <[email-masked]>
Date: Tue, 23 Oct 2018 10:42:02 +0100

On 22/10/2018 21:17, Norman Finn wrote:
> I would fully support the creation of a Deterministic Wireless WG. I 
> believe that such a group and DetNet would complement each others' 
> efforts.  The goals are similar, but the solutions are sufficiently 
> different that I would not want wireless support to be a goal of DetNet.
This is something that also needs to be addressed for cellular radio, 
which has to live with the same laws of physics. Currently the emphasis 
in 5G mobile is on eMBB (enhanced mobile broadband), but URLLC 
(ultra-reliable low latency) is also promised. The only work on it I'm 
aware of is reported at 
https://www.ngmn.org/fileadmin/ngmn/content/downloads/Technical/2018/180819_NGMN_5G_Ext_Req_TF_D2_2_v2.0.pdf

-- 
John Grant
Nine Tiles, Cambridge, England
+44 1223 862599 and +44 1223 511455
http://www.ninetiles.com

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 23 Oct 2018 10:47:30 +0000

OK, cool then. Let's talk!

I created a doodle for a PAW bar Bof  see when we could meet; https://doodle.com/poll/ikewr3wcztiztppx 
Please enter if you have a matching availability

Cheers,

Pascal

> -----Original Message-----
> From: detnet <[email-masked]> On Behalf Of John Grant
> Sent: mardi 23 octobre 2018 11:42
> To: [email-masked]
> This is something that also needs to be addressed for cellular radio, which has
> to live with the same laws of physics. Currently the emphasis in 5G mobile is
> on eMBB (enhanced mobile broadband), but URLLC (ultra-reliable low latency)
> is also promised. The only work on it I'm aware of is reported at

---

From: "Venkatesan, Ganesh" <[email-masked]>
Date: Tue, 23 Oct 2018 11:49:45 +0000

Hello Pascal:

I will not be at IETF 103 but will be at IEEE802 Plenary the following week.

Here is my rationale for keeping 802.11 as part of the IETF DetNet activity:

  1.  Real life deployments will typically be wired/wireless (802.11), specifically a wired core with 802.11 end points (the first and the last link).
  2.  Some of 802.1TSN protocols have analogue in the IEEE802.11 domain (802.1AS over 802.11, 802.1Qat over 802.11; and there is ongoing discussion on 802.1Qbv over 802.11

Cheers --
ganesh

From: Pascal Thubert (pthubert) <[email-masked]>
Sent: Tuesday, October 23, 2018 10:16 AM
To: Norman Finn <[email-masked]>; Venkatesan, Ganesh <[email-masked]>; Andrew G. Malis <[email-masked]>
Cc: detnet WG <[email-masked]>; [email-masked]
Subject: RE: [Detnet] proposed addition of IEEE802.11 as L2 Media to dtaft-ietf-detnet-use-cases-19

Cheers,

Pascal

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Norman Finn

-- Norm

Cheers --
ganesh

To: Venkatesan, Ganesh <[email-masked]<mailto:[email-masked]>>; Andrew G.. Malis <[email-masked]<mailto:[email-masked]>>

Having said that ...

-- Norm

Cheers --
ganesh

Ganesh,

Thanks,
Andy

x.3.1 Bounded Latency

x.3.2 Low Latency

x.6 Future work

References:

Cheers --
ganesh