Subject: [Detnet] Secdir last call review of draft-ietf-detnet-use-cases-19

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 24 Oct 2018 09:06:25 -0700

Reviewer: Phillip Hallam-Baker
Review result: Ready

I have reviewed the document, and it is ready for publication. The document is
an analysis of the use cases and (now) properly refers to a separate security
considerations section.

The use cases document is ready for publication and this should go forward now.
However the security considerations document is still a work in progress, no
document shepherd assigned. Which is of course right and proper for a security
considerations relating to the final proposal. And of course it is useful to
nail down the use cases before looking at the security considerations. But the
use cases having deferred security to the external document risks creating a
deadlock situation.

It is important that the document contain a link to the security considerations
to be supplied but this should not hold up publication as an RFC.

My only comment on the referenced SC document at this stage is that it might be
that the term 'deterministic networking' overstates the requirements evidenced
by the use cases. In many of the cited use cases, what is required is a higher
degree of confidence that the network characteristics meet certain requirements
than an absolute guarantee. It might be that 'predictable networking' provides
a better description of those requirements.

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Wed, 24 Oct 2018 19:57:43 +0000

Thanks Phillip. Given that the link in the Use Cases draft to the Security draft is informational only then it can't cause a publication deadlock, correct? 
Thanks,
Ethan (as DetNet Use Cases draft editor).

-----Original Message-----
From: Phillip Hallam-Baker <[email-masked]> 
Sent: Wednesday, October 24, 2018 9:06 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir last call review of draft-ietf-detnet-use-cases-19

I have reviewed the document, and it is ready for publication. The document is an analysis of the use cases and (now) properly refers to a separate security considerations section.

The use cases document is ready for publication and this should go forward now.
However the security considerations document is still a work in progress, no document shepherd assigned. Which is of course right and proper for a security considerations relating to the final proposal. And of course it is useful to nail down the use cases before looking at the security considerations. But the use cases having deferred security to the external document risks creating a deadlock situation.

It is important that the document contain a link to the security considerations to be supplied but this should not hold up publication as an RFC.

My only comment on the referenced SC document at this stage is that it might be that the term 'deterministic networking' overstates the requirements evidenced by the use cases. In many of the cited use cases, what is required is a higher degree of confidence that the network characteristics meet certain requirements than an absolute guarantee. It might be that 'predictable networking' provides a better description of those requirements.

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 26 Oct 2018 16:51:23 -0500

> Thanks Phillip. Given that the link in the Use Cases draft to the Security draft is informational only then it can't cause a publication deadlock, correct? 

That's correct.

-Benjamin