Subject: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

From: Alissa Cooper <[email-masked]>
Date: Wed, 05 Dec 2018 13:37:17 -0800

Alissa Cooper has entered the following ballot position for
draft-ietf-detnet-problem-statement-07: Abstain

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-problem-statement/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I am balloting ABSTAIN, which does not block publication of this document. I
agree with Mirja's first ballot point. Moreover, the document contains
forward-looking statements that will presumably be overtaken by events in the
near future, e.g. the statements about what the IETF will need to do in Section
1.

Nit:

Section 2 says: "Considerable experience ([ODVA]/[EIP],[AVnu],
[Profinet],[HART],[IEC62439], [ISA100.11a] and [WirelessHART], etc...)"

It seems like the "etc." should be replaced with an enumerated list of
citations, or a description of what the other experience is that isn't
explicitly listed.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 6 Dec 2018 09:55:46 +0000

Many thanks, Alissa,

To Mirja (cc) 's point I modified the bullet and the previous one as follows:

   o  provide additional reliability through redundancy, in particular

      with packet Packet Replication, Elimination and Ordering Functions

      (PREOF) where the former may generate an out-of-order delivery

      that may need to be corrected by the latter;

   o  indicate the flows and packet sequences in-band with the flows,

      this is needed for flows that require PREOF in order to isolate

      duplicates and reorder in the end;

> agree with Mirja's first ballot point. Moreover, the document contains forward-

> looking statements that will presumably be overtaken by events in the near

> future, e.g. the statements about what the IETF will need to do in Section 1.

[PT>] Could we reword to something like: “At the time of this writing, the expectation is that the IETF will …”

The sentence would become

   At the time of this writing, the expectation is that once the
   abstract model is agreed upon, the IETF will specify the signaling
   elements to be used to establish a path and the tagging elements to
   be used identify the flows that are to be forwarded along that path.
   The expectation is also that IETF will specify the necessary
   protocols, or protocol additions, based on relevant IETF
   technologies, to implement the selected model.

> It seems like the "etc." should be replaced with an enumerated list of citations,

> or a description of what the other experience is that isn't explicitly listed.

[PT>]  Agreed ; what about :

   Considerable experience from automation and professional audio/video

   networks (e.g., [ODVA]/[EIP], [AVnu], [Profinet], [HART], [IEC62439],

   [ISA100.11a] and [WirelessHART]) has shown that …

Please let me know if all this works.

Again, many thanks Alissa !

Pascal

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 6 Dec 2018 09:40:05 -0500

Thanks, the changes LGTM.

Alissa

> On Dec 6, 2018, at 4:55 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> Many thanks, Alissa,
>

---

From: Karl Weber <[email-masked]>
Date: Fri, 7 Dec 2018 10:44:40 +0000

Dear all,

I think that the citation

 Is not very helpful.

Followed by a list of requirements is very misleading, as many of the key points in the list (e.g. reliability parameter) cannot be found in the documents.

Quite a few widely accepted organizations with networks related to this requirements are not listed like CPLA/CCLink, CANopen, Sercos and EtherCAT.
EtherCAT has a draft profile for TSN with a Liaison to IEEE 802.1 other do not have that.

AVnu does not have its own network but uses AVB/TSN.
IEC62439 is a standard but Profinet is also a standard 61158-10 as well as many of the others.
Sometimes organizations sometimes networks or both

A few of the links are broken or do not show substantial technical information but marketing material.
Suggest to provide a better base for the requirement or use other documents such as industrial use cases from the joint IEEE/IEC project.

Karl

From: detnet [mailto:[email-masked]] On Behalf Of Alissa Cooper
Sent: Donnerstag, 6. Dezember 2018 15:40
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: Lou Berger <[email-masked]>; [email-masked]; Mirja Kühlewind <[email-masked]>; Janos Farkas <[email-masked]>; [email-masked]; [email-masked]; IESG <[email-masked]>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Alissa

Beckhoff Automation GmbH & Co. KG | Managing Director: Dipl. Phys. Hans Beckhoff
Registered office: Verl, Germany | Register court: Guetersloh HRA 7075

On Dec 6, 2018, at 4:55 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:

Many thanks, Alissa,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 7 Dec 2018 13:29:10 +0000

Unsure what you are really proposing Karl.

The claim is correct, automation and AVD want detnet and tsn for applications like control loops, motion detection and propagation of digital time/phase sensitive signals. Now, the list of pointers is agreeably incomplete.

Could you be more specific on proposed changes ? Are you missing a  reference you would like to see?

As it goes the text predates all the work we did in the use cases draft. Proposal is to replace all the links you quoted by just one on the detnet use cases. Would that work for you ?

Regards,

Pascal

Le 7 déc. 2018 à 11:44, Karl Weber <[email-masked]<mailto:[email-masked]>> a écrit :

Dear all,

Karl

From: detnet [mailto:[email-masked]] On Behalf Of Alissa Cooper
Sent: Donnerstag, 6. Dezember 2018 15:40
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Cc: Lou Berger <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Mirja Kühlewind <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; IESG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Alissa

Many thanks, Alissa,

Pascal

---

From: Karl Weber <[email-masked]>
Date: Fri, 7 Dec 2018 13:55:54 +0000

I would reference to https://1.ieee802.org/tsn/iec-ieee-60802-tsn-profile-for-industrial-automation/ industrial use case document, which covers also aspects beyond TSN.
It is well accepted by a larger group of experts (IEC and IEEE) and covers quite a few items found in the list below.

But this is my preferred choice.

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Freitag, 7. Dezember 2018 14:29
To: Karl Weber <[email-masked]>
Cc: Alissa Cooper <[email-masked]>; Lou Berger <[email-masked]>; [email-masked]; Mirja Kühlewind <[email-masked]>; Janos Farkas <[email-masked]>; [email-masked]; [email-masked]; IESG <[email-masked]>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Regards,

Pascal

Dear all,

Karl

Alissa

Many thanks, Alissa,

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 7 Dec 2018 14:26:25 +0000

Hello Karl :

I think that the IEC/IEEE60802 reference would be very useful in the use cases draft related to section 3 of https://tools.ietf.org/html/draft-ietf-detnet-use-cases-19 , cc’ing Ethan for this. Note that IEC60870-5 is already listed so IEC transport protocols are included in a more general fashion already. This makes the use cases draft the most complete reference I can include to serve your point, even better if Ethan adds the proposed reference.

I can also list smartgrid automation in the sentence you quoted as an additional example.

Would that work for you?

Pascal

From: Karl Weber <[email-masked]>
Sent: vendredi 7 décembre 2018 14:56
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: Alissa Cooper <[email-masked]>; Lou Berger <[email-masked]>; [email-masked]; Mirja Kühlewind <[email-masked]>; Janos Farkas <[email-masked]>; [email-masked]; [email-masked]; IESG <[email-masked]>
Subject: RE: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Freitag, 7. Dezember 2018 14:29
To: Karl Weber <[email-masked]<mailto:[email-masked]>>
Cc: Alissa Cooper <[email-masked]<mailto:[email-masked]>>; Lou Berger <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Mirja Kühlewind <[email-masked]<mailto:[email-masked]>>; Janos Farkas <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; IESG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Regards,

Pascal

Karl

Alissa

Many thanks, Alissa,

Pascal

---

From: János Farkas <[email-masked]>
Date: Tue, 18 Dec 2018 17:23:19 +0100

Hi,

Adding a reference to IEC/IEEE 60802 is fine and would be good. However, 
we should not go beyond that at this stage with the problem statement draft.

Regards,
Janos

On 12/7/2018 2:55 PM, Karl Weber wrote:
>
> I would reference to 
> https://1.ieee802.org/tsn/iec-ieee-60802-tsn-profile-for-industrial-automation/ 
> industrial use case document, which covers also aspects beyond TSN.
>
> It is well accepted by a larger group of experts (IEC _and_ IEEE) and 
> covers quite a few items found in the list below.
>
> *From:*Pascal Thubert (pthubert) [mailto:[email-masked]]
> *Sent:* Freitag, 7. Dezember 2018 14:29
> *To:* Karl Weber <[email-masked]>
> *Cc:* Alissa Cooper <[email-masked]>; Lou Berger 
> <[email-masked]>; [email-masked]; 
> Mirja Kühlewind <[email-masked]>; Janos Farkas 
> <[email-masked]>; [email-masked]; [email-masked]; 
> IESG <[email-masked]>
> *Subject:* Re: [Detnet] Alissa Cooper's Abstain on 
> draft-ietf-detnet-problem-statement-07: (with COMMENT)
>
> The claim is correct, automation and AVD want detnet and tsn for 
> applications like control loops, motion detection and propagation of 
> digital time/phase sensitive signals. Now, the list of pointers is 
> agreeably incomplete.
>
> As it goes the text predates all the work we did in the use cases 
> draft. Proposal is to replace all the links you quoted by just one on 
> the detnet use cases. Would that work for you ?
>
> Regards,
>
> Pascal
>
>
> Le 7 déc. 2018 à 11:44, Karl Weber <[email-masked] 
> <mailto:[email-masked]>> a écrit :
>
>
>     Considerable experiencefrom automation and professional audio/video
>
>     _ Is not very helpful_.
>     Followed by a list of requirements is very misleading, as many of
>     the key points in the list (e.g. reliability parameter) cannot be
>     found in the documents.
>
>     Quite a few widely accepted organizations with networks related to
>     this requirements are not listed like CPLA/CCLink, CANopen, Sercos
>     and EtherCAT.
>
>     Suggest to provide a better base for the requirement or use other
>     documents such as industrial use cases from the joint IEEE/IEC
>     project.
>
>     Karl
>
>     *From:*detnet [mailto:[email-masked]] *On Behalf Of
>     *Alissa Cooper
>     *Sent:* Donnerstag, 6. Dezember 2018 15:40
>     *To:* Pascal Thubert (pthubert) <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* Lou Berger <[email-masked] <mailto:[email-masked]>>;
>     [email-masked]
>     <mailto:[email-masked]>; Mirja
>     Kühlewind <[email-masked] <mailto:[email-masked]>>;
>     Janos Farkas <[email-masked]
>     <mailto:[email-masked]>>; [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; IESG <[email-masked] <mailto:[email-masked]>>
>     *Subject:* Re: [Detnet] Alissa Cooper's Abstain on
>     draft-ietf-detnet-problem-statement-07: (with COMMENT)
>
>         On Dec 6, 2018, at 4:55 AM, Pascal Thubert (pthubert)
>         <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Many thanks, Alissa,
>
>         */[PT>]/*Could we reword to something like: “At the time of
>         this writing, the expectation is thatthe IETF will …”
>
>         At the time of this writing, the expectation is thatonce the
>
>         The expectation is alsothat IETF will specify the necessary
>
>         *//*
>         */[PT>] /*Agreed ; what about :
>
>             Considerable experiencefrom automation and professional audio/video
>
>         *//*

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 18 Dec 2018 16:59:42 +0000

Hello János :

The proposal on the table is to change the text as follows:

Before:
   Considerable experience ([ODVA]/[EIP],[AVnu],
   [Profinet],[HART],[IEC62439], [ISA100.11a] and [WirelessHART],
   etc...) has shown that these applications need a some or all of a
   suite of features that includes:

after:
   The Deterministic Networking Use Cases [I-D.ietf-detnet-use-cases]
   document indicates that applications in multiple fields need some or
   all of a suite of features that includes:

The point is that the reference to 60802 should really be in section 3 of the use cases draft, where this and many other cases are referenced,
Does that work? I’m ready to publish that change as -09.

All the best,

Pascal

From: János Farkas <[email-masked]>
Sent: mardi 18 décembre 2018 17:23
To: Karl Weber <[email-masked]>; Pascal Thubert (pthubert) <[email-masked]>
Cc: Alissa Cooper <[email-masked]>; Lou Berger <[email-masked]>; [email-masked]; Mirja Kühlewind <[email-masked]>; [email-masked]; [email-masked]; IESG <[email-masked]>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Hi,

Adding a reference to IEC/IEEE 60802 is fine and would be good. However, we should not go beyond that at this stage with the problem statement draft.

Regards,
Janos

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Freitag, 7. Dezember 2018 14:29
To: Karl Weber <[email-masked]><mailto:[email-masked]>
Cc: Alissa Cooper <[email-masked]><mailto:[email-masked]>; Lou Berger <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Mirja Kühlewind <[email-masked]><mailto:[email-masked]>; Janos Farkas <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; IESG <[email-masked]><mailto:[email-masked]>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Regards,

Pascal

Karl

Alissa

Many thanks, Alissa,

Pascal

---

From: János Farkas <[email-masked]>
Date: Wed, 19 Dec 2018 13:24:10 +0100

Hi Pascal,

The proposal is good.
Sorry, I missed it somehow.

Thank you,
Janos

On 12/18/2018 5:59 PM, Pascal Thubert (pthubert) wrote:
> The point is that the reference to 60802 should really be in section 3 
> of the use cases draft, where this and many other cases are referenced,
>
> *From:*János Farkas <[email-masked]>
> *Sent:* mardi 18 décembre 2018 17:23
> *To:* Karl Weber <[email-masked]>; Pascal Thubert (pthubert) 
> <[email-masked]>
> Mirja Kühlewind <[email-masked]>; [email-masked]; 
> [email-masked]; IESG <[email-masked]>
> Adding a reference to IEC/IEEE 60802 is fine and would be good. 
> However, we should not go beyond that at this stage with the problem 
> statement draft.
>
> Regards,
> Janos
>
>     It is well accepted by a larger group of experts (IEC _and_ IEEE)
>     and covers quite a few items found in the list below.
>
>     <mailto:[email-masked]>
>     *Cc:* Alissa Cooper <[email-masked]>
>     <mailto:[email-masked]>; Lou Berger <[email-masked]>
>     <mailto:[email-masked]>;
>     Kühlewind <[email-masked]> <mailto:[email-masked]>;
>     Janos Farkas <[email-masked]>
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; IESG <[email-masked]> <mailto:[email-masked]>
>     applications like control loops, motion detection and propagation
>     of digital time/phase sensitive signals. Now, the list of pointers
>     is agreeably incomplete.
>
>     draft. Proposal is to replace all the links you quoted by just one
>     on the detnet use cases. Would that work for you ?
>
>     Regards,
>
>     Pascal
>
>
>         Followed by a list of requirements is very misleading, as many
>         of the key points in the list (e.g. reliability parameter)
>         cannot be found in the documents.
>
>         Quite a few widely accepted organizations with networks
>         related to this requirements are not listed like CPLA/CCLink,
>         CANopen, Sercos and EtherCAT.
>
>         A few of the links are broken or do not show substantial
>         technical information but marketing material.
>
>         Suggest to provide a better base for the requirement or use
>         other documents such as industrial use cases from the joint
>         IEEE/IEC project.
>
>         Karl
>
>             */[PT>]/*Could we reword to something like: “At the time
>             of this writing, the expectation is thatthe IETF will …”
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Dec 2018 16:44:58 +0000

Many thanks János and all;

Lou:

For all I know, this solves all the issues that were reported during the IESG review so far. I published it as -09 (https://www.ietf.org/id/draft-ietf-detnet-problem-statement-09.txt).
I just found an  open question from Alvaro but it can easily be resolved during the RFC editor steps if we really want to.
Apparently the draft now has enough to pass now, but I’d prefer that it is published together with the architecture and use cases drafts so the cross reference has the RFC numbers.

All the best,

Pascal

From: János Farkas <[email-masked]>
Sent: mercredi 19 décembre 2018 13:24
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: Karl Weber <[email-masked]>; Alissa Cooper <[email-masked]>; Lou Berger <[email-masked]>; [email-masked]; Mirja Kühlewind <[email-masked]>; [email-masked]; [email-masked]; IESG <[email-masked]>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Hi Pascal,

The proposal is good.

Thank you,
Janos

Before:

after:

All the best,

Pascal

From: János Farkas <[email-masked]><mailto:[email-masked]>
Sent: mardi 18 décembre 2018 17:23
To: Karl Weber <[email-masked]><mailto:[email-masked]>; Pascal Thubert (pthubert) <[email-masked]><mailto:[email-masked]>
Cc: Alissa Cooper <[email-masked]><mailto:[email-masked]>; Lou Berger <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Mirja Kühlewind <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; IESG <[email-masked]><mailto:[email-masked]>
Subject: Re: [Detnet] Alissa Cooper's Abstain on draft-ietf-detnet-problem-statement-07: (with COMMENT)

Hi,

Regards,
Janos

Regards,

Pascal

Karl

Alissa

Many thanks, Alissa,

Pascal