Subject: [Detnet] Alvaro Retana's Yes on draft-ietf-detnet-problem-statement-07: (with COMMENT)

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Dec 2018 16:38:57 +0000

Hello Alvaro :

I was digging the datatracker and found the following comment from you:
"
Given the close relationship between this document and draft-ietf-detnet-use-cases, I think that it would have been beneficial to produce a single document.  As it stands neither one normatively references the other.

draft-ietf-detnet-architecture-09 says it better:

   The Deterministic Networking Problem Statement
   [I-D.ietf-detnet-problem-statement] introduces Deterministic
   Networking, and Deterministic Networking Use Cases
   [I-D.ietf-detnet-use-cases] summarizes the need for it.
I'm sorry I cannot remember seeing this comment before, and I could not dig it in my mail client, so I do not know what happened with it.

As it goes, the problem statement precedes the architecture document and cannot really reference it normatively.
On the other hand the problem statement is a consequence of the use case draft so it is heavily based on it.

Still there is a forward note that references it, so we do have a reference.
                 Forward note: The DetNet Architecture
   [I-D.ietf-detnet-architecture] is the document produced by the DetNet
   WG to describe that model.

But in general when we mention a DetNet architecture we present it as an abstract architecture to be defined as opposed to work already done, so we abstained to have a reference to the architecture draft.

More than that seems artificial and I'm tempted to leave things as is. If you think it is important then I'm OK add a sentence or modify the one quoted above in the next editions.

Please let us know if that's OK?

Pascal

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 19 Dec 2018 13:06:00 -0800

Pascal:

Hi!

The document is fine with me…this was just a non-blocking comment to say
that I would have preferred one document instead of two…but no change is
needed.

Thanks for following up.

Alvaro.

On December 19, 2018 at 11:39:07 AM, Pascal Thubert (pthubert) (
[email-masked]) wrote:

Hello Alvaro :

“

Given the close relationship between this document and
draft-ietf-detnet-use-cases, I think that it would have been beneficial to
produce a single document.  As it stands neither one normatively references
the other.

I’m sorry I cannot remember seeing this comment before, and I could not dig
it in my mail client, so I do not know what happened with it.

As it goes, the problem statement precedes the architecture document and
cannot really reference it normatively.

On the other hand the problem statement is a consequence of the use case
draft so it is heavily based on it.

But in general when we mention a DetNet architecture we present it as an
abstract architecture to be defined as opposed to work already done, so we
abstained to have a reference to the architecture draft.

More than that seems artificial and I’m tempted to leave things as is. If
you think it is important then I’m OK add a sentence or modify the one
quoted above in the next editions.

Please let us know if that’s OK?

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 19 Dec 2018 21:23:10 +0000

All good then, Alvaro.

Merry Christmas : )

Pascal

Le 19 déc. 2018 à 22:06, Alvaro Retana <[email-masked]<mailto:[email-masked]>> a écrit :

Pascal:

Hi!

The document is fine with me…this was just a non-blocking comment to say that I would have preferred one document instead of two…but no change is needed.

Thanks for following up.

Alvaro.

On December 19, 2018 at 11:39:07 AM, Pascal Thubert (pthubert) ([email-masked]<mailto:[email-masked]>) wrote:
Hello Alvaro :

I’m sorry I cannot remember seeing this comment before, and I could not dig it in my mail client, so I do not know what happened with it.

More than that seems artificial and I’m tempted to leave things as is. If you think it is important then I’m OK add a sentence or modify the one quoted above in the next editions.

Pascal