Subject: [Detnet] DetNet Security Draft - IP Data Plane Specific section

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 2 Jul 2019 06:02:18 +0000

Hi All,
I am having difficulty getting a contribution for our proposed "last remaining" section of the DetNet Security draft, which is the "IP Data Plane Specific" section.  Could it be that there is nothing to say? What if I said the following - who would we need to have review this statement to poke some holes in it? I mean, that is essentially the text I'm looking for, should it actually exist.

Proposed text for "IP Data Plane Considerations for DetNet" section:

"The IP protocol has a long history of security considerations and mitigations, and its use as a DetNet Data Plane introduces no new security issues that were not there before (apart from those already described in the data-plane-independent section of this document).

Thus the security considerations for a DetNet based on an IP data plane are purely inherited from the rich IP Security literature and code/application base, and the data-plane-independent section of this document".

Is that good? Should we ask for a review from the SECDIR for this statement?

Ethan (as Editor, DetNet Security draft).

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 2 Jul 2019 07:20:20 -0400

Ethan,

That's certainly good as initial text for the section. As far as a SECDIR
review, I'm sure that our WG chars will be asking the SECDIR for an early
review of the entire document before it goes to WG last call. At least that
what I would do in their place. :-)

Cheers,
Andy

On Tue, Jul 2, 2019 at 2:02 AM Grossman, Ethan A. <[email-masked]> wrote:

> Hi All,
>
> I am having difficulty getting a contribution for our proposed “last
> remaining” section of the DetNet Security draft, which is the “IP Data
> Plane Specific” section.  Could it be that there is nothing to say? What if
> I said the following – who would we need to have review this statement to
> poke some holes in it? I mean, that is essentially the text I’m looking
> for, should it actually exist.
>
>
>
> Proposed text for “IP Data Plane Considerations for DetNet” section:
>
>
>
> “The IP protocol has a long history of security considerations and
> mitigations, and its use as a DetNet Data Plane introduces no new security
> issues that were not there before (apart from those already described in
> the data-plane-independent section of this document).
>
>
>
> Thus the security considerations for a DetNet based on an IP data plane
> are purely inherited from the rich IP Security literature and
> code/application base, and the data-plane-independent section of this
> document”.
>
>
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>

---

From: "Grossman, Ethan A." <[email-masked]>
Date: Tue, 2 Jul 2019 15:49:08 +0000

OK, well, if I can get the MPLS-specific text from Stewart in time for me to get it into a revision in time for the draft deadline this coming Monday, I can include this also, at least as a placeholder (or lightning rod).
Ethan.

From: Andrew G. Malis <[email-masked]>
Sent: Tuesday, July 2, 2019 4:20 AM
To: Grossman, Ethan A. <[email-masked]>
Cc: detnet WG <[email-masked]>
Subject: Re: [Detnet] DetNet Security Draft - IP Data Plane Specific section

Ethan,

That's certainly good as initial text for the section. As far as a SECDIR review, I'm sure that our WG chars will be asking the SECDIR for an early review of the entire document before it goes to WG last call. At least that what I would do in their place. :-)

Cheers,
Andy

On Tue, Jul 2, 2019 at 2:02 AM Grossman, Ethan A. <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,
I am having difficulty getting a contribution for our proposed “last remaining” section of the DetNet Security draft, which is the “IP Data Plane Specific” section.  Could it be that there is nothing to say? What if I said the following – who would we need to have review this statement to poke some holes in it? I mean, that is essentially the text I’m looking for, should it actually exist.

“The IP protocol has a long history of security considerations and mitigations, and its use as a DetNet Data Plane introduces no new security issues that were not there before (apart from those already described in the data-plane-independent section of this document).

Thus the security considerations for a DetNet based on an IP data plane are purely inherited from the rich IP Security literature and code/application base, and the data-plane-independent section of this document”.

Ethan (as Editor, DetNet Security draft).
_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_detnet&d=DwMFaQ&c=lI8Zb6TzM3d1tX4iEu7bpg&r=ZcHC6wX_gDwPDcfMaFNZiQ&m=xhuMBCdrQg6A5lgr0QmGgB55MasslYPYw_S2eT4cDC0&s=T3VJk4yZ0s4huZyS-9h8VbaGXp4sPlOEsivHNBH5SSo&e=>