Subject: [Detnet] Martin Duke's Discuss on draft-ietf-detnet-flow-information-model-12: (with DISCUSS and COMMENT)

From: Martin Duke via Datatracker <[email-masked]>
Date: Tue, 08 Dec 2020 13:02:31 -0800

Martin Duke has entered the following ballot position for
draft-ietf-detnet-flow-information-model-12: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-flow-information-model/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Secs 5.9.6 defines Maximum Reordering Tolerance with an example: "The
difference of sequence number values in
   consecutive packets at the Egress cannot be bigger than
   "MaxMisordering + 1"."

While this definition is actionable, it interacts uncomfortably with Maximum
Consecutive Loss. If MCL < MRT, there are cases where it will violate MRT but
not MCL, which would subvert the usually understood meaning of reordering.

Moreover, if MaxMisordering is 3, the sequence 6, 4, 0 would not trigger this
definition even though there is very significant reordering here.

A better example would be "When a packet arrives at the egress after a packet
with a higher sequence number, the difference between the sequence number
values cannot be bigger than
   "MaxMisordering + 1"."

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Sec 1. s/rational/rationale

Sec 1.2 and 1.3. What is the difference between the "flow information model"
that is stated goal and the "flow data model" that is a stated non-goal?

Sec 5.5 Octets/second seems like a very odd unit for Max/Min Payload size. This
should either be Octets, or the metric should be renamed Max/Min Payload Rate,
or something to that effect.

Sec 5.5. the section says a lot about violations of the minimum, but not the
maximum. This approach seems inconsistent.

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 11 Dec 2020 12:36:03 +0000

Hi Martin,

Many thanks for the review and the good comments.
Proposals for resolving them are below marked <BV>.

Please let me know if You are happy with them.

Thanks
Bala'zs

-----Original Message-----
From: Martin Duke via Datatracker <[email-masked]> 
Sent: Tuesday, December 8, 2020 10:03 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Lou Berger <[email-masked]>; [email-masked]
Subject: Martin Duke's Discuss on draft-ietf-detnet-flow-information-model-12: (with DISCUSS and COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Secs 5.9.6 defines Maximum Reordering Tolerance with an example: "The difference of sequence number values in
   consecutive packets at the Egress cannot be bigger than
   "MaxMisordering + 1"."

While this definition is actionable, it interacts uncomfortably with Maximum Consecutive Loss. If MCL < MRT, there are cases where it will violate MRT but not MCL, which would subvert the usually understood meaning of reordering.

Moreover, if MaxMisordering is 3, the sequence 6, 4, 0 would not trigger this definition even though there is very significant reordering here.

A better example would be "When a packet arrives at the egress after a packet with a higher sequence number, the difference between the sequence number values cannot be bigger than
   "MaxMisordering + 1"."

<BV> Thanks, fully valid comment. I like your proposal to resolve the issue for 
the example, so intend to change accordingly.
OLD TEXT
   The maximum allowed misordering can be measured for example based on
   sequence number.  The difference of sequence number values in
   consecutive packets at the Egress cannot be bigger than
   "MaxMisordering + 1".
NEW TEXT
   The maximum allowed misordering can be measured for example based 
   on sequence numbers. When a packet arrives at the egress after a 
   packet with a higher sequence number, the difference between the 
   sequence number values cannot be bigger than
   "MaxMisordering + 1".
END

<BV> OK.

<BV> Data model refers to YANG and we have a dedicated draft for YANG.
https://datatracker.ietf.org/doc/draft-ietf-detnet-yang/

Sec 5.5 Octets/second seems like a very odd unit for Max/Min Payload size. This should either be Octets, or the metric should be renamed Max/Min Payload Rate, or something to that effect.

<BV> Upps. That is an error.
OLD TEXT
   PayloadSizes are specified in octets per second.
NEW TEXT
  PayloadSizes are specified in octets.
END

Sec 5.5. the section says a lot about violations of the minimum, but not the maximum. This approach seems inconsistent.
<BV> Right. Sending more traffic than maximum results in possible drop and/or 
not fulfilling the service requirements of the flow. Some new text to be added 
before the second paragraph after the attribute list.
OLD TEXT
   N/A.
NEW TEXT
  Flows exceeding the traffic specification (i.e., having more traffic than 
  defined by the maximum attributes) may receive a different network 
  behavior than the DetNet network has been engineered for. Excess 
  traffic due to malicious or malfunctioning devices can be prevented 
  or mitigated (e.g., through the use of existing mechanisms such as 
  policing and shaping).
END

---

From: Martin Duke <[email-masked]>
Date: Fri, 11 Dec 2020 14:14:07 -0800

These changes are great, thanks. I will remove the DISCUSS in draft-13.

Non-blocking, but I might say “YANG data model” instead of “data model”,
just to make the distinction less obscure. And possibly an informative
reference to the yang draft.

On Fri, Dec 11, 2020 at 4:36 AM Balázs Varga A <[email-masked]>
wrote:

> Cc: [email-masked];
> [email-masked]; [email-masked]; Lou Berger <[email-masked]>;
> [email-masked]
> Subject: Martin Duke's Discuss on
> draft-ietf-detnet-flow-information-model-12: (with DISCUSS and COMMENT)
>
> While this definition is actionable, it interacts uncomfortably with
> Maximum Consecutive Loss. If MCL < MRT, there are cases where it will
> violate MRT but not MCL, which would subvert the usually understood meaning
> of reordering.
>
> Moreover, if MaxMisordering is 3, the sequence 6, 4, 0 would not trigger
> this definition even though there is very significant reordering here.
>
> A better example would be "When a packet arrives at the egress after a
> packet with a higher sequence number, the difference between the sequence
> number values cannot be bigger than
>    "MaxMisordering + 1"."
>
> Sec 5.5 Octets/second seems like a very odd unit for Max/Min Payload size.
> This should either be Octets, or the metric should be renamed Max/Min
> Payload Rate, or something to that effect.
>
> Sec 5.5. the section says a lot about violations of the minimum, but not
> the maximum. This approach seems inconsistent.

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 14 Dec 2020 08:03:46 +0000

Hi Martin,
Thanks for the feedback. v13 was uploaded.
https://www.ietf.org/archive/id/draft-ietf-detnet-flow-information-model-13.txt
I have added an informative reference to the YANG data model as well.
Many thanks & cheers
Bala’zs

From: Martin Duke <[email-masked]>
Sent: Friday, December 11, 2020 11:14 PM
To: Balázs Varga A <[email-masked]>
Cc: Lou Berger <[email-masked]>; The IESG <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Martin Duke's Discuss on draft-ietf-detnet-flow-information-model-12: (with DISCUSS and COMMENT)

Non-blocking, but I might say “YANG data model” instead of “data model”, just to make the distinction less obscure. And possibly an informative reference to the yang draft.

On Fri, Dec 11, 2020 at 4:36 AM Balázs Varga A <[email-masked]<mailto:[email-masked]>> wrote:
Hi Martin,

Thanks
Bala'zs

-----Original Message-----
From: Martin Duke via Datatracker <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, December 8, 2020 10:03 PM
To: The IESG <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Lou Berger <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Martin Duke's Discuss on draft-ietf-detnet-flow-information-model-12: (with DISCUSS and COMMENT)

<BV> OK.