Subject: [Detnet] Robert Wilton's No Objection on draft-ietf-detnet-mpls-over-udp-ip-07: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Tue, 01 Dec 2020 06:03:42 -0800

Robert Wilton has entered the following ballot position for
draft-ietf-detnet-mpls-over-udp-ip-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-detnet-mpls-over-udp-ip/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I would like to thank the authors for this easy to read and understand
document, and also thank Dan for his OPSDIR review.

Related to Dan's question on the manageability section, as a non blocking
comment, I wonder whether it would be helpful to have informational references
to either the Detnet YANG model or the Detnet OAM documents?  This might be
helpful to future readers when they are relating the suite of Detnet documents
together.  However, I appreciate that this would create forward references to
those documents and will leave it to the discretion of the authors (and
responsible AD) to decide whether such references would be helpful here.  It
would also be worth noting that adding such references may also create an
inconsistency with the other Detnet documents currently in the RFC editor queue
unless they also have similar references added.

Regards,
Rob

---

From: Balázs Varga A <[email-masked]>
Date: Mon, 14 Dec 2020 16:03:32 +0000

Hi Robert,

Many thanks for your comments. I see your point, this is unfortunately a side-effect of covering 
the DetNet data plane in multiple dedicated documents.
We have referred to YANG and OAM in the IP and the MPLS data plane documents. In order to 
avoid inconsistency (as You have recognized the issue as well) they were not added in this 
document. 
So, I would keep the document in its current form.

Many thanks
Bala'zs

-----Original Message-----
From: Robert Wilton via Datatracker <[email-masked]> 
Sent: Tuesday, December 1, 2020 3:04 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Ethan Grossman <[email-masked]>; [email-masked]
Subject: Robert Wilton's No Objection on draft-ietf-detnet-mpls-over-udp-ip-07: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I would like to thank the authors for this easy to read and understand document, and also thank Dan for his OPSDIR review.

Related to Dan's question on the manageability section, as a non blocking comment, I wonder whether it would be helpful to have informational references to either the Detnet YANG model or the Detnet OAM documents?  This might be helpful to future readers when they are relating the suite of Detnet documents together.  However, I appreciate that this would create forward references to those documents and will leave it to the discretion of the authors (and responsible AD) to decide whether such references would be helpful here.  It would also be worth noting that adding such references may also create an inconsistency with the other Detnet documents currently in the RFC editor queue unless they also have similar references added.

Regards,
Rob