Subject: [Detnet] Flow Identification in IPv6

From: Greg Mirsky <[email-masked]>
Date: Sat, 6 Mar 2021 12:20:09 -0800

Dear Authors,
thank you for bringing your proposal to the discussion. I agree with your
view that the explicit routing enabled by SRv6 creates an environment where
PREOF can be used. And, as we know, The PREOF may be used in a DetNet
domain to lower packet loss ratio and provide bounded latency.
After reading the draft, I've got a question for you. What do you see as
the difference between the IPv6 Flow Label per RFC 6437 and the Flow
Identification field in the TLV proposed in the draft? Could the IPv6 Flow
Label be used to identify the flow for the PREOF?

Regards,
Greg

---

From: "Yangfan (IP Standard)" <[email-masked]>
Date: Mon, 8 Mar 2021 09:38:27 +0000

Hi Greg,

Literally speaking, IPv6  Flow Label could be used to identify a specific flow needing redundancy protection in SRv6 data plane. But I may have concerns that flow label cannot be protected to be unmodified en route. A modified flow label can be a disaster for the traffics  which are seeking for deterministic forwarding, not only this flow, also affecting other flows using redundancy protection. And with several security issues mentioned in RFC6437, I doubt if it is a good idea to user IPv6 Flow Label.
Just my 2cents opinion, how do you and other people see it?

Regards,
Fan

发件人: Greg Mirsky [mailto:[email-masked]]
发送时间: 2021年3月7日 4:20
收件人: [email-masked]
抄送: 6man WG <[email-masked]>; DetNet WG <[email-masked]>; Greg Mirsky <[email-masked]>
主题: Flow Identification in IPv6

Dear Authors,
thank you for bringing your proposal to the discussion. I agree with your view that the explicit routing enabled by SRv6 creates an environment where PREOF can be used. And, as we know, The PREOF may be used in a DetNet domain to lower packet loss ratio and provide bounded latency.
After reading the draft, I've got a question for you. What do you see as the difference between the IPv6 Flow Label per RFC 6437 and the Flow Identification field in the TLV proposed in the draft? Could the IPv6 Flow Label be used to identify the flow for the PREOF?

Regards,
Greg

---

From: Tom Herbert <[email-masked]>
Date: Mon, 8 Mar 2021 09:31:58 -0700

> Just my 2cents opinion, how do you and other people see it?

If this is to be used in a SRv6 domain which is itself a limited
domain, then I think the problems you mention aren't as much of a
concern since flow label would be used in a controlled environment.
The upside of using flow label is that it's already in the IPv6
header, it can be consumed by non-SRv6 devices, and putting the same
information in TLVs incurs the overhead and cost of processing TLVs in
the critical datapath.

Tom

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 9 Mar 2021 17:03:22 +1300

> information in TLVs incurs the overhead and cost of processing TLVs in

The main downside is that it cannot convey any semantics and there is
a rule about how its value is created. It's no more at risk of being
modified than any other unauthenticated header field, so I agree that
within an SRV6 domain malicious modification doesn't seem like a
big risk. An attacker who could do that could do any kind of damage
they wanted.

Regards
    Brian

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Mar 2021 18:05:05 +0100

How about taking a bit from the "reserved" field in the draft
to indicate if/when the IPv6 header flow label is being used
as the flow identification field. That would make using the flow
label field an option for the operator to decide.

For example, i could see not wanting to use the flow label field
if it's pushed down from encapulated IPv6 traffic and used already
for some other purpose than PREOF.

Cheers
    Toerless

On Tue, Mar 09, 2021 at 05:03:22PM +1300, Brian E Carpenter wrote:
> >> ?????????: Greg Mirsky [mailto:[email-masked]]
> >> ????????????: 2021???3???7??? 4:20
> >> ?????????: [email-masked]
> >> ??????: 6man WG <[email-masked]>; DetNet WG <[email-masked]>; Greg Mirsky <[email-masked]>
> >> ??????: Flow Identification in IPv6
> >>
> >>
> >>
> >> Dear Authors,
> >>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet

-- 
---
[email-masked]