Subject: Re: [Detnet] New version of DetNet YANG

From: Balázs Varga A <[email-masked]>
Date: Tue, 2 Mar 2021 14:18:16 +0000

Hi Don,

Thanks, cool.

Two question for clarification (we may discuss on Monday as well):

1, Are there YANG parameters defined for the QoS functions used in the DetNet
forwarding sub-layer? I have found e.g., the forwarding sub-layer related MPLS
label operations, but not the QoS related ones.

2, Are there sub-networks specific YANG parameters defined/referenced as well?

Many thanks
Bala'zs

From: detnet <[email-masked]> On Behalf Of Don Fedyk
Sent: Friday, February 19, 2021 8:37 PM
To: 'DetNet WG' <[email-masked]>
Subject: [Detnet] New version of DetNet YANG

Hi

We have posted a new version of the DetNet YANG

https://www.ietf.org/archive/id/draft-ietf-detnet-yang-11.txt

(This issue corrects some yang validation checks that a few days earlier submission missed. )

This version the authors think is at a level of completeness we will be asking for WG last call.

Please have a look and any post comments.  We plan to present the highlights at the next DetNet meeting.

Cheers,

Don

---

From: Don Fedyk <[email-masked]>
Date: Wed, 3 Mar 2021 14:10:28 +0000

Hi Balázs

  1.  We have the traffic flow requirements and flow-spec requests that can be applied at the application, service sub-layer and forwarding sub-layer.  Each forwaring type,  IP and MPLS have the data plane QoS objects.  ( DSCP for IP and traffic-class for MPLS).   An SDN controller or a management plane could correlate QoS reservation of resources to a flow with the appropriate markings.  And you could stich a path on various nodes with  MPLS label. But we do not have a control plane function to correlate QoS traffic in the YANG models that we have to any database. (i.e. a traffic engineering database)   I suspect there are existing YANG models that do some of that but we have not looked into that because we do not have DetNet documents in this area.
  2.  I'm not sure what you mean by sub-network specific YANG parameters.  Is there a DetNet document that you are referring to?

Cheers
Don

From: Balázs Varga A <[email-masked]>
Sent: Tuesday, March 2, 2021 9:18 AM
To: Don Fedyk <[email-masked]>; 'DetNet WG' <[email-masked]>
Subject: RE: New version of DetNet YANG

Hi Don,

Thanks, cool.

Many thanks
Bala'zs

From: detnet <[email-masked]<mailto:[email-masked]>> On Behalf Of Don Fedyk
Sent: Friday, February 19, 2021 8:37 PM
To: 'DetNet WG' <[email-masked]<mailto:[email-masked]>>
Subject: [Detnet] New version of DetNet YANG

Hi

Cheers,

Don

---

From: Balázs Varga A <[email-masked]>
Date: Fri, 5 Mar 2021 11:37:12 +0000

Hi Don,

1, OK, thanks.

2, On sub-networks my question is related to the mapping of DetNet flows to sub-networks' flows/streams.
2.a, Scenarios in the "draft-ietf-detnet-ip-over-mpls" and "draft-ietf-detnet-mpls-over-udp-ip". I see "mpls-over-ip"
in the flow type next hop choices, but nothing regarding "ip-over-mpls". Have I missed something?

2.b, Further, I have had also the TSN drafts in mind "draft-ietf-detnet-ip-over-tsn", "draft-ietf-detnet-mpls-over-tsn"
and "draft-ietf-detnet-tsn-vpn-over-mpls". YANG for TSN is defined in IEEE, however for mapping DetNet flows
to/from TSN Streams may require e.g., some common identifier. What do You think?

Cheers
Bala'zs

From: Don Fedyk <[email-masked]>
Sent: Wednesday, March 3, 2021 3:10 PM
To: Balázs Varga A <[email-masked]>; 'DetNet WG' <[email-masked]>
Subject: RE: New version of DetNet YANG

Hi Balázs

Cheers
Don

From: Balázs Varga A <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 2, 2021 9:18 AM
To: Don Fedyk <[email-masked]<mailto:[email-masked]>>; 'DetNet WG' <[email-masked]<mailto:[email-masked]>>
Subject: RE: New version of DetNet YANG

Hi Don,

Thanks, cool.

Many thanks
Bala'zs

Hi

Cheers,

Don

---

From: Don Fedyk <[email-masked]>
Date: Mon, 8 Mar 2021 14:13:44 +0000

Hi Balázs
Inline [Don]
Cheers
Don

Hi Don,

1, OK, thanks.

2, On sub-networks my question is related to the mapping of DetNet flows to sub-networks' flows/streams.
2.a, Scenarios in the "draft-ietf-detnet-ip-over-mpls" and "draft-ietf-detnet-mpls-over-udp-ip". I see "mpls-over-ip"
in the flow type next hop choices, but nothing regarding "ip-over-mpls". Have I missed something?
[Don] I'm finding it hard to parse your meaning - Sorry.  If you are referring to the YANG  yes we have ip-over-mpls
This is well specified.  We do not have MPLS over IP but we have aggregation of Service Sub-layer and Forwarding Sublayer over
A service sublayer which could be IP.  We do not explicitly support IP-IN-IP tunnel formats  (additional field).
We need WG guidance if this is to be done in this YANG or other.  We made a call to have a clear aggregation model and
these needed to be implemented first.

2.b, Further, I have had also the TSN drafts in mind "draft-ietf-detnet-ip-over-tsn", "draft-ietf-detnet-mpls-over-tsn"
and "draft-ietf-detnet-tsn-vpn-over-mpls". YANG for TSN is defined in IEEE, however for mapping DetNet flows
to/from TSN Streams may require e.g., some common identifier. What do You think?
[Don] We allow Ethernet to be included from an application as an interface.  This is a transparent data service.
We can prune that stream on Ethernet parameters only egress we simply hand the decapsulated stream back to the application.
However if you create an application interface for a second stream you can map that to a different service sub layer and
Use the service sub-layer to differentiate the application at egress.
Both of these issues need additional discussion if the WG if we are to add the function.
The configuration and aggregation  model provides some capabilities because they are building blocks.

Cheers
Bala'zs

From: Don Fedyk <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, March 3, 2021 3:10 PM
To: Balázs Varga A <[email-masked]<mailto:[email-masked]>>; 'DetNet WG' <[email-masked]<mailto:[email-masked]>>
Subject: RE: New version of DetNet YANG

Hi Balázs

Cheers
Don

Hi Don,

Thanks, cool.

Many thanks
Bala'zs

Hi

Cheers,

Don