Subject: [Detnet] [Detnet ] Fwd: New draft on A Queuing Mechanism with Multiple Cyclic Buffers

From: Dangjuanna <[email-masked]>
Date: Wed, 3 Mar 2021 07:01:56 +0000

Hi All,

Network forwarding with bounded latency and zero congestion loss is important for various industrial applications.  The DetNet working group draft "DetNet Bounded Latency"[draft-ietf-detnet-bounded-latency] describes requirements for queuing mechanisms.  To cope with long link delay, more than two cyclic buffers can be used.  Among the referenced queuing mechanisms, Cyclic Queuing and Forwarding (CQF) requires no per-flow dynamic state at core nodes, which is scalable when the number of flows grows.  This draft<https://www.ietf.org/archive/id/draft-dang-queuing-with-multiple-cyclic-buffers-00.txt> discusses the details of the cyclic queuing mechanisms. We propose a queuing model and mechanism with multiple cyclic buffers, which can improve bandwidth utilization without sacrificing latency and jitter.

I list a few points as follows for discussion.

1.       The mechanism with multiple cyclic buffers can be used for bounded latency guarantee.

2.       In actual deployment, we need to know which nodes have this mechanism. Therefore, both the controller and YANG model need to be extended.

3.       While the latency is guaranteed, network bandwidth utilization and long-distance deployment should be the key considerations.

I hope that those above issues will arouse our attention.

Regards,

Joanna

-----Original Message-----

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

Sent: 2021年2月22日 20:07

To: Liubingyang (Bryan) <[email-masked]<mailto:[email-masked]>>; Dangjuanna <[email-masked]<mailto:[email-masked]>>

Subject: New Version Notification for draft-dang-queuing-with-multiple-cyclic-buffers-00.txt

A new version of I-D, draft-dang-queuing-with-multiple-cyclic-buffers-00.txt

has been successfully submitted by Joanna Dang and posted to the IETF repository.

Name:               draft-dang-queuing-with-multiple-cyclic-buffers

Revision:  00

Title:                  A Queuing Mechanism with Multiple Cyclic Buffers

Document date:       2021-02-22

Group:               Individual Submission

Pages:               6

URL:            https://www.ietf.org/archive/id/draft-dang-queuing-with-multiple-cyclic-buffers-00.txt

Status:         https://datatracker.ietf.org/doc/draft-dang-queuing-with-multiple-cyclic-buffers/

Htmlized:       https://datatracker.ietf.org/doc/html/draft-dang-queuing-with-multiple-cyclic-buffers

Htmlized:       https://tools.ietf.org/html/draft-dang-queuing-with-multiple-cyclic-buffers-00

Abstract:

   This document presents a queuing mechanism with multiple cyclic

   buffers.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Mohammadpour Ehsan <[email-masked]>
Date: Wed, 3 Mar 2021 08:31:46 +0000

Hello Joanna,

I think this is an interesting topic to be studied. The CQF with two buffers is addressed in IEEE802.1Q (annex T); however, it is not discussing multiple-queue version that leads to increase bandwidth utilisation when the dead time is large. From my understanding, this document covers CQF with multiple queues that is very nice. Regarding that, I have two questions:

1) Is the proposed mechanism operating in non-synchronised network?
2) Does the proposed mechanism allow different cycle times throughout a network? If so, how does the buffer allocation work (I didn’t get it well from the document)?

Thanks!

Best,
Ehsan

On 3 Mar 2021, at 08:01, Dangjuanna <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

Regards,

Joanna

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: 2021年2月22日 20:07
To: Liubingyang (Bryan) <[email-masked]<mailto:[email-masked]>>; Dangjuanna <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-dang-queuing-with-multiple-cyclic-buffers-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

_______________________________________________
detnet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/detnet

---

From: "Liubingyang (Bryan)" <[email-masked]>
Date: Wed, 3 Mar 2021 10:18:33 +0000

Hi Ehsan,

Great questions.

First, the queues of different nodes do not have to open/close at the same time.  Theoretically, time does not have to be synchronized. What is required is that the difference between the cycle starting times of neighbor nodes should be stable, i.e., the maximum time interval error (MTIE) should be bounded. According to ITU-T G.8261, the MTIE is bounded by 300 ns when a chain of up to 20 enhanced synchronous Ethernet (SyncE) clocks are traceable to an enhanced primary reference time clock (ePRTC).

The CQF as described in 802.1Q should work with different cycle times. I suspect the mechanism described in this draft should work with different cycle times, too. But I haven’t worked into the details. We can together discuss and work on it. Do you mean that a single node can run multiple cyclic buffers, and some of the buffers are with cycle values 10us, 20us, 40us … ?

Bryan (Bingyang Liu)

From: detnet [mailto:[email-masked]] On Behalf Of Mohammadpour Ehsan
Sent: Wednesday, March 3, 2021 4:32 PM
To: Dangjuanna <[email-masked]>
Cc: [email-masked]; Liubingyang (Bryan) <[email-masked]>
Subject: Re: [Detnet] [Detnet ] Fwd: New draft on A Queuing Mechanism with Multiple Cyclic Buffers

Hello Joanna,

Thanks!

Best,
Ehsan

Hi All,

Regards,

Joanna

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: 2021年2月22日 20:07
To: Liubingyang (Bryan) <[email-masked]<mailto:[email-masked]>>; Dangjuanna <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-dang-queuing-with-multiple-cyclic-buffers-00.txt

Abstract:

The IETF Secretariat

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 3 Mar 2021 13:18:04 +0100

Hi Ehsan,

To add to Bryans explanations:

The way i understand IEEE CQF, the MTIE really needs to make the clock of adjacent nodes stay
within the dead interval, so that packets received are appropriately put into the right
cycle purely ased on their arrival time. I think the dead time is <= 10% of cycle time,
 leading to often MTIE requirements in the nsec range.

In the packet header tagged queuing, my understanding is that a simple operating model exists
when the MTIE is such that a packet with a particular cycle tag does arrive within the window
in which the receiver can accept packets for that cycle instance. If you have
for example 4 cycles i think the MTIE can be > 1 cycle time, which is a factor 10 larger
than without indicating the cycle in a packet tag. If time synchronization was used to
achieve the MTIE, then it could be a factor 10 less accurate over CQF, which especially in wide
area networks could be a significant capex/opex reduction.

Just off the top of my head. There is a lot of room IMHO for optimization, for example,
if every buffer is virtual on the receive side, and can thus receive all the time,
then it should be possible to achieve this relaxed MTIE with fewer cycle tags
on the wire (and less overall latency).

There are IMHO also be good uses of the scheme without strict admission control and not
requring zero congestion loss - in the same way that i think PREOF will find deployments
without combining it with explicit admission control. In those scenarios, the requirments
for specific MTIE guarantees will also be different (IMHO). Aka: it would be great to
recognize these schemes such as CQF and his multi-buffer cyclic queuing also independently
from congestion loss as a building block in DetNet for not only bounded latency,
but tightly bounded jitter, for example in the bounded latency draft - in the same way
as PREOF is also recognized as an individual building block to provide significant reduced NCL.

Let us know what you think!

Cheers
    Toerless

On Wed, Mar 03, 2021 at 10:18:33AM +0000, Liubingyang (Bryan) wrote:
> The CQF as described in 802.1Q should work with different cycle times. I suspect the mechanism described in this draft should work with different cycle times, too. But I haven???t worked into the details. We can together discuss and work on it. Do you mean that a single node can run multiple cyclic buffers, and some of the buffers are with cycle values 10us, 20us, 40us ??? ?
> 
> Bryan (Bingyang Liu)
> 
> 2) Does the proposed mechanism allow different cycle times throughout a network? If so, how does the buffer allocation work (I didn???t get it well from the document)?
> 
> Thanks!
> 
> 
> Best,
> Ehsan
> 
> 
> 
> Sent: 2021???2???22??? 20:07

> [email-masked]

-- 
---
[email-masked]