Subject: [Detnet] Reference to an Informational RFC

From: Don Fedyk <[email-masked]>
Date: Wed, 8 Sep 2021 14:39:00 +0000

Hi John

While going through last call comments on draft-ietf-detnet-yang.txt  https://datatracker.ietf.org/doc/html/draft-ietf-detnet-yang
Tom Petch Noted, among his many comments,
"It is unfortunate that RFC9016 is Informational - it needs to be a Normative Reference IMO; your AD is probably familiar with this problem as it occurred as recently as last month and will doubtless occur many times again. "

What is the course of action for us?

Thanks
Don & Authors

---

From: "Black, David" <[email-masked]>
Date: Wed, 8 Sep 2021 14:57:39 +0000

Dell Customer Communication - Confidential

Check with your AD - this is allowed as an exception if it is truly necessary, but attention has to be called to the exception (e.g., in the IETF Last Call announcement, if I remember correctly).

Thanks, --David

From: detnet <[email-masked]> On Behalf Of Don Fedyk
Sent: Wednesday, September 8, 2021 10:39 AM
To: John Scudder; [email-masked]
Cc: [email-masked]; 'DetNet Chairs'
Subject: [Detnet] Reference to an Informational RFC

[EXTERNAL EMAIL]
Hi John

While going through last call comments on draft-ietf-detnet-yang.txt  https://datatracker.ietf.org/doc/html/draft-ietf-detnet-yang [datatracker.ietf.org]<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-detnet-yang__;!!LpKI!3snW_FEN5Y_49XLeTZS0lTspVb80pCSiv52DYRHQLrQOwsrbbLYpWK9tSapny8x0$>
Tom Petch Noted, among his many comments,
"It is unfortunate that RFC9016 is Informational - it needs to be a Normative Reference IMO; your AD is probably familiar with this problem as it occurred as recently as last month and will doubtless occur many times again. "

Thanks
Don & Authors

---

From: John Scudder <[email-masked]>
Date: Wed, 8 Sep 2021 17:10:05 +0000

Yes, exactly as David says. If the normative reference is needed, there’s no need to shy away from it, the process is not onerous. (And we can subsequently also get 9016 onto the downref registry if it belongs there, as itsounds like it might). https://datatracker.ietf.org/doc/downref/

—John

On Sep 8, 2021, at 10:57 AM, Black, David <[email-masked]> wrote:

[External Email. Be cautious of content]

Check with your AD – this is allowed as an exception if it is truly necessary, but attention has to be called to the exception (e.g., in the IETF Last Call announcement, if I remember correctly).

Thanks, --David

[EXTERNAL EMAIL]
Hi John

While going through last call comments on draft-ietf-detnet-yang.txt  https://datatracker.ietf.org/doc/html/draft-ietf-detnet-yang [datatracker.ietf.org]<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-detnet-yang__;!!LpKI!3snW_FEN5Y_49XLeTZS0lTspVb80pCSiv52DYRHQLrQOwsrbbLYpWK9tSapny8x0$>
Tom Petch Noted, among his many comments,
“It is unfortunate that RFC9016 is Informational - it needs to be a Normative Reference IMO; your AD is probably familiar with this problem as it occurred as recently as last month and will doubtless occur many times again. “

Thanks
Don & Authors

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 8 Sep 2021 15:18:56 -0400

The downref should also be included in the document shepherd's writeup. The
rule is that an informative RFC can be a normative reference if it's
required to properly understand or implement the draft.

Cheers,
Andy

On Wed, Sep 8, 2021 at 1:10 PM John Scudder <jgs=
[email-masked]> wrote:

> Yes, exactly as David says. If the normative reference is needed, there’s
> no need to shy away from it, the process is not onerous. (And we can
> subsequently also get 9016 onto the downref registry if it belongs there,
> as itsounds like it might). https://datatracker.ietf.org/doc/downref/
>
> —John
>
> Check with your AD – this is allowed as an exception if it is truly
> necessary, but attention has to be called to the exception (e.g., in the
> IETF Last Call announcement, if I remember correctly).
>
>
>
> Thanks, --David
>
>
>
> *From:* detnet <[email-masked]> *On Behalf Of *Don Fedyk
> *Sent:* Wednesday, September 8, 2021 10:39 AM
> *To:* John Scudder; [email-masked]
> *Cc:* [email-masked]; 'DetNet Chairs'
> *Subject:* [Detnet] Reference to an Informational RFC
>
>
>
> [EXTERNAL EMAIL]
>
> Hi John
>
>
>
> [datatracker.ietf.org]
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-ietf-detnet-yang__;!!LpKI!3snW_FEN5Y_49XLeTZS0lTspVb80pCSiv52DYRHQLrQOwsrbbLYpWK9tSapny8x0$>
>
> “It is unfortunate that RFC9016 is Informational - it needs to be a
> Normative Reference IMO; your AD is probably familiar with this problem as
> it occurred as recently as last month and will doubtless occur many times
> again. “
>
>
>
> _______________________________________________
> detnet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/detnet
>