Subject: Delivering "Internet browser configuration" using DHCP

From: "SOM Bandyopadhyay" <[email-masked]>
Date: Thu, 23 Sep 1999 17:52:52 -0400 (EDT)

Hi,

Did any one attempt to define DHCP options to deliver "Internet browser configuration" ? Examples for these options are NNTP servers, POP3/mail servers, Proxy servers...So one can define a general category of option called "Internet browser configuration" and under that all these configuration information can be obtained.

After getting this information ( by DHCP client ) we of couse need some OS specific implementation to modify browsers configuration...I feel this will be a cool thing to do and wondering someone must have thought about doing this already..

Any one else has any interest on this area and find this useful?

thanks, som.

---

From: Eric Michelsen <[email-masked]>
Date: Thu, 23 Sep 1999 21:50:45 -0400 (EDT)

How about using the next-server option, and downloading a configuration
file?  That provides a general mechanism for a wide variety of
configuration.
-------------------------------------------
Eric L. Michelsen, Copper Mountain Networks 

> -----Original Message-----
> From: SOM Bandyopadhyay [mailto:[email-masked]]
> Sent: Thursday, September 23, 1999 14:55
> To: Multiple recipients of list
> Subject: Delivering "Internet browser configuration" using DHCP
> 
> 
> Hi,
> 
> Did any one attempt to define DHCP options to deliver 
> "Internet browser configuration" ? Examples for these options 
> are NNTP servers, POP3/mail servers, Proxy servers...So one 
> can define a general category of option called "Internet 
> browser configuration" and under that all these configuration 
> information can be obtained.
> 
> After getting this information ( by DHCP client ) we of couse 
> need some OS specific implementation to modify browsers 
> configuration...I feel this will be a cool thing to do and 
> wondering someone must have thought about doing this already..
>

---

From: "Eric A. Hall" <[email-masked]>
Date: Fri, 24 Sep 1999 18:45:32 -0400 (EDT)

> Did any one attempt to define DHCP options to deliver "Internet
> browser configuration" ?

If it's not there, probably not.

> After getting this information ( by DHCP client ) we of couse need
> some OS specific implementation to modify browsers configuration...I
> feel this will be a cool thing to do and wondering someone must have
> thought about doing this already..

Network Telesystems has a Win32 client that can do events based on DHCP
changes. NT 4 (and supposedly Win3k) will let you store pre-defined
options in the registry, so you could do some triggers on that, too.
Some of the Linux distributions use scripts with the DHCP client. OS/2
has a REXX-based script for it.

I personally prefer Netscape's Roaming Access configuration profile,
since it is LDAP-based and cross-platform without having to depend on
whatever local DHCP server is in use. User-based profiles are better for
knowledge users; locale-based profiles are better for fixed-function
systems. My Personal opinion.

-- 
Eric A. Hall                                            [email-masked]
+1-650-685-0557                                    http://www.ehsco.com