Subject: FWD: I-D ACTION:draft-privat-dhc-doublephase-01.txt

From: Thomas Narten <[email-masked]>
Date: Wed, 29 Sep 1999 10:33:05 -0400 (EDT)

Comments? Seems like a protocol change as much as a new option. The
option specifies that the client should also send additional DHCP
packets to a second server.

------- Forwarded Message

From: [email-masked]
To: IETF-Announce: ;
Date: Wed, 29 Sep 1999 06:56:14 -0400
Subject: I-D ACTION:draft-privat-dhc-doublephase-01.txt
Reply-to: [email-masked]

--NextPart

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Double Phase DHCP Configuration
	Author(s)	: J. Privat
	Filename	: draft-privat-dhc-doublephase-01.txt
	Pages		: 4
	Date		: 28-Sep-99
	
This proposal allows host configuration to be split between two
different DHCP servers, potentially under different administration.
This may be useful to satisfy specific regulatory, operational
or business model requirements.
This draft proposes two different approaches. In one approach, a
DHCP server redirects clients to a second DHCP server. In the other,
a DHCP server acts as a proxy to a second server.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-privat-dhc-doublephase-01.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-privat-dhc-doublephase-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-privat-dhc-doublephase-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

--NextPart
Content-Type: Multipart/Alternative; Boundary="OtherAccess"

--OtherAccess
Content-Type: Message/External-body;
	access-type="mail-server";
	server="[email-masked]"

Content-Type: text/plain
Content-ID:	<[email-masked]>

ENCODING mime
FILE /internet-drafts/draft-privat-dhc-doublephase-01.txt

--OtherAccess
Content-Type: Message/External-body;
	name="draft-privat-dhc-doublephase-01.txt";
	site="ftp.ietf.org";
	access-type="anon-ftp";
	directory="internet-drafts"

Content-Type: text/plain
Content-ID:	<[email-masked]>

--OtherAccess--

--NextPart--

------- End of Forwarded Message

---

From: Nathan Lane <[email-masked]>
Date: Thu, 30 Sep 1999 17:26:45 -0400 (EDT)

I'm a bit confused as to why we would want to make a change as drastic as this to the clients, much more time intensive than a server change (i.e., I prefer the proxy method much more).  I think DHCP server A proxies to DHCP server B to get the options between DHCPDISCOVER & DHCPOFFER using LDAP or some other generic mechanism is a better approach.  While it is sometimes difficult to insert an extra processing step between discover & offer due to time constraints, it would not require massive client changes.  

In section 5, also, the client is quite broken if something more than just the IP address, netmask and default gateway are not given.  You do specify the specific partitions to be outside the scope of the document; perhaps a warning indicating broken clients would be appropriate or a more complete fallback set of options?  What I'm getting at is some method of informing the user that their configuration is incomplete and should not expect full functionality.  (A special DNS server with a * RR that points to a default "your client is broken" website is a possibility, but perhaps beyond the scope of this document.)

Just some ideas that may help us all to better understand and use this effectively.

-Nathan Lane
Senior Network Engineer
Wal-Mart Stores, Inc.
(501) 277-5786

> -----Original Message-----
> From:	Thomas Narten [SMTP:[email-masked]]
> Sent:	Wednesday, September 29, 1999 9:41 AM
> To:	Multiple recipients of list
> Subject:	FWD: I-D ACTION:draft-privat-dhc-doublephase-01.txt
>