Subject: [dhcwg] DHCP Options

From: Katia Linker <[email-masked]>
Date: Tue, 21 May 2002 18:12:35 +0200

Hi !
If I understand correct, DHCP server must send a message
which has an option field of no less than 312 bytes. And if
max DHCP message size (option code = 57) allows larger
size, the option field of larger size will be sent. Anyway,
it is impossible to send an option field of less than 312 bytes.
Please, tell me if it's right.
    Thanks in advance.

Katya Linker
Radlan Computer Communications Ltd.
Atidim Technological Park Bldg #4
Tel Aviv 61131, Israel
Tel: +972-3-7657900
Fax: +972-3-6487368
Visit us on http://www.radlan.com

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 21 May 2002 12:25:00 -0500

> Anyway,

I don't think so.   RFC2131 says the option field is variable in length, so 
presumably it could be as small as 64 bytes (the size of a bootp option 
field).