Subject: RE: [dhcwg] dhcpv6-24: compression in DNS names

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Wed, 15 May 2002 12:33:35 -0500

I'm fine with it as well. There will likely be few cases where multiple domain names appear in a single option - so the savings will be small.

- Bernie

-----Original Message-----
From: Ted Lemon [mailto:[email-masked]]
Sent: Wednesday, May 15, 2002 1:32 PM
To: Thomas Narten
Cc: [email-masked]
Subject: Re: [dhcwg] dhcpv6-24: compression in DNS names

> How about just removing the requirement to support compression. This
> will simplify implementations and doesn't appear to result in any real
> loss of functionality.

Works for me.   In the cases where we're using domain names, it's unlikely 
we'd be able to compress more than the last label anyway, so we're only 
talking about three bytes of compression (e.g., with .com).

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 15 May 2002 15:23:15 -0400

this makes sense for IPv6.
/jim

> From: Thomas Narten [mailto:[email-masked]]
> Sent: Wednesday, May 15, 2002 1:00 PM
> To: [email-masked]
> Subject: [dhcwg] dhcpv6-24: compression in DNS names
> 
> 
> [Note: the IESG is starting to review this document, and I'm getting
> questions comments on the ID].
> 
> This document specifies that DNS Names are represented in DNS
> on-the-wire formate, and compression MUST be supported. I understand
> that DHCPv4 supports this now (with recent options).
> 
> But there is also complexity associated with the compression part. In
> DHCPv4, options were limited in size (255 bytes). DHCPv6 doesn't have
> this restriction. So the need for compression is reduced.
> 
> Thomas