Subject: RE: [dhcwg] <draft-ietf-dhc-agent-subnet-selection-03.txt> - Clas sfull ?

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Thu, 10 Oct 2002 09:45:36 -0500

Longest prefix matching is only needed if the server allows overlapping subnets (such as 20.0.0.0/8 and 20.1.0/16). If the server doesn't allow this, there is no problem.
 
- Bernie

-----Original Message-----
From: Van Aken Dirk [mailto:[email-masked]]
Sent: Thursday, October 10, 2002 10:32 AM
To: 'Bernie Volz (EUD)'; 'Ted Lemon'
Cc: [email-masked]'; Dedecker Hans; Dekeyser Miek; [email-masked]'
Subject: RE: [dhcwg] <draft-ietf-dhc-agent-subnet-selection-03.txt> - Clas sfull ?

If a relay agent supplies a masked IP address only, the scenario only works fine provided the server does "longest prefix matching" on its available pools.
If the server does not start with the pool having the smallest mask, situations where VLSM (Variable Length Subnet Mask) is applied will not converge no ?

-----Original Message-----
From: Bernie Volz (EUD) [mailto:[email-masked]]
Sent: Thursday 10 October 2002 2:59
To: Van Aken Dirk; 'Ted Lemon'
Cc: [email-masked]'; Dedecker Hans; Dekeyser Miek; [email-masked]'
Subject: RE: [dhcwg] <draft-ietf-dhc-agent-subnet-selection-03.txt> - Clas sfull ?

There is no need to do this. What's the benefit? 

You'd have to configure the relay agent with more information than it currently 
needs. (While in many cases the relay is probably a router and has this 
information, why is it needed?) The server can figure out the subnet without 
the prefix because the server needs both the address and subnet mask length for 
all of the subnets (at least those it will be allocating addresses on). 

Also, what happens if the server and relay agent disagree on the subnet mask 
length? Suppose you wrongly configured the relay to send 20.0.0.0/23 and the 
server is configured with 20.0.0.0/24? 

- Bernie 

-----Original Message----- 
From: Van Aken Dirk [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Thursday, October 10, 2002 3:16 AM 
To: 'Ted Lemon' 
Cc: [email-masked]'; Dedecker Hans; Dekeyser Miek; 
[email-masked]' 
Subject: RE: [dhcwg] <draft-ietf-dhc-agent-subnet-selection-03.txt> - 
Clas sfull ? 

Hi Ted, 

As you as you mentioned in the reply, it is indeed exactly the same problem 
as with giaddr. 

But why can this problem not be solved ? After all, the overloading of 
giaddr (communication with the relay agent and address pool selection) was 
defined 17 years ago (RFC951-1985). All networks were classfull at that time 
but today almost all IP systems can operate in a classless environment.. 

As it is a totally new DHCP Relay Information Sub-Option, one can easily 
define two fields: IP address and IP mask or IP address and Prefix length. 

One could eventually reuse the syntax of <draft-ietf-dhc-csr-07.txt> - The 
Classless Static Route Option for DHCPv4. 

Best regards - Dirk 

-----Original Message----- 
From: Ted Lemon [ mailto:[email-masked] <mailto:[email-masked]> ] 
Sent: Tuesday 8 October 2002 11:32 
To: Van Aken Dirk 
Cc: [email-masked]'; Dedecker Hans; Dekeyser Miek 
Subject: Re: [dhcwg] <draft-ietf-dhc-agent-subnet-selection-03.txt> - 
Classfull ? 

> I wonder though how the DHCP server can derive a subnet from a single 
> quantity being an IP address. e.g. 20.0.0.0 can be an alias for 
> 20.0.0.0/8 
> or 20.0.0.0/29. 
> So my guess is that the only way the DHCP server can derive the subnet 
> form 
> is based on the leading bits of the address being either class A, B or 
> C. 

The DHCP server is configured with a list of subnets.   It has to be, 
to make address assignment decisions. 

This is exactly the same problem that you have if you use giaddr for 
subnet selection. 

_______________________________________________ 
dhcwg mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/dhcwg <https://www1.ietf.org/mailman/listinfo/dhcwg>  
_______________________________________________ 
dhcwg mailing list 
[email-masked] 
https://www1.ietf.org/mailman/listinfo/dhcwg <https://www1.ietf.org/mailman/listinfo/dhcwg>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 10 Oct 2002 10:23:35 -0500

> Longest prefix matching is only needed if the server allows 
> overlapping subnets (such as 20.0.0.0/8 and 20.1.0/16). If the server 
> doesn't allow this, there is no problem.

The ISC DHCP server handles subnet overlaps just fine without the relay 
agent sending a subnet mask.   Bernie's point about which configuration 
you trust is the correct rebuttal to this whole line of reasoning, I 
think.   It would actually be harmful to send a subnet mask in the 
subnet selection option.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Thu, 10 Oct 2002 11:39:21 -0400

As I remember, Ted's last sentence reflects the consensus of the dhc WG at 
the time the subnet selection option was reviewed: the subnet mask is 
information that the server must be configured with (regardless of whether 
the subnet selection option is used); sending the subnet mask from the 
relay agent would be redundant and represent an opportunity for the 
information from the relay agent and the server to be out of sync.  Thus, 
the subnet selection option does not include a subnet mask...

- Ralph

At 10:23 AM 10/10/2002 -0500, Ted Lemon wrote:
>>Longest prefix matching is only needed if the server allows overlapping 
>>subnets (such as 20.0.0.0/8 and 20.1.0/16). If the server doesn't allow 
>>this, there is no problem.
>
>think.   It would actually be harmful to send a subnet mask in the subnet 
>selection option.
>

---

From: Kim Kinnear <[email-masked]>
Date: Thu, 10 Oct 2002 15:31:57 -0400

At 11:39 AM 10/10/2002, Ralph Droms wrote:
>As I remember, Ted's last sentence reflects the consensus of the dhc WG at the time the subnet selection option was reviewed: the subnet mask is information that the server must be configured with (regardless of whether the subnet selection option is used); sending the subnet mask from the relay agent would be redundant and represent an opportunity for the information from the relay agent and the server to be out of sync.  Thus, the subnet selection option does not include a subnet mask...

        I also remember it exactly this way, and agree wholeheartedly
        with Ted!

        Cheers -- Kim

>>The ISC DHCP server handles subnet overlaps just fine without the relay agent sending a subnet mask.   Bernie's point about which configuration you trust is the correct rebuttal to this whole line of reasoning, I think.   It would actually be harmful to send a subnet mask in the subnet selection option.
>>