Subject: RE: [dhcwg] Conflicting information regarding DHCP options 82 and 83.

From: John Schnizlein <[email-masked]>
Date: Wed, 09 Oct 2002 13:31:16 -0400

And DHCP option 83 should also be part of this IANA cleanup.
I recall a remark in an IETF plenary that IANA was still planning
to clean up the assignments, and that DHCP options was recognized
as needing work.

Thanks for the historical explanation of the (erroneous) option 84.

John

At 01:10 PM 10/9/2002, Woundy, Richard wrote:
>IANA seems to be a little more confused than we realize.
>
>Looking at http://www.iana.org/assignments/bootp-dhcp-parameters, I see:
>
>   82      Agent Circuit ID         N    Agent Circuit ID
>   83      Agent Remote ID          N    Agent Remote ID
>   84      Agent Subnet Mask        N    Agent Subnet Mask
>
>And then later on the same page:
>
>DHCP Agent Sub-Option Codes  per [RFC3046]
>
>Code    Sub-Option Description                 Reference
>-----   -----------------------                ---------
>   1    Agent Circuit ID Sub-option            [RFC3046]
>   2    Agent Remote ID Sub-option             [RFC3046]
>   3    Sub-option 3 is reserved and should      [Droms]
>        not be assigned at this time;
>        proprietary and incompatible usages
>        of this sub-option value have been
>        seen limited deployment.
>   4    DOCSIS Device Class Suboption          [RFC3256]
>
>It appears that IANA assigned three DHCP option codes (82-84) when only one
>DHCP option code was assigned in RFC 3046 (82).
>
>Note that an earlier draft of RFC 3046 had a third suboption, "Agent Subnet
>Mask Sub-option", that was removed prior to RFC publication -- this is why
>suboption 3 is "reserved". That's why I think option 84 should be part of
>this IANA cleanup.
>
>-- Rich

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Wed, 09 Oct 2002 16:29:17 -0400

At one point, I did some work on an option code cleanup.  I still have the 
basic information if anyone is interested in picking it up and finishing 
the review, or I can move it forward.  Options 83 and 84 are on the list as 
"returnable".

- Ralph