Subject: [dhcwg] How should a DHCPv6 server respond to retransmitted packets

From: Raymond Jayaraj <[email-masked]>
Date: Fri, 25 Oct 2002 10:26:33 +0800 (CST)

Hi all,

How should a server respond to retransmitted packets
received after a
REPLY packet is sent, e.g.:

DHC6CLIENT      DHC6SERVER      INFOSERVER
|               |               (e.g. LDAP)
|               |               |
|1)INFO-REQ     |               |
|>>>            |               |
|   >>>         |               |
|      >>>      |               |
|         >>>   |               |
|            >>>|2)processing/retrieve info
|3)INFO-REQ     |>>>>>>>>>>>>>>>|
|>>>            |<<<<<<<<<<<<<<<|
|   >>>      <<<|               |
|      >>><<<   |               |
|      <<<>>>   |               |
|   <<<      >>>|               |
|<<< 4)REPLY    |5)???          |

What should (5) be? Should the server:

a) drop (3) and subsequent duplicates (base on
transaction id).

b) reprocess the request and retransmit the reply,
i.e. do (2)&(4)
   again.

c) retransmit the reply, i.e. do (4) again.

d) do any of the above (implementation specific).

No indication for the above could be found in the
draft. I suspect
it should be a) or d), but it'd be nice to know for
sure.

------------------------------------------------------------------------
Raymond J. Jayabal                 | ICR, A-STAR
[email-masked]         | 20 Science Park
Rd #02-34/37
Tel: +65 6870 9330                 | Singapore 117674
------------------------------------------------------------------------

__________________________________________________
Do You Yahoo!?
Great flight deals, travel info and prizes!
http://sg.travel.yahoo.com
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ralph Droms <[email-masked]>
Date: Fri, 25 Oct 2002 08:41:00 -0400

In the case of Information-request, the answer is (b) or (c), depending on 
the implementation.  The responses to retransmitted Informat-request 
messages are likely to be identical, so the use of a response cache 
shouldn't affect the results of the message exchange.

- Ralph

---

From: "Raymond J. Jayabal" <[email-masked]>
Date: Fri, 25 Oct 2002 21:07:20 +0800

> In the case of Information-request, the answer is (b) or (c),
> depending on the implementation

What about the other client messages, e.g. RENEW, etc? Is it safe to
apply (b) or (c) too?

----- Original Message -----
From: "Ralph Droms" <[email-masked]>
To: "Raymond Jayaraj" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, October 25, 2002 8:41 PM
Subject: Re: [dhcwg] How should a DHCPv6 server respond to retransmitted
packets

---

From: "Raymond J. Jayabal" <[email-masked]>
Date: Sat, 26 Oct 2002 02:28:29 +0800

Hi,

Stumbled upon what may or may not be a problem, given that (b) is an
acceptable alternative to (c), as follows.

                              *  *  *

Whether (b) or (c), the client will receive 2 or more REPLY packets.

As the client will leave its 'waiting-for-REPLY' state when it receives
REPLY #1, I assume it will drop REPLY #2 and subsequent REPLY packets
and configure itself based on REPLY #1.

Further assume that the server (or the network it serves, or the
information services it rely on to satisfy client requests) is in
State-1 when request #1 arrives, and State-2 when request #2 arrives.

If (b) is allowed, then the REPLY packets will differ in content. Since
REPLY #2 is last to leave the server, it would have committed to memory
that it sent State-2 data to the client, whereas the client would have
configured itself with State-1 data. This doesn't seem to be a good
situation in the general sense, even if it happens for a short while.

In case of (c), both client and server will always be synchronised.
When State-2 happens, server will know exactly which clients need
updating.

Does this disqualify (b) as an alternative? Or is it still an acceptable
implementation?

- Ray

----- Original Message -----
From: "Ralph Droms" <[email-masked]>
To: "Raymond Jayaraj" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, October 25, 2002 8:41 PM
Subject: Re: [dhcwg] How should a DHCPv6 server respond to retransmitted
packets