Subject: RE: [dhcwg] Comments on draft-chowdhury-dhc-bcmcv4-option

From: "Kuntal Chowdhury" <[email-masked]>
Date: Tue, 3 Aug 2004 12:29:21 -0400

Ted,

Thanks for your comment/suggestion. We added the informative diagram to at
least give the reader some idea what B-cast and M-cast service typically
include. If you think a simplified diagram will suffice we can do that in
the next revision.

FQDN is used to give the operator flexibility in deploying the service. Some
operators would like to use DNS infrastructure to distribute the most
appropriate controller for a broadcast program.

Regards,
Kuntal

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of Ted Lemon
>Sent: Tuesday, August 03, 2004 10:21 AM
>To: [email-masked]
>Subject: [dhcwg] Comments on draft-chowdhury-dhc-bcmcv4-option
>
>
>Reading over this draft, a couple of things jump out at me.   
>The first 
>is that all the text describing how BCMCS works should 
>probably be left 
>out.   I would put in a one-paragraph description of what 
>BCMCS does.   
>Putting in a big diagram and a detailed description doesn't help the 
>implementor, and the description didn't actually tell me much about 
>what the protocol does.
>
>The other things is, do you really need to send FQDNs?   They 
>take up a 
>lot of space in a DHCP packet.   I would rather see you send IPv4 
>address/port number tuples if you want to be able to specify 
>the port.  
>  This would also eliminate the need to consume two option 
>codes, which 
>in DHCPv4 is theoretically an issue.
>
>
>_______________________________________________
>dhcwg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/dhcwg
>
>

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 3 Aug 2004 09:52:22 -0700

> appropriate controller for a broadcast program.

If you fill up the DHCP packet, the operator loses that flexibility.   
An easy way to provide the same flexibility is to do the lookup on the 
DHCP server.