Subject: [Dhcpv6bis] Proofread RFC3315bis after #142

From: Marcin Siodelski <[email-masked]>
Date: Thu, 17 Mar 2016 14:55:33 +0100

Hi,

I finally managed to combine sections 17, 18, 19 of the original
RFC3315, into a single section, now called "DHCP Configuration
Exchanges" with subsections: "Client Behavior" and "Server Behavior". It
turned out to be tedious and definitely not a 'copy-paste' type of work.
Because of that, I am asking if someone could proofread the new text
which is available on the 'ticket142_rebase' branch of our git repository:

$ git checkout ticket142_rebase

For your convenience I also attached the txt version of the updated
document.

I am not sure what we can do before the submission cutoff. Basically, we
can just defer the merge of my changes until it has sufficient number of
proofreads, which likely means that we will not include it in the
version we publish for IETF Buenos Aires. Or, we can merge it as is, and
fix issues (hopefully minor) later. The latter has the advantage of
minimizing the risk of merge conflicts because the changes I made are
quite heavy. It also has obvious disadvantages...

Thanks,
Marcin

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 17 Mar 2016 14:26:03 +0000

Hi Marcin:

Thanks for working on this (and yes, I suspected it was much more than just copy/paste!). It does seem that the bulk of the changes are the new section 17 replacing 17, 18, and 19 in the published 03 (using the tools.ietf.org diffs utility shows most other differences are just because of the section renumbering - and a few other changes made since 03 was published). This is a lot of text (pages 41-72).

I'll try to review, but it probably is a stretch to get this in before the 3/21 deadline, and I agree it best to wait until after IETF-95 to publish this version. But, we can see what happens over the next few days (I will work out with Tomek as to who will post, as I think Tomek may be traveling shortly - with likely limited access to Internet).

- Bernie

-----Original Message-----
From: Dhcpv6bis [mailto:[email-masked]] On Behalf Of Marcin Siodelski
Sent: Thursday, March 17, 2016 9:56 AM
To: [email-masked]
Subject: [Dhcpv6bis] Proofread RFC3315bis after #142

Hi,

I finally managed to combine sections 17, 18, 19 of the original RFC3315, into a single section, now called "DHCP Configuration Exchanges" with subsections: "Client Behavior" and "Server Behavior". It turned out to be tedious and definitely not a 'copy-paste' type of work.
Because of that, I am asking if someone could proofread the new text which is available on the 'ticket142_rebase' branch of our git repository:

For your convenience I also attached the txt version of the updated document.

I am not sure what we can do before the submission cutoff. Basically, we can just defer the merge of my changes until it has sufficient number of proofreads, which likely means that we will not include it in the version we publish for IETF Buenos Aires. Or, we can merge it as is, and fix issues (hopefully minor) later. The latter has the advantage of minimizing the risk of merge conflicts because the changes I made are quite heavy. It also has obvious disadvantages...

Thanks,
Marcin