Subject: [Dhcpv6bis] Authors on draft-ietf-dhc-rfc3315bis

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 30 Aug 2017 12:34:00 +0000

Hi:

Suresh (cc’d) indicated that we should look to reduce the authors at the “top” of the document as the IESG is pushing for limiting this to 5. We currently have 8 authors.

While it is only ONE measure of contribution, the following link provides the GITHUB commits by person:

https://github.com/dhcwg/rfc3315bis/graphs/contributors

Other contributions which this does not show are involvement in discussions (either in our jitsu or face-to-face (@ IETF) meetings). And, in reviewing and editing some of the text (such as in google docs).

In the co-authors call today (Ted, Tim, and I), we discussed this. Ted feels it is worth pushing back on this as everyone has contributed – it isn’t like we had “fake” authors that just pushed to have their name on the document.

Certainly, there are a few people that have contributed less over time, but that doesn’t diminish their earlier contributions.

So, what should we do?

  1.  If there’s anyone on the authors list that is OK with being removed from the initial list of authors (you’d still be in the authors list in the end), let me know.
  2.  If anyone has any thoughts on this topic, please comment.

  *   Bernie

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Aug 2017 09:13:22 -0400

As you know, I think that this isn't appropriate.   Of course, I also happen to be the person with the lowest number of commits, but I believe I have offered some fairly substantial contribution, particularly early in the process.   I've done more commenting than direct editing; I believe that is a relevant contribution.   I don't know who we'd vote off the island, and that's really what we're being asked to do.   This is not a situation where the list of authors has been padded with do-nothing authors: rather, it's a situation where there was a ton of work to do, and a lot of people contributed meaningfully.

I would respectfully ask that Suresh push back on this request in this case.   I realize that it's stylistically bad, but this is an unusual document—it's a merge of several previous documents, and that merge was a lot of work, more so than is reflected by the current page count.

> On Aug 30, 2017, at 8:34 AM, Bernie Volz (volz) <[email-masked]> wrote:
> 
> Hi:
>  
> https://github.com/dhcwg/rfc3315bis/graphs/contributors <https://github.com/dhcwg/rfc3315bis/graphs/contributors>
>  
> If there’s anyone on the authors list that is OK with being removed from the initial list of authors (you’d still be in the authors list in the end), let me know.
> If anyone has any thoughts on this topic, please comment.
>  
> Bernie
> _______________________________________________
> Dhcpv6bis mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/dhcpv6bis <https://www.ietf.org/mailman/listinfo/dhcpv6bis>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 30 Aug 2017 21:45:36 -0400

Please remove me as an author; I am happy to remain in the
Contributors/Acknowledgements.

--
]               Never
--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 30 Aug 2017 21:47:50 -0400

Ted Lemon <[email-masked]> wrote:
    > merge of several previous documents, and that merge was a lot of work, more
    > so than is reflected by the current page count.

I would propose that nobody who was an author of any of the merged documents
should be left out (unless they were not involved at all).

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 31 Aug 2017 02:15:54 +0000

Hi Ted,
  And I do plan to progress with the author list as is, but I wanted to give Bernie a heads up in case the draft encounters resistance in the IESG. Some of the IESG members are working on a statement concerning number of authors and if it does get formalized before this document hits the IESG, it is going to make my job much much harder. I will keep you all updated on how things go.

Thanks
Suresh

On Aug 30, 2017, at 9:13 AM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:

On Aug 30, 2017, at 8:34 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:

Hi:

So, what should we do?

  *   Bernie

_______________________________________________
Dhcpv6bis mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcpv6bis

---

From: Ted Lemon <[email-masked]>
Date: Wed, 30 Aug 2017 22:42:05 -0400

Okay, thanks!

On Wed, Aug 30, 2017 at 10:15 PM, Suresh Krishnan <[email-masked]> wrote:

> Hi Ted,
>   And I do plan to progress with the author list as is, but I wanted to
> give Bernie a heads up in case the draft encounters resistance in the IESG.
> Some of the IESG members are working on a statement concerning number of
> authors and if it does get formalized before this document hits the IESG,
> it is going to make my job much much harder. I will keep you all updated on
> how things go.
>
> Thanks
> Suresh
>
> On Aug 30, 2017, at 9:13 AM, Ted Lemon <[email-masked]> wrote:
>
> As you know, I think that this isn't appropriate.   Of course, I also
> happen to be the person with the lowest number of commits, but I believe I
> have offered some fairly substantial contribution, particularly early in
> the process.   I've done more commenting than direct editing; I believe
> that is a relevant contribution.   I don't know who we'd vote off the
> island, and that's really what we're being asked to do.   This is not a
> situation where the list of authors has been padded with do-nothing
> authors: rather, it's a situation where there was a ton of work to do, and
> a lot of people contributed meaningfully.
>
> I would respectfully ask that Suresh push back on this request in this
> case.   I realize that it's stylistically bad, but this is an unusual
> document—it's a merge of several previous documents, and that merge was a
> lot of work, more so than is reflected by the current page count.
>
> Suresh (cc’d) indicated that we should look to reduce the authors at the
> “top” of the document as the IESG is pushing for limiting this to 5. We
> currently have 8 authors.
>
> Other contributions which this does not show are involvement in
> discussions (either in our jitsu or face-to-face (@ IETF) meetings). And,
> in reviewing and editing some of the text (such as in google docs).
>
> In the co-authors call today (Ted, Tim, and I), we discussed this. Ted
> feels it is worth pushing back on this as everyone has contributed – it
> isn’t like we had “fake” authors that just pushed to have their name on the
> document.
>
> Certainly, there are a few people that have contributed less over time,
> but that doesn’t diminish their earlier contributions.
>
> So, what should we do?
>
>
>    1. If there’s anyone on the authors list that is OK with being removed
>    from the initial list of authors (you’d still be in the authors list in the
>    end), let me know.
>    - Bernie
> [email-masked]

---

From: Ralph Droms <[email-masked]>
Date: Thu, 31 Aug 2017 07:01:01 -0400

Suresh - will a statement of the IESG about authors go out for public review and consensus?  I would be concerned about any statement that places an arbitrary limit on the number of authors without a method for considering situations like rfc3315bis, where there is (presumably) good motivation and WG consensus for the current author list.

- Ralph

> On Aug 30, 2017, at 10:15 PM, Suresh Krishnan <[email-masked]> wrote:
> 
> Hi Ted,