Subject: Authentication Draft - Outstanding issues List

From: "William A. Arbaugh" <[email-masked]>
Date: Thu, 10 Dec 1998 12:34:02 -0500 (EST)

I'm listing the issues that people have raised about the current draft.
My plan is to address each one individually over the next few months as
time permits.  If I have missed something, or you would like to add
something please let me know and I will add it to the list.

1. Client identification - how
	(me)

2. Over specified use/storage of shared key
	(Peter Ford)

3. Kiosk problem, i.e. Server id first
	(Peter Ford)

4. Demonstrate support for PKI
	(Baiju Patel)

5. Interaction with Relay Agent
	(Mike Carney)

6. Global replay counter
	(Olafur)

7. Leverage EAP- if possible
	(Several)

-----------------------------------------------------------------------
Bill Arbaugh			   
email:  [email-masked] 
web  :  http://www.cis.upenn.edu/~waa
-----------------------------------------------------------------------

---

From: Kim Kinnear <[email-masked]>
Date: Thu, 10 Dec 1998 14:22:10 -0500 (EST)

Bill,

Actually, we (Mark Stapp and I ) had two issues that 
we were unable to fit into the Orlando meeting:

8. There seems to be no mention of the following DHCP
messages:

	DHCPNAK
	DHCPDECLINE
	DHCPRELEASE

It seems to us that these need to be explictly mentioned 
and that authentication approach/action taken for each one
specified.

9. A small issue is the use of the counter used to avoid
replay attacks.  Its use (and when it is incremented) is
well specified for the server, but on the client side
the specific times it should be incremented could perhaps
be better spelled out.

Cheers -- Kim Kinnear and Mark Stapp

---

From: "William A. Arbaugh" <[email-masked]>
Date: Thu, 10 Dec 1998 14:24:27 -0500 (EST)

Kim/Mark,

Thanks.  I've added them to the list.

Bill

-----------------------------------------------------------------------
Bill Arbaugh			   
email:  [email-masked] 
-----------------------------------------------------------------------