Subject: [dhcwg] Generic DHCPv6 Message

From: "Paul Tan" <[email-masked]>
Date: Fri, 5 Apr 2002 17:30:45 +0800

DHCPv6 - server-address and unicastHi all,

I am currently implementing DHCPv6 (draft 23) and have some questions regarding the DHCPv6 Relay Message.

Question: Is it possible to have a generic DHCPv6 message structure for all (even the relayed messages) messages ? I must apologise if this issue has been rised previously.

The idea is to have a common DHCP message for all message exchange. Since both the link-address and client-return-address are IPv6 addresses, we can carried these addresses as Options (e.g Address Option) in the DHCPv6 message. These options are placed in front of the rest of the options (e.g Client/Server Message Options) so that servers can discard any messages from the Relay if the servers decide not to reply based on the two addresses.

The advantage is a preferred generic message structure for all DHCPv6 messages. This enables the processing of DHCPv6 message to be identical for both the server and relay (at least the encoding/decoding mechanism). Or is there any issues that I have overlook.

I must apologize if my proposal sounds irrelevant. Please comment.

Thank you,
Paul

---

From: "Bernie Volz (EUD)" <[email-masked]>
Date: Fri, 5 Apr 2002 16:04:44 -0600

Paul:
 
We certainly could have placed these into options. But, these two messages really do need some additional special processing so I'm not sure there would be much of an advantage.
 
- Bernie

-----Original Message-----
From: Paul Tan [mailto:[email-masked]]
Sent: Friday, April 05, 2002 4:31 AM
To: [email-masked]
Subject: [dhcwg] Generic DHCPv6 Message

Hi all,

 

 
Thank you,
Paul