Subject: RE: [dhcwg] Deafult Router information for DHCPv6

From: "Bound, Jim" <[email-masked]>
Date: Fri, 21 May 2004 23:07:47 -0400

Christian,

I have been down this patha and I cannot see a good case for this to be
in DHCPv6.  I concur with Eric and Bernie.  The entire conversion of
routes on a link should come from ND RA.  Once the edge link routers
have the prefixes it is automatic for the hosts.  I can see any good
reason to add state to the IPv6 network architecture for route
propogation?  

thanks
/jim 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Cristian Cadar
> Sent: Friday, May 21, 2004 4:50 AM
> To: [email-masked]
> Subject: [dhcwg] Deafult Router information for DHCPv6
> 
> 
> Hi,
> 
> I know that this issue was already discussed on the list but 
> I ran into a problem which I would like to clarify here. 
> Seemingly the only way for getting the default router 
> information is to make use of the RA. So when I'm using 
> dhcpv6 and want get the default router information is it a 
> MUST to use the RA for this pourpose? I could not find any 
> statement in any of the RFC/drafts saying that.
> I mean for the time being I cannot see any other possibility.
> There might be scenarios where the use of RA is not desired 
> and prefering to have a dhcpv6 option carrying this 
> information along. If the use of RA is not a MUST I think we 
> need a new option.
> 
> 
> Thanks,
> Cristian
> 
> 
> 
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Tim Chown <[email-masked]>
Date: Sat, 22 May 2004 11:51:24 +0100

This reminds me, I don't think the IPv6 nodes requirements draft has yet
gone final, since draft-ietf-ipv6-node-requirements-08 still exists on the
IETF I-D area.

Should we not update this before it goes final with the wording that has
been agreed for the M and O flags, and also to clarify the assertion below,
that RAs are the way to get default router and onlink prefix information?

It would be a shame to not convey this consensus in the nodes document.
In the draft, that's at least section 4.5.2 and 4.5.5 that probably need a 
tweak.

Tim