Subject: [dhcwg] Deafult Router information for DHCPv6

From: Cristian Cadar <[email-masked]>
Date: Fri, 21 May 2004 10:49:33 +0200

Hi,

I know that this issue was already discussed on the list but I ran into a problem
which I would like to clarify here. 
Seemingly the only way for getting the default router information is to make use of 
the RA. So when I'm using dhcpv6 and want get the default router information 
is it a MUST to use the RA for this pourpose? I could not find any statement in any of the RFC/drafts saying that.
I mean for the time being I cannot see any other possibility.
There might be scenarios where the use of RA is not desired and prefering to have a dhcpv6 option
carrying this information along. If the use of RA is not a MUST I think we need a new option.

Thanks,
Cristian

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz" <[email-masked]>
Date: Fri, 21 May 2004 07:39:45 -0400

It would be far better to have *ONE* way in which this information is
configured and as RAs already provide it, use that mechanism.

If you can come up with a VERY GOOD motivation for why DHCPv6 needs to have
an option to specify routing information, feel free to write it up and
submit it (personal submission draft) and request for it to be considered a
Working Group item.

- Bernie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Cristian Cadar
> Sent: Friday, May 21, 2004 4:50 AM
> To: [email-masked]
> Subject: [dhcwg] Deafult Router information for DHCPv6
> 
> 
> 
> Hi,
> 
> I know that this issue was already discussed on the list but 
> I ran into a problem which I would like to clarify here. 
> is it a MUST to use the RA for this pourpose? I could not 
> find any statement in any of the RFC/drafts saying that. I 
> mean for the time being I cannot see any other possibility. 
> There might be scenarios where the use of RA is not desired 
> and prefering to have a dhcpv6 option carrying this 
> information along. If the use of RA is not a MUST I think we 
> need a new option.
> 
> 
> Thanks,
> Cristian
> 
> 
> 
> 
>

---

From: Cristian Cadar <[email-masked]>
Date: Fri, 21 May 2004 17:46:27 +0200

Hi Bernie

I agree completely with you having only one solution for that, I raised the
question since I had not found any statement saying that "When use statefull
dhcpv6 MUST use RA for getting the default route information" 

On the other hand having for instance an IPv6 network with 100 subnets I would not 
feel like installing and managing the radvd daemon on all of the routers in the network just  to make
the default router information available for the clients, instead I'd rather configure it through
a statefull dhcpv6 server for all clients of the network. 

Cristian

-- 
________________________________________________________
| Cristian Cadar                   [email-masked]
| Network Laboratories Heidelberg  NEC Europe Ltd.
| Kurfuerstenanlage 36             D 69115 Heidelberg
| Tel. (+49) 6221 90511-21         Fax: (+49) 6221 90511-55
| URL:  http://www.netlab.nec.de/heidelberg/index.html
| ________________________________________________________

---

From: "Bernie Volz" <[email-masked]>
Date: Fri, 21 May 2004 12:37:09 -0400

There is no statement in RFC3315 because there doesn't need to be one. See
the IPv6 specifications (such as RFC 2462, 2461) as these cover the IPv6
requirements.

I also don't understand your "100 subnets [perfixes or links?]" situation
... You've got to configure the routers anyway, so they already have all of
the information! (Though they could use DHCPv6 & prefix delegation!!)

- Bernie

> Sent: Friday, May 21, 2004 11:46 AM
> To: [email-masked]
> Subject: Re: [dhcwg] Deafult Router information for DHCPv6
> 
> 
> Hi Bernie
> 
> I agree completely with you having only one solution for 
> that, I raised the question since I had not found any 
> statement saying that "When use statefull dhcpv6 MUST use RA 
> for getting the default route information" 
> 
> feel like installing and managing the radvd daemon on all of 
> the routers in the network just  to make the default router 
> information available for the clients, instead I'd rather 
> configure it through a statefull dhcpv6 server for all 
> clients of the network. 
> 
> Cristian
> 
> 
> > If you can come up with a VERY GOOD motivation for why 
> DHCPv6 needs to 
> > have an option to specify routing information, feel free to 
> write it 
> > up and submit it (personal submission draft) and request 
> for it to be 
> > considered a Working Group item.
> > 
> > - Bernie
> >

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 21 May 2004 10:27:30 -0700 (PDT)

> On the other hand having for instance an IPv6 network with 100 subnets I
> would not  feel like installing and managing the radvd daemon on all of the
> routers in the network just  to make the default router information
> available for the clients, instead I'd rather configure it through a
> statefull dhcpv6 server for all clients of the network. 

But the router advertisements are needed to provide the on-link prefixes
to the hosts in addition to the default router. And that isn't the end
of the list...

My point is that your argument above is really that all information carried in 
router advertisement messages (including future extensions?) also needs to be
available as DHCP options.

I certainly don't see a strong enough case for that level of duplication.

  Erik