Subject: RE: [dhcwg] Enabling ipv6 forwarding with dhcpv6

From: "Bound, Jim" <[email-masked]>
Date: Tue, 25 May 2004 12:11:39 -0400

Hi Christian,

IPv6 is very clear about Host vs Router.  An interface cannot be both.
So a router interface would not be using a DHCPv6 client is my guess. I
think giving hints to the Host interface of a client that has a router
interface state too is not a good idea.  A UNIX router interface will
get all it needs from being a router.  We had to do this to support
MIPv6 HA on UNIX where I work and the trick is to get all the OSPF,
IS-IS, RIPng, BGP et al updates via routing daemon for that interface.

Does this answer help?

Good question.

/jim 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Cristian Cadar
> Sent: Monday, May 24, 2004 5:30 AM
> To: [email-masked]
> Subject: [dhcwg] Enabling ipv6 forwarding with dhcpv6
> 
> Hi ,
> 
> Since there might be clients configured by dhcpv6 with 
> routing capabilities in the network I'm missing the feature 
> of enabling the ipv6 forwarding in dhcpv6. As far as I know 
> the RA does not provide this feature. On a dual-stack UNIX 
> machine there are two different flags to be set for enabling 
> ip forwarding, one for ipv4 and the other for ipv6.
> Is there any way for doing it with dhcp or RA ? I could not find any.
> 
> TNX
> Cristian
> 
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/dhcwg
> 
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Cristian Cadar <[email-masked]>
Date: Thu, 27 May 2004 13:18:31 +0200

Hi Jim,

I think since the use of the RA daemon on ipv6 routers is "almost" a must and it comes together
with enabling the ipv6 forwarding the problem is somehow solved.  
I might be wrong....

Cristian

-- 
________________________________________________________
| Cristian Cadar                   [email-masked]
| Network Laboratories Heidelberg  NEC Europe Ltd.
| Kurfuerstenanlage 36             D 69115 Heidelberg
| Tel. (+49) 6221 90511-21         Fax: (+49) 6221 90511-55
| URL:  http://www.netlab.nec.de/heidelberg/index.html
| ________________________________________________________