Subject: RE: [dhcwg] RE: purpose of m/o bit

From: "Bound, Jim" <[email-masked]>
Date: Sat, 4 Jun 2005 01:30:13 -0400

But it is possible to change the meaning of A=0 to mean use dhc if you
have it.

Also multiple prefixes can be provided. 

L and A are orthogonal. If you set L and not A all that was stated is
use these for link knowlege but not for autoconfigure.

/jim 

> -----Original Message-----
> From: Erik Nordmark [mailto:[email-masked]] 
> Sent: Friday, June 03, 2005 1:22 PM
> To: [email-masked]
> Cc: Bound, Jim; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [dhcwg] RE: purpose of m/o bit
> 
> [email-masked] wrote:
> 
> > Yes, agreed. Going further, maybe A=0 could signal this?
> 
> But the A flag is per prefix, not per RA.
> And so far we haven't assigned any semantics to a flag in the prefix 
> being zero; the semantics are associated with the flags being 
> set to one.
> That model seems to be useful when extending the flags in the 
> prefixes 
> since it provide orthogonal flags. For instance, we added the 
> 'R' flag 
> and with that we can have Prefix option which set only the R flag (as 
> well as the R flag in combination with one of A and L) and 
> the addrconf 
> and on-link pieces don't get confused by a prefix with R=1, A=0, L=0; 
> those functions just ignore prefixes that have A=0 and L=0, 
> respectively.
> 
>    Erik
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Sat, 4 Jun 2005 11:14:29 +0200

On 4-jun-2005, at 7:30, Bound, Jim wrote:

> But it is possible to change the meaning of A=0 to mean use dhc

Sure.

> if you have it.

But not that part. If the autonomous address configuration flag is  
zero for all prefixes in an RA, a host not implementing DHCPv6 is  
dead in the water.

(Some implemtations, such as KAME, don't properly fall back on IPv4  
when they don't have any IPv6 addresses but do have an IPv6 default  
route because there are RAs.)

What exactly is the problem we're trying to solve here?

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 06 Jun 2005 10:41:59 -0700

Bound, Jim wrote:
> But it is possible to change the meaning of A=0 to mean use dhc if you have
> it.
> 
> L and A are orthogonal. If you set L and not A all that was stated is use
> these for link knowlege but not for autoconfigure.

But the fact that the A flag appears in every Prefix information option 
makes defining the semantics of A=0 as "use DHC" quite tricky.

Suppose the RA contains 2 PIOs:
	prefix1, A=1, O=1, R=0
	prefix2. A=0, O=0, R=1
(The R flag was defined in the Mobile IPv6 RFC)

Should this mean "use DHC" or not?

What if some future RFC introduces an additional flag in the Prefix 
information option (as Mobile IPv6 just did); what's the semantics of
	A=0, O=0, R=0, New flag=1
in terms of DHC? Does the semantics change whether or not there are 
other prefixes included in the RA.

Thus defining the semantics of the M/O bits in the RA is trivial 
compared to trying to overload A=0!

    Erik