Subject: [dhcwg] RE: DHCP options 128-135 in use -- please place on "Tentatively Assigned" list re. RFC 3942

From: "IANA" <[email-masked]>
Date: Tue, 21 Jun 2005 08:07:18 -0700

Peter,
 
We apologize for the delay in responding.
The below options have been marked as tentatively assigned.

See: http://www.iana.org/assignments/bootp-dhcp-parameters

According to RFC 3942 they will need to be documented.  See the 
IANA Considerations section 6, part 2:

2. receive notices from vendors that have been using one or more of
      the options in the 128-223 range that they are using the option
      and are willing to document that usage.  IANA will list these
      options as "Tentatively Assigned".

Also section 4, part 4 of the document:

   4. For those options in the "Tentatively Assigned" state, vendors
      have 18 months following this RFC's publication date to submit an
      Internet-Draft documenting the option.  The documented usage MUST
      be consistent with the existing usage.  When the option usage is
      published as an RFC, IANA will move the option to the "Assigned"
      state.

      If no Internet-Draft is published within the 18 months or should
      one of these Internet-Drafts expire after the 18 months, IANA will
      move the option to the "Unassigned" state, and the option may then
      be assigned to any new publicly defined options in accordance with
      [RFC2939].

Thank you, 

Michelle Cotton
IANA

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, May 19, 2005 11:10 AM
To: [email-masked]; [email-masked]
Subject: DHCP options 128-135 in use -- please place on "Tentatively
Assigned" list re. RFC 3942

[ sorry, resend to add a subject for tracking...  please ignore previous ] 

Hello DHC WG and IANA, 

Regarding RFC 3942, this is to document our (Mitel Networks) use of DHCP
options 128-135 in the current vendor-specific range, and to request these
be placed on the "Tentatively Assigned"  list. 

Our usage is as follows.  All are related to configuration of IP Phones (and
similar devices) in a VoIP network. 

Option    Usage 
======    ===== 
128       TFPT Server IP address (for IP Phone - specific sw load) 
129       Call Server IP address 
130       Discrimination string (to identify vendor) 
131       Remote statistics server IP address 
132       802.1P VLAN ID 
133       802.1Q L2 Priority 
134       Diffserv Code Point 
135       HTTP Proxy for phone-specific applications 

Please confirm that these will go on the Tentatively Assigned list (or
perhaps some already are). 

Also, it is not completely clear whether an I-D documenting this same
information is or is not required.  We are currently looking at getting away
from this scheme, in favor of better defined / standardized vendor-specific
methods.  Given this, and the high likelihood of clashes over the same
options wanted for use by others, we do not currently intend to pursue
standardization of these options.  Is an I-D required to complete the
process of putting the options on the Tentatively Assigned list?   

While we're on it, is there already, or will there be, a definitive list of
all the options in Tentatively Assigned state?   

Regards, 
Peter Blatherwick 
Sr. Solutions Architect, 
Mitel Networks 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Tue, 21 Jun 2005 13:30:30 -0400

Peter:
 
I think the next step for you regarding the I-D is to request that it be
considered a DHC WG item. Though I think Ralph may already have
indicated that these "RFC 3942" related drafts would be. But, I think
you should make a formal request to the WG for this.
 
I still have to finalize the tentatively assigned list - I did
distribute a preliminary list to IANA (Michelle) and the DHC WG chairs
two weeks ago.
 
I've attached that list in PDF format, so if any DHC WG members have
comments on the list, please let me know ASAP.
 
- Bernie

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
	Sent: Tuesday, June 21, 2005 1:04 PM
	To: IANA; Bernie Volz (volz)
	Cc: [email-masked]
	Subject: [dhcwg] RE: DHCP options 128-135 in use -- please place
on "Tentatively Assigned" list re. RFC 3942

	Hello Michelle / IANA folks, Bernie,   
	
	First, thanks for the confirmation.  Much appreciated.   
	
	Re the I-D, I have already submitted this, as
http://www.ietf.org/internet-drafts/draft-blatherwick-dhc-mitel-site-opt
ions-usage-00.txt     
	
	Is there another step needed at this point in time?   I note
that it did not get announced to the DHC WG, as requested when sent for
posting.     
	
	BTW, we do not currently intend to try to standardize these,
merely ensure they get on the Tentatively Assigned list.  (This could
change of course.)   
	
	Regards, and thanks again, 
	Peter Blatherwick 
	Sr. Solutions Architect, 
	Mitel Networks 

	"IANA" <[email-masked]> 

21.06.05 11:07 

        To:        <[email-masked]>, <[email-masked]> 
        cc:         
        Subject:        RE: DHCP options 128-135 in use -- please place
on "Tentatively Assigned"  list re. RFC 3942

	Peter,

	
	
	2. receive notices from vendors that have been using one or more
of
	     the options in the 128-223 range that they are using the
option
	     and are willing to document that usage.  IANA will list
these
	     options as "Tentatively Assigned".

	  4. For those options in the "Tentatively Assigned" state,
vendors
	     have 18 months following this RFC's publication date to
submit an
	     Internet-Draft documenting the option.  The documented
usage MUST
	     be consistent with the existing usage.  When the option
usage is
	     published as an RFC, IANA will move the option to the
"Assigned"
	     state.
	
	     If no Internet-Draft is published within the 18 months or
should
	     one of these Internet-Drafts expire after the 18 months,
IANA will
	     move the option to the "Unassigned" state, and the option
may then
	     be assigned to any new publicly defined options in
accordance with
	     [RFC2939].
	
	Thank you, 
	
	Michelle Cotton
	IANA

	From: [email-masked]
[mailto:[email-masked]] 
	Sent: Thursday, May 19, 2005 11:10 AM
	To: [email-masked]; [email-masked]
	Subject: DHCP options 128-135 in use -- please place on
"Tentatively
	Assigned" list re. RFC 3942

	[ sorry, resend to add a subject for tracking...  please ignore
previous ] 
	
	Hello DHC WG and IANA, 
	
	Regarding RFC 3942, this is to document our (Mitel Networks) use
of DHCP
	options 128-135 in the current vendor-specific range, and to
request these
	be placed on the "Tentatively Assigned"  list. 
	
	Our usage is as follows.  All are related to configuration of IP
Phones (and
	similar devices) in a VoIP network. 
	
	Option    Usage 
	======    ===== 
	128       TFPT Server IP address (for IP Phone - specific sw
load) 

	Please confirm that these will go on the Tentatively Assigned
list (or
	perhaps some already are). 
	
	Also, it is not completely clear whether an I-D documenting this
same
	information is or is not required.  We are currently looking at
getting away
	from this scheme, in favor of better defined / standardized
vendor-specific
	methods.  Given this, and the high likelihood of clashes over
the same
	options wanted for use by others, we do not currently intend to
pursue
	standardization of these options.  Is an I-D required to
complete the
	process of putting the options on the Tentatively Assigned list?

	While we're on it, is there already, or will there be, a
definitive list of
	all the options in Tentatively Assigned state?   
	
	Regards, 
	Peter Blatherwick 
	Sr. Solutions Architect, 
	Mitel Networks