Subject: RE: [dhcwg] RFC 3942 notice: GNU GRUB, DHCP option 150

From: "C. M. Heard" <[email-masked]>
Date: Wed, 28 Sep 2005 11:02:37 -0700 (PDT)

>>>>> On Saturday, March 12, 2005 8:25 AM Yoshinori K. Okuji wrote:
Okuji> I would like to notify that GNU GRUB uses the DHCP option
Okuji> 150, according to
Okuji> RFC 3942.
Okuji>
Okuji> GNU GRUB Configuration Path
Okuji>
Okuji> This specifies the path-name that contains a configuration
Okuji> for GNU GRUB.
Okuji>
Okuji> The code for this option is 150.  Its minimum length is 1.
Okuji>
Okuji>     Code   Len    Configuration Pathname
Okuji>    +-----+-----+-----+-----+-----+-----+--
Okuji>    | 150 |  n  |  n1 |  n2 |  n3 |  n4 |  ...
Okuji>    +-----+-----+-----+-----+-----+-----+--

>>>>> On Sat, 12 Mar 2005 13:07:35 -0500 Bernie Volz replied:
Bernie> Looks like we now have 3 "users" of Option 150:
Bernie> 
Bernie> 1. GNU GRUB
Bernie> 2. DRAFT-RAJ-DHC-TFTP-ADDR-OPTION-00.TXT
Bernie> 3. Etherboot

In http://www.iana.org/assignments/bootp-dhcp-parameters, however,
I see the following:

   150     TFTP server address (Tentatively Assigned - 23 Jun 2005)
   150     Etherboot	
   150     GRUB configuration path name

This seems to contradict RFC 3942, which says that if multiple vendors
come forward none will be assigned the option:

      NOTE: If multiple vendors of an option number come forward and can
      demonstrate that their usage is in reasonably wide use, none of
      the vendors will be allowed to keep the current option number, and
      they MUST go through the normal process of getting a publicly
      assigned option [RFC2939].                                     

What gives?

//cmh

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Wed, 28 Sep 2005 15:06:27 -0400

Oh, OK. That was just a choice not to repeat tentatively assigned for
each of the entries when there was more than one for a single option
number.

- Bernie 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of David W. Hankins
> Sent: Wednesday, September 28, 2005 2:54 PM
> To: [email-masked]
> Subject: Re: [dhcwg] RFC 3942 notice: GNU GRUB, DHCP option 150
> 
> On Wed, Sep 28, 2005 at 02:33:06PM -0400, Bernie Volz (volz) wrote:
> > Well, what you like us to do?
> 
> I think he is concerned about the words 'tentatively assigned' that
> appears only on the 'TFTP Server Address' incarnation of the option.
> 
> A simple misunderstanding, I think.
> 
> -- 
> David W. Hankins		"If you don't do it right the 
> first time,
> Software Engineer			you'll just have to do 
> it again."
> Internet Systems Consortium, Inc.		-- Jack T. Hankins
>