Subject: RE: [dhcwg] RFC 3942 notice: GNU GRUB, DHCP option 150

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Wed, 28 Sep 2005 14:33:06 -0400

Well, what you like us to do?

Software is shipping with these codes, and documenting the fact that
there are conflicts are useful.

What the 3942 is saying is that when these folks go for an "IETF"/"IANA"
assigned option for non-conflicting use, they won't be able to use 150.
The I-Ds that they write should document the historic usage (that option
150 was/is in use). But, they should also request a NEW official IANA
assignment.

And, IANA obviously can't put option 150 in the pool for future options.

Given what we know today, RFC 3942 could certainly have documented more
of this, but it also would have greatly complicated the description.

- Bernie  

> -----Original Message-----
> From: C. M. Heard [mailto:[email-masked]] 
> Sent: Wednesday, September 28, 2005 2:03 PM
> To: DHC WG
> Cc: Bernie Volz (volz); Ralph Droms (rdroms); Richard Johnson 
> (raj); Timothy Legge; Yoshinori K. Okuji; BUG-GRUB
> Subject: RE: [dhcwg] RFC 3942 notice: GNU GRUB, DHCP option 150
> 
> >>>>> On Saturday, March 12, 2005 8:25 AM Yoshinori K. Okuji wrote:
> Okuji> I would like to notify that GNU GRUB uses the DHCP option
> Okuji> 150, according to
> Okuji> RFC 3942.
> Okuji>
> Okuji> GNU GRUB Configuration Path
> Okuji>
> Okuji> This specifies the path-name that contains a configuration
> Okuji> for GNU GRUB.
> Okuji>
> Okuji> The code for this option is 150.  Its minimum length is 1.
> Okuji>
> Okuji>     Code   Len    Configuration Pathname
> Okuji>    +-----+-----+-----+-----+-----+-----+--
> Okuji>    | 150 |  n  |  n1 |  n2 |  n3 |  n4 |  ...
> Okuji>    +-----+-----+-----+-----+-----+-----+--
> 
> >>>>> On Sat, 12 Mar 2005 13:07:35 -0500 Bernie Volz replied:
> Bernie> Looks like we now have 3 "users" of Option 150:
> Bernie> 
> Bernie> 1. GNU GRUB
> Bernie> 2. DRAFT-RAJ-DHC-TFTP-ADDR-OPTION-00.TXT
> Bernie> 3. Etherboot
> 
> In http://www.iana.org/assignments/bootp-dhcp-parameters, however,
> I see the following:
> 
>    150     TFTP server address (Tentatively Assigned - 23 Jun 2005)
>    150     Etherboot	
>    150     GRUB configuration path name
> 
> This seems to contradict RFC 3942, which says that if multiple vendors
> come forward none will be assigned the option:
> 
>       NOTE: If multiple vendors of an option number come 
> forward and can
>       demonstrate that their usage is in reasonably wide use, none of
>       the vendors will be allowed to keep the current option 
> number, and
>       they MUST go through the normal process of getting a publicly
>       assigned option [RFC2939].                                     
> 
> What gives?
> 
> //cmh
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Wed, 28 Sep 2005 11:54:27 -0700

> Well, what you like us to do?

I think he is concerned about the words 'tentatively assigned' that
appears only on the 'TFTP Server Address' incarnation of the option.

A simple misunderstanding, I think.

-- 
David W. Hankins		"If you don't do it right the first time,
Software Engineer			you'll just have to do it again."
Internet Systems Consortium, Inc.		-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "C. M. Heard" <[email-masked]>
Date: Wed, 28 Sep 2005 12:21:19 -0700 (PDT)

> of this, but it also would have greatly complicated the description.

The reason I raised the issue is because the registry entry in
http://www.iana.org/assignments/bootp-dhcp-parameters seems to
suggest the option is tentatively assigned to one of the three
vendor-specific uses:

|    150     TFTP server address (Tentatively Assigned - 23 Jun 2005)
|    150     Etherboot	
|    150     GRUB configuration path name

My apologies if I misread the intent.

//cmh