Subject: RE: [dhcwg] [NEED Help] How to assign an block of addresses to therequesting router via DHCPv4

From: "Bernie Volz \(volz\)" <[email-masked]>
Date: Mon, 12 Sep 2005 13:16:55 -0400

You can't do this with DHCPv4.

You can get multiple addresses, but you'll need to use a unique client
identifier for each address.

- Bernie 

> -----Original Message-----
> From: Yin LU [mailto:[email-masked]] 
> Sent: Monday, September 12, 2005 1:14 PM
> To: Bernie Volz (volz)
> Cc: [email-masked]
> Subject: Re: [dhcwg] [NEED Help] How to assign an block of 
> addresses to therequesting router via DHCPv4
> 
> Thank you all! Your suggestions would be very helpful. 
> 
> But I think the very thing I wanna find is how to get several
> individual addresses, instead of continuous addresses in an assigned
> subnet, in a single session (say, 2 roundtrips typically) between the
> router and the server via DHCPv4.
> 
> Subnet Delegation may be not very flexible after all, especially in
> the small-scale remoting access scenario. Is there any extended
> options will do?
> 
> 
> 2005/9/12, Bernie Volz (volz) <[email-masked]>:
> > See
> > 
> http://www.ietf.org/internet-drafts/draft-ietf-dhc-subnet-allo
c-03.txt.
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > On Behalf Of Yin LU
> > > Sent: Monday, September 12, 2005 5:08 AM
> > > To: [email-masked]
> > > Subject: [dhcwg] [NEED Help] How to assign an block of
> > > addresses to therequesting router via DHCPv4
> > >
> > > Hi,
> > >
> > > Is there someone kindly enough to tell me some clues 
> about assignning
> > > an block of addresses (or a subnet) to the router via DHCPv4, just
> > > like the way of Prefix Delegatinon Options in DHCPv6? It 
> seems that I
> > > failed to find something about this function in DHCPv4 RFC.Any
> > > suggestion would be greatly appreciated.
> > >
> > > LU Yin
> > > Nanjing University
> > > China
> > >
> > > _______________________________________________
> > > dhcwg mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/dhcwg
> > >
> >
> 

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: Yin LU <[email-masked]>
Date: Mon, 12 Sep 2005 10:31:08 -0700

That's to say, I could only get one address per requesting session via
DHCPv4, and I should use client identifier option to tell the server
how to distinguish the binding relationships between the
multi-requests, isn't it?