Subject: [dhcwg] PPP and DHCP

From: "Gonzalez, Pedro - ACD " <[email-masked]>
Date: Wed, 31 Jan 2007 17:55:45 -0500

Hi,

I was wondering if there was any information on running DHCP/Ipv4 over
PPP links. Is there a way to use DHCP to configure the IP address of a
device on its PPP interface instead of using IPCP? 

I am new to this mailing list. So, please pardon me if this question has
been raised before. In that case, I'd appreciate any po="Times New Roman">};</FONT></SPAN>

<BR><SPAN LANG="en-gb">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<BR>
</SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">And&nbsp; the terminal : </FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">[root@localhost ~]# dhcp6s -dDf eth0</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:43:59 extracted an existing DUID from /var/lib/dhcpv6/dhcp6s_duid: 00:01:00:01:0d:48:8c:d8:00:11:09:34:d5:bd</FONT></SPAN></P>

<P><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:43:59 set timer for syncing file ...</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:43:59 interface definition for eth0 is ok&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<BR>
</FONT></SPAN>
</P>

<P><SPAN LANG="en-gb"><FONT FACE="Times New Roman">In the DHCPv6 Clinet :</FONT></SPAN>
</P>

<P><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Dhcp6c.conf </FONT></SPAN>
</P>

<P><SPAN LANG="en-gb"><FONT FACE="Times New Roman">interface eth0 {</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">#&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; information-only;</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; send rapid-commit;</FONT></SPAN>

<BR><SPAN LANG="en-gb">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; <FONT FACE="Times New Roman">request prefix-delegation;</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">#&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; request temp-address;</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">};</FONT></SPAN>

<BR><SPAN LANG="en-gb">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<BR>
</SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">In the terminal :</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">[root@localhost dhcp-0.10]# ./dhcp6c -c ./dhcp6c.conf -dDf eth0</FONT></SPAN>
</P>

<P><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;[interface] (9)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;5&gt;[eth0] (4)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;begin of closure [{] (1)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;comment [#&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; information-only;] (19)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;[send] (4)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;[rapid-commit] (12)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;end of sentence [;] (1)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;[request] (7)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;[prefix-delegation] (17)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;end of sentence [;] (1)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;comment [#&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; request temp-address;] (23)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;end of closure [}] (1)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 &lt;3&gt;end of sentence [;] (1)</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/26/2007 09:39:57 extracted an existing DUID from /var/lib/dhcpv6/dhcp6c_duid:</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">00:01:00:01:0d:4b:2e:6d:00:01:02:9d:71:c4</FONT></SPAN>

<BR><SPAN LANG="en-gb"><FONT FACE="Times New Roman">Jan/inters to the
discussion.

Thanks,

Pedro Gonzalez
System Test Engineer
ITT ACD
77 River Road
Clifton, NJ 07014

************************************
This e-mail and any files transmitted with it are proprietary and intended solely
for the use of the individual or entity to whom they are addressed. If you have
received this e-mail in error please notify the sender. Please note that any views
or opinions presented in this e-mail are solely those of the author and do not
necessarily represent those of ITT, Inc. The recipient should check
this e-mail and any attachments for the presence of viruses. ITT accepts
no liability for any damage caused by any virus transmitted by this e-mail.
************************************

_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg

---

From: "David W. Hankins" <[email-masked]>
Date: Mon, 12 Feb 2007 11:42:11 -0800

> device on its PPP interface instead of using IPCP? 

I realize this sounds rude, but why would you want to?

DHCP is more tailored to brodcast networks.  Isn't it easier to just
use IPCP?

> been raised before. In that case, I'd appreciate any pointers to the
> discussion.

I think there was a query several months ago by someone who wanted
"DHCP option x" via PPP.  Actually I'm not sure that was on this list.

It would be intriguing for there to be a general purpose PPP CP
for containing DHCP options.  But I'm not sure DHCP message
exchanges (and leases) fit.

-- 
David W. Hankins	"If you don't do it right the first time,
Software Engineer		you'll just have to do it again."
Internet Systems Consortium, Inc.	-- Jack T. Hankins
_______________________________________________
dhcwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/dhcwg