Subject: Re: [dhcwg] draft-volz-dhc-dhcpv4-vendor-message-00.txt

From: Richard Johnson <[email-masked]>
Date: Fri, 12 Dec 2008 14:29:50 -0800

But this draft specifies the existance of a DHCP Message Type option.   
It's just that the message type is set to 254 and then there's an  
additional Vendor-specific Message type option.

/raj

On Nov 19, 2008, at 10:13 PM, Ted Lemon wrote:

> On Nov 19, 2008, at 11:58 PM, Bernie Volz (volz) wrote:
>> The lack of the DHCP Message Type option may trigger a server to  
>> assume
>> that this is a BOOTP packet? I need to double check RFC 2131 what  
>> really
>> distinguishes a DHCP from a BOOTP, but I think it might be  
>> existence of
>> this option?
>
> Hm, you raise a good point - a server that doesn't know about this  
> option might in fact send a BOOTREPLY in response to a DHCP packet  
> with an unknown vendor-specific type.
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 12 Dec 2008 17:44:02 -0500

You lost some of the thread here ...

Ted was wondering whether we needed the "DHCP Message Type" option with
a Vendor-Message number (254) at all. He was thinking we could just use
the new vendor-message option and be done with it.

But that doesn't work, I think, because the appearance of the DHCP
Message Type option is what makes a BOOTP packet a DHCP packet.

- Bernie 

-----Original Message-----
From: Richard Johnson (raj) 
Sent: Friday, December 12, 2008 5:30 PM
To: Ted Lemon
Cc: Bernie Volz (volz); [email-masked]
Subject: Re: [dhcwg] draft-volz-dhc-dhcpv4-vendor-message-00.txt

/raj

---

From: Richard Johnson <[email-masked]>
Date: Fri, 12 Dec 2008 14:47:00 -0800

Yep, Ted just sent me the same basic note.  As I mentioned to him, I  
was having email problems for a little while after the conference and  
probably lost that part of the thread.

Thanks.

/raj