Subject: [dhcwg] Request for review of draft-xia-netlmm-lma-discovery-01.txt

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Apr 2009 12:35:30 -0500

A new draft came by this morning that needs review by the DHC working  
group, and I'd like to suggest that people read it.   The two things  
that jump out about this draft are that it uses a DHCPv6 option, and  
it appears to require that the DHCPv6 server communicate with an AAA  
server on behalf of the client.   So it would be good if some of our  
DHCP gurus here in the DHC working group could review it and say what  
they think.

Having read the draft myself, I'm curious as to what motivates using  
the DHCPv6 server for this, and so I am requesting that someone from  
the netlmm working group briefly summarize the motivation behind this  
draft and the way it uses DHCPv6 so that we can do an informed review.

Thanks!

Ted

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 29 Apr 2009 13:39:35 -0400

Hi Ted,

I am not sure who requested this draft to be reviewed by the DHC WG.
There is no consensus in the NETLMM WG at this point for the PMIPv6 MAG
function to use DHCPv6 to obtain the LMA IP address. So any DHC WG
review would be premature at this point.

Vijay

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Ted Lemon
> Sent: Wednesday, April 29, 2009 10:36 AM
> To: dhc WG
> Cc: [email-masked]
> Subject: [dhcwg] Request for review of 
> draft-xia-netlmm-lma-discovery-01.txt
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Apr 2009 13:00:49 -0500

> review would be premature at this point.

My motivation in asking for review of this document before it's been  
adopted by the netlmm working group as a work item, is that it appears  
to make a rather novel use of the DHCPv6 protocol.   Unless the netlmm  
working group has already decided not to adopt this draft, I think it  
makes some sense for you to consider feedback from the DHC working  
group on the draft when you are deliberating on whether or not to  
adopt the draft as a netlmm working group item.

So if in fact there is no likelihood that the netlmm working group  
will adopt this draft, it would certainly save us some effort to know  
that.  Otherwise I think actually this is a good time for the DHC  
working group to give the draft a quick preliminary review.

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 29 Apr 2009 11:06:32 -0700

Ted Lemon wrote:
> makes some sense for you to consider feedback from the DHC working group 
> on the draft when you are deliberating on whether or not to adopt the 
> draft as a netlmm working group item.
> 
> So if in fact there is no likelihood that the netlmm working group will 
> adopt this draft, it would certainly save us some effort to know that.  
> Otherwise I think actually this is a good time for the DHC working group 
> to give the draft a quick preliminary review.

In my personal opinion, the MAG does not have behave as a DHCPv6 client 
at all. See RFC 5213, that specifies DHCPv6 functions on the MAG and the 
LMA. So this solution is a non-starter as a solution.

Vijay

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 29 Apr 2009 12:20:54 -0700 (PDT)

Hi Ted,
  The reason we wrote this draft is already stated in netlmm charter (http://www.ietf.org/html.charters/netlmm-charter.html) item 6 which states that:
6) Automatic LMA discovery: This will define the ability for MAGs to
automatically discover and use an LMA within a PMIPv6 domain. The
scope of this effort may include specifying the use of DNS or DHCP
based LMA discovery or LMA discovery using policy information
retrieved via AAA protocols

  At the moment we don't know if netlmm will adopt this draft. There is another draft co-authored by Vijay which is about some other non-DHCP means of LMA discovery, hence Vijay's intervention here ..
  Based on the above having a quick preliminary review by DHC WG will be quite helpful to netlmm folks.
 
Regards,
 
Behcet
> review would be premature at this point.

My motivation in asking for review of this document before it's been adopted by the netlmm working group as a work item, is that it appears to make a rather novel use of the DHCPv6 protocol.  Unless the netlmm working group has already decided not to adopt this draft, I think it makes some sense for you to consider feedback from the DHC working group on the draft when you are deliberating on whether or not to adopt the draft as a netlmm working group item.

So if in fact there is no likelihood that the netlmm working group will adopt this draft, it would certainly save us some effort to know that.  Otherwise I think actually this is a good time for the DHC working group to give the draft a quick preliminary review..

________________________________

From: Ted Lemon <[email-masked]>
To: Vijay Devarapalli <[email-masked]>
Cc: dhc WG <[email-masked]>; "[email-masked]" <[email-masked]>
Sent: Wednesday, April 29, 2009 1:00:49 PM
Subject: Re: [dhcwg] Request for review of draft-xia-netlmm-lma-discovery-01.txt

---

From: Frank Xia <[email-masked]>
Date: Wed, 29 Apr 2009 14:46:39 -0500

Hi Vijay

If there is no ready DHCP client function in MAG,
we should make it because our job is find a way
to solve  real business problems.

Give you a very relevant example.

There is no existing DHCP client function for
a mobile router, however, Ralph enables it
in his draft  http://tools.ietf.org/id/draft-ietf-mext-nemo-pd-02.txt

BR
Frank

----- Original Message ----- 
From: "Vijay Devarapalli" <[email-masked]>
To: "Ted Lemon" <[email-masked]>
Cc: "dhc WG" <[email-masked]>; <[email-masked]>
Sent: Wednesday, April 29, 2009 1:06 PM
Subject: Re: [netlmm] [dhcwg] Request for review 
ofdraft-xia-netlmm-lma-discovery-01.txt

>> adopted by the netlmm working group as a work item, is that it appears to 
>> make a rather novel use of the DHCPv6 protocol.   Unless the netlmm 
> In my personal opinion, the MAG does not have behave as a DHCPv6 client at 
> all. See RFC 5213, that specifies DHCPv6 functions on the MAG and the LMA. 
> So this solution is a non-starter as a solution.
>
> Vijay
>
> netlmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netlmm

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 29 Apr 2009 13:26:36 -0700

Behcet,

We had numerous discussions on this in the past. The MAG is not a DHCP
client according to any of the specifications we have so far. I don't think
it makes sense for the MAG to implement DHCP client functionality just to
obtain the LMA IP address.

Moreover, the MAG acting as a DHCP client doesn't is not valid in any of the
SDO architectures that are using PMIPv6.

We shouldn't extend protocols just because we can.

Vijay

On 4/29/09 12:20 PM, "Behcet Sarikaya" wrote:

> Hi Ted,
>   The reason we wrote this draft is already stated in netlmm charter
> (http://www.ietf.org/html.charters/netlmm-charter.html) item 6 which states
> that:
>   At the moment we don't know if netlmm will adopt this draft. There is
> another draft co-authored by Vijay which is about some other non-DHCP means of
> LMA discovery, hence Vijay's intervention here .
> My motivation in asking for review of this document before it's been adopted
> by the netlmm working group as a work item, is that it appears to make a
> rather novel use of the DHCPv6 protocol.  Unless the netlmm working group has
> already decided not to adopt this draft, I think it makes some sense for you
> to consider feedback from the DHC working group on the draft when you are
> deliberating on whether or not to adopt the draft as a netlmm working group
> item.
> 
> So if in fact there is no likelihood that the netlmm working group will adopt
> this draft, it would certainly save us some effort to know that.  Otherwise I
> think actually this is a good time for the DHC working group to give the draft
> a quick preliminary review.
>