Subject: [dhcwg] Call for adoption: draft-guo-softwire-6rd-ipv6-config-02.txt

From: Ted Lemon <[email-masked]>
Date: Tue, 10 May 2011 22:58:17 -0400

This document proposes a mechanism for configuring the IPv6 stack over a 6RD tunnel using DHCPv6.   It was presented at the meeting in Prague.   This is an interesting problem because the DHCPv6 spec prevents DHCP clients from configuring themselves directly over tunnels. Two solutions were suggested: either relax some restrictions in RFC3315 with regard to source addresses, or else use a DHCPv6 relay agent to forward the packet over the tunnel.   The consensus of the room was to adopt the work; although this is related to 6RD, it is a DHCP-specific draft, so there was agreement that the DHC working group is the right place for the work.

If you agree that the working group should do this work, please indicate that agreement on the list; likewise if you disagree.   If you have no opinion, there is no need to say so.

We will evaluate the consensus on Wednesday, May 25.   Please get your comments in before that time.

---

From: Ole Troan <[email-masked]>
Date: Mon, 16 May 2011 10:39:48 +0200

> If you agree that the working group should do this work, please indicate that agreement on the list; likewise if you disagree.   If you have no opinion, there is no need to say so.

agree. (and think this has wider applicability than just 6rd (basically any link that doesn't support link-local addressing or multicast or the DHCPv6 client has a need to send directly to a server not directly connected to it)).

cheers,
Ole

---

From: Xu Xiaohu <[email-masked]>
Date: Mon, 16 May 2011 17:38:04 +0800

I also agree that the working group should do this work.

Best wishes,
Xiaohu

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Ole
> Troan
> 发送时间: 2011年5月16日 16:40
> 收件人: Ted Lemon
> 抄送: [email-masked] WG
> 主题: Re: [dhcwg] Call for adoption:
draft-guo-softwire-6rd-ipv6-config-02.txt
> 
> > This document proposes a mechanism for configuring the IPv6 stack over a
> 6RD tunnel using DHCPv6.   It was presented at the meeting in Prague.
> This is an interesting problem because the DHCPv6 spec prevents DHCP
clients
> from configuring themselves directly over tunnels. Two solutions were
> suggested: either relax some restrictions in RFC3315 with regard to source
> addresses, or else use a DHCPv6 relay agent to forward the packet over the
> tunnel.   The consensus of the room was to adopt the work; although this
is
> related to 6RD, it is a DHCP-specific draft, so there was agreement that
the
> DHC working group is the right place for the work.
> >
> > If you agree that the working group should do this work, please indicate
that
> agreement on the list; likewise if you disagree.   If you have no opinion,
there
> is no need to say so.
> 
> agree. (and think this has wider applicability than just 6rd (basically
any link
> that doesn't support link-local addressing or multicast or the DHCPv6
client has
> a need to send directly to a server not directly connected to it)).
> 
> cheers,
> Ole
> 
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Mark Townsley <[email-masked]>
Date: Mon, 16 May 2011 11:32:01 +0200

+1

---

From: Ted Lemon <[email-masked]>
Date: Tue, 24 May 2011 15:31:20 -0400

Reminder: the call for adoption on this draft expires tomorrow.   Thus far there seems to be adequate support for adopting the work, and no objections.   If you wish to weigh in on the question, please do so today.

Thanks!

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 24 May 2011 15:35:45 -0400

have a question: this draft talks about 6rd. but my reading is that this 
issue is more generic than 6rd, isn't it? Should that be written in a 
more generic way (i.e. a dhcpv6 client that can't use its link-local 
address as source for some types of links, including 6rd)?

Marc.

-- 
=========
IETF81 Quebec city: http://ietf81.ca
IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
DTN Implementation: http://postellation.viagenie.ca
NAT64-DNS64 Opensource: http://ecdysis.viagenie.ca
Space Assigned Number Authority: http://sanaregistry.org

---

From: Ted Lemon <[email-masked]>
Date: Tue, 24 May 2011 16:38:49 -0400

On May 24, 2011, at 3:35 PM, Marc Blanchet wrote:
> have a question: this draft talks about 6rd. but my reading is that this issue is more generic than 6rd, isn't it? Should that be written in a more generic way (i.e. a dhcpv6 client that can't use its link-local address as source for some types of links, including 6rd)?

My expectation is that whatever mechanism we come up with will be general; 6rd is the motivation for doing the work right now, not the only possible use for the work.   Your participation in making sure that the work is properly scoped would be greatly appreciated.   :)

---

From: Ted Lemon <[email-masked]>
Date: Wed, 25 May 2011 12:16:44 -0400

> We will evaluate the consensus on Wednesday, May 25.   Please get your comments in before that time.

The consensus seems to be that this work is worth doing, although there was some discussion about the scope of the work.   I think the authors should consider working with Marc Blanchet to get the document scoped correctly, and possibly bring him on as a co-author.  In any case, the working group has adopted this as a working group item, so the authors should submit a draft-ietf-... draft.

BTW, if the authors agree to expand the scope, I would suggest calling the draft something like "DHCPv6 through Tunnels" and draft-ietf-dhc-dhcpv6-tunnels-00.txt instead of keeping 6rd in the name.

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 25 May 2011 13:07:55 -0400

> BTW, if the authors agree to expand the scope, I would suggest calling the draft something like "DHCPv6 through Tunnels" and draft-ietf-dhc-dhcpv6-tunnels-00.txt instead of keeping 6rd in the name.

I would even make it more like "DHCPv6 through non-capable LL links" 
(well, not good, but will have to figure that out).

Marc.

---

From: Xu Xiaohu <[email-masked]>
Date: Thu, 26 May 2011 09:10:38 +0800

Hi Ted,

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Ted
> Lemon
> 发送时间: 2011年5月26日 0:17
> 收件人: [email-masked] WG
that
there
> The consensus seems to be that this work is worth doing, although there
was
> some discussion about the scope of the work.   I think the authors should
> consider working with Marc Blanchet to get the document scoped correctly,
> and possibly bring him on as a co-author.  In any case, the working group
has
> adopted this as a working group item, so the authors should submit a
> draft-ietf-... draft.

Fully agree. Welcome Marc to work with us to get the document scoped
correctly.

> BTW, if the authors agree to expand the scope, I would suggest calling the
> draft something like "DHCPv6 through Tunnels" and
> draft-ietf-dhc-dhcpv6-tunnels-00.txt instead of keeping 6rd in the name.

It's a good point.

Best regards,
Xiaohu

---

From: Xu Xiaohu <[email-masked]>
Date: Thu, 26 May 2011 09:24:03 +0800

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表
> Marc Blanchet
> 发送时间: 2011年5月26日 1:08
> 收件人: [email-masked]
> >> If you agree that the working group should do this work, please
indicate that
there
was
has
> (well, not good, but will have to figure that out).

How about " DHCPv6 through Tunnels incapable of Carrying Link-Local
Addresses"

Best regards,
Xiaohu

---

From: Ted Lemon <[email-masked]>
Date: Thu, 26 May 2011 10:13:39 -0400

Le May 25, 2011 à 9:24 PM, Xu Xiaohu a écrit :
> DHCPv6 through Tunnels incapable of Carrying Link-Local
> Addresses

Kind of long.   Naive question: are there tunnels that can carry link-local addresses?

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 26 May 2011 10:34:09 -0400

> Kind of long.   Naive question: are there tunnels that can carry link-local addresses?

well that was around my initial thoughts: we need to define the spec to 
cover all links that have the same properties as 6rd (tunnel or not) and 
then show 6rd as the example.

Marc.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 26 May 2011 21:05:23 -0400

Le May 26, 2011 à 10:34 AM, Marc Blanchet a écrit :
> well that was around my initial thoughts: we need to define the spec to cover all links that have the same properties as 6rd (tunnel or not) and then show 6rd as the example.

Be careful: if you try to broaden the scope so far that it changes the solution, make sure that the problem that you're using to justify broadening the scope is a real problem, and not a theoretical problem.

---

From: Xu Xiaohu <[email-masked]>
Date: Fri, 27 May 2011 18:13:35 +0800

Hi Ted, 

Your observation is right. We will take " DHCPv6 through Tunnels " as the
draft title.

Best regards,
Xiaohu

> -----邮件原件-----
> 发件人: Ted Lemon [mailto:[email-masked]]
> 发送时间: 2011年5月26日 22:14
> 收件人: Xu Xiaohu
> 抄送: 'Marc Blanchet'; [email-masked]
> Kind of long.   Naive question: are there tunnels that can carry
link-local
> addresses?