Subject: Re: [dhcwg] Call for adoption: draft-xia-dhc-host-gen-id-04

From: Suresh Krishnan <[email-masked]>
Date: Fri, 6 May 2011 18:38:38 -0400

Hi Ted,
   I have read the draft and I am supportive of the problem this draft 
is trying to solve (i.e. allow host generated IIDs). But, the mechanism 
proposed in the draft is a bit unclear for me to say whether this is the 
best way to solve the solution or not. In particular, the semantics of 
the IA_PA are not detailed very well. e.g. How exactly is this different 
from an IA_PD with a 64 bit prefix? Can a prefix inside a IA_PA be 
shared across multiple clients etc.

Thanks
Suresh

2011/4/25, Ted Lemon <[email-masked]>:
> The working group discussed this draft in Prague and there was interest in
> taking on the work.   The draft is an attempt to solve the problem of how to
> use CGAs and other host-generated addresses with DHCP.   If you are in favor
> of taking on this work, please let us know.   If you think this is work the
> working group should not do, please let us know.   If you think the draft
> doesn't adequately address the problem at present, please get involved.
>
> I will evaluate the working group consensus on adopting this work on Friday,
> May 6.
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Jiangsheng <[email-masked]>
Date: Mon, 09 May 2011 03:05:07 +0000

Hi, Suresh,

Thanks for your read and support.

In principle, the format of IA_PA is the same with IA_PD except for Option code. The different is on the semantics and usage model. The IA_PD option is to delegate prefix to a routable device for itself use only. The IA_PA option is to assign/notify a prefix to a host device. The prefix inside an IA_PA is shared across many clients. We will make this clear in next version. Thanks for pointing this out.

Best regards,

Sheng

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Suresh Krishnan
> Sent: Saturday, May 07, 2011 6:39 AM
> To: Ted Lemon
> Cc: [email-masked] WG
> Subject: Re: [dhcwg] Call for adoption: draft-xia-dhc-host-gen-id-04
> 
> Hi Ted,

---

From: Ted Lemon <[email-masked]>
Date: Tue, 10 May 2011 22:33:13 -0400

On Apr 25, 2011, at 1:31 AM, Ted Lemon wrote:
> I will evaluate the working group consensus on adopting this work on Friday, May 6.

The working group consensus seems to be in favor of this document.   We will adopt it as a working group item.   Several good suggestions were made; I hope that the people who participated in this call for adoption will continue to follow the document and help the editors to improve it.