Subject: Re: [dhcwg] dhcwg Digest, Vol 96, Issue 38

From: Shankari Vaidyalingam <[email-masked]>
Date: Fri, 27 Apr 2012 18:29:57 +0530

Hi,

Can you let me know where can I get this draft -
draft-ietf-dhc-client-id-02.

Regards,
Shankari.V

On Fri, Apr 27, 2012 at 12:30 AM, <[email-masked]> wrote:

> If you have received this digest without all the individual message
> attachments you will need to update your digest options in your list
> subscription.  To do so, go to
>
> https://www.ietf.org/mailman/listinfo/dhcwg
>
> Click the 'Unsubscribe or edit options' button, log in, and set "Get
> MIME or Plain Text Digests?" to MIME.  You can set this option
> globally for all the list digests you receive at this point.
>
>
>
> Send dhcwg mailing list submissions to
>        [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>        https://www.ietf.org/mailman/listinfo/dhcwg
> or, via email, send a message with subject or body 'help' to
>        [email-masked]
>
> You can reach the person managing the list at
>        [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of dhcwg digest..."
>
>
> Today's Topics:
>
>   1. Re: WGLC: draft-ietf-dhc-client-id-02 (Richard Johnson)
>   2. Re: Call for adoption:    draft-yeh-dhc-dhcpv6-authorization-opt
>      (Sheng Jiang)
>   3. Re: Call  for     adoption:
> draft-yeh-dhc-dhcpv6-authorization-opt
>      (Leaf yeh)
>   4. Re: Call for      adoption:
> draft-yeh-dhc-dhcpv6-authorization-opt
>      (Tina TSOU)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Wed, 25 Apr 2012 12:59:39 -0700
> From: Richard Johnson <[email-masked]>
> To: Ted Lemon <[email-masked]>
> Cc: DHC WG <[email-masked]>
> Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-client-id-02
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=windows-1252
>
> I definitely support this draft, although I think the current description
> of the problem to be solved could use quite a lot of work to make it more
> clear.  Your own description is quite clear, but the document is not really.
>
> /raj
>
>
> On Apr 14, 2012, at 5:54 AM, Ted Lemon wrote:
>
> > This document corrects a bug in RFC2131 that forbids the DHCP server
> from returning a DHCP client identifier.   The lack of a DHCP client
> identifier creates a problem in two cases: where the underlying transport
> has no link-layer address, and where two clients are running on the same
> host, supplying different client identifiers so as to present different
> network identities.   In both of these cases, insufficient information is
> returned from the DHCP server to clearly identify the client that is the
> intended recipient of the message.   The only way to fix this is to
> _require_ the DHCP server to return the client identifier if it receives
> it.   This is what the proposed document does.
> >
> > We checked for consensus in the meeting, and four people were in favor
> of advancing the draft; nobody was against.
> >
> > I think this is actually pretty important work?it's a lingering bug in
> the spec which I think will come back to bite us more and more as we start
> getting deeper into the dual-stack transition.   So if you haven't read the
> document, please do.
> >
> > If you support advancing it, please signify by replying to this message
> and saying that you support it. If you think it's a bad idea, please
> signify by replying to this message and explaining why.   If you have
> comments or changes to propose, please send them along, and also signify
> whether you are in favor of advancement with the change, without the
> change, or oppose advancement.
> >
> > We will determine consensus on April 27, based solely on responses on
> the mailing list, so please do respond.
> >
> > Thanks!
> >
> > _______________________________________________
> > dhcwg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/dhcwg
>
>
>
> ------------------------------
>
> Message: 2
> Date: Wed, 25 Apr 2012 23:42:38 +0000
> From: Sheng Jiang <[email-masked]>
> To: Ted Lemon <[email-masked]>, DHC WG <[email-masked]>
> Subject: Re: [dhcwg] Call for adoption:
>        draft-yeh-dhc-dhcpv6-authorization-opt
> Message-ID:
>        <
> [email-masked]>
>
> Content-Type: text/plain; charset="us-ascii"
>
> Support adopt this draft.
>
> Sheng
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Ted Lemon
> > Sent: Wednesday, April 25, 2012 7:38 PM
> > To: DHC WG
> > Subject: [dhcwg] Call for adoption: draft-yeh-dhc-dhcpv6-authorization-
> > opt
> >
> > One of the authors of this draft has requested a formal call for
> > adoption.   There was substantial support for the work in the DHC
> > working group meeting in Paris, and no objections.   The idea is to
> > have a RADIUS option for DHCPv6, similar to the functionality present
> > in DHCPv4.
> >
> > If you favor or oppose taking this on as working group work, please
> > signify by replying to this message.   If you have comments or concerns,
> > please raise them now.
> >
> > We will make a determination of consensus on May 9.
> >
> > _______________________________________________
> > dhcwg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/dhcwg
>
>
> ------------------------------
>
> Message: 3
> Date: Thu, 26 Apr 2012 01:36:56 +0000
> From: Leaf yeh <[email-masked]>
> To: Ted Lemon <[email-masked]>, Tomek Mrugalski
>        <[email-masked]>
> Cc: "<[email-masked]>" <[email-masked]>
> Subject: Re: [dhcwg] Call       for     adoption:
>        draft-yeh-dhc-dhcpv6-authorization-opt
> Message-ID:
>        <
> [email-masked]>
>
> Content-Type: text/plain; charset="utf-8"
>
> Tomek - Once adopted, it seems reasonable to call this draft
> draft-ietf-dhc-dhcpv6-radius-option, rather than -authorization-.
> Ted - Yes, I agree completely.   Leaf, is that okay with you?
>
> FYI again, the context including the title of draft & the name of the new
> option  has been updated to the 'RADIUS option' in the draft-yeh-01.
>
> Yes, I am OK with this suggestion.
>
>
> Best Regards,
> Leaf
>
>
>
> ----------------------------------------------------------------------------------------------------------------
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Ted Lemon
> Sent: Wednesday, April 25, 2012 9:53 PM
> To: Tomek Mrugalski
> Cc: <[email-masked]>
> Subject: Re: [dhcwg] Call for adoption:
> draft-yeh-dhc-dhcpv6-authorization-opt
>
> On Apr 25, 2012, at 9:37 AM, Tomek Mrugalski <[email-masked]>
> ?wrote:
> Once adopted, it seems reasonable to call this draft
> draft-ietf-dhc-dhcpv6-radius-option, rather than -authorization-.
>
> Yes, I agree completely. ? Leaf, is that okay with you?
>
> Tomek, are you for or against adoption? ? (Or don't have an opinion?)
>
>
> ------------------------------
>
> Message: 4
> Date: Thu, 26 Apr 2012 02:59:50 +0000
> From: Tina TSOU <[email-masked]>
> To: Sheng Jiang <[email-masked]>
> Cc: DHC WG <[email-masked]>, Ted Lemon <[email-masked]>
> Subject: Re: [dhcwg] Call for   adoption:
>        draft-yeh-dhc-dhcpv6-authorization-opt
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
>
> I support adoption of this draft.
>
> Sent from my iPad
>
> On Apr 25, 2012, at 5:00 PM, "Sheng Jiang" <[email-masked]> wrote:
>
> > Support adopt this draft.
> >
> > Sheng
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]] On Behalf
> >> Of Ted Lemon
> >> Sent: Wednesday, April 25, 2012 7:38 PM
> >> To: DHC WG
> >> Subject: [dhcwg] Call for adoption: draft-yeh-dhc-dhcpv6-authorization-
> >> opt
> >>
> >> One of the authors of this draft has requested a formal call for
> >> adoption.   There was substantial support for the work in the DHC
> >> working group meeting in Paris, and no objections.   The idea is to
> >> have a RADIUS option for DHCPv6, similar to the functionality present
> >> in DHCPv4.
> >>
> >> If you favor or oppose taking this on as working group work, please
> >> signify by replying to this message.   If you have comments or concerns,
> >> please raise them now.
> >>
> >> We will make a determination of consensus on May 9.
> >>
> >> _______________________________________________
> >> dhcwg mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/dhcwg
> > _______________________________________________
> > dhcwg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/dhcwg
>
>
> ------------------------------
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>
>
> End of dhcwg Digest, Vol 96, Issue 38
> *************************************
>

---

From: "Prashant Jhingran (pjhingra)" <[email-masked]>
Date: Mon, 30 Apr 2012 21:02:01 +0530

http://www.ietf.org/id/draft-ietf-dhc-client-id-02.txt

-

Regards,

Prashant Jhingran

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Shankari Vaidyalingam
Sent: Friday, April 27, 2012 6:30 PM
To: [email-masked]
Subject: Re: [dhcwg] dhcwg Digest, Vol 96, Issue 38

Hi,

Regards,
Shankari.V

Today's Topics:

Message: 1

I definitely support this draft, although I think the current
description of the problem to be solved could use quite a lot of work to
make it more clear.  Your own description is quite clear, but the
document is not really.

/raj

from returning a DHCP client identifier.   The lack of a DHCP client
identifier creates a problem in two cases: where the underlying
transport has no link-layer address, and where two clients are running
on the same host, supplying different client identifiers so as to
present different network identities.   In both of these cases,
insufficient information is returned from the DHCP server to clearly
identify the client that is the intended recipient of the message.   The
only way to fix this is to _require_ the DHCP server to return the
client identifier if it receives it.   This is what the proposed
document does.
> I think this is actually pretty important work?it's a lingering bug in
the spec which I think will come back to bite us more and more as we
start getting deeper into the dual-stack transition.   So if you haven't
read the document, please do.
>
> If you support advancing it, please signify by replying to this
message and saying that you support it. If you think it's a bad idea,
please signify by replying to this message and explaining why.   If you
have comments or changes to propose, please send them along, and also
signify whether you are in favor of advancement with the change, without
the change, or oppose advancement.

Message: 2
 
<[email-masked]

Sheng

Message: 3
 
<[email-masked]

FYI again, the context including the title of draft & the name of the
new option  has been updated to the 'RADIUS option' in the draft-yeh-01.

Best Regards,
Leaf

------------------------------------------------------------------------
----------------------------------------
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Ted Lemon
Sent: Wednesday, April 25, 2012 9:53 PM
To: Tomek Mrugalski
Cc: <[email-masked]>
Subject: Re: [dhcwg] Call for adoption:
draft-yeh-dhc-dhcpv6-authorization-opt

On Apr 25, 2012, at 9:37 AM, Tomek Mrugalski
<[email-masked]>
?wrote:
Once adopted, it seems reasonable to call this draft
draft-ietf-dhc-dhcpv6-radius-option, rather than -authorization-.

Message: 4

Sent from my iPad