Subject: [dhcwg] WGLC: draft-ietf-dhc-dhcpv4-over-ipv6

From: Ted Lemon <[email-masked]>
Date: Sat, 23 Jun 2012 13:32:31 +0000

The authors of this draft believe that their work on it is complete and have asked for a working group last call.

The draft is a bit of transition technology to enable allocation of IPv4 addresses for tunnel endpoints on an IPv6-only network using DHCP.   It works by relaying DHCPv4 packets over DHCPv6.

The DHC working group is agnostic to whether this is the right way to set up tunnels; the question for the DHC working group is whether this is a good DHCP protocol extension.   Please review the draft for correctness and indicate whether or not you support advancing it.   If you are in favor, please say so.   If you aren't, please say so, and (ideally) explain why.

We will evaluate consensus sometime on or after June 9.

Thanks!

---

From: Ted Lemon <[email-masked]>
Date: Sat, 23 Jun 2012 13:33:24 +0000

On Jun 23, 2012, at 9:32 AM, Ted Lemon wrote:
We will evaluate consensus sometime on or after June 9.

July 9.

---

From: Francis Dupont <[email-masked]>
Date: Sat, 23 Jun 2012 21:39:58 +0200

>  We will evaluate consensus sometime on or after June 9.

=> July 9?

I support the draft and have two comments:
 - I implemented it (it is used in Light weight Dual-Stack Lite demos)
 - if/when it will be adopted it should be fine to define a new DHCPv6
  option giving DHCPv4-over-IPv6 agents (i.e., TRA or TSV), something
  like an array of IPv6 addresses should do the job...

Thanks

[email-masked] (or [email-masked] for the first comment)

---

From: Ted Lemon <[email-masked]>
Date: Sat, 23 Jun 2012 21:59:53 +0000

On Jun 23, 2012, at 3:39 PM, Francis Dupont wrote:
- if/when it will be adopted it should be fine to define a new DHCPv6
 option giving DHCPv4-over-IPv6 agents (i.e., TRA or TSV), something
 like an array of IPv6 addresses should do the job...

Nice idea.   Why wait?   :)

---

From: Francis Dupont <[email-masked]>
Date: Sun, 24 Jun 2012 19:09:52 +0200

>   like an array of IPv6 addresses should do the job...

=> if this could not delay the adoption of DHCPv4 over IPv6 I agree.

Thanks

[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Sun, 24 Jun 2012 17:31:19 +0000

On Jun 24, 2012, at 7:09 PM, Francis Dupont wrote:
=> if this could not delay the adoption of DHCPv4 over IPv6 I agree.

It would be independent, I think.   It might have a normative or informative reference to the DHCPv4 over IPv6 draft, but not vice versa.

---

From: Francis Dupont <[email-masked]>
Date: Sun, 24 Jun 2012 19:43:02 +0200

In your previous mail you wrote:

> It would be independent, I think.  It might have a normative or
> informative reference to the DHCPv4 over IPv6 draft, but not vice
> versa.

=> perhaps I misunderstood your idea: I thought about an addition in
the current draft, of course a new one can't show this kind of issue.

Thanks

---

From: Peng Wu <[email-masked]>
Date: Mon, 25 Jun 2012 01:47:01 +0800

Ted and Francis,

Tomasz and I (well mostly Tomasz) have actually started something on
this topic.
There is a draft available at
http://tools.ietf.org/html/draft-mrugalski-softwire-dhcpv4-over-v6-option-00.
We did submit it to Softwire, though. Should it move to DHC?

On Mon, Jun 25, 2012 at 1:31 AM, Ted Lemon <[email-masked]> wrote:
> It would be independent, I think.   It might have a normative or informative
> reference to the DHCPv4 over IPv6 draft, but not vice versa.
>
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>

---

From: Francis Dupont <[email-masked]>
Date: Sun, 24 Jun 2012 20:41:11 +0200

>  We did submit it to Softwire, though. Should it move to DHC?

=> perhaps. BTW it is a copy of the DS-Lite option and IMHO a FQDN
is not the best solution for DHCPv4 over IPv6 (i.e., I really prefer
an array of addresses).

Regards