Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-client-id-04

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Mon, 13 Aug 2012 15:00:07 +0000

Hi Bernie,

Thanks for supporting. Yes, you are right. Version is 04.

Regarding including reference to DHCPINFORM, I guess the document talks about server including 'Client Identifier' in OFFER/ACK/NAK irrespective of the message type from the client. Having said that, I think document in it's current state actually covers this scenario as well. Please let me know if you think otherwise.

Thanks,
Gaurav

-----Original Message-----
From: Bernie Volz (volz) 
Sent: Monday, August 13, 2012 8:16 PM
To: Ted Lemon; dhc WG
Cc: [email-masked]; Gaurav Halwasia (ghalwasi); Prashant Jhingran (pjhingra)
Subject: RE: WGLC: draft-ietf-dhc-client-id-02 [really -04]

The current draft is 04, not 02.

I am OK with advancing this draft.

However, might be nice to also include DHCPINFORM in this document? The DHCPACK sent in response should also include the Client Identifier option if sent in by the client (while this is generally not broadcast and may not suffer the same issues as the other messages, just be clean to allow the server to have consistent processing to include the Client Identifier in all responses to the client).

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ted Lemon
Sent: Friday, August 10, 2012 9:35 AM
To: dhc WG
Subject: [dhcwg] WGLC: draft-ietf-dhc-client-id-02

The authors have requested a working group last call for this draft.   This is the document that clarifies the use of the DHCP client identifier by DHCP servers, particularly in cases where chaddr is zero.   Please review the draft and indicate on the mailing list whether you support its advancement or oppose its advancement.

We will determine consensus on August 24.

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 13 Aug 2012 15:09:18 +0000

Yes, you are correct. The document is indeed just refers to the responses - not the requests.

- Bernie

-----Original Message-----
From: Gaurav Halwasia (ghalwasi) 
Sent: Monday, August 13, 2012 11:00 AM
To: Bernie Volz (volz); Ted Lemon; dhc WG
Cc: [email-masked]; Prashant Jhingran (pjhingra)
Subject: RE: WGLC: draft-ietf-dhc-client-id-04

Hi Bernie,

Thanks,
Gaurav

-----Original Message-----
From: Bernie Volz (volz) 
Sent: Monday, August 13, 2012 8:16 PM
To: Ted Lemon; dhc WG
Cc: [email-masked]; Gaurav Halwasia (ghalwasi); Prashant Jhingran (pjhingra)
Subject: RE: WGLC: draft-ietf-dhc-client-id-02 [really -04]

- Bernie

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 14 Aug 2012 00:43:18 +0000

Support to advance this work.

Sheng

>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Gaurav Halwasia (ghalwasi)
>Sent: Monday, August 13, 2012 11:00 PM
>Cc: [email-masked]
>Subject: Re: [dhcwg] WGLC: draft-ietf-dhc-client-id-04
>
>Hi Bernie,
>
>Regarding including reference to DHCPINFORM, I guess the document talks
>about server including 'Client Identifier' in OFFER/ACK/NAK irrespective of the
>message type from the client. Having said that, I think document in it's current
>state actually covers this scenario as well. Please let me know if you think
>otherwise.
>
>Thanks,
>Gaurav
>
>However, might be nice to also include DHCPINFORM in this document? The
>DHCPACK sent in response should also include the Client Identifier option if
>sent in by the client (while this is generally not broadcast and may not suffer
>the same issues as the other messages, just be clean to allow the server to
>have consistent processing to include the Client Identifier in all responses to
>the client).
>
>- Bernie
>
>The authors have requested a working group last call for this draft.   This is
>the document that clarifies the use of the DHCP client identifier by DHCP
>servers, particularly in cases where chaddr is zero.   Please review the draft
>and indicate on the mailing list whether you support its advancement or
>oppose its advancement.
>

---

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Tue, 14 Aug 2012 06:12:47 +0000

I support this work too.

On 8/14/12 6:13 AM, "Sheng Jiang" <[email-masked]> wrote:

>>Of Ted Lemon