Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt-01.txt

From: [email-masked]
Date: Mon, 13 Aug 2012 19:33:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Dynamic Host Configuration Working Group of the IETF.

	Title           : Client Link-layer Address Option in DHCPv6
	Author(s)       : Gaurav Halwasia
                          Shwetha Bhandari
                          Wojciech Dec
	Filename        : draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt-01.txt
	Pages           : 6
	Date            : 2012-08-13

Abstract:
   This document specifies the format and mechanism that is to be used
   for encoding client link-layer address in DHCPv6 relay forward
   messages by defining a new DHCPv6 Client Link-layer Address option.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt-01

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: perl-list <[email-masked]>
Date: Tue, 14 Aug 2012 09:28:08 -0400 (EDT)

I for one would like to thank Cisco for their work on this. My company is quite interested in this option. Does anyone know where we are in the timeline? Specifically, any estimates as to when we might see support for this in production software (I know it isn't all the way through the IETF process yet)? 

----- Original Message -----

> From: [email-masked]
> To: [email-masked]
> Cc: [email-masked]
> Sent: Monday, August 13, 2012 10:33:01 PM
> Subject: [dhcwg] I-D Action:
> draft-ietf-dhc-dhcpv6-client-link-layer-addr-opt-01.txt

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Tue, 14 Aug 2012 14:30:49 +0000

On Aug 14, 2012, at 9:28 AM, perl-list wrote:
I for one would like to thank Cisco for their work on this.  My company is quite interested in this option.  Does anyone know where we are in the timeline?  Specifically, any estimates as to when we might see support for this in production software (I know it isn't all the way through the IETF process yet)?

I'd like to see the authors bring this to WGLC quickly (like, this month).   However, that is up to them.   And of course, the working group will need to give substantive (and hopefully in-scope) review to maximize document quality.   (Yes, that is a hint! :)

---

From: Chuck Anderson <[email-masked]>
Date: Tue, 14 Aug 2012 10:07:51 -0400

I support this draft.  I wouldn't mind standardizing a way for a
client to add LL address to DHCPv6, but agree that it is probably best
to leave that for future standards action and move forward with this
draft which standardizes only having the relay agent add the LL
address.

Thanks.

---

From: Andre Kostur <[email-masked]>
Date: Tue, 14 Aug 2012 08:10:36 -0700

On Mon, Aug 13, 2012 at 7:33 PM, <[email-masked]> wrote:
>         Filename        :

I think section 2, paragraph 1 is somewhat superfluous (does it really
matter how DHCPv4 carries the link-layer address, or merely that it
does carry it in every packet?).  I think that it would be clearer to
start with paragraph 2, talking about how we wish to associate a
DHCPv6 lease with a DHCPv4 lease instead of focusing on the link-layer
address first, then talking about why it's a problem.

--
Andre Kostur

---

From: perl-list <[email-masked]>
Date: Tue, 14 Aug 2012 12:54:46 -0400 (EDT)

paragraph 1 is fine in my opinion as it does provide some background regarding how things were done. 

Also - it might be important to note in paragraph 2 that without the link layer address, there is no global way to identify DHCPv4 and DHCPv6 allocations to the same hardware as the IDs are not compatible. A lthough I have seen an RFC somewhere about making the IDs from DHCPv6 used in DHCPv4, it is unlikely that this will happen on any wide scale. It is also possible, in some cases, but not all, to extract the hardware address from the DUID (depending on what method of generation was used). Perhaps some of this logic should be added to the draft as further evidence for the need of this option? 

I don't know - the way it reads now, it sounds like it is just there to help people who haven't implemented some other available tracking method. The reality is that there isn't a reliable alternative to correlate between DHCPv4 and DHCPv6. 
----- Original Message -----

> From: "Andre Kostur" <[email-masked]>
> To: [email-masked]
> Sent: Tuesday, August 14, 2012 11:10:36 AM
> Subject: Re: [dhcwg] I-D Action:

> > This draft is a work item of the Dynamic Host Configuration Working
> > Group
> > of the IETF.
> >