Subject: [dhcwg] Load Balancing for DHCPv6

From: Andre Kostur <[email-masked]>
Date: Tue, 28 Aug 2012 09:39:32 -0700

Dear all:

I have submitted a new I-D updating RFC 3074 to apply to DHCPv6.

The text is available at:
http://www.ietf.org/internet-drafts/draft-kostur-dhc-loadbv6-00.txt

Comments and suggestions welcome.   I am looking to have the WG take
this on as a work item.

--
Andre Kostur

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 29 Aug 2012 05:10:24 +0000

Looks fine to me ... you beat me to doing this draft.

One thought I had, especially regarding the DUID-UUID, was to drop the first two octets (DUID-Type) from the hashing as that allows coverage of the full UUID. Also, the DUID-Type field hardly seems worth hashing - as there's unlikely to be much, if any, variability in that data (at best the values would be 00-01, 00-02, 00-03, or 00-04 today).

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Andre Kostur
Sent: Tuesday, August 28, 2012 12:40 PM
To: [email-masked]
Subject: [dhcwg] Load Balancing for DHCPv6

Dear all:

--
Andre Kostur
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Andre Kostur <[email-masked]>
Date: Wed, 29 Aug 2012 07:53:12 -0700

Regarding DUIDs, what I do wonder about is DUID-EN.  How many devices out
there actually use it (I have not encountered any as yet), and if they do,
how variable are the first 10-12 bytes of the data that the vendor is
choosing?   We could still skip the DUID type, but the enterprise ID will
stil have some variability across the entire population (I suppose unless
the DHCP servers are deployed in an entirely homogenous network).

On Tue, Aug 28, 2012 at 10:10 PM, Bernie Volz (volz) <[email-masked]> wrote:

> One thought I had, especially regarding the DUID-UUID, was to drop the
> first two octets (DUID-Type) from the hashing as that allows coverage of
> the full UUID. Also, the DUID-Type field hardly seems worth hashing - as
> there's unlikely to be much, if any, variability in that data (at best the
> values would be 00-01, 00-02, 00-03, or 00-04 today).
>
> - Bernie
>

-- 
 *Andre Kostur*
Senior Product Design Engineer
*P:* 604-678-2864
*E:* [email-masked]
*Toll-Free:* 1-800-877-1856

*F:* 604-678-2864
*VoIP:* sip:[email-masked]

 <http://www.incognito.com>

 <http://www.incognito.com/company/events>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Aug 2012 15:19:45 +0000

On Aug 29, 2012, at 7:53 AM, Andre Kostur <[email-masked]<mailto:[email-masked]>> wrote:
Regarding DUIDs, what I do wonder about is DUID-EN.  How many devices out there actually use it (I have not encountered any as yet), and if they do, how variable are the first 10-12 bytes of the data that the vendor is choosing?   We could still skip the DUID type, but the enterprise ID will stil have some variability across the entire population (I suppose unless the DHCP servers are deployed in an entirely homogenous network).

We're likely only getting one bit out of this hash, so I don't think this is really an issue—a pair of plaintexts that match in the first 12 bytes and differ in the last two will still be likely to produce a different result, just as if the plaintext were only two bytes.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Aug 2012 15:19:45 +0000

On Aug 28, 2012, at 10:10 PM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:
One thought I had, especially regarding the DUID-UUID, was to drop the first two octets (DUID-Type) from the hashing as that allows coverage of the full UUID. Also, the DUID-Type field hardly seems worth hashing - as there's unlikely to be much, if any, variability in that data (at best the values would be 00-01, 00-02, 00-03, or 00-04 today).

In principle, hashing the DUID type would distinguish between two DUIDs that only differed by type.   But I agree with you that it's not likely to be important—this is just a hash.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 29 Aug 2012 16:45:07 +0000

> Regarding DUIDs, what I do wonder about is DUID-EN.  How many devices out there actually use it 
> (I have not encountered any as yet), and if they do, how variable are the first 10-12 bytes of the data 
> that the vendor is choosing?   We could still skip the DUID type, but the enterprise ID will stil have some
> variability across the entire population (I suppose unless the DHCP servers are deployed in an entirely homogenous network).

Broadband Forum requires use of DUID-EN for "Residential Gateways" that wish to meet its TR-124 specification.
http://www.broadband-forum.org/technical/download/TR-124_Issue-3.pdf
Barbara

---

From: Andre Kostur <[email-masked]>
Date: Wed, 29 Aug 2012 09:57:46 -0700

> http://www.broadband-forum.org/technical/download/TR-124_Issue-3.pdf

Say, this discussion is happening because of the 16-byte limitation.
Does anybody recall why the original load balancing had the 16 byte
restriction?

-- 
Andre Kostur

---

From: Ted Lemon <[email-masked]>
Date: Wed, 29 Aug 2012 17:02:41 +0000

On Aug 29, 2012, at 9:57 AM, Andre Kostur <[email-masked]<mailto:[email-masked]>> wrote:
Does anybody recall why the original load balancing had the 16 byte
restriction?

Nope.   It might be worth visiting the question of whether the hash algorithm is the right one.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 29 Aug 2012 17:11:34 +0000

I think the reason for the limit was:

  *   Most v4 identifiers were short
  *   Longer identifiers incur more processing cost (though that is likely a minor issue)
  *   As Ted has pointed out, it is likely only 1 or perhaps 2 bits that end up being 'useful'

But, I do agree that the best is just to remove this restriction in the new v6 draft and say that the entire DUID is hashed (the DUID is limited to 128 bytes but hopefully few, if any, use anything that long).

- Bernie

From: Ted Lemon <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, August 29, 2012 1:02 PM
To: Andre Kostur <[email-masked]<mailto:[email-masked]>>
Cc: "STARK, BARBARA H" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Cisco Employee <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dhcwg] Load Balancing for DHCPv6