Subject: [dhcwg] draft-lemon-dhc-topo-conf

From: Ted Lemon <[email-masked]>
Date: Sat, 13 Apr 2013 15:19:05 -0400

I just submitted a new document to the tracker that attempts to document existing practice with respect to how DHCP options are derived and sent to clients in modern DHCP servers.   This is a first draft, and probably needs some new examples.   People on this mailing list will, I suspect, find it difficult to remain awake while reading it because it is such old hat to us, but it's been brought to my attention recently that not everybody in the IETF is an expert on DHCP server configuration; this document is an attempt to provide a short, pithy tutorial for IETF document writers who are interested in understanding how DHCP is used in practice.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-lemon-dhc-topo-conf

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-lemon-dhc-topo-conf-00

---

From: Sten Carlsen <[email-masked]>
Date: Sun, 14 Apr 2013 11:52:12 +0200

Hi

I think this is a good initiative and a good start. I hope there will be
some additional contributions from other perspectives.

My first comment is to Figure 1, you have 4 relays. They are all placed
in the gateways, it may be beneficial to place at least one of them away
from the gateway to indicate that this is also a valid configuration.

On 13/04/13 21:19, Ted Lemon wrote:
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

-- 
Best regards

Sten Carlsen

No improvements come from shouting:
       "MALE BOVINE MANURE!!!"

---

From: Ted Lemon <[email-masked]>
Date: Sun, 14 Apr 2013 14:07:17 +0000

On Apr 14, 2013, at 5:52 AM, Sten Carlsen <[email-masked]<mailto:[email-masked]>> wrote:
My first comment is to Figure 1, you have 4 relays. They are all placed in the gateways, it may be beneficial to place at least one of them away from the gateway to indicate that this is also a valid configuration.

It's certainly a "valid" configuration, but I don't think it's a common configuration, and I'm trying to describe current practice in this document, not what you "could" do.   For that, you ought to buy the DHCP Handbook!   :)

Seriously, do you know of common deployments where the relay is configured that way?   Out side of academic experiments, I'm not aware of any.   I've done that as a hack when I wanted to make the relay do something unusual, but it's always been a temporary measure on the way to getting the feature into the place where I really want it, not as an end in itself.

---

From: Sten Carlsen <[email-masked]>
Date: Mon, 15 Apr 2013 12:28:27 +0200

I don't have the information you ask for. OTOH I have seen this
particular question come up in the DHCP-users so often that it looks
like a common setup.

One possible reason to do so might be separation of responsibilities,
not that I think that is the best way but it seems to happen often anyway.

On 14/04/13 16:07, Ted Lemon wrote:
>> My first comment is to Figure 1, you have 4 relays. They are all
>> placed in the gateways, it may be beneficial to place at least one of
>> them away from the gateway to indicate that this is also a valid
>> configuration.
>
> It's certainly a "valid" configuration, but I don't think it's a
> common configuration, and I'm trying to describe current practice in
> this document, not what you "could" do.   For that, you ought to buy
> the DHCP Handbook!   :)
>
> Seriously, do you know of common deployments where the relay is
> configured that way?   Out side of academic experiments, I'm not aware
> of any.   I've done that as a hack when I wanted to make the relay do
> something unusual, but it's always been a temporary measure on the way
> to getting the feature into the place where I really want it, not as
> an end in itself.
>

-- 
Best regards

Sten Carlsen

       "MALE BOVINE MANURE!!!"

---

From: Ted Lemon <[email-masked]>
Date: Mon, 15 Apr 2013 13:58:29 +0000

On Apr 15, 2013, at 6:28 AM, Sten Carlsen <[email-masked]<mailto:[email-masked]>> wrote:
I don't have the information you ask for. OTOH I have seen this particular question come up in the DHCP-users so often that it looks like a common setup.

Fair enough.  I see it come up on dhcp-users too; it usually looks like a prototyping scenario when I've seen these questions raised.   It also makes sense in low-demand environments where you're using a native linux machine as a router.   It's probably worth mentioning this in the document; I don't think it's the most common use case, by far, but it's certainly true that you can do things this way, and the document shouldn't exclude that possibility.