Subject: [dhcwg] RFC 6925 on The DHCPv4 Relay Agent Identifier Sub-Option

From: [email-masked]
Date: Mon, 29 Apr 2013 11:50:14 -0700 (PDT)

A new Request for Comments is now available in online RFC libraries.

        RFC 6925

        Title:      The DHCPv4 Relay Agent Identifier 
                    Sub-Option 
        Author:     B. Joshi,
                    R. Desetti,
                    M. Stapp
        Status:     Standards Track
        Stream:     IETF
        Date:       April 2013
        Mailbox:    [email-masked], 
                    [email-masked], 
                    [email-masked]
        Pages:      8
        Characters: 17664
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-dhc-relay-id-suboption-13.txt

        URL:        http://www.rfc-editor.org/rfc/rfc6925.txt

This document defines a new Relay Agent Identifier sub-option for the
Dynamic Host Configuration Protocol (DHCP) Relay Agent Information
option.  The sub-option carries a value that uniquely identifies the
relay agent device within the administrative domain.  The value is
normally administratively configured in the relay agent.  The
sub-option allows a DHCP relay agent to include the identifier in the
DHCP messages it sends.

This document is a product of the Dynamic Host Configuration Working Group of the IETF.

This is now a Proposed Standard.

STANDARDS TRACK: This document specifies an Internet standards track
protocol for the Internet community,and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Internet
Official Protocol Standards (STD 1) for the standardization state and
status of this protocol.  Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  http://www.ietf.org/mailman/listinfo/ietf-announce
  http://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see http://www.rfc-editor.org/rfcsearch.html.
For downloading RFCs, see http://www.rfc-editor.org/rfc.html.

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: "Simon Hobson" <[email-masked]>
Date: Tue, 30 Apr 2013 11:56:59 +0100

>relay agent device within the administrative domain. 

I'm not clear what problem this is trying to solve, and how it's going to do it.

In the case of the factory floor network, I can't see what this identifier provides that's not already provided by the GI-Addr field. In the general case knowing the relay agent identifier won't narrow down the location of the client any further than GI-Addr. In the case where the relay agent serves multiple remote networks, it would appear that the agent identifier will be less specific than the GI-Addr.
If the clients are connected to a switch, and so multiple clients can be served by one interface, then only the switch would know the locations - and could insert Option-82 into client requests. The relay agent will not know the location (switch port) unless the switch informs it by (eg) inserting something like Option-82.

Or have I missed something ?