Subject: Re: [dhcwg] draft-lemon-dhc-topo-conf

From: "Simon Hobson" <[email-masked]>
Date: Mon, 15 Apr 2013 16:40:44 +0100

Ted Lemon wrote:
>I just submitted a new document to the tracker that attempts to document existing practice with
> respect to how DHCP options are derived and sent to clients in modern DHCP servers.   This is a
> first draft, and probably needs some new examples.   People on this mailing list will, I suspect, find
> it difficult to remain awake while reading it because it is such old hat to us, but it's been brought to
> my attention recently that not everybody in the IETF is an expert on DHCP server configuration; this
> document is an attempt to provide a short, pithy tutorial for IETF document writers who are interested
> in understanding how DHCP is used in practice.

I'd say a very good document.

I'd agree with Sten that it would be good to include a non-router relay agent. As you say, it's not a common arrangement, and that probably reinforces the false belief some people have that the agent must be in the router.
Use cases I can see would include situations where the user requires more functionality than that provided by the one embedded in their router - though I have to admit I can't think of one right now ! One that does come up on the ISC DHCP users list relates to situation where the backhaul (links C & E in your diagram) are not broadcast media and not supported by the ISC software - though that's an implementation limitation rather than anything inherent in the protocol.
Probably the most common situation is cross-department jurisdiction "issues" between those that manage the routers and those that manage the servers.

Apart from this, I think I would have been labelling the Relay Agents as Router + Relay Agent. As it stands, it appears that a relay agent is something different to a router and may be a source of confusion. Would something like this be better ?
    +---+---+
    | relay  |
    |   +   |
    | router |
    |  A   |
    +---+---+

One section did catch my eye, Section5,Dynamic Lookup where it says :
> However, all modern commercial DHCP servers handle name resolution by
> querying the resolver each time a DHCP packet comes in.
Some readers may miss the subtlety of this. Last I heard this was not the case for the ISC server (which of course isn't commercial software), but the casual reader may be left expecting this dynamic lookup from all "common" servers.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 15 Apr 2013 16:00:55 +0000

> Apart from this, I think I would have been labelling the Relay Agents as Router + Relay Agent. As it stands, it appears that a relay agent is something different to a router and may be a source of…

One of the examples I considered using was an LDRA, which is a switch, not a router.   Also, the diagram was getting crowded.   So that's why I didn't draw it that way.   But I've adjusted the text in the first to make it clear that the relay is also a router; the other example already mentioned that.   I envisioned adding a few more examples, including the LDRA example, but wanted to publish a -00 so that people could take a look at it and comment before adding more text.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 15 Apr 2013 16:41:59 +0000

(Co-chair hat mostly off.)

While fairly "basic" DHCP, it is good work as there are a lot of people out there that are not DHCP experts. So having something like this to provide them is great.

Two other concepts that are often difficult for non-DHCP experts that should be considered are:
- Shared subnets - this is where multiple subnets are in use on one wire for leasing
- Grouped subnets - this is where the giaddr or link-address are on a subnet/prefix that is not being used for address assignment and thus needs to be associated with another subnet/prefix. This is similar to the shared subnet, but no leases are being assigned from one of the subnets (the "source" subnet).

Of course, both v4 and v6 examples would be best.

(Co-chair hat on.)

Do you want a call for adoption of this work? I think it would be a good item for the WG to adopt.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ted Lemon
Sent: Monday, April 15, 2013 12:01 PM
To: Simon Hobson
Cc: <[email-masked]>
Subject: Re: [dhcwg] draft-lemon-dhc-topo-conf

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Ted Lemon <[email-masked]>
Date: Mon, 15 Apr 2013 16:49:48 +0000

> - Shared subnets - this is where multiple subnets are in use on one wire for leasing

Yup.

> - Grouped subnets - this is where the giaddr or link-address are on a subnet/prefix that is not being used for address assignment and thus needs to be associated with another subnet/prefix. This is…

Are there a lot of cases where this happens?   I know there's a lot of goo in the protocol to support this behavior, but I haven't actually seen it used in the wild.

> Do you want a call for adoption of this work? I think it would be a good item for the WG to adopt.

Yes, I was thinking a call for adoption would be a good idea.   I could also use a co-author.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 15 Apr 2013 21:57:55 +0000

>I know there's a lot of goo in the protocol to support this behavior, but I haven't actually seen it used in the wild.

Yes, it does happen. And, I suspect it will be more likely with DHCPv6 - and it gets interesting if there are ULAs or multiple prefixes from which to assign (for renumbering?).

> I could also use a co-author.

Ah ... that means "supply text" :)

We can discuss offline.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ted Lemon
Sent: Monday, April 15, 2013 12:50 PM
To: Bernie Volz (volz)
Cc: <[email-masked]>
Subject: Re: [dhcwg] draft-lemon-dhc-topo-conf

Yup.