Subject: Re: [dhcwg] draft-lemon-dhc-topo-conf

From: "Simon Hobson" <[email-masked]>
Date: Tue, 16 Apr 2013 16:45:24 +0100

Ted Lemon wrote:
>> - Grouped subnets - this is where the giaddr or link-address are on a subnet/prefix that is not being used for address assignment and thus needs to be associated with another subnet/prefix. This is similar to the shared subnet, but no leases are being assigned from one of the subnets (the "source" subnet).
>
>Are there a lot of cases where this happens?   I know there's a lot of goo in the protocol to support this behavior, but I haven't actually seen it used in the wild.

Is this latter a special case of a shared subnet (ie where one subnet is nothing but a skeleton definition), or something else ?

---

From: Ted Lemon <[email-masked]>
Date: Tue, 16 Apr 2013 16:11:48 +0000

> Is this latter a special case of a shared subnet (ie where one subnet is nothing but a skeleton definition), or something else ?

Again, I don't really know.   The link selection suboption and the subnet selection option in DHCPv4 are examples of this.   And then there are cases in provider environments where you might have a PE router connected to a bunch of links that you're treating as a single link, but you want to control the address allocation based on a link identifier (e.g., Circuit ID), for example.

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 17 Apr 2013 04:12:05 +0000

That is indeed one way you can think about it.

A v4 example is that giaddr is 10.1.0.1 and you want to allocate leases from 10.2.*.*. So you might set up a subnet for 10.1.0.0/24 and 10.2.0.0/16. No leases are configured for the 10.1.0.0/24.

There may be other considerations for the 10.1.0.0/24 - such as not do support INFORMs from that subnet; but that's a more minor detail and rarely that significant since probably there are no 'real' DHCP clients on it anyway.

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Simon Hobson
Sent: Tuesday, April 16, 2013 11:45 AM
To: [email-masked]
Subject: Re: [dhcwg] draft-lemon-dhc-topo-conf

Is this latter a special case of a shared subnet (ie where one subnet is nothing but a skeleton definition), or something else ?
_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg