Subject: [dhcwg] Review request - draft-josyula-dhc-multicast - DHCP Option for IPTV source addresses

From: Ramakanth Josyula <[email-masked]>
Date: Fri, 4 Oct 2013 12:16:59 -0600

Hi,

I have submitted the below internet draft proposing a new DHCP option for IPTV source addresses.

http://www.ietf.org/internet-drafts/draft-josyula-dhc-multicast-02.txt

I would request you to review this document and provide the comments on standardizing the same.

Please guide me through the process if I miss anything with respect to the process of the review.

Thanks and regards,

Ramakanth.

Below is the brief introduction about the background and the benefits of the proposed option :

Back ground :

IPTV Solution is widely integrated as part of the broadband networks in triple/multi play solutions. In many cases this service is run by delivering multicast streams to the IP hosts/Set top boxes connected to the home gateways.  IGMP protocol in IPv4 networks and   MLD protocol in IPv6 networks are commonly used for requesting these  multicast streams from the nearest router connected via an access network. By using the IGMP version-3 in IPv4 networks and MLD version-2 in IPv6 networks, the hosts can request multicast streams from the specific set of multicast sources.

The proposed option is intended to supply all the available IPv4 or IPv6 source addresses from which the multicast hosts can request and receive the multicast streams.

Benefits of implementing this option :

   - It provides an effective method for maintaining and updating the multicast source address information to every multicast host in the network as per their individual SLAs.

   - Intermediate access nodes can snoop this option from the DHCP messages to extend the its multicast services like : Authentication of multicast users, integrating non-source aware multicast clients etc.

   - Convergence of IPTV services from different users can be achieved at the user level irrespective of the multicast transmitting technologies used in the network. For example, any service provider who manages the aggregation
     and access networks can receive the multicast streams from different sources/networks (may not be under their own administration) and feed them to their access networks.

   - The subscribers can easily validate the quality of the service offered by different IPTV sources dynamically and switch to the interested source as per their own set of requirements.

---

From: Tom Taylor <[email-masked]>
Date: Tue, 08 Oct 2013 06:16:56 -0400

Before I actually look at the document, could I suggest that you draw it 
to the attention of the MBONED Working Group? They have a related 
problem statement document 
draft-ietf-mboned-multrans-addr-acquisition-02 that might benefit from 
adding your ideas.

Tom Taylor

On 04/10/2013 2:16 PM, Ramakanth Josyula wrote:
> *Below is the brief introduction about the background and the benefits
> of the proposed option :*
>
> *_Back ground : _*
>
> IPTV Solution is widely integrated as part of the broadband networks in
> triple/multi play solutions. In many cases this service is run by
> delivering multicast streams to the IP hosts/Set top boxes connected to
> the home gateways.  IGMP protocol in IPv4 networks and   MLD protocol in
> IPv6 networks are commonly used for requesting these  multicast streams
> from the nearest router connected via an access network. By using the
> IGMP version-3 in IPv4 networks and MLD version-2 in IPv6 networks, the
> hosts can request multicast streams from the specific set of multicast
> sources.
>
> The proposed option is intended to supply all the available IPv4 or IPv6
> source addresses from which the multicast hosts can request and receive
> the multicast streams.
>
> *_Benefits of implementing this option :_*
>
>     - It provides an effective method for maintaining and updating the
> multicast source address information to every multicast host in the
> network as per their individual SLAs.
>
>     - Intermediate access nodes can snoop this option from the DHCP
> messages to extend the its multicast services like : Authentication of
> multicast users, integrating non-source aware multicast clients etc.
>
>     - Convergence of IPTV services from different users can be achieved
> at the user level irrespective of the multicast transmitting
> technologies used in the network. For example, any service provider who
> manages the aggregation
>
>       and access networks can receive the multicast streams from
> different sources/networks (may not be under their own administration)
> and feed them to their access networks.
>
>     - The subscribers can easily validate the quality of the service
> offered by different IPTV sources dynamically and switch to the
> interested source as per their own set of requirements.
>
>
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>