Subject: [dhcwg] Fwd: New Version Notification for draft-mglt-homenet-naming-architecture-dhc-options-00.txt

From: Daniel Migault <[email-masked]>
Date: Sun, 20 Oct 2013 21:51:46 +0200

Hi,

Please find a description of DHCP options intended to configure the "IPv6
Home Network Naming Delegation". [1]

Feel free to make comments!

Best Regards,
Daniel

URL:
http://www.ietf.org/internet-drafts/draft-mglt-homenet-naming-architecture-dhc-options-00.txt
Htmlized:
http://tools.ietf.org/html/draft-mglt-homenet-naming-architecture-dhc-options-00

[1]
http://www.ietf.org/internet-drafts/draft-mglt-homenet-front-end-naming-delegation-03.txt

---------- Forwarded message ----------
From: <[email-masked]>
Date: Sun, Oct 20, 2013 at 9:41 PM
Subject: New Version Notification for
draft-mglt-homenet-naming-architecture-dhc-options-00.txt
To: Wouter Cloetens <[email-masked]>, Chris Griffiths <
[email-masked]>, Daniel Migault <[email-masked]>, Ralf Weber <
[email-masked]>

A new version of I-D,
draft-mglt-homenet-naming-architecture-dhc-options-00.txt
has been successfully submitted by Daniel Migault and posted to the
IETF repository.

Filename:        draft-mglt-homenet-naming-architecture-dhc-options
Revision:        00
Title:           DHCP DNS Public Authoritative Server Options
Creation date:   2013-10-20
Group:           Individual Submission
Number of pages: 35
URL:
http://www.ietf.org/internet-drafts/draft-mglt-homenet-naming-architecture-dhc-options-00.txt
Status:
http://datatracker.ietf.org/doc/draft-mglt-homenet-naming-architecture-dhc-options
Htmlized:
http://tools.ietf.org/html/draft-mglt-homenet-naming-architecture-dhc-options-00

Abstract:
   The home network naming architecture as described in [I-D.mglt-
   homenet-front-end-naming-delegation] requires a complex naming
   configuration on the CPE.  This configuration MAY not be handled
   easily by the average end user.  Furthermore, such misconfiguration
   MAY result in making home network unreachable.

   This document proposes a DHCP options that provide the CPE all
   necessary parameters to set up the home network naming architecture.

   First, this DHCP options provide automatic configuration and avoid
   most end users' misconfiguration.  Most average end users may not
   require specific configuration, and their ISP default configuration
   MAY fully address their needs.  In that case, the naming homenet
   architecture configuration will be completely transparent to the end
   users.  Then, saving naming configuration outside the CPE, makes it
   resilient to change of CPE or CPE upgrades.  Such configuration may
   also be configured by the end user, via the customer area of their
   ISP.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: Sten Carlsen <[email-masked]>
Date: Mon, 21 Oct 2013 00:19:28 +0200

Hi

Having read this lightly and not thoroughly it strikes me that it almost
amounts to hijacking the customers own naming efforts?  If I read this
wrongly, please excuse, my opinions may not be the general opinions.

The way I see this, is that either I know what I want and make my own
DNS-entries or I don't care, in which case there is no meaning in doing
naming for people, specially as these namings will likely not be
meaningful to people.

Just my 0.02EUR

On 20/10/13 21.51, Daniel Migault wrote:
> Hi, 
>
> Please find a description of DHCP options intended to configure
> the "IPv6 Home Network Naming Delegation". [1]
>
> URL: http://www.ietf.org/internet-drafts/draft-mglt-homenet-naming-architecture-dhc-options-00.txt
> Htmlized: http://tools.ietf.org/html/draft-mglt-homenet-naming-architecture-dhc-options-00
>
> [1]  http://www.ietf.org/internet-drafts/draft-mglt-homenet-front-end-naming-delegation-03.txt
>
>
>
> From: <[email-masked] <mailto:[email-masked]>>
> To: Wouter Cloetens <[email-masked]
> <mailto:[email-masked]>>, Chris Griffiths
> <[email-masked] <mailto:[email-masked]>>, Daniel Migault
> <[email-masked] <mailto:[email-masked]>>, Ralf Weber
> <[email-masked] <mailto:[email-masked]>>
>
>
>
> A new version of I-D,
> until the htmlized version and diff are available at tools.ietf.org
> <http://tools.ietf.org>.
>
> The IETF Secretariat
>
>
>
>
> -- 
> Daniel Migault
> Orange Labs -- Security
> +33 6 70 72 69 58 <tel:%2B33%206%2070%2072%2069%2058>
>
>
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

-- 
Best regards

Sten Carlsen

No improvements come from shouting:

       "MALE BOVINE MANURE!!!"

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 21 Oct 2013 01:09:56 +0000

These are comments with WG co-chair hat off.

I don't recall providing input to this document:

11<http://tools.ietf.org/html/draft-mglt-homenet-naming-architecture-dhc-options-00#section-11>.  Acknowledgment

We would like to thank Tomasz Mrugalski and Bernie Volz for their
   comments on the design of the DHCP Options.

And at first glance this looks like encapsulation gone crazy!!

I haven't yet read it carefully enough to determine whether this makes sense to do.

I don't like things like requiring a server to return "empty" options if it "understands" them but they were not configured (or "badly" configured). And I can't see any benefit to the client for doing this documented (there's no special action the client is specified to take) -- so why do it?

- Bernie (from iPad)

On Oct 20, 2013, at 3:52 PM, "Daniel Migault" <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Please find a description of DHCP options intended to configure the "IPv6 Home Network Naming Delegation". [1]

Best Regards,
Daniel

---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Sun, Oct 20, 2013 at 9:41 PM
Subject: New Version Notification for draft-mglt-homenet-naming-architecture-dhc-options-00.txt
To: Wouter Cloetens <[email-masked]<mailto:[email-masked]>>, Chris Griffiths <[email-masked]<mailto:[email-masked]>>, Daniel Migault <[email-masked]<mailto:[email-masked]>>, Ralf Weber <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-mglt-homenet-naming-architecture-dhc-options-00.txt
has been successfully submitted by Daniel Migault and posted to the
IETF repository.

Status:          http://datatracker.ietf.org/doc/draft-mglt-homenet-naming-architecture-dhc-options

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

--
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58<tel:%2B33%206%2070%2072%2069%2058>
_______________________________________________
dhcwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Daniel Migault <[email-masked]>
Date: Mon, 21 Oct 2013 13:21:08 +0200

Hi,

Thanks for reading it even "lightly and not thoroughly" ;-). My response is
in the text below and we will try to make it clearer in the next versions.

On Mon, Oct 21, 2013 at 12:19 AM, Sten Carlsen <[email-masked]> wrote:

> Actually that is the reverse. The DHCP options  makes possible for a user
to define its naming configuration for the homenet and push it to any CPE
that is plugged. This avoids reconfiguration when changing CPE or when the
CPE settups are erased.
Although specific configuration may concern a fraction of end users, we
believe the large portion of end users, prefers a default naming settings
that may be proposed by the DHCP.

> naming for people, specially as these namings will likely not be meaningful
> to people.
>
> Well, most of our end users do not really care about configuring DNS
architectures for their home network. At most they want it to work on a
specific domain name "example.com" so they can reach there service like "
myvideo.example.com"  from outside the homenet. This latest name is
meaningful for them, they are interested in the naming service to work
properly. However,  they are not interested in deep understanding of the
naming architecture and most probably not in how to perform key roll over.
It looks these end users are just in between your two alternatives.

Note also that you can also just ignore the DHCP Options.

Just my 0.02€
> dhcwg mailing [email-masked]://www.ietf.org/mailman/listinfo/dhcwg
>
>
> --
> Best regards
>
> Sten Carlsen
>

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: Daniel Migault <[email-masked]>
Date: Mon, 21 Oct 2013 13:53:58 +0200

Hi Bernie,

Thanks for your feed back. See my comments in the text.

On Mon, Oct 21, 2013 at 3:09 AM, Bernie Volz (volz) <[email-masked]> wrote:

>  11 <http://tools.ietf.org/html/draft-mglt-homenet-naming-architecture-dhc-options-00#section-11>.  Acknowledgment
>
>  We received comments and recommendations from the previous version on
Jul 05 -- Basically splitting the complex option we proposed, and following
(and reading) the guide lines. We expected to present our new design at
IETF87, but ran out schedule.

This is also my opinion. My understanding of the option guidelines was to
use encapsulation of options instead of specific format. We might have
mis-understood something or gone too far. Either ways I am very glad to
have your feed backs. We can easily remove some encapsulations.

>  There is no complex or hidden reasons for encapsulation. We might have
done it the wrong way. This version is expected to be a document for
discussion. We hope next versions converge quickly.

>  I don't like things like requiring a server to return "empty" options if
> it "understands" them but they were not configured (or "badly" configured).
> And I can't see any benefit to the client for doing this documented
> (there's no special action the client is specified to take) -- so why do it?
>
> The only benefit for the client is that it can decide between sending a
message with "Options not supported" or "Badly configured Homenet Naming
Architectures". We can remove this requirement.

> - Bernie (from iPad)
>
> On Oct 20, 2013, at 3:52 PM, "Daniel Migault" <[email-masked]> wrote:
>
>   Hi,
>

-- 
Daniel Migault
Orange Labs -- Security
+33 6 70 72 69 58

---

From: Sten Carlsen <[email-masked]>
Date: Mon, 21 Oct 2013 14:55:09 +0200

On 21/10/13 13.21, Daniel Migault wrote:
>
> Actually that is the reverse. The DHCP options  makes possible for a
> user to define its naming configuration for the homenet and push it to
> any CPE that is plugged. This avoids reconfiguration when changing CPE
> or when the CPE settups are erased.
> Although specific configuration may concern a fraction of end users,
> we believe the large portion of end users, prefers a default naming
> settings that may be proposed by the DHCP.
Good, I did read it and was not sure which way names were pushed - so at
least it was not clear to me.
>  
>
>     The way I see this, is that either I know what I want and make my
>     own DNS-entries or I don't care, in which case there is no meaning
>     in doing naming for people, specially as these namings will likely
>     not be meaningful to people.
>
> architectures for their home network. At most they want it to work on
> a specific domain name "example.com <http://example.com>" so they can
> reach there service like "myvideo.example.com
> <http://myvideo.example.com>"  from outside the homenet. This latest
> name is meaningful for them, they are interested in the naming service
> to work properly. However,  they are not interested in deep
> understanding of the naming architecture and most probably not in how
> to perform key roll over. It looks these end users are just in between
> your two alternatives.
I agree very much, this I believe is what most people want. I personally
want to be able to control what can reach into my home and what in the
home can reach outside, so far we are few with that wish.

After some time, privacy concerns may drive people to want more control
over what is accessible on their network from the outside and control of
naming is one step (if it has no name, less chance someone wants to talk
to it). Access control has nothing else to do with DHCP, for that you
must acquire your own firewall.
> Note also that you can also just ignore the DHCP Options.
I assume most will do that, unless some setup-wizard will help.

-- 
Best regards

Sten Carlsen

       "MALE BOVINE MANURE!!!"