Subject: [dhcwg] DHCPv6 Stateful Issues

From: Timothy Winters <[email-masked]>
Date: Mon, 3 Feb 2014 12:07:06 -0500

Hi Bernie,
	While testing some IPv6 CE Router I've noticed an issue that this draft might want to address.  When a DHCP Client receives both the IA_NA and IA_PD in the reply, the Client performs DAD on the IA_NA.   If DAD fails some implementations keep the IA_PD and try for a different IA_NA.   Other IPv6 CE Routers will Release the IA_PD in this scenario.  

	 I would think the proper thing to do would be to keep the IA_PD so your LAN as addressing.   Is something that we can talk about in this document?

~Tim

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 4 Feb 2014 13:25:28 +0000

Hi Tim:

I too would have expected just the IA_NA (IAADDR) to be declined. You don't mention what the clients are doing in this case (sending a Decline with both the IA_NA and IA_PD or sending a Release with both - or sending a Decline for the IA_NA and Release for the IA_PD)?

A DAD conflict should result in a Decline. So, it would seem to me that the added step of sending a Release for the IA_PD (IAPREFIX) is extra effort and not necessary/warranted. And I would hope these clients aren't sending a Decline for the IA_PD (IAPREFIX).

Also, did the routers doing the IA_PD Release earlier request the IA_NA and IA_PD in the same packet (transaction) or different ones?

Be nice if you had a packet trace available to see what the interaction here is?

This does sound like a candidate for discussion in the draft, but we need a bit more information before considering to add it.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Timothy Winters
Sent: Monday, February 03, 2014 12:07 PM
To: [email-masked] WG
Subject: [dhcwg] DHCPv6 Stateful Issues

Hi Bernie,

~Tim

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Timothy Winters <[email-masked]>
Date: Wed, 5 Feb 2014 11:13:37 -0500

Hi Bernie,
	I've enclosed a capture of the behavior.   This particular device did send two separate Release messages.  Let me know if you have other questions.

Regards,
Tim

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Thu, 6 Feb 2014 21:23:39 +0000

>From the packet capture it sends a Decline for the address and a Release for the prefix. While I would consider this acceptable, the Release  isn't optimum (and likely creates unnecessary overhead for both client and server). I would expect the client will Solicit and will get (another different) address and possibly the same or a different prefix. Would likely have been better for client to keep the prefix ... it can go back to Solicit asking for both, as prefix will be given to client again or based on the Stateful Issues, do a Request - but that is not presently allowed per RFC 3315.

-          Bernie

From: Timothy Winters [mailto:[email-masked]]
Sent: Wednesday, February 05, 2014 11:14 AM
To: Bernie Volz (volz)
Cc: [email-masked] WG
Subject: Re: [dhcwg] DHCPv6 Stateful Issues

Hi Bernie,

Regards,
Tim

On Feb 4, 2014, at 8:25 AM, Bernie Volz (volz) <[email-masked]<mailto:[email-masked]>> wrote:

> To: [email-masked]<mailto:[email-masked]> WG
> [email-masked]<mailto:[email-masked]>