Subject: [dhcwg] draft-jiang-dhc-stateless-reconfiguration-01

From: Yusuke DOI <[email-masked]>
Date: Mon, 17 Feb 2014 11:16:00 +0900

Hi,

Let me speak out (again) that I'm interested in the following draft in the context of roll/6lo-ish LLN, in particular, over 802.15.4.

>         Title           : Stateless Reconfiguration in Dynamic Host Configuration Protocol for IPv6 (DHCPv6)
>         Authors         : Sheng Jiang
>                           Bing Liu
> 	Filename        : draft-jiang-dhc-stateless-reconfiguration-01.txt

We have an application of DHCPv6 that may use statelss mode to deliver network configurations to nodes over wireless mesh network (=> draft-doi-roll-mpl-parameter-configuration-04). Stateless mode is preferred on traffic efficiency (periodic renewal traffic is not preferred on LLN). However sometimes we may need to update configured parameters. We definitely need stateless reconfiguration.

>    {Question to WG No.1} There are three potential mechanisms to create
>    relay agent destinations on the DHCPv6 server:

We prefer b) to remove duplicated messages.

>    {Question to WG No.2} There could be two kind of stateless DHCPv6
>    reconfiguration modes as the following, which one is proper?  Or we
>    should support both?

Is there any difficulty to support both modes? I think these two modes should have different use cases. 'Push mode' will fit to our use case because the configuration is network-wide and push-mode (with multicast target -- it can be broadcasted on a link) is much much more efficient than trigger mode in LLN. But some administrator may want to have per-client configuration and that is the nature of DHCP, as described.

Regards,

// Yusuke DOI <[email-masked]>

---

From: Sheng Jiang <[email-masked]>
Date: Mon, 17 Feb 2014 05:42:35 +0000

Hi, Yusuke,

Thanks for your reply and support. Some explanation below.

>Is there any difficulty to support both modes? I think these two modes should
>have different use cases. 'Push mode' will fit to our use case because the
>configuration is network-wide and push-mode (with multicast target -- it can
>be broadcasted on a link) is much much more efficient than trigger mode in
>LLN. But some administrator may want to have per-client configuration and
>that is the nature of DHCP, as described.

The difficulty is no technical aspect. However, there are two considerations for push mode:

a) the push mode is different from traditional DHC behavior in that clients is the initiator. So, this would need the agreement of DHC WG However, even the existing reconfiguration in stateful DHCPv6 is initiated by server side. So, this may not be too controversial. It is still a question requiring confirmation for now.

b) "push mode' may have more security issues that trigger mode. How to prevent a fake DHCPv6 server push malicious configuration is a difficulty, although DHCPv6 snooping may help. "Trigger mode" is safer for that client would contact original server for update configuration.

Regards,

Sheng

>_______________________________________________
>dhcwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dhcwg