Subject: [dhcwg] Question on relay agent behavior in DHCPv6 prefix delegation

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 3 Feb 2014 16:49:19 +0000

Hi, RFC3633 says:

"14.  Relay agent behavior

   A relay agent forwards messages containing Prefix Delegation options
   in the same way as described in section 20, "Relay Agent Behavior" of
   RFC 3315.

   If a delegating router communicates with a requesting router through
   a relay agent, the delegating router may need a protocol or other
   out-of-band communication to add routing information for delegated
   prefixes into the provider edge router."

My question is, since the publication of RFC3633 has there been a
new RFC published that specifies "a protocol or other out-of-band
communication to add routing information"?

Thanks - Fred
[email-masked]

---

From: Andre Kostur <[email-masked]>
Date: Mon, 3 Feb 2014 09:35:33 -0800

The RFC doesn't get into details since it may not even be the
delegating router doing the route updates.   As an example, in a cable
network, it may be the CMTS (who plays the role of Relay Agent from
DHCPv6's perspective) who is snooping the PD traffic and may emit the
appropriate routing updates into the network (using some other
standard dynamic routing protocol such as OSPF).

On Mon, Feb 3, 2014 at 8:49 AM, Templin, Fred L
<[email-masked]> wrote:
> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg

-- 
Andre Kostur

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 3 Feb 2014 18:10:48 +0000

Hi Andre,

> -----Original Message-----
> From: Andre Kostur [mailto:[email-masked]]
> Sent: Monday, February 03, 2014 9:36 AM
> To: Templin, Fred L
> Cc: [email-masked] WG
> Subject: Re: [dhcwg] Question on relay agent behavior in DHCPv6 prefix delegation
> 

Thanks for this. So, it seems that the RFC3633 DHCPv6 relays (and maybe
also servers) can snoop the PD exchanges and update the routing system
via some unspecified means. But, are there any more recent publications
that have either attempted or succeeded in specifying a standard method?

Thanks - Fred

---

From: Ted Lemon <[email-masked]>
Date: Mon, 3 Feb 2014 14:41:17 -0500

On Feb 3, 2014, at 1:10 PM, Templin, Fred L <[email-masked]> wrote:
> But, are there any more recent publications

I can't think of any.

---

From: Ralph Droms <[email-masked]>
Date: Mon, 3 Feb 2014 14:57:01 -0500

>> that have either attempted or succeeded in specifying a standard method?

"DHCP Relay Agent Assignment Notification Option" <draft-droms-dhc-dhcpv6-agentopt-delegate>, R. Droms, B. Volz, O. Troan

1.  Introduction

   The DHCP Relay Agent Assignment Notification option encapsulates
   address and prefix options to indicate that an address or prefix has
   been assigned.  The option may also carry other information required
   by the network element for configuration related to the assigned
   address or prefix.

   For example, a network administrator uses the DHCP Relay Agent
   Assignment Notification option to inform a relay agent of a prefix
   that has been delegated through DHCP PD to a DHCP client.  The relay
   agent notifies the network element on which the it is implemented of
   the delegation information so the network element can add routing
   information about the delegated prefix into the appropriate routing
   protocols.

The dhc WG discussed the idea and decided not to take on the work due to some fundamental issues in using the option reliably; e.g., ensuring that all DHCPv6 messages were relayed through the device that was actually interested in configuring itself for the delegated prefix.

The idea was to formalize what is now accomplished through snooping.

- Ralph

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 3 Feb 2014 22:01:11 +0000

Hi Ralph,

> From: Ralph Droms [mailto:[email-masked]]
> Sent: Monday, February 03, 2014 11:57 AM
> To: Templin, Fred L
> Cc: [email-masked] WG; Andre Kostur; Lemon Ted
> The dhc WG discussed the idea and decided not to take on the work due to some fundamental issues in
> using the option reliably; e.g., ensuring that all DHCPv6 messages were relayed through the device
> that was actually interested in configuring itself for the delegated prefix.

Thanks, I think I remember this now. I now have a use case where it is
possible to ensure that all DHCPv6 messages are relayed through the same
device. Would it make sense to revive this work and try again?

> The idea was to formalize what is now accomplished through snooping.

Is this kind of snooping for the purpose of routing system manipulation
seen in common practice today?

Thanks - Fred

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 04 Feb 2014 15:05:42 +0100

> that have either attempted or succeeded in specifying a standard method?

Solutions (like 'snooping') to the problem have been explored in a 
number of documents at IETF and others.

I with co-authors have attempted to formulate it as a problem in October 
2014, and analyzed some solutions
"Route Problem at Relay during DHCPv6 Prefix Delegation"
draft-petrescu-relay-route-pd-problem-00.txt

Alex

---

From: "Templin, Fred L" <[email-masked]>
Date: Tue, 4 Feb 2014 16:31:52 +0000

Hi Alex,

> From: dhcwg [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
> Sent: Tuesday, February 04, 2014 6:06 AM
> To: [email-masked]

I have been down this road before too, and can dig up some of my
old expired drafts if there is interest. I also remember being
actively engaged in the RAAN option discussions a long while back
and sort of lost track of where that all ended up, but thanks to
Ralph for his update on the status.

> draft-petrescu-relay-route-pd-problem-00.txt

That is interesting. Are you planning to continue this work?

Thanks - Fred

---

From: Ralph Droms <[email-masked]>
Date: Tue, 4 Feb 2014 11:33:46 -0500

> device. Would it make sense to revive this work and try again?

I can't speak for the WG.  I recommend you review the discussion of the previous draft in detail and be sure to address the issues raised there...

> seen in common practice today?

Cisco implements snooping.  I can't say how widely it is used.

- Ralph

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 04 Feb 2014 17:55:52 +0100

Le 04/02/2014 17:31, Templin, Fred L a écrit :
> Hi Alex,
>
>> -----Original Message----- From: dhcwg
>> [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
>> Sent: Tuesday, February 04, 2014 6:06 AM To: [email-masked]
>>>> -----Original Message----- From: Andre Kostur
>>>> [mailto:[email-masked]] Sent: Monday, February 03, 2014
>>>> 9:36 AM To: Templin, Fred L Cc: [email-masked] WG Subject: Re:
>>>> [dhcwg] Question on relay agent behavior in DHCPv6 prefix
>>>> delegation
>>>>
>>>> delegating router doing the route updates.   As an example, in
>>>> a cable network, it may be the CMTS (who plays the role of
>>>> Relay Agent from DHCPv6's perspective) who is snooping the PD
>>>> traffic and may emit the appropriate routing updates into the
>>>> network (using some other standard dynamic routing protocol
>>>> such as OSPF).
>>>
>>> Thanks for this. So, it seems that the RFC3633 DHCPv6 relays (and
>>> maybe also servers) can snoop the PD exchanges and update the
>>> routing system via some unspecified means. But, are there any
>>> more recent publications that have either attempted or succeeded
>>> in specifying a standard method?
>>
> I have been down this road before too, and can dig up some of my old
> expired drafts if there is interest. I also remember being actively
> engaged in the RAAN option discussions a long while back and sort of
> lost track of where that all ended up, but thanks to Ralph for his
> update on the status.
>
>> I with co-authors have attempted to formulate it as a problem in
>> October 2014, and analyzed some solutions "Route Problem at Relay
>> during DHCPv6 Prefix Delegation"

Well yes.

I have spent some time identifying interested parties, and laid down a
problem draft.  I have presented it to DHC WG, got feeback, and
subsequently announced it on the RTGAREA email list.

I think that formulating a problem meaningfully may help, some times,
designing solutions.  A future solution to this problem may be useful
beyond DHC WG.

Hence my interest.  It's rather speculative, but there it is.

Alex

>
> Thanks - Fred [email-masked]
>
>> Alex
>>
>>>
>>> Thanks - Fred [email-masked]
>>>
>>>>> A relay agent forwards messages containing Prefix Delegation
>>>>> options in the same way as described in section 20, "Relay
>>>>> Agent Behavior" of RFC 3315.
>>>>>
>>>>> If a delegating router communicates with a requesting router
>>>>> through a relay agent, the delegating router may need a
>>>>> protocol or other out-of-band communication to add routing
>>>>> information for delegated prefixes into the provider edge
>>>>> router."
>>>>>
>>>>> My question is, since the publication of RFC3633 has there
>>>>> been a new RFC published that specifies "a protocol or other
>>>>> out-of-band communication to add routing information"?
>>>>>
>>>>> Thanks - Fred [email-masked]
>>>>>
>>>>> _______________________________________________ dhcwg mailing
>>>>> list [email-masked]
>>>> -- Andre Kostur
>>> _______________________________________________ dhcwg mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg
>>>
>>>
>>
>>
>> _______________________________________________ dhcwg mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/dhcwg
>
>