Subject: [dhcwg] WGLC for draft-ietf-dhc-dhcpv4-active-leasequery-00 - Respond by Feb. 28

From: Tomek Mrugalski <[email-masked]>
Date: Tue, 11 Feb 2014 21:38:24 +0100

We have adopted two active leasequery drafts after Vancouver meeting.
There was moderate interest in that work during adoption call, but
we never saw any discussions about them on the ML. Since authors
confidence in those proposals are high due to existing implementations,
they have requested WGLC.

After a quick discussion between chairs, we have decided to go ahead
with the WGLC, hoping that it will trigger some reviews and discussion.
Please make no mistake - those drafts need reviews and comments. A
simple "I support this" followed with couple +1s will not do do the
trick here.

This WGLC is for draft-ietf-dhc-dhcpv4-active-leasequery-00. Please send
your comments by Feb. 28th. Note that although both documents are very
similar, they are separate drafts and are going through separate WGLCs.
If you support this work, make sure that you clearly state which draft
(v4, v6 or both) you support. Each WGLC will be assessed independently.

Finally, I'd also remind you that we are looking for volunteers to do
the shepherding work. Please let us know if you'd like to be a shepherd
for one of those documents. It is not a difficult task, but some prior
IETF experience is necessary. As a shepherd, you can get unique insight
into the WGLC process and better exposure to how IESG works. Having such
an experience can be useful with moving your own draft forward faster.

Bernie & Tomek

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 24 Feb 2014 19:42:17 +0000

Reminder that this WGLC is outstanding.

We need feedback in order to determine whether to advance this document.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Tomek Mrugalski
Sent: Tuesday, February 11, 2014 3:38 PM
To: dhcwg
Subject: [dhcwg] WGLC for draft-ietf-dhc-dhcpv4-active-leasequery-00 - Respond by Feb. 28

We have adopted two active leasequery drafts after Vancouver meeting.
There was moderate interest in that work during adoption call, but we never saw any discussions about them on the ML. Since authors confidence in those proposals are high due to existing implementations, they have requested WGLC.

After a quick discussion between chairs, we have decided to go ahead with the WGLC, hoping that it will trigger some reviews and discussion.
Please make no mistake - those drafts need reviews and comments. A simple "I support this" followed with couple +1s will not do do the trick here.

This WGLC is for draft-ietf-dhc-dhcpv4-active-leasequery-00. Please send your comments by Feb. 28th. Note that although both documents are very similar, they are separate drafts and are going through separate WGLCs.
If you support this work, make sure that you clearly state which draft (v4, v6 or both) you support. Each WGLC will be assessed independently.

Finally, I'd also remind you that we are looking for volunteers to do the shepherding work. Please let us know if you'd like to be a shepherd for one of those documents. It is not a difficult task, but some prior IETF experience is necessary. As a shepherd, you can get unique insight into the WGLC process and better exposure to how IESG works. Having such an experience can be useful with moving your own draft forward faster.

Bernie & Tomek

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: Kim Kinnear <[email-masked]>
Date: Thu, 27 Feb 2014 10:42:57 -0500

I wrote this draft, and believe that it should be moved forward.

I would sure appreciate some additional eyes on it if we elect to
move it forward, as I'm sure there are things that we've missed.

Regards -- Kim

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Thu, 27 Feb 2014 17:28:49 +0000

I read the document and it looks good to move forward.  Thanks for putting together this document. 

Cheers,

Hemant

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Kim Kinnear (kkinnear)
Sent: Thursday, February 27, 2014 10:43 AM
To: Bernie Volz (volz)
Cc: dhcwg; Kim Kinnear (kkinnear)
Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-dhcpv4-active-leasequery-00 - Respond by Feb. 28

I would sure appreciate some additional eyes on it if we elect to move it forward, as I'm sure there are things that we've missed.

Regards -- Kim

---

From: Ian Farrer <[email-masked]>
Date: Thu, 27 Feb 2014 20:29:37 +0100

I’ve read the draft and can see some potentially useful applications for this, so I think it should be moved forward.

Cheers,
Ian

---

From: Lewis Donzis <[email-masked]>
Date: Thu, 27 Feb 2014 14:01:37 -0600 (CST)

I also have read the draft and agree that it should be moved forward.

We have already implemented a client and have experience with this
protocol in large production networks, and it has proven to be extremely
useful and has significant advantages over standard leasequery.

This may be outside the scope of this discussion, but it would be nice if
the specification included, perhaps in section 7, that the server MUST or
at least SHOULD include lease state changes for both dynamic and reserved
addresses.  There has been some ambiguity on this and it would be nice if
all implementations were consistent in this regard.  At a minimum, the
DHCP server should provide the same information via active leasequery that
it provides via standard leasequery.

lew

> > This WGLC is for 
> draft-ietf-dhc-dhcpv4-active-leasequery-00. Please send

---

From: Qi Sun <[email-masked]>
Date: Fri, 28 Feb 2014 17:26:07 +0800

I have read this document, and I support this document to move forward.

A small suggestion:
Would it be helpful if there is a reference to related section of RFC6926 when the query-start-time option is first mentioned? Because I'm not quite familiar with RFC6929, it confuses me a little on what the query-start-time option is used for. 
BTW, I'm OK with the current shape if the option should be a well-known option. 

Thanks!

Best Regards,
Qi