Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-access-network-identifier-05 - Respond by Jan. 12th

From: Sheng Jiang <[email-masked]>
Date: Mon, 12 Jan 2015 06:10:41 +0000

As the document shepherd, I have reviewed this document. In principle, I have no objection to move this document forward. I can confirm most of my previous comments have been taken cared on some level.

However, there are still many minor issues and nits, which I think need to be fixed before sending to IESG. One of such examples, which I don't understand why, is that several "MUST" have recently changed to be "must" in the latest version (the previous "MUST" was correct for my eyes).

Best regards,

Sheng

>-----Original Message-----
>From: dhcwg [mailto:[email-masked]] On Behalf Of Tomek
>Mrugalski
>Sent: Friday, December 19, 2014 2:47 AM
>To: dhcwg
>Subject: [dhcwg] WGLC for draft-ietf-dhc-access-network-identifier-05 -
>Respond by Jan. 12th
>
>Hello everyone,
>
>Authors feels that this document is ready for WGLC, so here it is. This
>message starts the DHC working group last call for "Access Network
>Identifier Option in DHCP"
>(draft-ietf-dhc-access-network-identifier-05), which is a standards
>track document.
>
>The draft is available at:
>http://tools.ietf.org/html/draft-ietf-dhc-access-network-identifier-05
>
>As there is a slower time approaching with many people expected to
>finally go off-line for a while, this WGLC is longer than usual. Please
>send your comments by Jan. 12th, 2015. If you do not feel this document
>should advance, please state your reasons why.
>
>There are no IPR claims reported at this time.
>
>Sheng Jiang is the assigned shepherd for this document.
>
>Bernie & Tomek
>
>_______________________________________________
>dhcwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Gaurav Halwasia (ghalwasi)" <[email-masked]>
Date: Mon, 12 Jan 2015 09:06:09 +0000

I have read and reviewed this draft earlier and I think this document
should advance. 

Thanks
Gaurav

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 14 Jan 2015 19:31:17 +0000

Sorry for being a bit late with comments, but I'm on vacation.

I did review the document and while I think in general the options follow the guidelines, I do have some concerns with the way some of the options are documented and formatted. Most of this is just making the field descriptions and like more "DHCPish".

So, I plan (once back from vacation) to take the pen to update the document (easier than outlining the list of issues). Then general concerns include:
1. Option field descriptions. For example, many say that (sub) option length does not include code and length, but we generally already know that in DHCP so probably best NOT to include. We should just say "length of the option data" or something similar.
2. Use of Relay agent suboption numbers in the client option. There's nothing wrong with this, but it isn't mentioned until the very end so I want to make sure that is pointed out early -- this is more in case someone wants to add new ones at a later date that they realize that there is one numbering space for the suboptions -- the Relay Agent suboptions.
3. Diagrams - section 4.2 has a "Reserved" field in the diagram, but it seems to have been dropped (based on length and lack of field description).
4. Paragraph breaks. For example, in 4.3.1 the encoding requirement for UTF-8 should be a separate paragraph to assure it is clear that this applies to all network names (not just PLMN).
5.There is a bit more -- that's just a few highlights.

(I will also look into the issues raised by Sheng below regarding MUST.)

I do have some questions ... in a few cases there is a minimum length for fields (such as 4.3.1 Network Name) specified for the length field. I can understand that having an empty Network name is not a good idea (so >0 would be appropriate), but why is it 2 characters? I am just concerned whether this might have been a hold over when someone though the length might include the code and length?

Tomek and I will discuss this draft later this week to see if it could be considered to have passed WGLC and issue a statement based on our evaluation. I do feel that the feedback on the draft was very light (though not against). The question will be whether the edits are sufficient to suggest another last call (perhaps a short one) and whether we feel anyone else might comment.

This draft has a somewhat lower bar than usual as we normally wouldn't be too deeply involved in this kind of work (since the Option Guidelines should be followed and the work would be done in a group that better understands the data being conveyed and how it might be used); but there is no such other WG and hence it ended up with DHC.

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: Monday, January 12, 2015 1:11 AM
To: Tomek Mrugalski; dhcwg
Subject: Re: [dhcwg] WGLC for draft-ietf-dhc-access-network-identifier-05 - Respond by Jan. 12th

Best regards,

Sheng

---

From: Tomek Mrugalski <[email-masked]>
Date: Thu, 15 Jan 2015 18:20:25 +0100

I have no objections for this draft to move forward. I did a detailed
review of an earlier version of this draft. My comments were fully
addressed in this revision. I don't have any new comments at this time.

Tomek