Subject: [dhcwg] I-D Action: draft-ietf-dhc-dhcpv6-yang-00.txt

From: [email-masked]
Date: Fri, 16 Oct 2015 04:27:22 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Dynamic Host Configuration Working Group of the IETF.

        Title           : YANG Data Model for DHCPv6 Configuration
        Authors         : Yong Cui
                          Hao Wang
                          Linhui Sun
                          Ted Lemon
                          Ian Farrer
	Filename        : draft-ietf-dhc-dhcpv6-yang-00.txt
	Pages           : 84
	Date            : 2015-10-16

Abstract:
   There has no unified method to configure DHCPv6 server ,relay and
   client itself, always pre-configured manually by operators.

   IETF netmod WG has developed a general data model for NETCONF
   protocol, YANG data model [RFC6020].

   This document defines a YANG data model for the configuration and
   management of DHCPv6 server, DHCPv6 relay and DHCPv6 client.  With
   this model, the operators can configure and manage the devices by
   using NETCONF.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dhc-dhcpv6-yang/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-dhc-dhcpv6-yang-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Linhui Sun <[email-masked]>
Date: Sat, 17 Oct 2015 10:33:48 +0800

Hi all,

We have updated the WG version for the DHCPv6 YANG model. The major changes
from the version in Prague include,

1) Resolve the DUID issue by defining an union type.

2) Add "new-or-standard-option" container for the model extensibility and
also provide a generic form to configure options.

3) Fix the YANG model grammar errors, fulfill the description of data nodes.

Could you please review the draft and your valuable comments are more than
welcome.

Best regards,
Linhui

2015-10-16 19:27 GMT+08:00 <[email-masked]>:

> _______________________________________________
> dhcwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dhcwg
>