Subject: [dhcwg] FW: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

From: Sunil Gandhewar <[email-masked]>
Date: Thu, 1 Oct 2015 17:51:35 +0000

DHC WG members,

This is the DHCPv6 version for the Relay Initiated Release.

The updates in this version mainly focuses on the applicability of the functionality and describes different possible configurations where this functionality could be useful. 

In this version we described the importance of the functionality from the Service Provider's point of view, where they would like to stress on limitation on the amount of resources rather than the IPv6 addresses. We added the use cases for this functionality and described configurable behavior at different network devices.

This version is an update as per the comments from DHC WG members, different vendors and implementers of the DHCPv6 protocol as well as the Service Providers.

Looking forward for comments from you. Thanks in advance.

Regards,
Sunil Gandhewar
Juniper Networks, Inc.
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 01, 2015 9:51 PM
To: Sunil Gandhewar; Sunil Gandhewar
Subject: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

A new version of I-D, draft-gandhewar-dhc-v6-relay-initiated-release-01.txt
has been successfully submitted by Sunil M. Gandhewar and posted to the IETF repository.

Name:		draft-gandhewar-dhc-v6-relay-initiated-release
Revision:	01
Title:		DHCPv6 Relay Initiated Release
Document date:	2015-10-01
Group:		Individual Submission
Pages:		14
URL:            https://www.ietf.org/internet-drafts/draft-gandhewar-dhc-v6-relay-initiated-release-01.txt
Status:         https://datatracker.ietf.org/doc/draft-gandhewar-dhc-v6-relay-initiated-release/
Htmlized:       https://tools.ietf.org/html/draft-gandhewar-dhc-v6-relay-initiated-release-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-gandhewar-dhc-v6-relay-initiated-release-01

Abstract:
   The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) is
   initiated by a DHCPv6 client.  A DHCPv6 server can force DHCPv6
   client to send RENEW or INFORMATION-REQUEST by sending a RECONFIGURE
   message.  There may be multiple DHCPv6 network devices connected in
   between a DHCPv6 client and a server, each one reserving resources
   for the DHCPv6 client.  There are no DHCPv6 messages that a relay can
   initiate in order to control the client binding.

   A DHCPv6 client may not always send a RELEASE message when it no
   longer needs the IPv6 address or prefix and network resources for the
   associated services it is using.  This document specifies a way to
   request release to be initiated by an intermediate DHCPv6 network
   device, e.g.  DHCPv6 relay, on behalf of DHCPv6 client.  This helps
   to relinquish network resources sooner than the lease expiration
   time.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dan Seibel <[email-masked]>
Date: Fri, 2 Oct 2015 08:13:22 -0600

I support this draft and think it could provide value in the service provider context.

Thanks

Dan

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Sunil Gandhewar
Sent: Thursday, October 01, 2015 11:52 AM
To: [email-masked]
Cc: Sunil Gandhewar
Subject: [dhcwg] FW: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

DHC WG members,

Regards,
Sunil Gandhewar
Juniper Networks, Inc.
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 01, 2015 9:51 PM
To: Sunil Gandhewar; Sunil Gandhewar
Subject: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

Abstract:

The IETF Secretariat

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Topazi, Chris (CCI-Atlanta)" <[email-masked]>
Date: Fri, 2 Oct 2015 14:10:59 +0000

We believe that this is a good feature to release resources which could otherwise be tied up for a much longer period of time. We would like to see this, and the DHCPv4 version, as an RFC. While with DHCPv6, we are not as concerned with address management as we are with the DHCPv4 case, this feature helps us keep better track of active leases and aids us in troubleshooting customer issues with connectivity, especially in our DOCSIS and PON networks, where we often do not have direct connectivity to the CPE behind the access device.
We support both the DHCPv6 and DHCPv4 versions of the DHCP relay initiated release to become an RFC.

Regards,
Chris  
________________________
Chris Topazi
Access Engineering
Cox Communications
(404) 269-1021 office
(404) 308-8278 mobile

-----Original Message-----
From: Sunil Gandhewar [mailto:[email-masked]] 
Sent: Thursday, October 01, 2015 1:52 PM
To: [email-masked]
Cc: Sunil Gandhewar
Subject: FW: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

DHC WG members,

Regards,
Sunil Gandhewar
Juniper Networks, Inc.
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 01, 2015 9:51 PM
To: Sunil Gandhewar; Sunil Gandhewar
Subject: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

Abstract:

The IETF Secretariat

---

From: "Twogood, DeAun" <[email-masked]>
Date: Wed, 7 Oct 2015 17:15:14 +0000

Hello,

I reviewed the drafts for both DHCPv4 and DHCPv6. I feel this is very good, a nice feature to release resources which would be otherwise stuck for a long duration.  This will dramatically improve the scaling numbers for systems. We would like to see this as RFC. We support both the versions i.e. for DHCPv4 and DHCPv6 to become RFC.

Regards,

DeAun Twogood
North America CW Program Manager
Global Contingent Workforce

-----Original Message-----
From: Sunil Gandhewar [mailto:[email-masked]] 
Sent: Thursday, October 01, 2015 1:52 PM
To: [email-masked]
Cc: Sunil Gandhewar
Subject: FW: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

DHC WG members,

Regards,
Sunil Gandhewar
Juniper Networks, Inc.
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 01, 2015 9:51 PM
To: Sunil Gandhewar; Sunil Gandhewar
Subject: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

Abstract:

The IETF Secretariat

---

From: "Bhawtankar, Jaya T." <[email-masked]>
Date: Thu, 8 Oct 2015 13:34:12 +0000

I believe this is a valuable feature to release the resources earlier, which otherwise would be stuck for a long time. I fully support both the versions, 
DHCPv4 and DHCPv6, would like to see they become RFCs.

Thanks,
Jaya Bhawtankar
Lead Engineer
Coriant

-----Original Message-----
From: Sunil Gandhewar [mailto:[email-masked]] 
Sent: Thursday, October 01, 2015 12:52 PM
To: [email-masked]
Cc: Sunil Gandhewar
Subject: FW: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

DHC WG members,

Regards,
Sunil Gandhewar
Juniper Networks, Inc.
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 01, 2015 9:51 PM
To: Sunil Gandhewar; Sunil Gandhewar
Subject: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

Abstract:

The IETF Secretariat

---

From: Phill Magill <[email-masked]>
Date: Mon, 12 Oct 2015 13:02:56 +0000

Hi,

I have reviewed this draft both DHCPv4 and DHCPv6 and feel that this has some real world application and will help us free up much needed resources. This will also help the scalability of our systems dramatically.

I support this to become an RFC.

Rgds
Phill

Phill Magill | Head of Network Innovation | Innovation and Architecture |
TalkTalk Technology | part of the TalkTalk Group plc

1 Siemens Road, Northbank Industrial Estate, Irlam, Manchester M44 5AH | Internal 440 2159, External 0161 222 2159, Mobile 07929 160 888

[email-masked] | www.talktalk.co.uk

-----Original Message-----
From: Sunil Gandhewar [mailto:[email-masked]] 
Sent: 01 October 2015 18:52
To: [email-masked]
Cc: Sunil Gandhewar
Subject: FW: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

DHC WG members,

Regards,
Sunil Gandhewar
Juniper Networks, Inc.
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 01, 2015 9:51 PM
To: Sunil Gandhewar; Sunil Gandhewar
Subject: New Version Notification for draft-gandhewar-dhc-v6-relay-initiated-release-01.txt

Abstract:

The IETF Secretariat

##############################################################################
This communication together with any attachments transmitted with it
("this E-Mail") is intended only for the use of the addressee and may contain
information which is privileged and confidential. If the reader of this E-Mail
is not the intended recipient or the employee or agent responsible for
delivering it to the intended recipient you are hereby notified that any use,
dissemination, forwarding, printing or copying of this E-Mail is strictly
prohibited. Addressees should check this E-mail for viruses. The Company makes
no representations as regards the absence of viruses in this E-Mail. If you
have received this E-Mail in error please notify our IT Service Desk
immediately by e-mail at [email-masked] Please then immediately
delete, erase or otherwise destroy this E-Mail and any copies of it.

Any opinions expressed in this E-Mail are those of the author and do not
necessarily constitute the views of the Company. Nothing in this E-Mail shall
bind the Company in any contract or obligation.

For the purposes of this E-Mail "the Company" means TalkTalk Telecom Group PLC
and/or any of its subsidiaries.

Please feel free to visit our website: www.talktalkgroup.com 

TalkTalk Telecom Group Plc (Registered in England & Wales No. 7105891)
11 Evesham Street, London W11 4AR
##############################################################################