Subject: Re: [dhcwg] DHCPv6 RENEW with a new address

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Fri, 9 Dec 2016 13:56:24 +0000

Hi,

I posted this question in dhcp-users group. Since there was no answer, I am resending the same question to DHCWG. 

> > Hi,
>>
> > What would be a real life use case (even better, use cases) for 
> > getting a new address during the IPv6 address renewal?
>>
> >> Thanks,
> > Dusan.

18.1.3. Creation and Transmission of Renew Messages
    "The server may also add new addresses to the IA. "
    "The server may remove addresses from the IA by setting the preferred and valid lifetimes of those addresses to zero."

When will server do this? How can I test it?

Regards,
Dusan.

-----Original Message-----
From: dhcp-users [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, November 24, 2016 7:00 AM
To: [email-masked]
Subject: dhcp-users Digest, Vol 97, Issue 16

Send dhcp-users mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.isc.org_mailman_listinfo_dhcp-2Dusers&d=DQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=bJvWui61rhgrP19VTIFe8ZmEgn8gb0lK0b29th12ekc&s=Bvgv76PzHyLYpsyoPoihwhizQ7bhyZt9SXyXYOyteTA&e=
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific than "Re: Contents of dhcp-users digest..."

Today's Topics:

   1. Re: DHCPv6 RENEW with a new address (Mudric, Dusan (Dusan))

----------------------------------------------------------------------

Message: 1
Date: Wed, 23 Nov 2016 14:39:47 +0000
From: "Mudric, Dusan (Dusan)" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: Re: DHCPv6 RENEW with a new address
Message-ID:
	<[email-masked]>
	
Content-Type: text/plain; charset="us-ascii"

On RENEW, it is allowed to remove the old IPv6 address and add a new one:

https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc3315-23section-2D18.1.3&d=DQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=bJvWui61rhgrP19VTIFe8ZmEgn8gb0lK0b29th12ekc&s=9wJndZlFqkiC7Dx4A4Cykpsgx1MtPKxUcrnOk7ssG7I&e= 

18.1.3. Creation and Transmission of Renew Messages
    "The server may also add new addresses to the IA. "
    "The server may remove addresses from the IA by setting the preferred and valid lifetimes of those addresses to zero."

When will server do this? After an outage?

Regards,
Dusan.

> Date: Tue, 22 Nov 2016 10:00:03 -0500 (EST)
> From: perl-list <[email-masked]>
> To: Users of ISC DHCP <[email-masked]>
> Subject: Re: DHCPv6 RENEW with a new address
> Message-ID:
>	<[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
> I don't think that it would ever happen quite that way. If the renewal failed, at the end of the lease, the client > device should send a solicit message which could result in a new address (or the same address the client had > before). I don't think the client can get a new (different?) address during renewal? 
>
> Anyone else? 
>
> > From: "Mudric, Dusan (Dusan)" <[email-masked]>
> > To: [email-masked]
> > Sent: Tuesday, November 22, 2016 9:07:05 AM
> > Subject: DHCPv6 RENEW with a new address
> >
> > Hi,
>>
> > What would be a real life use case (even better, use cases) for 
> > getting a new address during the IPv6 address renewal?
>>
> >> Thanks,
> > Dusan.

------------------------------

Subject: Digest Footer

_______________________________________________
dhcp-users mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__lists.isc.org_mailman_listinfo_dhcp-2Dusers&d=DQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=bJvWui61rhgrP19VTIFe8ZmEgn8gb0lK0b29th12ekc&s=Bvgv76PzHyLYpsyoPoihwhizQ7bhyZt9SXyXYOyteTA&e= 

------------------------------

End of dhcp-users Digest, Vol 97, Issue 16
******************************************

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Fri, 9 Dec 2016 16:07:10 +0000

The most likely cases are if there has been a reconfiguration on the server or a network renumbering event has occurred (which might add a new prefix before an old one is removed).

An easy way to test this is to change the configuration on the server so that the old prefix from which the client got leases is no longer valid when the Renew occurs. Or, add a second prefix to the configuration (so that the client is supposed to get an address from each prefix).

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Mudric, Dusan (Dusan)
Sent: Friday, December 09, 2016 8:56 AM
To: [email-masked]
Subject: Re: [dhcwg] DHCPv6 RENEW with a new address

Hi,

Regards,
Dusan.

-----Original Message-----
From: dhcp-users [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, November 24, 2016 7:00 AM
To: [email-masked]
Subject: dhcp-users Digest, Vol 97, Issue 16

Today's Topics:

Message: 1

Regards,
Dusan.

Subject: Digest Footer

_______________________________________________
dhcwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dhcwg

---

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Fri, 9 Dec 2016 17:14:21 +0000

Thank you Bernie

Dusan

-----Original Message-----
From: Bernie Volz (volz) [mailto:[email-masked]] 
Sent: Friday, December 09, 2016 11:07 AM
To: Mudric, Dusan (Dusan); [email-masked]
Subject: RE: [dhcwg] DHCPv6 RENEW with a new address

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Mudric, Dusan (Dusan)
Sent: Friday, December 09, 2016 8:56 AM
To: [email-masked]
Subject: Re: [dhcwg] DHCPv6 RENEW with a new address

Hi,

Regards,
Dusan.

-----Original Message-----
From: dhcp-users [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, November 24, 2016 7:00 AM
To: [email-masked]
Subject: dhcp-users Digest, Vol 97, Issue 16

Today's Topics:

Message: 1

Regards,
Dusan.

Subject: Digest Footer

_______________________________________________
dhcwg mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_dhcwg&d=DQIFAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=TqN0vVxtwdsttFd4jQTChaTm3FoRHrQcEUtVlu4_VqE&s=hYRqEl3WEt-frCty44b5MZwchujLFaf3pdjLFTh4wko&e=

---

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Tue, 13 Dec 2016 17:54:08 +0000

Hi Bernie,

I tried adding another subnet, fc00::/64, to the dhcpd6.conf but the client did not get one more address in REPLY for RENEW. It  got 2000::410 again. What exactly should I do to get a new address during RENEW-REPLY?

subnet6 fc00::/64 {
host SIP_phone_9611_at_Dusan_desk {
  hardware ethernet 6c:a8:49:87:4f:2a;
  fixed-address6 fc00::208;
  fixed-prefix6 fc00::/64;
}

   range6 fc00::610 fc00::612;
}

subnet6 2000::/64 {
   range6 2000::410 2000::450;
}

Regards,
Dusan.

-----Original Message-----
From: Bernie Volz (volz) [mailto:[email-masked]] 
Sent: Friday, December 09, 2016 11:07 AM
To: Mudric, Dusan (Dusan); [email-masked]
Subject: RE: [dhcwg] DHCPv6 RENEW with a new address

- Bernie

-----Original Message-----
From: dhcwg [mailto:[email-masked]] On Behalf Of Mudric, Dusan (Dusan)
Sent: Friday, December 09, 2016 8:56 AM
To: [email-masked]
Subject: Re: [dhcwg] DHCPv6 RENEW with a new address

Hi,

Regards,
Dusan.

-----Original Message-----
From: dhcp-users [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, November 24, 2016 7:00 AM
To: [email-masked]
Subject: dhcp-users Digest, Vol 97, Issue 16

Today's Topics:

Message: 1

Regards,
Dusan.

Subject: Digest Footer

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Tue, 13 Dec 2016 18:19:32 +0000

You’ll have to ask this question on the support forum for whatever server implementation you are using. This is not the forum for implementation specific support questions.

- Bernie

On 12/13/16, 12:54 PM, "Mudric, Dusan (Dusan)" <[email-masked]> wrote:

    Hi Bernie,

    subnet6 fc00::/64 {

    subnet6 2000::/64 {
    
    Regards,
    Dusan.
    
    -----Original Message-----
    From: Bernie Volz (volz) [mailto:[email-masked]] 
    Sent: Friday, December 09, 2016 11:07 AM
    To: Mudric, Dusan (Dusan); [email-masked]
    Subject: RE: [dhcwg] DHCPv6 RENEW with a new address

    
    - Bernie
    
    -----Original Message-----
    From: dhcwg [mailto:[email-masked]] On Behalf Of Mudric, Dusan (Dusan)
    Sent: Friday, December 09, 2016 8:56 AM
    To: [email-masked]
    Subject: Re: [dhcwg] DHCPv6 RENEW with a new address
    
    Hi,

    

    Regards,
    Dusan.

    -----Original Message-----
    From: dhcp-users [mailto:[email-masked]] On Behalf Of [email-masked]
    Sent: Thursday, November 24, 2016 7:00 AM
    To: [email-masked]
    Subject: dhcp-users Digest, Vol 97, Issue 16

    

    Today's Topics:

    
    Message: 1

    

    
    Regards,
    Dusan.

    
    Subject: Digest Footer