Subject: [Dime] Murray Kucherawy's No Objection on draft-ietf-dime-group-signaling-13: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Mon, 01 Feb 2021 17:41:26 -0800

Murray Kucherawy has entered the following ballot position for
draft-ietf-dime-group-signaling-13: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dime-group-signaling/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I agree with Barry's editorial suggestions.

What does the "*)" in the table in Section 3.3 mean?

>From Section 10:

   [...]  if the Diameter client or server is
   compromised, an attacker could launch DoS attacks by terminating a
   large number of sessions with a limited set of commands using the
   session group management concept.

Is it worth mentioning that an attacker could also mess with the set of
sessions associated with a group, possibly causing disruptions other than bulk
session terminations?

---

From: Marco Liebsch <[email-masked]>
Date: Wed, 24 Feb 2021 15:15:59 +0000

Thanks a lot for your review and comments, Murray. Please see inline [ml] for our feedback.

-----Original Message-----
From: Murray Kucherawy via Datatracker <[email-masked]> 
Sent: Dienstag, 2. Februar 2021 02:41
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Murray Kucherawy's No Objection on draft-ietf-dime-group-signaling-13: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

[ml] Thanks for spotting this. It's actually a leftover from a removed remark (editor's note) that we had in past revisions. We'll remove the tag from the table in revision 14.   

Is it worth mentioning that an attacker could also mess with the set of sessions associated with a group, possibly causing disruptions other than bulk session terminations?

[ml] yes, it's a valid scenario during an attack, too. We propose the following extension to the existing text to cover your proposal:

“..if the Diameter client or server is compromised, an attacker could launch DoS attacks by terminating or applying change operations 
to a large number of sessions with a limited set of commands using the session group management concept.” 

marco