Subject: typos in the event MIB draft 05

From: Bram van der Waaij <[email-masked]>
Date: Fri, 16 Oct 1998 11:04:32 +0200

Hi,

During the examination of the event mib draft 05 we found a number
of probable typos. In the case there was an inconsistency we
have made a sugestion to solve it. Using all these changes the
mib can be compiled using smicng.
Perhaps some of the sugested changed are incorrect, please let us
know so we also can correct it.

IMPORTS area
 - Counter32 and BITS must be added to SNMPv2-SMI
 - TruthValue must be added to SNMPv2-TC, TimeStamp removed
 -  NOTIFICATION-GROUP must be added to SNMPv2-CONF

mteTriggerEntry
 - DESCRIPTION statement is missing
 - mteTriggerteble must be mteTriggerTable

MteTriggerTable
 - type of mteTriggerValueID must be OBJECT IDENTIFIER
 - type of mteTriggerBooleanStartup must be TruthValue

mteTriggerValue
 - quote (") is missing at the end of the description

mteTriggerContextNameWildcard
 - quote (") is missing at the end of the description

mteTriggerObjectTable
 - SEQUENCE OF mteTriggerObjectEntry must be
   SEQUENCE OF MteTriggerObjectEntry 

mteTriggerObjectEntry
 - SYNTAX mteTriggerObjectEntry must be
   SYNTAX MteTriggerObjectEntry 
 - DESCRIPTION statement is missing
 - mteTriggerObjectteble must be mteTriggerObjectTable

mteTriggerObjectEntry ::= SEQUENCE { must be
MteTriggerObjectEntry ::= SEQUENCE {
 - type of mteTriggerObjectID must be OBJECT IDENTIFIER

mteTriggerObjectValueIDWildcard must be
mteTriggerObjectIDWildcard 
 - quote (") is missing at the end of the description

mteEventName
- mteEventCreationEntry must be mteEventEntry

mteEventActions
- BITS { notification, set } must probably be
  BITS { notification(0), set(1) }

mteEventSetObject
- There is a quote (") within the description, must be removed

mteEventSetTargetTag
- There is a quote (") within the description, must be removed

mteEventSetContextName
- There is a quote (") within the description, must be removed

mteEventSetContextNameWildcard
- ::= { mteTriggerEntry 10 } must be 
  ::= { mteEventEntry 11 } 

eventMIBNotificationObjectss must probably be
eventMIBNotificationObjects 

mteHotTrigger
 - quote (") is missing at the end of the description
 - ::= { mteTrigger 1 } must be 
   ::= { mteTrigger 4 } 

mteHotTargetName
 - quote (") is missing at the end of the description
 - ::= { mteTrigger 2 } must be 
   ::= { mteTrigger 5 } 

mteHotContextName
 - ::= { mteTrigger 3 } must be 
   ::= { mteTrigger 6 } 

mteHotOID
 - ::= { mteTrigger 3 } must be 
   ::= { mteTrigger 7 } 

mteFailedReason
 - quote (") is missing at the end of the description
 - ::= { mteTrigger 6 } must be 
   ::= { mteTrigger 9 } 

eventMIBCompliance
  mteTriggerTargetTag
    - Double quote (") at the end of the description
  mteTriggerSetTargetTag
    - Double quote (") at the end of the description
  mteTriggerObjectValueIDWildcard must be
  mteTriggerObjectIDWildcard 

eventNotificationObjectGroup
 - mterHotValue must be 
   mteHotValue

eventNotificationGroup OBJECT-GROUP must be
eventNotificationGroup NOTIFICATION-GROUP 
 - OBJECTS { must be 
   NOTIFICATIONS {

-- 
Bram
         _          Bram van der Waaij           tel.: +31 53 4894664
    ----(_)----     <[email-masked]>      fax : +31 53 4894524
  ___  | | |                                    room : INF-4032
 /   \ | | |        Centre for Telematics and Information Technology
|      | | |        University of Twente
 \___/ | | |        P.O. Box 217   7500 AE Enschede  The Netherlands

---

From: Bob Stewart <[email-masked]>
Date: Fri, 30 Oct 1998 08:26:11 -0500

At 11:04 AM 10/16/98 +0200, Bram van der Waaij wrote:
>of probable typos.

Thanks for the list.  Randy's reply and Bram's reply to that I believe
covered any issues from this, so these are in my file of edits to do.

	Bob