Subject: Re: typos in the event MIB draft 05

From: Randy Presuhn <[email-masked]>
Date: Fri, 16 Oct 1998 17:04:30 -0700 (PDT)

Hi - 

(writing as a contributor, not chair)

> Date: Fri, 16 Oct 1998 11:04:32 +0200
> From: Bram van der Waaij <[email-masked]>
> To: [email-masked]
> CC: [email-masked]
> Subject: typos in the event MIB draft 05
...
> During the examination of the event mib draft 05 we found a number
> of probable typos. In the case there was an inconsistency we
> have made a sugestion to solve it. Using all these changes the
> mib can be compiled using smicng.
> Perhaps some of the sugested changed are incorrect, please let us
> know so we also can correct it.
> 
> 
> IMPORTS area
>  - Counter32 and BITS must be added to SNMPv2-SMI

Counter32 yes, BITS no.  The insistance on IMPORTing bits is a
peculiarity of the tool used.

>  - TruthValue must be added to SNMPv2-TC, TimeStamp removed
>  -  NOTIFICATION-GROUP must be added to SNMPv2-CONF

ok.

> mteTriggerEntry
>  - DESCRIPTION statement is missing
>  - mteTriggerteble must be mteTriggerTable

ok.

> MteTriggerTable
>  - type of mteTriggerValueID must be OBJECT IDENTIFIER
>  - type of mteTriggerBooleanStartup must be TruthValue

ok

> mteTriggerValue
>  - quote (") is missing at the end of the description

ok

> mteTriggerContextNameWildcard
>  - quote (") is missing at the end of the description

ok

> mteTriggerObjectTable
>  - SEQUENCE OF mteTriggerObjectEntry must be
>    SEQUENCE OF MteTriggerObjectEntry 

ok

> mteTriggerObjectEntry
>  - SYNTAX mteTriggerObjectEntry must be
>    SYNTAX MteTriggerObjectEntry 
>  - DESCRIPTION statement is missing
>  - mteTriggerObjectteble must be mteTriggerObjectTable

ok

> mteTriggerObjectEntry ::= SEQUENCE { must be
> MteTriggerObjectEntry ::= SEQUENCE {
>  - type of mteTriggerObjectID must be OBJECT IDENTIFIER

ok

> mteTriggerObjectValueIDWildcard must be
> mteTriggerObjectIDWildcard 

ok, but there'd need to be some matching fixes to some object
description clauses as well.

>  - quote (") is missing at the end of the description

ok

> mteEventName
> - mteEventCreationEntry must be mteEventEntry

ok

> mteEventActions
> - BITS { notification, set } must probably be
>   BITS { notification(0), set(1) }

ok

> mteEventSetObject
> - There is a quote (") within the description, must be removed

ok

> mteEventSetTargetTag
> - There is a quote (") within the description, must be removed

ok

> mteEventSetContextName
> - There is a quote (") within the description, must be removed

ok

> mteEventSetContextNameWildcard
> - ::= { mteTriggerEntry 10 } must be 
>   ::= { mteEventEntry 11 } 

ok

> eventMIBNotificationObjectss must probably be
> eventMIBNotificationObjects 

ok

> mteHotTrigger
>  - quote (") is missing at the end of the description
>  - ::= { mteTrigger 1 } must be 
>    ::= { mteTrigger 4 } 

ok

> mteHotTargetName
>  - quote (") is missing at the end of the description
>  - ::= { mteTrigger 2 } must be 
>    ::= { mteTrigger 5 } 

ok

> mteHotContextName
>  - ::= { mteTrigger 3 } must be 
>    ::= { mteTrigger 6 } 
> 
> mteHotOID
>  - ::= { mteTrigger 3 } must be 
>    ::= { mteTrigger 7 } 
> 
> mteFailedReason
>  - quote (") is missing at the end of the description
>  - ::= { mteTrigger 6 } must be 
>    ::= { mteTrigger 9 } 

Huh? I think if mteHotOID were numbered 4, the rest of this juggling
wouldn't be needed.

> eventMIBCompliance
>   mteTriggerTargetTag
>     - Double quote (") at the end of the description

ok

>   mteTriggerSetTargetTag
>     - Double quote (") at the end of the description

ok

>   mteTriggerObjectValueIDWildcard must be
>   mteTriggerObjectIDWildcard 

ok

> eventNotificationObjectGroup
>  - mterHotValue must be 
>    mteHotValue

ok

> eventNotificationGroup OBJECT-GROUP must be
> eventNotificationGroup NOTIFICATION-GROUP 
>  - OBJECTS { must be 
>    NOTIFICATIONS {
...

ok.

 -----------------------------------------------------------------------
 Randy Presuhn           Email: [email-masked] http://www.bmc.com     
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 -----------------------------------------------------------------------
 In accordance with the BMC Communications Systems Use and Security
 Policy, I explicitly state that although my affiliation with BMC may be
 apparent, implied, or provided, my opinions are not necessarily those
 of BMC Software and that all external representations on behalf of
 BMC must first be cleared with a member of "the top management team."
 -----------------------------------------------------------------------

---

From: Bram van der Waaij <[email-masked]>
Date: Mon, 19 Oct 1998 10:21:23 +0200

Hi,

...

> peculiarity of the tool used.

Ok, I didn't know that.

...

> description clauses as well.

I agree, and I just made the suggestion to remove "Value", but
you can also add it to the mteTriggerObjectID. When you look at the
mteTriggerTable it uses the "Value" clause, but in the expressionMib 
in the expObjectTable is uses only "ID". SO both options are used.

...

> Huh? I think if mteHotOID were numbered 4, the rest of this juggling

No, because you just used number 5 and 6 for mteHotTrigger and 
mteHotTargetName so they are already in use. Of course should 
mteHotValue also be changed from 5 to 8, I mist that one in my last 
email. But perhaps there is a way to make less changes and still have
a correct numbering, I just numbered everything correct in the order
they are listed in the document.  

-- 
Bram
         _          Bram van der Waaij           tel.: +31 53 4894664
    ----(_)----     <[email-masked]>      fax : +31 53 4894524
  ___  | | |                                    room : INF-4032
 /   \ | | |        Centre for Telematics and Information Technology
|      | | |        University of Twente
 \___/ | | |        P.O. Box 217   7500 AE Enschede  The Netherlands